Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error circular dependencies
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
de11
n00b
n00b


Joined: 15 Oct 2017
Posts: 11

PostPosted: Mon Oct 16, 2017 3:14 pm    Post subject: Error circular dependencies Reply with quote

Hi ,

I did emerge --pretend --newuse --deep world and after that iif I try to emerge anything ,I always get this error
Code:
* Error: circular dependencies:

(dev-vcs/git-9999-r3:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-vcs/git-9999-r3:0/0::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.


portage/make.conf
Code:
 These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE and USE_EXPAND flags that were used for
# buidling in addition to what is provided by the profile.
USE="a52 acpi alsa consolekit dbus drm dri3 dts ffmpeg gtk smp network zlib iconv gpl \
bash-completion branding crypt cups device-mapper glamor imlib perl \
policykit fontconfig ntfs spell startup-notification text truetype unicode \
mmx sse2 udev x264 x265 pdf libav mp3 wifi ipv6 xvid flac nsplugin \
minizip gif jpeg nls png tiff test qt5 ncurses xkb pcre16 \
postproc threads hardcoded-tables encode bzip2 udisks \
-systemd -gnome -kde -bindist -handbook \
sse2 sse3 ssse3 X introspection nss-pen plugins"
CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
VIDEO_CARDS="intel radeon i965 amdgpu"
INPUT_DEVICES="evdev keyboard mouse synaptics"
ALSA_CARDS="hda-intel"
PYTHON_TARGETS="python2_7 python3_4"
RUBY_TARGETS="ruby24"
MAKEOPTS="-j5 -l4"
ACCEPT_KEYWORDS="~x86"
ACCEPT_LICENSE="*"
LINGUAS="en en_US"
L10N="en en-US"
FFTOOLS=""
ABI_X86="64 32"
GENTOO_MIRRORS="ftp://gentoo.mirrors.ovh.net/gentoo-distfiles/ http://gentoo.mirrors.ovh.net/gentoo-distfiles/ rsync://mirror.eu.oneandone.net/gentoo/"


please help
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 9979
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Oct 16, 2017 3:22 pm    Post subject: Reply with quote

dev-vcs/git-9999* are all hard masked. Are you sure that's what you want?

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
de11
n00b
n00b


Joined: 15 Oct 2017
Posts: 11

PostPosted: Mon Oct 16, 2017 3:29 pm    Post subject: Reply with quote

Not sure ,so everyfile that ends with -9999* are hard masked ?
I noticed now that emerge wants to download only hard masked ?
Code:
Calculating dependencies... done!


[nomerge       ] dev-vcs/git-9999-r3::gentoo  USE="blksha1 curl gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" LINGUAS="-bg -ca -de -fr -is -it -ko -pt_PT -ru -sv -vi -zh_CN" PYTHON_TARGETS="python2_7"
[ebuild  N    *]  app-text/asciidoc-9999::gentoo  USE="-examples -graphviz -highlight {-test}" PYTHON_SINGLE_TARGET="python2_7 -pypy" PYTHON_TARGETS="python2_7 -pypy" 0 KiB
[ebuild  N    *]   dev-vcs/git-9999-r3::gentoo  USE="blksha1 curl gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" LINGUAS="-bg -ca -de -fr -is -it -ko -pt_PT -ru -sv -vi -zh_CN" PYTHON_TARGETS="python2_7" 0 KiB

Total: 2 packages (2 new), Size of downloads: 0 KiB

 * Error: circular dependencies:
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19007
Location: here

PostPosted: Mon Oct 16, 2017 3:31 pm    Post subject: Reply with quote

John R. Graham wrote:
dev-vcs/git-9999* are all hard masked. Are you sure that's what you want?

All live ebuilds are masked by missing keyword.

You can post emerge =dev-vcs/git-9999-r3
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 9979
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Oct 16, 2017 3:37 pm    Post subject: Reply with quote

Probably a case of autounmask striking again.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
de11
n00b
n00b


Joined: 15 Oct 2017
Posts: 11

PostPosted: Mon Oct 16, 2017 3:39 pm    Post subject: Reply with quote

fedeliallalinea wrote:
John R. Graham wrote:
dev-vcs/git-9999* are all hard masked. Are you sure that's what you want?

All live ebuilds are masked by missing keyword.

You can post emerge =dev-vcs/git-9999-r3


Sure
Code:
emerge =dev-vcs/git-9999-r3
Calculating dependencies... done!


[nomerge       ] dev-vcs/git-9999-r3::gentoo  USE="blksha1 curl gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" LINGUAS="-bg -ca -de -fr -is -it -ko -pt_PT -ru -sv -vi -zh_CN" PYTHON_TARGETS="python2_7"
[ebuild  N    *]  app-text/asciidoc-9999::gentoo  USE="-examples -graphviz -highlight {-test}" PYTHON_SINGLE_TARGET="python2_7 -pypy" PYTHON_TARGETS="python2_7 -pypy" 0 KiB
[ebuild  N    *]   dev-vcs/git-9999-r3::gentoo  USE="blksha1 curl gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" LINGUAS="-bg -ca -de -fr -is -it -ko -pt_PT -ru -sv -vi -zh_CN" PYTHON_TARGETS="python2_7" 0 KiB

Total: 2 packages (2 new), Size of downloads: 0 KiB

 * Error: circular dependencies:

(dev-vcs/git-9999-r3:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-vcs/git-9999-r3:0/0::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19007
Location: here

PostPosted: Mon Oct 16, 2017 4:06 pm    Post subject: Reply with quote

But is your choice to use 9999 version of git?
If not post all output of command emerge --pretend --newuse --deep --tree @world with wgetpaste

EDIT: sorry John R. Graham I assumed that was a choice of user
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
de11
n00b
n00b


Joined: 15 Oct 2017
Posts: 11

PostPosted: Mon Oct 16, 2017 4:18 pm    Post subject: Reply with quote

fedeliallalinea wrote:
But is your choice to use 9999 version of git?
If not post all output of command emerge --pretend --newuse --deep --tree @world with wgetpaste

EDIT: sorry John R. Graham I assumed that was a choice of user


Not my choice to use 9999 version

Code:
emerge --pretend --newuse --deep --tree @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] x11-misc/pcmanfm-1.2.3
[nomerge       ]  x11-libs/libfm-1.2.4
[nomerge       ]   gnome-base/gvfs-1.30.4
[nomerge       ]    net-libs/libsoup-2.56.1
[nomerge       ]     net-libs/glib-networking-2.50.0
[ebuild   R    ]      net-libs/libproxy-0.4.13-r2  USE="-python*"
[nomerge       ] mate-base/caja-1.18.3
[nomerge       ]  gnome-base/gvfs-1.30.4
[nomerge       ]   sys-fs/udisks-2.7.3
[nomerge       ]    sys-libs/libblockdev-2.13
[nomerge       ]     dev-libs/volume_key-0.3.9
[ebuild   R    ]      app-crypt/gpgme-1.8.0-r3  USE="-python*"
[nomerge       ] gnome-base/gnome-keyring-3.20.0
[ebuild     U  ]  app-crypt/pinentry-1.0.0-r1 [0.9.7-r1]
[nomerge       ] x11-terms/xfce4-terminal-0.8.5.1
[nomerge       ]  x11-libs/vte-0.48.3 [0.46.2] USE="-vanilla%"
[nomerge       ]   x11-libs/gtk+-3.22.16
[nomerge       ]    net-print/cups-2.2.4 [2.1.4] USE="-python*"
[nomerge       ]     net-print/cups-filters-1.17.9
[nomerge       ]      app-text/poppler-0.57.0
[nomerge       ]       dev-qt/qtgui-5.9.2
[nomerge       ]        virtual/opengl-7.0-r1
[ebuild     U  ]         media-libs/mesa-17.2.2 [17.0.6] USE="-unwind%"
[nomerge       ] x11-base/xorg-server-1.19.5
[nomerge       ]  media-libs/mesa-17.2.2 [17.0.6] USE="-unwind%"
[nomerge       ]   sys-devel/llvm-5.0.0 [3.9.1-r1] USE="doc libffi ncurses -debug -gold -libedit {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[blocks b      ]    sys-devel/llvm:0 ("sys-devel/llvm:0" is blocking sys-devel/llvm-common-5.0.0, sys-devel/llvm-5.0.0)
[uninstall     ]     sys-devel/llvm-3.9.1-r1
[ebuild  NS    ]   sys-devel/llvm-5.0.0 [3.9.1-r1] USE="doc libffi ncurses -debug -gold -libedit {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild     U  ]    dev-util/cmake-3.9.4 [3.7.2] USE="-server%"
[nomerge       ] dev-libs/volume_key-0.3.9
[ebuild   R    ]  sys-fs/cryptsetup-1.7.5  USE="-python*"
[nomerge       ] virtual/ssh-0
[ebuild     U  ]  net-misc/openssh-7.6_p1 [7.5_p1-r1]
[nomerge       ] dev-util/geany-1.30.1
[ebuild   R    ]  x11-libs/vte-0.28.2-r208  USE="-python*"
[ebuild     U  ] mate-extra/mate-polkit-1.18.1 [1.12.0-r2]
[ebuild     U  ] app-admin/sudo-1.8.21_p2 [1.8.20_p2] USE="-sasl%"
[ebuild     U  ]  sys-auth/pambase-20150213-r1 [20150213] USE="-elogind%"
[nomerge       ] www-client/google-chrome-61.0.3163.100
[ebuild     U  ]  net-print/cups-2.2.4 [2.1.4] USE="-python*"
[nomerge       ] virtual/man-0-r1
[nomerge       ]  sys-apps/man-db-2.7.6.1-r2
[ebuild     U  ]   sys-apps/groff-1.22.3 [1.22.2]
[nomerge       ] sys-boot/grub-2.02
[ebuild     U  ]  sys-fs/lvm2-2.02.166-r2 [2.02.145-r2] USE="-sanlock%"
[ebuild     U  ]   sys-apps/util-linux-2.30.2 [2.28.2] USE="-python*"
[ebuild     U  ] x11-libs/vte-0.48.3 [0.46.2] USE="-vanilla%"
[ebuild     U  ] app-arch/xarchiver-0.5.4.12 [0.5.4] USE="-doc%"
[nomerge       ] sys-power/powertop-2.8
[ebuild     U  ]  dev-libs/libnl-3.4.0 [3.2.28] USE="-python*"
[nomerge       ] net-news/newsboat-2.10.1
[ebuild   R    ]  dev-libs/stfl-0.24  USE="-python*"
[nomerge       ] app-arch/p7zip-16.02-r1
[ebuild   R    ]  dev-lang/yasm-1.3.0  USE="-python*"
[ebuild     U  ] media-libs/alsa-lib-1.1.4.1 [1.1.2] USE="-python*"
[ebuild     U  ] app-misc/screenfetch-3.8.0 [3.7.0] USE="-curl%"
[ebuild     U  ] media-libs/faac-1.29.7.8 [1.28-r4] USE="-digitalradio%"
[ebuild     U  ] sys-apps/lm_sensors-3.4.0_p20170901 [3.4.0_p20160725] USE="-contrib%"
[ebuild     U  ] media-fonts/terminus-font-4.46 [4.40]
[ebuild     U  ] sys-process/procps-3.3.12-r1 [3.3.12] USE="-elogind%"
[nomerge       ] sys-devel/llvm-5.0.0 [3.9.1-r1] USE="doc libffi ncurses -debug -gold -libedit {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild  N     ]  sys-devel/llvm-common-5.0.0
[nomerge       ] gnome-base/gnome-keyring-3.20.0
[nomerge       ]  app-crypt/gcr-3.20.0
[nomerge       ]   x11-libs/gtk+-3.22.16
[nomerge       ]    dev-libs/gobject-introspection-common-1.52.1 [1.50.0]
[blocks b      ]     <dev-libs/gobject-introspection-1.52.1 ("<dev-libs/gobject-introspection-1.52.1" is blocking dev-libs/gobject-introspection-common-1.52.1)
[ebuild     U  ]      dev-libs/gobject-introspection-1.52.1 [1.50.0] PYTHON_SINGLE_TARGET="-python3_6%" PYTHON_TARGETS="-python3_6%"
[ebuild     U  ]       dev-libs/gobject-introspection-common-1.52.1 [1.50.0]
[nomerge       ] sys-devel/llvm-5.0.0 [3.9.1-r1] USE="doc libffi ncurses -debug -gold -libedit {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[nomerge       ]  dev-python/sphinx-1.6.3-r2  USE="-doc -latex -net {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]   dev-python/sphinxcontrib-websupport-1.0.1  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]    dev-python/sphinx-1.6.3-r2  USE="-doc -latex -net {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]     dev-python/requests-2.18.4  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]      dev-python/urllib3-1.22  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]       dev-python/pyopenssl-17.3.0  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]        dev-python/cryptography-2.0.3  USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]         dev-python/cffi-1.10.0  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[nomerge       ] virtual/modutils-0
[ebuild     U  ]  sys-apps/kmod-24 [23] USE="-python*" PYTHON_TARGETS="-python3_6%"
[nomerge       ] app-portage/repoman-2.3.3
[nomerge       ]  sys-apps/portage-2.3.8
[nomerge       ]   sys-apps/sandbox-2.10-r3
[ebuild     U  ]    app-misc/pax-utils-1.2.2-r2 [1.1.7] USE="-python*"
[nomerge       ] x11-base/xorg-server-1.19.5
[nomerge       ]  x11-base/xorg-drivers-1.19
[nomerge       ]   x11-drivers/xf86-video-ati-7.10.0
[ebuild     U  ]    x11-libs/libdrm-2.4.84 [2.4.80]
[nomerge       ] x11-misc/arandr-0.1.9
[nomerge       ]  dev-python/pygtk-2.24.0-r4
[nomerge       ]   gnome-base/libglade-2.6.4-r2
[ebuild     U  ]    dev-libs/glib-2.52.3 [2.50.3-r1]
[nomerge       ] app-arch/xarchiver-0.5.4.12 [0.5.4] USE="-doc%"
[nomerge       ]  x11-libs/gtk+-3.22.16
[ebuild     U  ]   dev-util/gdbus-codegen-2.52.3 [2.50.3] PYTHON_TARGETS="-python3_6%"
[nomerge       ] gnome-base/gnome-keyring-3.20.0
[ebuild   R    ]  sys-libs/libcap-ng-0.7.8  USE="-python*"
[ebuild     U  ]  dev-libs/libxslt-1.1.30-r1 [1.1.29-r1] USE="-python*"
[ebuild  rR    ] virtual/perl-File-Temp-0.230.400-r5
[ebuild  rR    ] virtual/perl-File-Path-2.130.0
[nomerge       ] media-gfx/scrot-0.8_p13
[ebuild     U  ]  media-libs/giblib-1.2.4-r1 [1.2.4] USE="-static-libs%"
[nomerge       ] dev-python/requests-2.18.4  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ]  dev-python/cryptography-2.0.3  USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]   virtual/python-ipaddress-1.0-r1  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]    dev-python/ipaddress-1.0.18  PYTHON_TARGETS="python2_7 -pypy"
[nomerge       ] dev-python/sphinx-1.6.3-r2  USE="-doc -latex -net {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/jinja-2.9.6  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]   dev-python/markupsafe-0.23  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] dev-python/urllib3-1.22  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/PySocks-1.6.7  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] dev-python/cffi-1.10.0  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/pycparser-2.18-r1  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]   dev-python/ply-3.10  USE="-examples" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] dev-python/urllib3-1.22  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ]  dev-python/cryptography-2.0.3  USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]   dev-python/asn1crypto-0.22.0  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]   dev-python/enum34-1.1.6  USE="-doc" PYTHON_TARGETS="python2_7 -pypy -pypy3"
[nomerge       ] dev-python/requests-2.18.4  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/chardet-3.0.4  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] dev-python/sphinx-1.6.3-r2  USE="-doc -latex -net {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/Babel-2.5.0  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]   dev-python/pytz-2017.2  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] dev-python/sphinxcontrib-websupport-1.0.1  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/sqlalchemy-1.1.14  USE="sqlite -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_5 -python3_6"
[ebuild  N     ]  dev-python/whoosh-2.7.4  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_5 -python3_6"
[ebuild  N     ]  dev-python/namespace-sphinxcontrib-1.0  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] dev-python/sphinx-1.6.3-r2  USE="-doc -latex -net {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/imagesize-0.7.1  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/alabaster-0.7.10  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/sphinx_rtd_theme-0.2.4  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/typing-3.6.2  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] dev-python/requests-2.18.4  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/idna-2.6  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[nomerge       ] app-portage/gentoolkit-0.4.0
[nomerge       ]  sys-apps/portage-2.3.8
[ebuild     U  ]   dev-python/pyxattr-0.6.0 [0.5.5] PYTHON_TARGETS="-python3_6%"
[nomerge       ] dev-util/cmake-3.9.4 [3.7.2] USE="-server%"
[ebuild  N     ]  app-crypt/rhash-1.3.5  USE="nls -debug -openssl -static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ] dev-python/sphinx-1.6.3-r2  USE="-doc -latex -net {-test}" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
[ebuild  N     ]  dev-python/snowballstemmer-1.2.1  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6"
[ebuild     U  ] dev-libs/boost-1.65.0 [1.62.0-r1] USE="-python*" PYTHON_TARGETS="-python3_6%"
[nomerge       ] virtual/shadow-0
[nomerge       ]  sys-apps/shadow-4.5
[ebuild   R    ]   sys-libs/cracklib-2.9.6-r1  USE="-python*"
[ebuild   R    ] sys-apps/file-5.32  USE="-python*"
[nomerge       ] dev-libs/boost-1.65.0 [1.62.0-r1] USE="-python*" PYTHON_TARGETS="-python3_6%"
[ebuild     U  ]  dev-util/boost-build-1.65.0 [1.62.0-r1] USE="-python*"

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.5:2/2::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libxml2[python,python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+)] required by (dev-util/itstool-2.0.2:0/0::gentoo, installed)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19007
Location: here

PostPosted: Mon Oct 16, 2017 4:50 pm    Post subject: Reply with quote

I'm little bit confused, git is installed in this moment? In emerge update command not appear but in this post seems not installed, and furthermore in the command there is no problem related to git
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5055

PostPosted: Mon Oct 16, 2017 5:33 pm    Post subject: Reply with quote

Post your package.mask and package.accept_keywords.
Back to top
View user's profile Send private message
de11
n00b
n00b


Joined: 15 Oct 2017
Posts: 11

PostPosted: Tue Oct 17, 2017 3:19 pm    Post subject: Reply with quote

Ant P. wrote:
Post your package.mask and package.accept_keywords.


I fixed package.use i think so im very new to gentoo just a noob. I got package.use folder with few app names full of content that should be written in package.use file
I suppose package.use should be a text file so i deleted the folder and created new text file and rewrite it, anyway emerge is working now and download git to.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1583

PostPosted: Tue Oct 17, 2017 9:25 pm    Post subject: Reply with quote

The package.use can either be a regular file or a directory with bunch of files. Mostly it is up to you on which is easier to maintain. I find it's much easier to only have to look in one file for anything, where if you have multiple files, you can split it up and have your own organization. The downside on it being a directory, is that it is very easy of having conflicting entries, the other downside is that pockage's auto-keyword only adds entries to the last file in alphabetic order, so it does not pay attention to any special organization that you do.
Back to top
View user's profile Send private message
Raus
n00b
n00b


Joined: 02 Jun 2018
Posts: 1

PostPosted: Sat Jun 02, 2018 9:18 pm    Post subject: Reply with quote

de11 wrote:
Ant P. wrote:
Post your package.mask and package.accept_keywords.


I fixed package.use i think so im very new to gentoo just a noob. I got package.use folder with few app names full of content that should be written in package.use file
I suppose package.use should be a text file so i deleted the folder and created new text file and rewrite it, anyway emerge is working now and download git to.


I am also having a similar problem but the above fix hasn't worked for me,
Anything I try to emerge has a dependency on git which has the circular dependency on itself

I haven't used Gentoo for a while so just trying to update a machine I built last year but haven't had much luck Googleing this one.

Code:
 emerge dev-vcs/git
Calculating dependencies... done!


[nomerge       ] dev-vcs/git-9999-r3::gentoo  USE="blksha1 curl gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[ebuild  N     ]  app-crypt/gnupg-2.2.7::gentoo  USE="bzip2 nls readline smartcard ssl -doc -ldap (-selinux) -tofu -tools -usb -wks-server" 6476 KiB
[ebuild  N     ]   app-crypt/pinentry-1.1.0-r2::gentoo  USE="ncurses -caps -emacs -fltk -gnome-keyring -gtk -qt5 -static" 457 KiB
[ebuild  N     ]    app-eselect/eselect-pinentry-0.7::gentoo  0 KiB
[ebuild  N     ]     app-eselect/eselect-lib-bin-symlink-9999::gentoo  0 KiB
[ebuild  N     ]      dev-vcs/git-9999-r3::gentoo  USE="blksha1 curl gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" PYTHON_TARGETS="python2_7" 0 KiB

Total: 5 packages (5 new), Size of downloads: 6933 KiB

 * Error: circular dependencies:

(dev-vcs/git-9999-r3:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-vcs/git-9999-r3:0/0::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.



---emerge --pretend --newuse --deep --tree --verbose-conflicts @world:

Code:
emerge --pretend --newuse --deep --tree --verbose-conflicts @world
These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgpg-error:0

  (dev-libs/libgpg-error-1.24:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libgpg-error-1.29:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgpg-error-1.25[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libgcrypt-1.8.2-r2:0/20::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^

dev-libs/glib:2

  (dev-libs/glib-2.48.2:2/2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-2.52.3:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.52.3:2 required by (dev-util/gdbus-codegen-2.52.3:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^

sys-devel/automake:1.15

  (sys-devel/automake-1.15:1.15/1.15::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-devel/automake-1.15.1-r2:1.15/1.15::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-devel/automake-1.15.1:1.15 required by (net-fs/nfs-utils-2.3.2:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (app-arch/xz-utils-9999:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (x11-libs/libXpm-3.5.12-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (net-libs/rpcsvc-proto-1.3.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (sys-apps/file-9999:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (sys-apps/util-linux-9999:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (net-misc/openssh-7.7_p1-r3:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (net-libs/libnsl-1.2.0:0/2::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (app-text/opensp-1.5.2-r6:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (dev-libs/libevent-9999:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^
    >=sys-devel/automake-1.15.1:1.15 required by (x11-libs/libXaw-1.0.13-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^^^

dev-lang/perl:0

  (dev-lang/perl-5.28.9999:0/5.27.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/perl-5.24.4:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24* required by (virtual/perl-Data-Dumper-2.160.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.24= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.24= required by (virtual/perl-Test-Harness-3.360.100_rc:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.24=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.24= required by (virtual/perl-Data-Dumper-2.160.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "=dev-lang/perl-5.24.1*".
(dependency required by "virtual/perl-Test-Harness-3.360.100_rc::gentoo" [installed])
(dependency required by "dev-lang/perl-5.28.9999::gentoo" [installed])
(dependency required by "dev-perl/Authen-SASL-2.160.0-r1::gentoo" [ebuild])
(dependency required by "dev-vcs/git-9999-r3::gentoo[perl]" [ebuild])
(dependency required by "dev-lang/python-exec-9999::gentoo" [ebuild])
(dependency required by "dev-python/pycrypto-2.6.1-r2::gentoo" [ebuild])
(dependency required by "dev-python/paramiko-9999::gentoo" [ebuild])
(dependency required by "dev-vcs/bzr-2.7.1_pre::gentoo[sftp]" [ebuild])
(dependency required by "net-print/cups-filters-9999::gentoo" [ebuild])
(dependency required by "net-print/cups-9999::gentoo" [ebuild])
(dependency required by "app-text/ghostscript-gpl-9.21::gentoo[cups]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


package.mask
Code:

<dev-lang/perl-5.18.0
<sys-apps/openrc-0.13.0
<sys-process/procps-3.3.9-r2
<sys-devel/libtool-2.4.3-r2


package.accept_keywords is empty

Any ideas would be much appreciated

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12472

PostPosted: Sat Jun 02, 2018 10:44 pm    Post subject: Reply with quote

That error message could be a bit clearer. You asked to install dev-vcs/git, and your currently active configuration picks =dev-vcs/git-9999-r3. That is a live ebuild, so to install that version, you need to download the sources directly from the upstream repository. The upstream repository is tracked in Git, so you need Git installed before you can download live sources. Hence, dev-vcs/git-9999-r3 depends on dev-vcs/git. Where it could be clearer is that you don't need =dev-vcs/git-9999-r3 to download the sources. Any recent Git will do. According to the eclass, >=dev-vcs/git-1.8.2.1 is acceptable. If you had an acceptable Git installed, this would work transparently. Since you don't, you need to get an older Git installed first. Non-live ebuilds can be installed from exported snapshots, thus avoiding the dependency on dev-vcs/git.

Did you intend to use live Git? If not, the simplest fix would be to switch back to a released version.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum