Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge sys-auth/nss-pam-ldapd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
corswors
n00b
n00b


Joined: 11 Oct 2017
Posts: 2

PostPosted: Wed Oct 11, 2017 1:18 pm    Post subject: emerge sys-auth/nss-pam-ldapd Reply with quote

Good day

Please can you advise on how can i only install/upgrade [ebuild U ] sys-auth/nss-pam-ldapd-0.9.8 [0.9.7]

Emerge want me to merge all of the packages but i only need sys-auth/nss-pam-ldapd-0.9.8 [0.9.7

Is this possible?

Code:
(13:45:17)(Beekman) asterheadtwo johann # emerge --ask sys-auth/nss-pam-ldapd

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/pyasn1-modules-0.0.8  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild  N     ] dev-python/python-ldap-2.4.19-r1  USE="sasl ssl -doc -examples" PYTHON_TARGETS="python2_7 (-pypy)"
[ebuild     U  ] sys-auth/nss-pam-ldapd-0.9.8 [0.9.7]


[Moderator edit: modified title to reference package name; added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7316
Location: ~Brussels - Belgique

PostPosted: Wed Oct 11, 2017 1:42 pm    Post subject: Reply with quote

Hi!,

The 2 other packages are required as dependancies for this new version. You can try to emerge only the package you want (--nodeps), but it would not build or not run.
Code:
--- nss-pam-ldapd-0.9.7.ebuild  2017-08-01 01:01:24.000000000 +0200
+++ nss-pam-ldapd-0.9.8.ebuild  2017-08-01 01:01:24.000000000 +0200
@@ -17,6 +17,7 @@

 COMMON_DEP="
        net-nds/openldap[${MULTILIB_USEDEP}]
+       dev-python/python-ldap[${PYTHON_USEDEP}]
        sasl? ( dev-libs/cyrus-sasl[${MULTILIB_USEDEP}] )
        kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
        virtual/pam[${MULTILIB_USEDEP}]


as you see in this diff, python-ldap has been added to that new version, and python-ldap requires an other dependancy
_________________
Kind regards,
Xavier Miller


Last edited by xaviermiller on Wed Oct 11, 2017 1:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16918
Location: here

PostPosted: Wed Oct 11, 2017 1:48 pm    Post subject: Reply with quote

Never use --nodeps option if you're not sure of what you do.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
corswors
n00b
n00b


Joined: 11 Oct 2017
Posts: 2

PostPosted: Wed Oct 11, 2017 2:03 pm    Post subject: Reply with quote

xaviermiller wrote:
Hi!,

The 2 other packages are required as dependancies for this new version. You can try to emerge only the package you want (--nodeps), but it would not build or not run.
Code:
--- nss-pam-ldapd-0.9.7.ebuild  2017-08-01 01:01:24.000000000 +0200
+++ nss-pam-ldapd-0.9.8.ebuild  2017-08-01 01:01:24.000000000 +0200
@@ -17,6 +17,7 @@

 COMMON_DEP="
        net-nds/openldap[${MULTILIB_USEDEP}]
+       dev-python/python-ldap[${PYTHON_USEDEP}]
        sasl? ( dev-libs/cyrus-sasl[${MULTILIB_USEDEP}] )
        kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
        virtual/pam[${MULTILIB_USEDEP}]


as you see in this diff, python-ldap has been added to that new version, and python-ldap requires an other dependancy


Good thanks for your reply if i just want to install a specific package how will i do this?

emerge --nodeps sys-auth/nss-pam-ldapd
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7316
Location: ~Brussels - Belgique

PostPosted: Wed Oct 11, 2017 2:06 pm    Post subject: Reply with quote

As said, --nodeps is not recommended in you case, because your package will be broken.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16918
Location: here

PostPosted: Wed Oct 11, 2017 2:06 pm    Post subject: Reply with quote

corswors wrote:
emerge --nodeps sys-auth/nss-pam-ldapd


fedeliallalinea wrote:
Never use --nodeps option if you're not sure of what you do.

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5962
Location: Saint Amant, Acadiana

PostPosted: Wed Oct 11, 2017 2:12 pm    Post subject: Reply with quote

In case you are given a task to manage a Gentoo box I suggest you take your time and go thru Gentoo install. You can do it in a virtual machine.
_________________
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11434

PostPosted: Thu Oct 12, 2017 1:12 am    Post subject: Re: emerge sys-auth/nss-pam-ldapd Reply with quote

corswors wrote:
Emerge want me to merge all of the packages but i only need sys-auth/nss-pam-ldapd-0.9.8
How did you determine that neither of the other packages are necessary?
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1605
Location: U.S.A.

PostPosted: Sat Oct 14, 2017 3:49 am    Post subject: Reply with quote

He can't answer you, because now he can't log into his system.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum