Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]wxGTK3.0.2 emake fail
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
joe6302413
n00b
n00b


Joined: 06 Dec 2014
Posts: 26
Location: Taipei, Taiwan

PostPosted: Wed Oct 11, 2017 11:53 am    Post subject: [SOLVED]wxGTK3.0.2 emake fail Reply with quote

Hi,
Recently, I am downgrading all my world packages to stable version.
And I faced the emake failure with x11-libs/wxGTK.
The emerge info is here https://pastebin.com/nMYFqyqN
The log file https://pastebin.com/aw1dAEPq

[ebuild UD] x11-libs/wxGTK-3.0.2.0-r2 [3.0.2.0-r3] USE="X libnotify opengl sdl tiff (-aqua) -debug -doc -gstreamer -webkit" ABI_X86="(64) -32 (-x32)"

It seems to be related to wxPython, but after rebuilding the wxPython the problem still occurs.
Thank you


Last edited by joe6302413 on Wed Oct 11, 2017 12:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22209
Location: here

PostPosted: Wed Oct 11, 2017 12:01 pm    Post subject: Reply with quote

It's related to gcc-6.x (see bug).
Probably this patch resolve problem.

Code:
# mkdir -p /etc/portage/patches/x11-libs/wxGTK-3.0.2.0-r2
# cd /etc/portage/patches/x11-libs/wxGTK-3.0.2.0-r2
# wget "https://github.com/wxWidgets/wxWidgets/commit/73e9e18ea09ffffcaac50237def0d9728a213c02.patch" -O wxGTK-gcc6-abs.patch
# emerge -1 =x11-libs/wxGTK-3.0.2.0-r2

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2657

PostPosted: Wed Oct 11, 2017 12:11 pm    Post subject: Reply with quote

See https://bugs.gentoo.org/show_bug.cgi?id=632144 and hope it will happen soon.
Back to top
View user's profile Send private message
joe6302413
n00b
n00b


Joined: 06 Dec 2014
Posts: 26
Location: Taipei, Taiwan

PostPosted: Wed Oct 11, 2017 12:42 pm    Post subject: Reply with quote

charles17 and fedeliallalinea, thank you both for the information.
You saved my day.
I should have checked the bug report earlier. Hope the stabilization will be soon.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum