Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openssl mit/ohne bindist
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
alexander_ro
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2014
Posts: 112

PostPosted: Mon Oct 09, 2017 2:51 pm    Post subject: openssl mit/ohne bindist Reply with quote

Hi Mädels ... Jungs ... :)

Wie ich im Titel bereits geschrieben habe gibt es Probleme mit dem USE="bindist". Ich habe schon einiges dazu gelesen wenn ich nicht falsch übersetzt habe wird das bindist dazu benutzt um Optionen in Paketen die evtl. Patent oder andere Probleme verursachen auszuschalten. Vermutlich wurde bindist bei der Auswahl des Gentoo Profils für die Installation gesetzt. Ich bin mir sehr sicher das ich es nicht gemacht habe.

Ein "emerge --ask --update --deep --with-bdeps=y --newuse world" liefert nun folgendes:

Code:

Calculating dependencies... done!
[ebuild   R    ] dev-libs/openssl-1.0.2l  USE="-bindist*"
[ebuild     U  ] net-dns/libidn2-2.0.4 [2.0.2]
[ebuild     U  ] dev-python/cryptography-2.0.2 [1.7.1] PYTHON_TARGETS="(-python3_6)"
[ebuild     U  ] dev-python/pyopenssl-17.2.0 [16.2.0] PYTHON_TARGETS="(-python3_6)"
[ebuild   R    ] cross-armv7a-hardfloat-linux-gnueabi/glibc-2.23-r4  USE="multilib*"
[ebuild   R    ] app-text/poppler-0.57.0  USE="qt5*"
[ebuild   R    ] app-text/qpdfview-0.4.16  USE="(-qt5%)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2l:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                  ^^^^^^^                                                                                                     
    dev-libs/openssl:0[bindist=] required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
                       ^^^^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2:0/0::gentoo, ebuild scheduled for merge)



********


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by app-text/qpdfview-0.4.16::gentoo[pdf]
# required by @selected
# required by @world (argument)
>=app-text/poppler-0.57.0 qt5
# required by dev-python/cryptography-2.0.2::gentoo
# required by dev-python/pyopenssl-17.2.0::gentoo
# required by dev-python/requests-2.18.2-r1::gentoo[ssl]
# required by @selected
# required by @world (argument)
>=dev-libs/openssl-1.0.2l -bindist


Wenn man in der package.use für openssl -bindist angibt verlangt er bindist und umgekehrt. Führt also nie zu einer Lösung. Wenn ich es richtig interpretiere wurden openssh, qtnetwork mit bindist gebaut und das Problem das cryptography aber ein openssl ohne bindist erwartet. Weil das sich schon ein wenig widerspricht ist mir im Moment nicht klar wie ich das lösen könnte.

Grüße
Alexander
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3252
Location: Germany

PostPosted: Mon Oct 09, 2017 9:02 pm    Post subject: Reply with quote

Hi,

ja, von dev-python/cryptography-2.0.2 wird aktuell hart ein openssl mit USE=-bindist verlangt,
schau zb direkt im ebuild
cryptography-2.0.2.ebuild wrote:
Code:
RDEPEND="
        !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist(-)] )
Anders geht es zZt scheinbar nicht.
Oder siehe auch in deinem emerge Output
Code:
  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2:0/0::gentoo, ebuild scheduled for merge)


Aber, musst du wirklich mit USE=bindist bauen?
Normal muss man Pakete nur mit bindist bauen wenn man die gebauten Binarys an andere Leute weitergeben möchte. Für den eigenen gebrauch tut es normal nicht nötig die patentgeschützten Inhalte bei den Paketen mit USE=bindist zu entfernen.

Falls du die gebauten Pakete nicht weitergeben möchtest, sondern sie nur für dich selbst nutzen möchtest, dann baue am besten normal ohne bindist (das ist normal auch default).
Wenn dem so ist, dann entferne am besten alle gesetzten bindist Einträge in der make.conf und package.use (schau zb via "grep -r bindist /etc/portage/"), damit sollte das "emerge -avuDU @world" Update dann normal auch sauber auflösen :)
Back to top
View user's profile Send private message
alexander_ro
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2014
Posts: 112

PostPosted: Mon Oct 09, 2017 9:19 pm    Post subject: Reply with quote

Danke für die Info. Dann hatte ich das ja gar nicht so ganz falsch verstanden. Nein die Gentoo Installationen laufen nur auf meinen eigenen Notebook und Servern. Ich habe jetzt das mal so gemacht wie Du vorgeschlagen hast das hat auch funktioniert.

Danke ... :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum