Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Steam failing to start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 578

PostPosted: Thu Oct 05, 2017 6:10 pm    Post subject: Steam failing to start Reply with quote

Hello all. I'm having some trouble with steam. It errors on starting up. Here is the messages it gives.

Specifically the part about missing libc.so.6. It must be the 32bit one from lib32. I believe it is provided by glibc if built using the multilib flag, glibc itself does not have a abi_x86_32 use flag. Any help would be great!

Code:

duby229@TheBeast ~ $ LIBGL_DEBUG=verbose STEAM_RUNTIME=1 /usr/bin/steam
Repairing installation, linking /home/duby229/.steam/steam to /home/duby229/.local/share/Steam
/home/duby229/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
/home/duby229/.local/share/Steam/steam.sh: line 154: VERSION_ID: unbound variable
Running Steam on gentoo  64-bit
STEAM_RUNTIME is enabled by the user
Error: You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6
/home/duby229/.local/share/Steam/steam.sh: line 712: /home/duby229/.local/share/Steam/ubuntu12_32/steam: No such file or directory
/home/duby229/.local/share/Steam/steam.sh: line 444: no match: ssfn*


Code:

TheBeast /home/duby229 # equery belongs /usr/lib/libc.so.6
 * Searching for /usr/lib/libc.so.6 ...


Code:

TheBeast /home/duby229 # emerge --info
Portage 2.3.10 (python 3.4.6-final-0, default/linux/amd64/13.0/desktop, gcc-6.4.0, glibc-2.25-r5, 4.13.4-gentoo x86_64)
=================================================================
System uname: Linux-4.13.4-gentoo-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.4.1
KiB Mem:    16294604 total,    803520 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 30 Sep 2017 18:30:01 +0000
Head commit of repository gentoo: a79590398ea15ac3cec7fb6933273a3baba1bc41
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p1.0) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.6::gentoo
dev-util/cmake:           3.9.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.31.2::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1::gentoo
sys-devel/gcc:            6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r5::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

steam-overlay
    location: /var/lib/layman/steam-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -mtune=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 1000 --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="64-bit-bfd X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cxx d3d9 dbus device-mapper dmraid dri drmkms dts dvd dvdr egl emboss encode evdev exif fam fbcon fbcondecor ffmpeg firefox flac fortran fuse gdbm gif git glamor gles1 gpm gtk hddtemp iconv jpeg lcms ldap libkms libnotify lm_sensors mad mng modules mp3 mp4 mpeg mtp multilib ncurses networkmanager nls nptl ogg opencl opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline s3tc sdl seccomp session spell sqlite ssl startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb vaapi vdpau vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext 3dnow 3dnowext sse sse2 sse4a" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse joystick libinput evdev" KERNEL="linux" L10N="en en_US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22 ruby24" USERLAND="GNU" VIDEO_CARDS="amdgpu r600 radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Code:


TheBeast /home/duby229 # cat /etc/portage/make.conf
CFLAGS="-O2 -pipe -march=native -mtune=native"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"

PORTAGE_NICENESS="19"
EMERGE_DEFAULT_OPTS="--jobs 1000 --keep-going"
MAKEOPTS="-j5"
ABI_X86="64 32"

ALSA_CARDS="hda-intel usb-audio"
VIDEO_CARDS="amdgpu r600 radeon radeonsi"
ACCEPT_KEYWORDS="~amd64"
INPUT_DEVICES="keyboard mouse joystick libinput evdev"
LINGUAS="en en_US"
L10N="en en_US"
RUBY_TARGETS="ruby22 ruby24"
PORTDIR_OVERLAY="/var/lib/layman/steam-overlay"

USE="-clang device-mapper dmraid fuse cddb mtp pulseaudio sqlite -bindist -bluetooth \
-cups -ipv6 git 64-bit-bfd fbcon fbcondecor -classic d3d9 gles1 -gles2 opencl \
hddtemp lm_sensors networkmanager  egl threads evdev libkms drmkms vaapi vdpau  \
ffmpeg s3tc -clang -vlc"
CPU_FLAGS_X86="mmx mmxext 3dnow 3dnowext sse sse2 sse4a"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
Back to top
View user's profile Send private message
arnvidr
Guru
Guru


Joined: 19 Aug 2004
Posts: 558
Location: Oslo, Norway

PostPosted: Thu Oct 05, 2017 9:16 pm    Post subject: Reply with quote

I don't have any libc.so.6 in any of my lib folders, but steam still works just fine. Is this a new install? How have you installed it? I'm using the steam-overlay version, but it shouldn't really matter.
_________________
Noone wrote:
anything
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3801
Location: Austro Bavaria

PostPosted: Thu Oct 05, 2017 9:49 pm    Post subject: Reply with quote

do you have

Code:
roman@ASUS-G75VW /lib $ ls -alh /lib/libc.so.6
lrwxrwxrwx 1 root root 12 Okt  5 23:08 /lib/libc.so.6 -> libc-2.25.so


Code:
ASUS-G75VW lib # equery belongs libc.so.6
 * Searching for libc.so.6 ...
sys-libs/glibc-2.25-r7 (/lib32/libc.so.6 -> libc-2.25.so)
sys-libs/glibc-2.25-r7 (/lib64/libc-2.25.so)
sys-libs/glibc-2.25-r7 (/lib64/libc.so.6 -> libc-2.25.so)
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 578

PostPosted: Thu Oct 05, 2017 10:05 pm    Post subject: Reply with quote

Roman_Gruber wrote:
do you have

Code:
roman@ASUS-G75VW /lib $ ls -alh /lib/libc.so.6
lrwxrwxrwx 1 root root 12 Okt  5 23:08 /lib/libc.so.6 -> libc-2.25.so


Code:
ASUS-G75VW lib # equery belongs libc.so.6
 * Searching for libc.so.6 ...
sys-libs/glibc-2.25-r7 (/lib32/libc.so.6 -> libc-2.25.so)
sys-libs/glibc-2.25-r7 (/lib64/libc-2.25.so)
sys-libs/glibc-2.25-r7 (/lib64/libc.so.6 -> libc-2.25.so)


Ok, so yeah it seems like libc.so.6 does actually exist now after I re-emerged glibc. but Steam still won't start. Still the same error

Code:

duby229@TheBeast ~ $ ls -alh /lib/libc.so.6
lrwxrwxrwx 1 root root 12 Oct  5 13:31 /lib/libc.so.6 -> libc-2.25.so


Code:

duby229@TheBeast ~ $ equery belongs libc.so.6
 * Searching for libc.so.6 ...
sys-libs/glibc-2.25-r5 (/lib32/libc.so.6 -> libc-2.25.so)
sys-libs/glibc-2.25-r5 (/lib64/libc.so.6 -> libc-2.25.so)
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 578

PostPosted: Thu Oct 05, 2017 10:07 pm    Post subject: Reply with quote

arnvidr wrote:
I don't have any libc.so.6 in any of my lib folders, but steam still works just fine. Is this a new install? How have you installed it? I'm using the steam-overlay version, but it shouldn't really matter.


Yeah, it is a new install. I too am using the steam-overlay which I grabbed using layman -a steam-overlay.

I'm wondering now if I need to set up user permissions in some special way? Steam won't run under root, but I'm wondering if my day to day user account isn't set up correctly with permissions of some kind?
Back to top
View user's profile Send private message
arnvidr
Guru
Guru


Joined: 19 Aug 2004
Posts: 558
Location: Oslo, Norway

PostPosted: Fri Oct 06, 2017 2:04 pm    Post subject: Reply with quote

Check what groups you have on your user. You might need to add the video group.
_________________
Noone wrote:
anything
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 578

PostPosted: Fri Oct 06, 2017 8:13 pm    Post subject: Reply with quote

Yeah, I'm definitely in the video group, here is my /etc/group file.
I think the games group is somehow wrong. I don't know how, but I don't think its getting read and used properly.

Code:

TheBeast /home/duby229 # cat /etc/group
root:x:0:root
bin:x:1:root,bin,daemon
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,adm
adm:x:4:root,adm,daemon,duby229
tty:x:5:
disk:x:6:root,adm,duby229
lp:x:7:lp
mem:x:8:
kmem:x:9:
wheel:x:10:root,duby229
floppy:x:11:root
news:x:13:news
uucp:x:14:uucp
console:x:17:
audio:x:18:duby229
cdrom:x:19:duby229
dialout:x:20:
tape:x:26:root
video:x:27:root,duby229,sddm
cdrw:x:80:duby229
usb:x:85:duby229
input:x:97:duby229
users:x:100:duby229
portage:x:250:portage
utmp:x:406:
nogroup:x:65533:
nobody:x:65534:
sshd:x:22:
man:x:15:
messagebus:x:249:
lpadmin:x:106:
polkitd:x:105:duby229
dhcp:x:104:
plugdev:x:103:duby229                                                                                                                                               
colord:x:102:                                                                                                                                                       
geoclue:x:101:                                                                                                                                                       
duby229:x:1000:                                                                                                                                                     
locate:x:999:                                                                                                                                                       
gkrellmd:x:998:                                                                                                                                                     
rtkit:x:997:                                                                                                                                                         
games:x:1001:duby229                                                                                                                                                 
kvm:x:78:duby229
sddm:x:996:
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 578

PostPosted: Sat Oct 07, 2017 1:20 pm    Post subject: Reply with quote

I'm still unable to get steam to start, and I still think it's because there is something wrong with the games group, although I could be entirely wrong. Does anybody have any experience or intuition about what could be wrong here?
Back to top
View user's profile Send private message
rh
n00b
n00b


Joined: 19 Sep 2006
Posts: 54

PostPosted: Sun Oct 08, 2017 7:01 am    Post subject: Reply with quote

Few possible causes:
1. Something wrong with glibc installation, like missing symlinks to libc or dynamic loader.
2. Something wrong with enviroment variables, such as HOME ending with backslash.
3. Non-standard shell or more commonly terminal emulator, this is usually fixed with using xterm instead of libvte based terminal emulator or posix shell instead non-posix compliant shell.
4. Some rare bug introduced with uncommon setup. For example, I had an issue some time ago with a certain version of mesa when using certain version of gcc with -march=native. These are most time consuming to find, I would try to recompile glibc with stable gcc and without optimizations first.

Since steam installs to user home dir, I don't think you need to be in games group. But my experience is installing steam manually instead via steam overlay, so I could be wrong. I don't know if empty lines are allowed in /etc/group, but you can check it by running groups in shell. I will print the groups you are member of.

Edit: I would defenietly start by building glibc with abi_x86_32. You are using much more up-to-date tool chain that is used in steam-runtime, could bring ABI incompatibility issues.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3801
Location: Austro Bavaria

PostPosted: Sun Oct 08, 2017 8:22 am    Post subject: Reply with quote

Did you followed the gentoo wiki regarding steam?
I just did it after your post and it worked here. I had to create one file by hand.

--

steam pulls most of its files from ubuntu regardless if you have em or not. Kinda annoying. so most of the dependencies are ignored of your box, instead the hard disc is wasted by downloanding ubuntu binaries and using these.
Did you checked your kernel for both 32 and 64bit capabilities, excution of binaries and such?

in the past i had big issues, steam wanted to use outdated curl library of my box

--

as you got over that stuff you mentioned in your first post, may I ask you to post your new output of steam, where it stops now?
please run in a terminal steam and post it, if its too big, post it on a pastebin
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5072
Location: Removed by Neddy

PostPosted: Sun Oct 08, 2017 8:33 am    Post subject: Reply with quote

Quote:
Error: You are missing the following 32-bit libraries, and Steam may not run:
/home/duby229/.local/share/Steam/steam.sh: line 712: /home/duby229/.local/share/Steam/ubuntu12_32/steam: No such file or directory
/home/duby229/.local/share/Steam/steam.sh: line 444: no match: ssfn*


Besides the libc thing... it looks like your steam install is corrupt or seriously not updated. Personally I don't use the steam ebuild... it pulls in too much junk and I just do the manual method.
Remove .local/share/Steam and try the manual method (see wiki) and see what is thrown up then. Then specifics as to what the ebuild did to your system can be figured out
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
arnvidr
Guru
Guru


Joined: 19 Aug 2004
Posts: 558
Location: Oslo, Norway

PostPosted: Sun Oct 08, 2017 2:40 pm    Post subject: Reply with quote

It's correct that you don't need to be in the games group for steam. That group is for games installed through portage.

Removing your ~/.local/share/Steam folder might be a good idea, as long as it's a new install nothing is lost, steam will rebuild on launch.
_________________
Noone wrote:
anything
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum