Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]Problemi emerge
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
antonellocaroli
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2016
Posts: 123

PostPosted: Thu Oct 05, 2017 5:55 pm    Post subject: [Risolto]Problemi emerge Reply with quote

Ho appena fatto una nuova installazione...dove é andato tutto bene.

solo che sto avendo una serie di problemi per installare Layman

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2k:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                  ^^^^^^^
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                ^^^^^^^^

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2:0/0::gentoo, ebuild scheduled for merge)

    dev-libs/openssl:0=[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-misc/curl-7.55.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/cryptography-2.0.2::gentoo
# required by dev-python/urllib3-1.22::gentoo
# required by dev-python/requests-2.18.2-r1::gentoo
# required by dev-python/ssl-fetch-0.4::gentoo
# required by app-portage/layman-2.4.2::gentoo
# required by layman (argument)
>=dev-libs/openssl-1.0.2l -bindist

Would you like to add these changes to your config files? [Yes/No] y

Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.use/iputils' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! The following installed packages are masked:
- sys-devel/binutils-2.28-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Code:
GentooPlayer /etc/portage/package.mask # emerge --autounmask-keep-masks --ask layman
--- Invalid atom in /etc/portage/package.use/openssl: dev-libs/openssl-1.0.2k
--- Invalid atom in /etc/portage/package.keywords/sys-kernel: dev-libs/openssl-1.1.0f

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/openssl-1.0.1:0=[bindist] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                ^^^^^^^
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by (net-misc/openssh-7.5_p1-r1:0/0::gentoo, installed)
                                  ^^^^^^^


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-portage/layman-2.4.2::gentoo[git]
# required by layman (argument)
=dev-vcs/git-2.14.2 ~amd64

Would you like to add these changes to your config files? [Yes/No] y

Autounmask changes successfully written.

 * IMPORTANT: 3 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "dev-libs/openssl:0=" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/openssl-1.1.0f::gentoo (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Lars Wendler <polynomial-c@gentoo.org> (26 Aug 2016)
# Masked while being tested and reverse deps aren't fully compatible

- dev-libs/openssl-1.0.2l::gentoo (masked by: backtracking: slot conflict)
- dev-libs/openssl-1.0.2k::gentoo (masked by: backtracking: slot conflict)

(dependency required by "dev-vcs/git-2.14.2::gentoo[-libressl]" [ebuild])
(dependency required by "app-portage/layman-2.4.2::gentoo[git]" [ebuild])
(dependency required by "layman" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Last edited by antonellocaroli on Thu Oct 05, 2017 8:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16904
Location: here

PostPosted: Thu Oct 05, 2017 6:17 pm    Post subject: Reply with quote

Rimuovi globalmente la use flag bindist (quindi nel make.conf) e lancia un
Code:
# emerge -UD @world

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2016
Posts: 123

PostPosted: Thu Oct 05, 2017 8:44 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Rimuovi globalmente la use flag bindist (quindi nel make.conf) e lancia un
Code:
# emerge -UD @world


Perfetto!!! Grazie, risolto.
Back to top
View user's profile Send private message
antonellocaroli
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2016
Posts: 123

PostPosted: Fri Oct 06, 2017 4:53 pm    Post subject: Reply with quote

Risolto, solo che ogni tanto ho questo meggio

Code:


!!! The following installed packages are masked:
- sys-devel/binutils-2.28-r2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16904
Location: here

PostPosted: Fri Oct 06, 2017 6:11 pm    Post subject: Reply with quote

Puoi postare il risultato del comando
Code:
$ qlist -Iv binutils

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2016
Posts: 123

PostPosted: Sat Oct 07, 2017 5:02 am    Post subject: Reply with quote

fedeliallalinea wrote:
Puoi postare il risultato del comando
Code:
$ qlist -Iv binutils


eccolo

Code:
qlist -Iv binutils
sys-devel/binutils-2.28-r2
sys-devel/binutils-config-5-r3
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16904
Location: here

PostPosted: Sat Oct 07, 2017 11:22 am    Post subject: Reply with quote

Aggiorna il tuo sistema visto che la versione stabile ora e' la 2.28.1.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2016
Posts: 123

PostPosted: Sat Oct 07, 2017 5:42 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Aggiorna il tuo sistema visto che la versione stabile ora e' la 2.28.1.


Grazie!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum