Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ glsa 201709-21 ] php
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1969

PostPosted: Sun Sep 24, 2017 10:26 pm    Post subject: [ glsa 201709-21 ] php Reply with quote

Gentoo Linux Security Advisory

Title: PHP: Multiple vulnerabilities (GLSA 201709-21)
Severity: normal
Exploitable: remote
Date: 2017-09-24
Updated: 2017-09-25
Bug(s): #624054, #626460, #629452
ID: 201709-21

Synopsis

Multiple vulnerabilities have been found in PHP, the worst of which
could result in the execution of arbitrary code.


Background

PHP is an open source general-purpose scripting language that is
especially suited for web development.


Affected Packages

Package: dev-lang/php
Vulnerable: < 5.6.31
Vulnerable: < 7.0.23
Unaffected: >= 5.6.31
Unaffected: >= 7.0.23
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PHP. Please review the
referenced CVE identifiers for details.


Impact

A remote attacker could execute arbitrary code with the privileges of
the process or cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All PHP 5.6.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.31"
   
All PHP 7.0.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-lang/php-7.0.23"
   


References


CVE-2017-11362


CVE-2017-11628


CVE-2017-12932


Last edited by GLSA on Tue Sep 26, 2017 4:17 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum