Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Aggiornamenti non trovati
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Sep 19, 2017 7:15 am    Post subject: Reply with quote

grazie del consiglio ! ora cerco una guida per fare un ebuild di termite
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Tue Sep 19, 2017 7:55 am    Post subject: Reply with quote

drudox wrote:
grazie del consiglio ! ora cerco una guida per fare un ebuild di termite

Se ti interessa ho creato l'ebuild di vte con la use flag termite-patch e lo trovi qui
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 6:38 am    Post subject: Reply with quote

ottimo !! grazie ! come lo installo ? scusami ma non ho mai fatto l'installazione di un ebuild ...

ho provato con
Code:
ebuild nome file manifest
ma mi da errore
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Wed Sep 20, 2017 6:43 am    Post subject: Reply with quote

drudox wrote:
ottimo !! grazie ! come lo installo ? scusami ma non ho mai fatto l'installazione di un ebuild ...

Per prima cosa devi crearti un overlay locale e poi aggiungere l'ebuild
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 3:55 pm    Post subject: Reply with quote

non mi funziona ..

Code:
 [root@quad-Gentoo /home/drudox]# cp Scaricati/vte-0.42.3.ebuild /usr/local/portage/app-dicts/vte/
 [root@quad-Gentoo /home/drudox]# pushd /usr/local/portage/app-dicts/vte/
/usr/local/portage/app-dicts/vte /home/drudox
 [root@quad-Gentoo ../portage/app-dicts/vte]# ls
vte-0.42.3.ebuild
 [root@quad-Gentoo ../portage/app-dicts/vte]# cd
 [root@quad-Gentoo ~]# pushd /usr/local/portage/app-dicts/vte/
/usr/local/portage/app-dicts/vte ~ /home/drudox
 [root@quad-Gentoo ../portage/app-dicts/vte]# repoman manifest
bash: repoman: comando non trovato
 [root@quad-Gentoo ../portage/app-dicts/vte]# repoman manifest
bash: repoman: comando non trovato
 [root@quad-Gentoo ../portage/app-dicts/vte]#
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Wed Sep 20, 2017 3:57 pm    Post subject: Reply with quote

Fai manualmente con
Code:
# ebuild /usr/local/portage/app-dicts/vte/vte-0.42.3.ebuild manifest

Devi copiare anche la cartella files in /usr/local/portage/app-dicts/vte prima di fare il manifest
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 4:01 pm    Post subject: Reply with quote

oh no scusa .. non avevo installato repoman !!
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 4:08 pm    Post subject: Reply with quote

dove sbaglio ??

Code:
 [root@quad-Gentoo ../portage/app-dicts/vte]# ebuild /usr/local/portage/app-dicts/vte/vte-0.42.3.ebuild manifest
>>> Creating Manifest for /usr/local/portage/app-dicts/vte
 [root@quad-Gentoo ../portage/app-dicts/vte]# emerge temite --ask

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "temite".

emerge: searching for similar names...
emerge: Maybe you meant any of these: dev-scheme/termite, x11-terms/termite, dev-python/tempita, sys-apps/utempter?
 [root@quad-Gentoo ../portage/app-dicts/vte]# emerge x11-terms/termite
Calculating dependencies... done!
[ebuild     UD ] x11-libs/vte-0.46.2 [0.48.3] USE="termite-patch%*"
[ebuild  N     ] x11-terms/termite-12

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/vte:2.91

  (x11-libs/vte-0.46.2:2.91/2.91::eroen, ebuild scheduled for merge) pulled in by
    >=x11-libs/vte-0.43.2:2.91[termite-patch(-)] required by (x11-terms/termite-12:0/0::eroen, ebuild scheduled for merge)
                                                                                                                                           

  (x11-libs/vte-0.48.3:2.91/2.91::dantrell-gnome-3-24, installed) pulled in by
    >=x11-libs/vte-0.48.2:2.91 required by (x11-terms/gnome-terminal-3.24.2:0/0::dantrell-gnome-3-24, installed)
    ^^             ^^^^^^^^^^^                                                                                                                                                           


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- dev-python/skype4py-1.0.35-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Raymond Jennings <shentino@gmail.com> (11 Jun 2017)
# Upstream announced EOL effective July 2017.
# Depends on qt4 which is being deprecated.
# Possible alternative is skypeforlinux,
# which uses the same account information but has different features.
# See bug #620722 and bug #608174.

- net-im/skype-4.3.0.37-r6::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 4:10 pm    Post subject: Reply with quote

ho gia dato
Code:
emerge --ask --verbose --oneshot app-dicts/vte
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Wed Sep 20, 2017 4:13 pm    Post subject: Reply with quote

Prima di tutto hai sbagliato la categoria che non e' app-dicts man x11-libs.
Quindi rimuovi tutta la cartella /usr/local/portage/app-dicts e poi fai i seguenti comandi
Code:
# mkdir -p /usr/local/portage/x11-libs
# cd /usr/local/portage/x11-libs
# wget "https://drive.google.com/uc?export=download&id=0BwtkLrqFAWz7cEZ3OUpLWHUxamM" -O vte.tar.gz
# tar xzvf vte.tar.gz
# rm vte.tar.gz
# cd vte
# ebuild vte-0.48.3.ebuild manifest

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 4:47 pm    Post subject: Reply with quote

grazie 1000 , sono riuscito ad avere termite senza problemi di compatibilita` :)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Wed Sep 20, 2017 4:52 pm    Post subject: Reply with quote

drudox wrote:
grazie 1000 , sono riuscito ad avere termite senza problemi di compatibilita` :)

E' che appena gnome avra' bisogno di una nuova version di vte avrai ancora lo stesso problema se nell'overlay non sara' presente come questa volta
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 5:03 pm    Post subject: Reply with quote

per adesso va bene cosi` !! .. poi credo gnome usi solo vte per gnome-terminal o sbaglio ? rinuncio volentieri a gnome-terminal se e` l'unico pacchetto che fa` storie ... (a meno che no ci siamo pacchetti che dipendano da gnome-terminal) .. che poi per i problemi che mi da gnome credo che alla fine staro con i3 e mate ! tu cosa usi ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Wed Sep 20, 2017 5:16 pm    Post subject: Reply with quote

drudox wrote:
per adesso va bene cosi` !! .. poi credo gnome usi solo vte per gnome-terminal o sbaglio ? rinuncio volentieri a gnome-terminal se e` l'unico pacchetto che fa` storie ... (a meno che no ci siamo pacchetti che dipendano da gnome-terminal) ..

Il comando equery b gnome-terminal potrebbe tornarti utile per capire se qualcuno dipende da questo pacchetto.

drudox wrote:
tu cosa usi ?

Sono tornato a kde da quando e' arrivata la version 5
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 6:19 pm    Post subject: Reply with quote

Code:
equery b gnome-terminal
 * Searching for gnome-terminal ...
x11-terms/gnome-terminal-3.24.2 (/usr/share/help/C/gnome-terminal)
x11-terms/gnome-terminal-3.24.2 (/usr/bin/gnome-terminal)


se ri capitano problemi rinuncio volentieri a gnome-terminal !
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Wed Sep 20, 2017 6:28 pm    Post subject: Reply with quote

drudox wrote:
se ri capitano problemi rinuncio volentieri a gnome-terminal !

Scusa ho sbagliato lettere non e' 'b' (belongs) ma 'd' (depends) che devi usare
Code:
# equery d gnome-terminal

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Wed Sep 20, 2017 7:41 pm    Post subject: Reply with quote

Code:
equery d gnome-terminal
 * These packages depend on gnome-terminal:
gnome-base/gnome-core-apps-3.24.0 (>=x11-terms/gnome-terminal-3.24.0)

Code:

 equery d gnome-terminal
 * These packages depend on gnome-terminal:
gnome-base/gnome-core-apps-3.24.0 (>=x11-terms/gnome-terminal-3.24.0)
┌─[21:39] drudox@ ─[~/Programming/Fortran/ODE2]
└──> equery d gnome-core-apps
 * These packages depend on gnome-core-apps:
gnome-base/gnome-3.24.0 (>=gnome-base/gnome-core-apps-3.24.0[cups?,bluetooth?,cdr?])


no direi non si possa fare a meno
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22541
Location: here

PostPosted: Wed Sep 20, 2017 7:57 pm    Post subject: Reply with quote

Si potrebbe provare con package.provided ma non so se poi ci sono altre complicazioni
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum