Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201709-09 ] Subversion
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1976

PostPosted: Sun Sep 17, 2017 11:26 pm    Post subject: [ GLSA 201709-09 ] Subversion Reply with quote

Gentoo Linux Security Advisory

Title: Subversion: Arbitrary code execution (GLSA 201709-09)
Severity: normal
Exploitable: remote
Date: 2017-09-17
Bug(s): #627480
ID: 201709-09

Synopsis

A command injection vulnerability in Subversion may allow remote
attackers to execute arbitrary code.


Background

Subversion is a version control system intended to eventually replace
CVS. Like CVS, it has an optional client-server architecture (where the
server can be an Apache server running mod_svn, or an ssh program as in
CVS’s :ext: method). In addition to supporting the features found in
CVS, Subversion also provides support for moving and copying files and
directories.


Affected Packages

Package: dev-vcs/subversion
Vulnerable: < 1.9.7
Unaffected: >= 1.9.7
Unaffected: > 1.8.18 < 1.8.19
Architectures: All supported architectures


Description

Specially crafted ‘ssh://...’ URLs may allow the owner of the
repository to execute arbitrary commands on client’s machine if those
commands are already installed on the client’s system. This is
especially dangerous when the third-party repository has one or more
submodules with specially crafted ‘ssh://...’ URLs. Each time the
repository is recursively cloned or submodules are updated the payload
will be triggered.


Impact

A remote attacker, by enticing a user to clone a specially crafted
repository, could possibly execute arbitrary code with the privileges of
the process.


Workaround

There are several alternative ways to fix this vulnerability. Please
refer to Subversion Team Announce for more details.


Resolution

All Subversion 1.9.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-vcs/subversion-1.9.7"
   
All Subversion 1.8.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-vcs/subversion-1.8.18"
   


References


CVE-2017-9800


Subversion Team Announce
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum