Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLU] Paquets dépendants de OpenSSL au lieu de LibreSSL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sat Sep 16, 2017 6:57 pm    Post subject: [RESOLU] Paquets dépendants de OpenSSL au lieu de LibreSSL Reply with quote

Bonsoir,

J'aimerai passer de OpenSSL à LibreSSL, mais malheureusement certains paquets dépendent de OpenSSL.
Si je veut faire ce changement c'est parce que OpenSSL 1.1.0f cause des erreurs et des conflits sur mon système.

Paquets compatibles uniquement OpenSSL:
Code:

dev-qt/qtnetwork-5.7.1
kde-frameworks/kdelibs4support-5.34.0
kde-frameworks/khtml-5.34.0
media-video/ffmpeg-3.2.6


Malheureusement je ne peux les désinstaller car certains logiciels dépendent d'eux.
Du coup je suis bloqué..

Auriez-vous une solution ?
J'aimerai bien faire une mise à jour global du système, mais lors de celle-ci openssl 1.1 veut s'installer.

Ah, et je suis sur une version de Gentoo datant du 1er septembre (2017) et en amd64.
_________________
- Luh

You're not bad at something, you're just better for doing other things.


Last edited by Luh on Sun Sep 17, 2017 3:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 667
Location: S.O. France

PostPosted: Sun Sep 17, 2017 8:41 am    Post subject: Reply with quote

Salut,

Tu peux suivre ce bug https://bugs.gentoo.org/561854

Par contre à partir du moment ou un paquet aura besoin de openssl, tu auras le conflit openssl/libressl
Back to top
View user's profile Send private message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sun Sep 17, 2017 8:42 am    Post subject: Reply with quote

Salut,

J'ai jeté un coup d'oeil sur le bugzilla et d'après https://bugs.gentoo.org/562050, c'est impossible.
Du coup je suis obligé de tout faire avec OpenSSL. Sauf que dev-lang/python-2.7.12 ne veut pas compiler avec la version 1.1.0f.

Message d'erreur lors de la compilation:
https://pastebin.com/PHh3vcjp

Y-a-t-il un moyen de spécifier la version à utiliser pour un paquet ? Ou pour le système entier ?
_________________
- Luh

You're not bad at something, you're just better for doing other things.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 667
Location: S.O. France

PostPosted: Sun Sep 17, 2017 9:16 am    Post subject: Reply with quote

https://bugs.gentoo.org/592480

Une raison d'utiliser la version testing d'openssl?
Back to top
View user's profile Send private message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sun Sep 17, 2017 9:36 am    Post subject: Reply with quote

sebB wrote:
https://bugs.gentoo.org/592480

Une raison d'utiliser la version testing d'openssl?


Tu voulais dire de ne pas utiliser la version 1.1.0 ?
J'ai le même soucis avec python 2.7.13:
https://pastebin.com/GwP0aZFp
_________________
- Luh

You're not bad at something, you're just better for doing other things.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 667
Location: S.O. France

PostPosted: Sun Sep 17, 2017 11:21 am    Post subject: Reply with quote

Quote:
Tu voulais dire de ne pas utiliser la version 1.1.0 ?

Oui. Tu as absolument bezoin de la version testing?
Le problème ne vient pas des versions de python mais de openssl
Back to top
View user's profile Send private message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sun Sep 17, 2017 12:11 pm    Post subject: Reply with quote

sebB wrote:
Quote:
Tu voulais dire de ne pas utiliser la version 1.1.0 ?

Oui. Tu as absolument bezoin de la version testing?
Le problème ne vient pas des versions de python mais de openssl


Si seulement c'était si simple :D
J'ai trois paquets qui dépendent d'openssl 1.1

Code:
# emerge -aq =openssl-1.0.2l

 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

[ebuild     UD] dev-libs/openssl-1.0.2l [1.1.0f]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2l:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/openssl-1.0.2l (Argument)
    dev-libs/openssl:0/0= required by (www-client/w3m-0.5.3-r9:0/0::gentoo, installed)
                    ^^^^^                                                                                                 
    (and 17 more with the same problems)

  (dev-libs/openssl-1.1.0f:0/1.1::gentoo, installed) pulled in by
    dev-libs/openssl:0/1.1=[abi_x86_64(-)] required by (net-misc/curl-7.55.1:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                             
    (and 2 more with the same problem)


Code:
# emerge -aq =openssl-1.0.2l --verbose-conflicts
  (dev-libs/openssl-1.1.0f:0/1.1::gentoo, installed) pulled in by
    dev-libs/openssl:0/1.1= required by (dev-perl/Net-SSLeay-1.810.0:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                     
    dev-libs/openssl:0/1.1= required by (net-misc/socat-1.7.3.2:0/0::gentoo, installed)
                    ^^^^^^^                                                                                               
    dev-libs/openssl:0/1.1=[abi_x86_64(-)] required by (net-misc/curl-7.55.1:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                             



Une idée ?
_________________
- Luh

You're not bad at something, you're just better for doing other things.


Last edited by Luh on Sun Sep 17, 2017 12:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16875
Location: here

PostPosted: Sun Sep 17, 2017 12:14 pm    Post subject: Reply with quote

No curl n'a pas besoin de openssl-1.1.0, c'est un bug du portage

EDIT: Tu peux essayer avec emerge -uDa =dev-libs/openssl-1.0.2l --backtrack=30
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sun Sep 17, 2017 1:19 pm    Post subject: Reply with quote

fedeliallalinea wrote:
No curl n'a pas besoin de openssl-1.1.0, c'est un bug du portage

EDIT: Tu peux essayer avec emerge -uDa =dev-libs/openssl-1.0.2l --backtrack=30


J'ai désinstallé la version 1.1 et je l'ai masquée.
Mais je n'arrive toujours pas à dire à dev-perl/Net-SSLeay, net-misc/curl et net-misc/socat d'utiliser la version 1.0.2l.

Code:
 
# emerge -uDa =dev-libs/openssl-1.0.2l --backtrack=30 --verbose-conflicts

[...]

(dev-libs/openssl-1.1.0f:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0/1.1=[abi_x86_64(-)] required by (net-misc/curl-7.55.1:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                             
    dev-libs/openssl:0/1.1= required by (dev-perl/Net-SSLeay-1.810.0:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                     
    dev-libs/openssl:0/1.1= required by (net-misc/socat-1.7.3.2:0/0::gentoo, installed)


Ensuite il me redemande de démasquer la version 1.1.0f...

Comment dois-je procéder ?
_________________
- Luh

You're not bad at something, you're just better for doing other things.
Back to top
View user's profile Send private message
Luh
n00b
n00b


Joined: 02 Sep 2017
Posts: 8
Location: Switzerland

PostPosted: Sun Sep 17, 2017 1:31 pm    Post subject: Reply with quote

Luh wrote:
fedeliallalinea wrote:
No curl n'a pas besoin de openssl-1.1.0, c'est un bug du portage

EDIT: Tu peux essayer avec emerge -uDa =dev-libs/openssl-1.0.2l --backtrack=30


J'ai désinstallé la version 1.1 et je l'ai masquée.
Mais je n'arrive toujours pas à dire à dev-perl/Net-SSLeay, net-misc/curl et net-misc/socat d'utiliser la version 1.0.2l.

Code:
 
# emerge -uDa =dev-libs/openssl-1.0.2l --backtrack=30 --verbose-conflicts

[...]

(dev-libs/openssl-1.1.0f:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0/1.1=[abi_x86_64(-)] required by (net-misc/curl-7.55.1:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                             
    dev-libs/openssl:0/1.1= required by (dev-perl/Net-SSLeay-1.810.0:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                     
    dev-libs/openssl:0/1.1= required by (net-misc/socat-1.7.3.2:0/0::gentoo, installed)


Ensuite il me redemande de démasquer la version 1.1.0f...

Comment dois-je procéder ?


Je crois avoir trouvé la solution, j'ai fait ces commandes et ça fonctionne :
Code:

# Installe la version 1.0.2l, la version 1.1.0f étant masquée (elle peut être dans le package.unmask, il faut l'enlever)
emerge -aq dev-libs/openssl
# Recompile les programmes qui utilisaient la version 1.1:
emerge -aq
emerge net-misc/curl
dev-perl/Net-SSLeay
net-misc/socat
# Mise à jour du système
emerge -aDNquv @world


Je met le poste en résolu si tout est bon une fois la MaJ faite.
Merci de votre aide en tous cas !
_________________
- Luh

You're not bad at something, you're just better for doing other things.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum