Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi con conky e qtwebkit
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
zar Marco
Apprentice
Apprentice


Joined: 09 Sep 2016
Posts: 240
Location: Colle Umberto ( TV )

PostPosted: Thu Sep 14, 2017 1:54 pm    Post subject: Problemi con conky e qtwebkit Reply with quote

Ciao ragazzi, in fase di aggiornamento ho avuto questi problemi. Come potrei risolvere?

Questo di conky https://paste.pound-python.org/show/TluJdmC8TAZetQfKPASV/
Questo di qtwebkit https://paste.pound-python.org/show/UNzXY6T9CFTsZfeFE4nr/
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 15981
Location: here

PostPosted: Thu Sep 14, 2017 2:07 pm    Post subject: Reply with quote

Per qwebkit devi selezionare ruby 2.2 con eselect
Code:
# eselect ruby list
...
# eselect ruby set ruby22


Per conky apri un thread nuovo (la politica e' un problema un thread), e aggiungi l'output con wgetpaste di /var/tmp/portage/app-admin/conky-1.10.4/work/conky-1.10.4_build/CMakeFiles/CMakeOutput.log e /var/tmp/portage/app-admin/conky-1.10.4/work/conky-1.10.4_build/CMakeFiles/CMakeError.log
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Apprentice
Apprentice


Joined: 09 Sep 2016
Posts: 240
Location: Colle Umberto ( TV )

PostPosted: Fri Sep 15, 2017 3:53 pm    Post subject: Reply with quote

Ok, grazie, risolto il problema con qwebkit . Detto ciò, da cosa hai capito qual'era il problema?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 15981
Location: here

PostPosted: Fri Sep 15, 2017 7:23 pm    Post subject: Reply with quote

zar Marco wrote:
Ok, grazie, risolto il problema con qwebkit . Detto ciò, da cosa hai capito qual'era il problema?

Vedendo il messaggio
Code:
/usr/lib64/ruby/2.1.0/rubygems.rb:15:in `require': cannot load such file -- rubygems/compatibility (LoadError)
   from /usr/lib64/ruby/2.1.0/rubygems.rb:15:in `<top (required)>'
   from <internal:gem_prelude>:1:in `require'
   from <internal:gem_prelude>:1:in `<compiled>'

ho visto che cercava ancora ruby 2.1 ma nel portage e' mascherato da un po', quindi la prima cosa che mi e' venuta in mente e' che dovevi settare ruby 2.2 nel tuo sistema
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Apprentice
Apprentice


Joined: 09 Sep 2016
Posts: 240
Location: Colle Umberto ( TV )

PostPosted: Fri Sep 15, 2017 8:44 pm    Post subject: Reply with quote

Ok, grazie. Ora apro il topic per conky
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum