Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox sound doesn't work after installing adblockers
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2418

PostPosted: Wed Sep 13, 2017 1:35 pm    Post subject: Reply with quote

Good to know. So it's time for testing (next firefox release) with USE=pulseaudio enabled.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 6246
Location: almost Mile High in the USA

PostPosted: Wed Sep 13, 2017 3:23 pm    Post subject: Reply with quote

Ah, now that makes it clear, I thought there was some version that makes libpulse a hard dep due to bit rot.
What sucks is that it's the slow machines that I'd like to avoid pulseaudio but those are the ones that need to recompile firefox. Go figure. *sigh*
I transitioned pretty much all of my fast machines to pulseaudio as that was the easiest solution and so far, none of them have problems with sound.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1668
Location: Edinburgh, UK

PostPosted: Wed Sep 13, 2017 8:00 pm    Post subject: Reply with quote

Hi there,

Anarchy wrote:
If you sync and re-emerge firefox you will have working sound. We enabled firefox bpf sandbox which is what broke alsa. Once firefox-52.x is EOL we will not support anything othen pulse audio in both firefox and firefox-bin.


I'll try doing this just now. Hopefully it'll work. I run an old system, so it takes a long time to emerge firefox.

As per pulseaudio becoming a hard dependency, I'll cross that bridge when I come to it, but I won't be installing pulseaudio as my system is old and I doubt it will play well.

Best,

Alex
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11280

PostPosted: Thu Sep 14, 2017 12:36 am    Post subject: Reply with quote

Anarchy: are there plans to allow Firefox to build without pulseaudio for users who are willing to have no sound at all? I like my webpages silent, so I have no problem dropping sound support if it means avoiding pulseaudio.
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1668
Location: Edinburgh, UK

PostPosted: Thu Sep 14, 2017 5:47 pm    Post subject: Reply with quote

Hi all,

Sound is indeed working again after I synced and re-emerged firefox.

The only mystery left is why youtube has become so damn slow of late. I mean, it's barely usable. All other webpages don't present a problem.

Best,

Alex
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum