Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Tue Sep 05, 2017 2:47 pm    Post subject: Wireless doesn't work Reply with quote

Hi everyone,

Recently I installed Gentoo on new HP 15-bs020nd laptop.

After following the wifi guide, wlan interface still doesn't appear in the ip addr list

Here is output of dmesg | grep firmware

Code:
[    0.766835] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[    0.766846] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.
[    2.803494] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-29.ucode failed with error -2
[    2.803626] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-28.ucode failed with error -2
[    2.807549] iwlwifi 0000:02:00.0: loaded firmware version 27.455470.0 op_mode iwlmvm

This is output of ip addr

Code:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 brd 127.255.255.255 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether f4:30:b9:52:9a:8d brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.249/24 brd 192.168.0.255 scope global eno1
       valid_lft forever preferred_lft forever
    inet6 fe80::62af:f22:734e:88a5/64 scope link
       valid_lft forever preferred_lft forever
3: sit0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default qlen 1000
    link/sit 0.0.0.0 brd 0.0.0.0

Also output of lshw -c network

Code:
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eno1
       version: 15
       serial: f4:30:b9:52:9a:8d
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.0.249 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:124 ioport:3000(size=256) memory:b1104000-b1104fff memory:b1100000-b1103fff
  *-network
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=iwlwifi latency=0
       resources: irq:126 memory:b1000000-b1001fff


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1324
Location: Montréal

PostPosted: Tue Sep 05, 2017 3:37 pm    Post subject: Reply with quote

You are better to use the command
Code:
ip l
or
ip link show

to see the network links active or not. ip addr is to show the Ip address of each network link. Be sure that all the firmware files that iwlwifi need are available at the moment it probe the device. If you compile iwlwifi in the kernel image the firmware files must be in the kernel image themselves or in an initramfs.
_________________
Paul
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Tue Sep 05, 2017 3:58 pm    Post subject: Reply with quote

I just did ip l, and this is what is says

Code:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether f4:30:b9:52:9a:8d brd ff:ff:ff:ff:ff:ff
3: sit0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/sit 0.0.0.0 brd 0.0.0.0

When configuring the kernel, I installed the wifi drivers as modules. How can I check if the firmware is in the kernel image?

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1324
Location: Montréal

PostPosted: Tue Sep 05, 2017 4:08 pm    Post subject: Reply with quote

If iwlwifi is in module you need the iwlwifi firmware files installed or at least the linux-firmware package. The firmware files are in the /lib/firmware directory. You can see the full path of the ones iwlwifi need with the output of
Code:
modinfo iwlwifi

_________________
Paul
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2445

PostPosted: Tue Sep 05, 2017 4:27 pm    Post subject: Re: Wireless doesn't work Reply with quote

concerned wrote:
Hi everyone,

Recently I installed Gentoo on new HP 15-bs020nd laptop.

After following the wifi guide, wlan interface still doesn't appear in the ip addr list

Here is output of dmesg | grep firmware

[ 0.766835] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[ 0.766846] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.
[ 2.803494] iwlwifi

Proceed with https://wiki.gentoo.org/wiki/Iwlwifi.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16928
Location: here

PostPosted: Tue Sep 05, 2017 6:06 pm    Post subject: Re: Wireless doesn't work Reply with quote

charles17 wrote:
Proceed with https://wiki.gentoo.org/wiki/Iwlwifi.

In particular Firmware section
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Tue Sep 05, 2017 8:09 pm    Post subject: Reply with quote

After going through dmesg log I noticed that there is one error related to iwlmvm

Code:
[    2.848890] iwlmvm: Unknown symbol dev_coredumpsg (err 0)


I checked this table, my wifi is Intel 3168, and as I can see the firmware supports kernel versions 4.6+, and my current kernel is 4.12.5.

I am wondering,

1. Do you think it is possible to update the kernel to suitable version without breaking Gentoo?

2. Will that fix this problem?
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Tue Sep 05, 2017 10:38 pm    Post subject: Reply with quote

concerned wrote:

I checked this table, my wifi is Intel 3168, and as I can see the firmware supports kernel versions 4.6+, and my current kernel is 4.12.5.

I am wondering,
1. Do you think it is possible to update the kernel to suitable version without breaking Gentoo?
2. Will that fix this problem?

With regards to 1. upgrading the kernel shouldn't break gentoo, and you should always have your last built kernel available as a fallback anyway, but
with regards to 2. as 4.12 is already > 4.6 this probably wont help - I haven't synced this machine this week, but 4.12.5 is the latest stable kernel I have available. I'd leave that alone.

As for this issue -
Quote:
After going through dmesg log I noticed that there is one error related to iwlmvm
Code:
[    2.848890] iwlmvm: Unknown symbol dev_coredumpsg (err 0)

So looking at the machine I am on:
Code:
ian@lw3 /usr/src/linux $ grep -R dev_coredumpsg ./
./include/linux/devcoredump.h:void dev_coredumpsg(struct device *dev, struct scatterlist *table,
./include/linux/devcoredump.h:static inline void dev_coredumpsg(struct device *dev, struct scatterlist *table,
./drivers/base/devcoredump.c:void dev_coredumpsg(struct device *dev, struct scatterlist *table,
./drivers/base/devcoredump.c:EXPORT_SYMBOL_GPL(dev_coredumpsg);

EXPORT_SYMBOL_GPL is telling you that you need dev_coredump enabled in your kernel.

Looking on this machine
Code:
ian@lw3 /usr/src/linux $ grep -i coredump ./drivers/base/Kconfig
config WANT_DEV_COREDUMP
     device coredump mechanism.
config ALLOW_DEV_COREDUMP
   bool "Allow device coredump" if EXPERT
     This option controls if the device coredump mechanism is available or
config DEV_COREDUMP
   default y if WANT_DEV_COREDUMP
   depends on ALLOW_DEV_COREDUMP

So you will need both DEV_COREDUMP and CONFIG_EXPERT in the kernel on this machine
Code:
ian@lw3 /usr/src/linux $ grep -i dev_coredump /usr/src/linux/.config
CONFIG_ALLOW_DEV_COREDUMP=y
so dev_coredump is set. I don't recall doing that, I'd guess it is on by default so is config_expert set?
Code:
ian@lw3 /usr/src/linux $ grep -i expert /usr/src/linux/.config
# CONFIG_RCU_EXPERT is not set
# CONFIG_EXPERT is not set
Okay, so without config_expert
Quote:
bool "Allow device coredump" if EXPERT
coredump is disabled.
So go into menuconfig and turn on EXPERT (you can search from menuconfig using / ie. '/ EXPERT') and COREDUMP if required, then recompile your kernel and you should be good to go.

Hope that helps.

edit typos
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2445

PostPosted: Wed Sep 06, 2017 6:01 am    Post subject: Reply with quote

concerned wrote:
After going through dmesg log I noticed that there is one error related to iwlmvm

Code:
[    2.848890] iwlmvm: Unknown symbol dev_coredumpsg (err 0)

Will you please give some more output as from
Code:
dmesg | grep -i -E '00:02.0|wlp|iwl|80211|firmware'
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 8:10 am    Post subject: Reply with quote

ian.au wrote:
concerned wrote:

I checked this table, my wifi is Intel 3168, and as I can see the firmware supports kernel versions 4.6+, and my current kernel is 4.12.5.

I am wondering,
1. Do you think it is possible to update the kernel to suitable version without breaking Gentoo?
2. Will that fix this problem?

With regards to 1. upgrading the kernel shouldn't break gentoo, and you should always have your last built kernel available as a fallback anyway, but
with regards to 2. as 4.12 is already > 4.6 this probably wont help - I haven't synced this machine this week, but 4.12.5 is the latest stable kernel I have available. I'd leave that alone.

As for this issue -
Quote:
After going through dmesg log I noticed that there is one error related to iwlmvm
Code:
[    2.848890] iwlmvm: Unknown symbol dev_coredumpsg (err 0)

So looking at the machine I am on:
Code:
ian@lw3 /usr/src/linux $ grep -R dev_coredumpsg ./
./include/linux/devcoredump.h:void dev_coredumpsg(struct device *dev, struct scatterlist *table,
./include/linux/devcoredump.h:static inline void dev_coredumpsg(struct device *dev, struct scatterlist *table,
./drivers/base/devcoredump.c:void dev_coredumpsg(struct device *dev, struct scatterlist *table,
./drivers/base/devcoredump.c:EXPORT_SYMBOL_GPL(dev_coredumpsg);

EXPORT_SYMBOL_GPL is telling you that you need dev_coredump enabled in your kernel.

Looking on this machine
Code:
ian@lw3 /usr/src/linux $ grep -i coredump ./drivers/base/Kconfig
config WANT_DEV_COREDUMP
     device coredump mechanism.
config ALLOW_DEV_COREDUMP
   bool "Allow device coredump" if EXPERT
     This option controls if the device coredump mechanism is available or
config DEV_COREDUMP
   default y if WANT_DEV_COREDUMP
   depends on ALLOW_DEV_COREDUMP

So you will need both DEV_COREDUMP and CONFIG_EXPERT in the kernel on this machine
Code:
ian@lw3 /usr/src/linux $ grep -i dev_coredump /usr/src/linux/.config
CONFIG_ALLOW_DEV_COREDUMP=y
so dev_coredump is set. I don't recall doing that, I'd guess it is on by default so is config_expert set?
Code:
ian@lw3 /usr/src/linux $ grep -i expert /usr/src/linux/.config
# CONFIG_RCU_EXPERT is not set
# CONFIG_EXPERT is not set
Okay, so without config_expert
Quote:
bool "Allow device coredump" if EXPERT
coredump is disabled.
So go into menuconfig and turn on EXPERT (you can search from menuconfig using / ie. '/ EXPERT') and COREDUMP if required, then recompile your kernel and you should be good to go.

Hope that helps.

edit typos


Thanks for the reply Ian,

I did turn on EXPERT=y, and COREDUMP was already on. There is also RCU_EXPERT which is still off. I recompiled and rebooted, but still wifi doesn't work.

charles17 wrote:
concerned wrote:
After going through dmesg log I noticed that there is one error related to iwlmvm

Code:
[    2.848890] iwlmvm: Unknown symbol dev_coredumpsg (err 0)

Will you please give some more output as from
Code:
dmesg | grep -i -E '00:02.0|wlp|iwl|80211|firmware'

Charles, here is the result

Code:
[    0.470554] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.518461] pci 0000:00:02.0: [8086:1916] type 00 class 0x030000
[    0.518473] pci 0000:00:02.0: reg 0x10: [mem 0xb0000000-0xb0ffffff 64bit]
[    0.518480] pci 0000:00:02.0: reg 0x18: [mem 0xa0000000-0xafffffff 64bit pref]
[    0.518485] pci 0000:00:02.0: reg 0x20: [io  0x4000-0x403f]
[    0.533761] pci 0000:02:00.0: [8086:24fb] type 00 class 0x028000
[    0.533854] pci 0000:02:00.0: reg 0x10: [mem 0xb1000000-0xb1001fff 64bit]
[    0.534190] pci 0000:02:00.0: PME# supported from D0 D3hot D3cold
[    0.534378] pci 0000:02:00.0: System wakeup disabled by ACPI
[    0.542479] pci 0000:00:02.0: vgaarb: setting as boot VGA device
[    0.542487] pci 0000:00:02.0: vgaarb: VGA device added: decodes=io+mem,owns=io+mem,locks=none
[    0.542501] pci 0000:00:02.0: vgaarb: bridge control possible
[    0.671198] pci 0000:00:02.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
[    0.767218] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[    0.767229] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.
[    0.767922] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    0.776673] [drm] Initialized i915 1.6.0 20170403 for 0000:00:02.0 on minor 0
[    1.875700] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops 0xffffffff8b0a9c80)
[    1.934749] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    2.777437] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-29.ucode failed with error -2
[    2.777555] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-28.ucode failed with error -2
[    2.785024] iwlwifi 0000:02:00.0: capa flags index 3 larger than supported by driver
[    2.785335] iwlwifi 0000:02:00.0: loaded firmware version 27.455470.0 op_mode iwlmvm
[    2.804729] iwlmvm: Unknown symbol dev_coredumpsg (err 0)


-----------------

For testing I booted the minimal install Gentoo image, and there wlan seems to be recognized. I did "modinfo_iwlwifi", and I can see this difference

On the non-working wifi install

Code:
depends:        cfg80211
vermagic:       4.12.5-gentoo SMP mod_unload modversions


On the working live minimal image

Code:
depends:
vermagic:       4.12.5-gentoo SMP mod_unload
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Wed Sep 06, 2017 8:24 am    Post subject: Reply with quote

concerned,
Quote:
I did turn on EXPERT=y, and COREDUMP was already on. There is also RCU_EXPERT which is still off. I recompiled and rebooted, but still wifi doesn't work.


Well as expert was off I'd suspect that was part of your problem. Did you point your bootloader to the newly compiled kernel?

Does
Code:
uname -a
list your most recently compiled kernel?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2445

PostPosted: Wed Sep 06, 2017 8:32 am    Post subject: Reply with quote

concerned wrote:
Charles, here is the result

Code:
[    0.470554] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.518461] pci 0000:00:02.0: [8086:1916] type 00 class 0x030000
[    0.518473] pci 0000:00:02.0: reg 0x10: [mem 0xb0000000-0xb0ffffff 64bit]
[    0.518480] pci 0000:00:02.0: reg 0x18: [mem 0xa0000000-0xafffffff 64bit pref]
[    0.518485] pci 0000:00:02.0: reg 0x20: [io  0x4000-0x403f]
[    0.533761] pci 0000:02:00.0: [8086:24fb] type 00 class 0x028000
[    0.533854] pci 0000:02:00.0: reg 0x10: [mem 0xb1000000-0xb1001fff 64bit]
[    0.534190] pci 0000:02:00.0: PME# supported from D0 D3hot D3cold
[    0.534378] pci 0000:02:00.0: System wakeup disabled by ACPI
[    0.542479] pci 0000:00:02.0: vgaarb: setting as boot VGA device
[    0.542487] pci 0000:00:02.0: vgaarb: VGA device added: decodes=io+mem,owns=io+mem,locks=none
[    0.542501] pci 0000:00:02.0: vgaarb: bridge control possible
[    0.671198] pci 0000:00:02.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
[    0.767218] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[    0.767229] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.
[    0.767922] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    0.776673] [drm] Initialized i915 1.6.0 20170403 for 0000:00:02.0 on minor 0
[    1.875700] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops 0xffffffff8b0a9c80)
[    1.934749] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    2.777437] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-29.ucode failed with error -2
[    2.777555] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-28.ucode failed with error -2
[    2.785024] iwlwifi 0000:02:00.0: capa flags index 3 larger than supported by driver
[    2.785335] iwlwifi 0000:02:00.0: loaded firmware version 27.455470.0 op_mode iwlmvm
[    2.804729] iwlmvm: Unknown symbol dev_coredumpsg (err 0)


Sorry, I was mistaken about the pci port. Could you please adjust to:
Code:
dmesg | grep -i -E '02:00.0|wlp|iwl|80211|firmware'
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 8:44 am    Post subject: Reply with quote

ian.au wrote:
concerned,
Quote:
I did turn on EXPERT=y, and COREDUMP was already on. There is also RCU_EXPERT which is still off. I recompiled and rebooted, but still wifi doesn't work.


Well as expert was off I'd suspect that was part of your problem. Did you point your bootloader to the newly compiled kernel?

Does
Code:
uname -a
list your most recently compiled kernel?


Actually it points to old Kernel compiled 3 days ago. This is what I did to recompile it

Code:
make menuconfig #make some changes to turn on EXPERT
save to .config
make -j3
make install
grub-mkconfig /boot/grub/grub.cfg #this one reported that it found 2 kernels, one new one old
reboot the PC
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 8:47 am    Post subject: Reply with quote

charles17 wrote:
concerned wrote:
Charles, here is the result

Code:
[    0.470554] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.518461] pci 0000:00:02.0: [8086:1916] type 00 class 0x030000
[    0.518473] pci 0000:00:02.0: reg 0x10: [mem 0xb0000000-0xb0ffffff 64bit]
[    0.518480] pci 0000:00:02.0: reg 0x18: [mem 0xa0000000-0xafffffff 64bit pref]
[    0.518485] pci 0000:00:02.0: reg 0x20: [io  0x4000-0x403f]
[    0.533761] pci 0000:02:00.0: [8086:24fb] type 00 class 0x028000
[    0.533854] pci 0000:02:00.0: reg 0x10: [mem 0xb1000000-0xb1001fff 64bit]
[    0.534190] pci 0000:02:00.0: PME# supported from D0 D3hot D3cold
[    0.534378] pci 0000:02:00.0: System wakeup disabled by ACPI
[    0.542479] pci 0000:00:02.0: vgaarb: setting as boot VGA device
[    0.542487] pci 0000:00:02.0: vgaarb: VGA device added: decodes=io+mem,owns=io+mem,locks=none
[    0.542501] pci 0000:00:02.0: vgaarb: bridge control possible
[    0.671198] pci 0000:00:02.0: Video device with shadowed ROM at [mem 0x000c0000-0x000dffff]
[    0.767218] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[    0.767229] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.
[    0.767922] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    0.776673] [drm] Initialized i915 1.6.0 20170403 for 0000:00:02.0 on minor 0
[    1.875700] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops 0xffffffff8b0a9c80)
[    1.934749] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    2.777437] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-29.ucode failed with error -2
[    2.777555] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-28.ucode failed with error -2
[    2.785024] iwlwifi 0000:02:00.0: capa flags index 3 larger than supported by driver
[    2.785335] iwlwifi 0000:02:00.0: loaded firmware version 27.455470.0 op_mode iwlmvm
[    2.804729] iwlmvm: Unknown symbol dev_coredumpsg (err 0)


Sorry, I was mistaken about the pci port. Could you please adjust to:
Code:
dmesg | grep -i -E '02:00.0|wlp|iwl|80211|firmware'


No problem, here is the new report
Code:
[    0.471673] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.534783] pci 0000:02:00.0: [8086:24fb] type 00 class 0x028000
[    0.534927] pci 0000:02:00.0: reg 0x10: [mem 0xb1000000-0xb1001fff 64bit]
[    0.535375] pci 0000:02:00.0: PME# supported from D0 D3hot D3cold
[    0.535615] pci 0000:02:00.0: System wakeup disabled by ACPI
[    0.768691] i915 0000:00:02.0: Direct firmware load for i915/skl_dmc_ver1_26.bin failed with error -2
[    0.768701] i915 0000:00:02.0: Failed to load DMC firmware [https://01.org/linuxgraphics/downloads/firmware], disabling runtime power management.
[    2.818620] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-29.ucode failed with error -2
[    2.818740] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-3168-28.ucode failed with error -2
[    2.822413] iwlwifi 0000:02:00.0: capa flags index 3 larger than supported by driver
[    2.822703] iwlwifi 0000:02:00.0: loaded firmware version 27.455470.0 op_mode iwlmvm
[    2.846187] iwlmvm: Unknown symbol dev_coredumpsg (err 0)
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Wed Sep 06, 2017 8:55 am    Post subject: Reply with quote

concerned wrote:
ian.au wrote:
concerned,
Quote:
I did turn on EXPERT=y, and COREDUMP was already on. There is also RCU_EXPERT which is still off. I recompiled and rebooted, but still wifi doesn't work.


Well as expert was off I'd suspect that was part of your problem. Did you point your bootloader to the newly compiled kernel?

Does
Code:
uname -a
list your most recently compiled kernel?


Actually it points to old Kernel compiled 3 days ago. This is what I did to recompile it

Code:
make menuconfig #make some changes to turn on EXPERT
save to .config
make -j3
make install
grub-mkconfig /boot/grub/grub.cfg #this one reported that it found 2 kernels, one new one old
reboot the PC


Try
Code:
cd /usr/src/linux
make && make modules_install
make install
grub-mkconfig -o /boot/grub/grub.cfg


And see which kernel you boot then.
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 9:03 am    Post subject: Reply with quote

ian.au wrote:
concerned wrote:
ian.au wrote:
concerned,
Quote:
I did turn on EXPERT=y, and COREDUMP was already on. There is also RCU_EXPERT which is still off. I recompiled and rebooted, but still wifi doesn't work.


Well as expert was off I'd suspect that was part of your problem. Did you point your bootloader to the newly compiled kernel?

Does
Code:
uname -a
list your most recently compiled kernel?


Actually it points to old Kernel compiled 3 days ago. This is what I did to recompile it

Code:
make menuconfig #make some changes to turn on EXPERT
save to .config
make -j3
make install
grub-mkconfig /boot/grub/grub.cfg #this one reported that it found 2 kernels, one new one old
reboot the PC


Try
Code:
cd /usr/src/linux
make && make modules_install
make install
grub-mkconfig -o /boot/grub/grub.cfg


And see which kernel you boot then.


I still have old kernel with a date of Sep 3
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Wed Sep 06, 2017 9:22 am    Post subject: Reply with quote

Okay, what is in
Code:
ls -l /usr/src/linux/arch/x86/boot/bzImage
and
Code:
ls -l /boot
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 9:33 am    Post subject: Reply with quote

ian.au wrote:
Okay, what is in
Code:
ls -l /usr/src/linux/arch/x86/boot/bzImage
and
Code:
ls -l /boot

Ian, here is the output
Code:
localhost ~ # ls -l /usr/src/linux/arch/x86/boot/bzImage
-rw-r--r-- 1 root root 8602384 Sep  6 13:01 /usr/src/linux/arch/x86/boot/bzImage
localhost ~ # ls -l /boot
total 25316
-rw-r--r-- 1 root root  114668 Sep  6 13:01 config-4.12.5-gentoo
-rw-r--r-- 1 root root  114668 Sep  6 12:39 config-4.12.5-gentoo.old
drwxr-xr-x 2 root root    4096 Sep  6 13:01 grub
-rw-r--r-- 1 root root 4238514 Sep  6 13:01 System.map-4.12.5-gentoo
-rw-r--r-- 1 root root 4238514 Sep  6 12:39 System.map-4.12.5-gentoo.old
-rw-r--r-- 1 root root 8602384 Sep  6 13:01 vmlinuz-4.12.5-gentoo
-rw-r--r-- 1 root root 8602384 Sep  6 12:39 vmlinuz-4.12.5-gentoo.old
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Wed Sep 06, 2017 9:38 am    Post subject: Reply with quote

concerned,

That all looks okay, you did reboot after the last grub-mkconfig ..?
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 9:40 am    Post subject: Reply with quote

ian.au wrote:
concerned,

That all looks okay, you did reboot after the last grub-mkconfig ..?

Yes I rebooted after the grub-mkconfig
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Wed Sep 06, 2017 9:50 am    Post subject: Reply with quote

Did you perhaps fail to mount /boot before copying the kernel over?

Can you post
Code:
uname -a &&mount
for me?
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 10:07 am    Post subject: Reply with quote

ian.au wrote:
Did you perhaps fail to mount /boot before copying the kernel over?

Can you post
Code:
uname -a &&mount
for me?

As I understand the /boot folder is on the main /dev/sda4 partition that is mounted at /, here is the result
Code:
Linux localhost 4.12.5-gentoo #1 SMP Sun Sep 3 03:26:48 CEST 2017 x86_64 Intel(R) Core(TM) i3-6006U CPU @ 2.00GHz GenuineIntel GNU/Linux
/dev/sda4 on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=494606,mode=755)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nodev,relatime,size=395992k,mode=755)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
selinuxfs on /sys/fs/selinux type selinuxfs (rw,relatime)
efivarfs on /sys/firmware/efi/efivars type efivarfs (ro,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc)
cpuset on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cpuacct on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
freezer on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Wed Sep 06, 2017 10:23 am    Post subject: Reply with quote

concerned,

boot is not mounted, and I would say that was the case when you copied your kernel over.

That means your latest kernel is now in a directory /boot on sda4

You can proceed in either one of two ways, copy the relevant files from/boot/* to ie /tmp/boot then mount /boot and copy them back to the new mount and reboot

Or just mount the /boot partition, re-compile kernel and run grub-mkconfig again and reboot
Back to top
View user's profile Send private message
concerned
n00b
n00b


Joined: 05 Sep 2017
Posts: 22

PostPosted: Wed Sep 06, 2017 11:18 am    Post subject: Reply with quote

ian.au wrote:
concerned,

boot is not mounted, and I would say that was the case when you copied your kernel over.

That means your latest kernel is now in a directory /boot on sda4

You can proceed in either one of two ways, copy the relevant files from/boot/* to ie /tmp/boot then mount /boot and copy them back to the new mount and reboot

Or just mount the /boot partition, re-compile kernel and run grub-mkconfig again and reboot

Ian, you are right.. I didn't have the /boot partition mounted. After mounting /dev/sda2 to /boot, and recompiling again, rebooted and now everything works.

The live minimal install iso works without EXPERT=y, so I tried turning it off and recompiling again, wifi still works. For anyone having similar problem, I can't say for sure because I made many changes these days, but I guess the problem was either that I didn't have the drivers as modules, or because I had both MVM and DVM selected, while I only needed MVM support.

Thanks a lot for the help! 8)
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 391
Location: Australia

PostPosted: Thu Sep 07, 2017 11:52 pm    Post subject: Reply with quote

concerned,
Great that you got it sorted out. Protocol here is once you've fixed your problem you go back and edit your initial post and add <solved> to the title.
Quote:
The live minimal install iso works without EXPERT=y, so I tried turning it off and recompiling again, wifi still works.

I think the kernel comes with coredump enabled, I suspect the expert flag just uncovers the option to turn it off / change it in menuconfig menus.

I think the initial problem (overlooking the /boot thing) you had was that you built your kernel drivers as modules, but skipped the
Code:
make modules_install
part of your kernel build.
Quote:
make menuconfig #make some changes to turn on EXPERT
save to .config
make -j3
make install
grub-mkconfig /boot/grub/grub.cfg #this one reported that it found 2 kernels, one new one old
reboot the PC

You always want to add make modules_install to your kernel build. You don't usually need to specify -j(x) on the make, in gentoo that is set in the MAKEOPTS= variable in /etc/portage/make.conf. You probably want to take a look at https://wiki.gentoo.org/wiki/Kernel/Upgrade#Reinstalling_external_kernel_modules for the maintenance of modules during upgrades. The gentoo handbook and wiki for kernel compilation are really worth a read for this stuff.

Welcome to gentoo, btw.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum