Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kopete-17.04.3 update blocked
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
apricus
n00b
n00b


Joined: 14 Jul 2007
Posts: 3

PostPosted: Mon Aug 21, 2017 2:46 pm    Post subject: kopete-17.04.3 update blocked Reply with quote

Hi,
Code:

# emerge -av1q kopete
[ebuild  NS   ] kde-apps/akonadi-1.13.1_pre20160203-r1 [17.04.3-r1] USE="mysql -postgres -sqlite {-test}"
[ebuild  N    ] kde-apps/kdepimlibs-4.14.10_p20160611  USE="handbook ldap (-aqua) -debug -prison {-test}"
[ebuild     U ] kde-apps/kopete-17.04.3 [16.12.3-r2] USE="addbookmarks autoreplace contactnotes handbook highlight history nowlistening pipes privacy ssl statistics texteffect translator urlpicpreview v4l xmpp (-aqua) (-cryptography) -debug -gadu -groupwise -jingle -latex -meanwhile -oscar -otr -skype -testbed -webpresence -winpopup -yahoo -zeroconf"
[blocks B     ] kde-apps/akonadi:4 ("kde-apps/akonadi:4" is blocking kde-apps/akonadi-17.04.3-r1)
[blocks B     ] kde-apps/kdepimlibs ("kde-apps/kdepimlibs" is blocking kde-apps/akonadi-17.04.3-r1)
[blocks B     ] kde-apps/kdepimlibs:4 ("kde-apps/kdepimlibs:4" is blocking kde-apps/akonadi-mime-17.04.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kdepimlibs-4.14.10_p20160611:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdepimlibs-4.14.10_p20160611:4[aqua=] (>=kde-apps/kdepimlibs-4.14.10_p20160611:4[-aqua]) required by (kde-apps/kopete-17.04.3:4/17.04::gentoo, ebuild scheduled for merge)

  (kde-apps/akonadi-17.04.3-r1:5/5::gentoo, installed) pulled in by
    >=kde-apps/akonadi-17.04.3:5 required by (kde-apps/kgpg-17.04.3:5/5::gentoo, installed)
    >=kde-apps/akonadi-17.04.3:5 required by (kde-apps/akonadi-contacts-17.04.3:5/5::gentoo, installed)
    >=kde-apps/akonadi-17.04.3:5 required by (kde-apps/akonadi-mime-17.04.3:5/5::gentoo, installed)

  (kde-apps/akonadi-mime-17.04.3:5/5::gentoo, installed) pulled in by
    >=kde-apps/akonadi-mime-17.04.3:5 required by (kde-apps/akonadi-contacts-17.04.3:5/5::gentoo, installed)



"akonadi-17.04.3-r1" blocks "kopete-17.04.3" update - Where is the problem?

Thanks.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5369
Location: Austria

PostPosted: Mon Aug 21, 2017 2:49 pm    Post subject: Reply with quote

You simply can't have both. kopete requires old kdepimlibs and that requires old akonadi.

see also... https://wiki.gentoo.org/wiki/KDE#KDE_PIM
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 168

PostPosted: Thu Sep 07, 2017 11:20 am    Post subject: Reply with quote

That's bad. I've checked the official website of kopete and KDE's bugzilla and found no notice on when they consider to adapt kopete to current KDE frameworks. I don't want to join the kopete-dev's mailinglist for that question, so: does anybody here (maybe the package maintainers?) know when kopete will be usable again on an updated system?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5369
Location: Austria

PostPosted: Thu Sep 07, 2017 12:18 pm    Post subject: Reply with quote

It is on the brink of removal unless kf5 branch is stable enough once 17.12 release is happening.

https://community.kde.org/Applications/17.12_repo_drop_list_kdelibs4#kopete
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum