Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Probleme mit qtwebkit
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Annaberlin
n00b
n00b


Joined: 19 Oct 2016
Posts: 44
Location: Berlin/Germany

PostPosted: Tue Aug 29, 2017 9:29 am    Post subject: [solved] Probleme mit qtwebkit Reply with quote

Hallo Forum, das Systemupdate scheitert, da sich qtwebkit nicht updaten lässt. Ich habe mal die Ausgabe nach dem ersten Fehler angehängt:

Code:
usr/lib64/ruby/2.1.0/rubygems.rb:15:in `require': cannot load such file -- rubygems/compatibility (LoadError)
   from /usr/lib64/ruby/2.1.0/rubygems.rb:15:in `<top (required)>'
   from <internal:gem_prelude>:1:in `require'
   from <internal:gem_prelude>:1:in `<compiled>'
make[2]: *** [Makefile.LLIntOffsetsExtractor:487: LLIntDesiredOffsets.h] Error 1
make[2]: Leaving directory '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1/Source/JavaScriptCore'
make[1]: *** [Makefile.JavaScriptCore:42: sub-LLIntOffsetsExtractor-pro-make_first-ordered] Error 2
make[1]: Leaving directory '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1/Source/JavaScriptCore'
make: *** [Makefile:91: sub-Source-JavaScriptCore-JavaScriptCore-pro-make_first-ordered] Error 2
 * ERROR: dev-qt/qtwebkit-5.7.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtwebkit-5.7.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtwebkit-5.7.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1'
 * S: '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1'

>>> Failed to emerge dev-qt/qtwebkit-5.7.1, Log file:

>>>  '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/temp/build.log'

 * Messages for package dev-qt/qtwebkit-5.7.1:

 * ERROR: dev-qt/qtwebkit-5.7.1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtwebkit-5.7.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtwebkit-5.7.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1'
 * S: '/var/tmp/portage/dev-qt/qtwebkit-5.7.1/work/qtwebkit-opensource-src-5.7.1


Somit lassen sich ca. 150 Pakete nicht mehr updaten, da qtwebkit abbricht.

Danke für eine Hilfe.


Last edited by Annaberlin on Sat Sep 02, 2017 8:24 am; edited 1 time in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4328

PostPosted: Tue Aug 29, 2017 10:58 am    Post subject: Reply with quote

Das Problem ist nicht qtwebkit. Es löst nur das Problem aus.
Deine ruby installation ist kaputt/inkonsistent.
Quote:
/usr/lib64/ruby/2.1.0/rubygems.rb:15:in `require': cannot load such file -- rubygems/compatibility (LoadError)
from /usr/lib64/ruby/2.1.0/rubygems.rb:15:in `<top (required)>'
from <internal:gem_prelude>:1:in `require'
from <internal:gem_prelude>:1:in `<compiled>'

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3251
Location: Germany

PostPosted: Tue Aug 29, 2017 12:17 pm    Post subject: Reply with quote

Ja, ruby:2.1 ist mittlerweile hart maskiert und sollte nicht mehr genutzt werden.
Code:
# emerge -pv dev-lang/ruby:2.1

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "dev-lang/ruby:2.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/ruby-2.1.10::gentoo (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Hans de Graaff <graaff@gentoo.org> (20 Aug 2017)
# Mask Ruby 2.1 for removal, bug 615822
# This version is no longer supported by upstream
# since March 2017.
# This mask also includes all remaining ruby21-only packages.

- dev-lang/ruby-2.1.9::gentoo (masked by: package.mask)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Zu deinem Problem (mit qtwebkit): Vermutlich musst du nur via eselect ruby
auf eine aktuellere installierte Version umschalten - dann sollte auch qtwebkit wieder fein bauen.
Back to top
View user's profile Send private message
Annaberlin
n00b
n00b


Joined: 19 Oct 2016
Posts: 44
Location: Berlin/Germany

PostPosted: Wed Aug 30, 2017 6:06 am    Post subject: Reply with quote

Hallo Josef.95 und firefly, danke für Eure schnelle Antwort. Darauf wäre ich nie gekommen. Leider komme ich in den nächsten Tagen nicht an den Rechner, um Feedback zu geben. Werde mich aber danach melden :-)
Back to top
View user's profile Send private message
Annaberlin
n00b
n00b


Joined: 19 Oct 2016
Posts: 44
Location: Berlin/Germany

PostPosted: Thu Aug 31, 2017 8:22 pm    Post subject: Reply with quote

hat alles bestens geklappt, vielen Dank :D :D :D
Back to top
View user's profile Send private message
raddaqii
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2005
Posts: 84
Location: Berlin, Germany

PostPosted: Sun Oct 08, 2017 7:40 pm    Post subject: Reply with quote

Me too. Danke!

Hatte lange schon vergessen und verdrängt überhaupt Ruby installiert zu haben. Ein einfaches
Code:
# eselect ruby set 2
hat hier ausgereicht.
_________________
--
Gentoo from 2004.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum