Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wifi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Apr 21, 2017 3:27 pm    Post subject: Wifi Reply with quote

Good morning all! I'm having a lot of difficulty getting my wireless up and running. I have wpa_supplicant, linux-firmware and just about everything else I can imagine installed on this box relating to a wireless connection. The wpa_gui has the adapter listed (wlo1) and the network sees my router along with everyone else's in my neighborhood. I entered my password and I get as far as associating (after authentication) and it just won't connect. I am assuming that this should be something simple but I can't seem to find the error. Please help.....

Thanks in advance for any assistance!
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Apr 21, 2017 4:36 pm    Post subject: Reply with quote

OK so found an issue, but I do not know how to fix the issue. I tried to restart networkmanager and it won't restart. Not sure where to go from here, or where I can see the error.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44043
Location: 56N 3W

PostPosted: Fri Apr 21, 2017 5:01 pm    Post subject: Reply with quote

FrankRizz0,

Put the output of dmesg onto a pastebin please.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Apr 21, 2017 5:16 pm    Post subject: Reply with quote

https://paste.pound-python.org/show/XTxRcXksnl8B0fEF6bok/
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44043
Location: 56N 3W

PostPosted: Fri Apr 21, 2017 5:43 pm    Post subject: Reply with quote

FrankRizz0,

Thin may not be important, as wileless worked later
Code:
[    7.730463] iwlwifi 0000:43:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
[    7.730498] iwlwifi 0000:43:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2

iwlwifi did find some firmware.

The interesting bit starts here
Code:
[   17.675223] wlo1: authenticate with c8:d7:19:46:4a:23
[   17.705334] wlo1: send auth to c8:d7:19:46:4a:23 (try 1/3)
[   17.766614] wlo1: authenticated
[   17.767707] wlo1: associate with c8:d7:19:46:4a:23 (try 1/3)
[   17.768595] wlo1: RX AssocResp from c8:d7:19:46:4a:23 (capab=0x1011 status=0 aid=2)
[   17.771142] wlo1: associated
[   17.771196] IPv6: ADDRCONF(NETDEV_CHANGE): wlo1: link becomes ready
[   17.771351] wlo1: deauthenticating from c8:d7:19:46:4a:23 by local choice (Reason: 3=DEAUTH_LEAVING)

then it repeats. Reason 3 means that the user told wifi to deauthenticate.

This is usually a sign that several different network managers are active and wpa-supplicant is receiving conflicting commands as they don't know about one another.

You mentioned NetworkManager. How do you start it?
What do you have in
Code:
/sbin/rc-update show

What is in your
Code:
/etc/conf.d/net


The idea is to only have a single network manager starting. The only way you can be sure of that is to get down to none, then add one to the default runlevel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Apr 21, 2017 5:52 pm    Post subject: Reply with quote

Hi Neddy, thanks for the reply. Here is the output of /sbin/rc-update show:

Code:
# /sbin/rc-update show
       NetworkManager |      default
               binfmt | boot
             bootmisc | boot
               cronie |      default
                 dbus |      default
                devfs |                                 sysinit
                dmesg |                                 sysinit
                 fsck | boot
             hostname | boot
              hwclock | boot
              keymaps | boot
            killprocs |                        shutdown
    kmod-static-nodes |                                 sysinit
                local |      default nonetwork
           localmount | boot
             loopback | boot
              modules | boot
             mount-ro |                        shutdown
                 mtab | boot
           net.enp5s0 |                                 sysinit
             netmount |      default
               procfs | boot
                 root | boot
            savecache |                        shutdown
                 sshd |      default
                 swap | boot
               sysctl | boot
                sysfs |                                 sysinit
            syslog-ng |      default
         termencoding | boot
                 udev |                                 sysinit
         udev-trigger |                                 sysinit
              urandom | boot
       wpa_supplicant |      default
                  xdm |      default


I've turned dhcp off, so this is what my /etc/conf.d/net looks like:

Code:
config_eth0="dhcpcd"
config_enp68s0="dhcpcd"
config_wlan1="dhcpcd"



code tags added by NeddySeagoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44043
Location: 56N 3W

PostPosted: Fri Apr 21, 2017 6:22 pm    Post subject: Reply with quote

FrankRizz0,

Code:
             netmount |      default
will force the network service to start as its going to try to mount all the network filesystems in /etc/fstab.
If you don't have any network filesystems remove this from the default runlevel.
Code:
       wpa_supplicant |      default
wpa_supplicant is called as needed, It sould not be in the default runlevel.

/etc/conf.d/net:
config_wlan1="dhcpcd"

You don't have a wlan1.
Code:
[    7.841848] iwlwifi 0000:43:00.0 wlo1: renamed from wlan0
but you did have a wlan0 until udev renamed it to wlo1.

What do you have in /etc/rc.conf for the
Code:
rc_depend_strict
rc_hotplug
options?
The comments explain what they do.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Apr 21, 2017 6:45 pm    Post subject: Reply with quote

Removed netmount from runlevel and also removed wpa_supplicant. In /etc/rc.conf rc_depend_strict was commented out. it is now rc_depend_strict="YES" and there is no rc_hotplug
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 44043
Location: 56N 3W

PostPosted: Fri Apr 21, 2017 7:17 pm    Post subject: Reply with quote

FrankRizz0,

You probably want
rc_depend_strict="NO" on a laptop so that the network service is up when either wired or wireless is up.
="YES" means you need both.

Anyway, what happens with wlo1 now?
The right answer is it stays down until you start it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Apr 21, 2017 7:24 pm    Post subject: Reply with quote

No idea how I read that wrong, I wanted it to be NO, but I still put YES, oh well. It's still wlo1, and it's still not working. I had to start dhcpcd to get wired internet, I'm assuming because I had it at yes?

Last edited by FrankRizz0 on Fri Apr 21, 2017 7:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Apr 21, 2017 7:27 pm    Post subject: Reply with quote

Well, dhcp seems to be handling my wireless just fine. Working now, thanks for all your help Neddy!
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Fri Aug 25, 2017 4:16 pm    Post subject: Reply with quote

Hi Neddy

Not sure if you're still watching this thread (or if anyone else is available for help) but I completely broke my Gentoo and had to reinstall. Unfortunately I'm having issues again with my wireless. I have gone through this thread multiple times and I can't figure out what the issue is. Below is my dmesg:

[url] https://paste.pound-python.org/show/5trVBv74tGTYTd83UVhi/

Here is my /etc/conf.d/net:

Code:
config_enp68s0="dhcpcd"
config_wlo1="dhcpcd"


Here is the output of /sbin/rc-update show:

Code:
# /sbin/rc-update show
               binfmt | boot
             bootmisc | boot
               cronie |      default
                 dbus |      default
                devfs |                                 sysinit
               dhcpcd |      default
                dmesg |                                 sysinit
                 fsck | boot
             hostname | boot
              hwclock | boot
              keymaps | boot
            killprocs |                        shutdown
    kmod-static-nodes |                                 sysinit
                local |      default nonetwork
           localmount | boot
             loopback | boot
              modules | boot
             mount-ro |                        shutdown
                 mtab | boot
          net.enp68s0 |      default
             netmount |      default
               procfs | boot
                 root | boot
            savecache |                        shutdown
                 sshd |      default
                 swap | boot
               sysctl | boot
                sysfs |                                 sysinit
            syslog-ng |      default
         termencoding | boot
                 udev |                                 sysinit
         udev-trigger |                                 sysinit
              urandom | boot
                  xdm |      default


In /etc/rc.conf I have rc_depend_strict="NO"

Finally, here is my wpa_supplicant.conf:

[url] https://paste.pound-python.org/show/DWHxddY0d5IskyQ3xSg4/
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sat Aug 26, 2017 1:16 pm    Post subject: Reply with quote

So I was finally able to connect, but unfortunately I could not use wpa_gui for this. I had to use wpa_cli. I did this by commenting everything out of my wpa_supplicant.conf except for ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel & update_config=1. I also added this below, which was directly from the wiki:

Code:
network={
        ssid="SSID"
        psk="your-secret-key"
        scan_ssid=1
        proto=RSN
        key_mgmt=WPA-PSK
        group=CCMP TKIP
        pairwise=CCMP TKIP
        priority=5
}


Not working the way I wanted it to, but it's working none the less.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2744

PostPosted: Sat Aug 26, 2017 2:57 pm    Post subject: Reply with quote

FrankRizz0 wrote:
Here is my /etc/conf.d/net:

Code:
config_enp68s0="dhcpcd"
config_wlo1="dhcpcd"

You might want to compare these settings with those in And ask yourself if you really want to set a value which is the default if none is set.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2744

PostPosted: Sat Aug 26, 2017 3:02 pm    Post subject: Reply with quote

FrankRizz0 wrote:
So I was finally able to connect, but unfortunately I could not use wpa_gui for this. I had to use wpa_cli. I did this by commenting everything out of my wpa_supplicant.conf except for ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel & update_config=1. I also added this below, which was directly from the wiki:

You'd better start from minimal configuration file as shown in the #Global section. wpa_gui and/or wpa_cli will add the »network« sections for you.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sat Aug 26, 2017 3:10 pm    Post subject: Reply with quote

Yes, previously wpa_gui was setting that for me but unfortunately it's not doing it after I reinstalled Gentoo. I do not have an answer for this unfortunately :-(
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Sun Aug 27, 2017 11:55 pm    Post subject: Reply with quote

So I've continued to work on this issue because of my apparent OCD. My wpa_gui is scanning fine, I can add other routers to it (wpa_gui), I can connect and I am connected, but when I do /etc/init.d/net.wlo1 I still get this error:

Code:
/etc/init.d/net.wlo1 restart
 * Bringing down interface wlo1
 *   Stopping dhcpcd on wlo1 ...
control_open: Connection refused
sending signal TERM to pid 5658
waiting for pid 5658 to exit                                                                 [ ok ]
 *   Stopping wpa_cli on wlo1 ...                                                            [ ok ]
 *   Stopping wpa_supplicant on wlo1 ...                                                     [ ok ]
RTNETLINK answers: No such file or directory
Error talking to the kernel
 * Bringing up interface wlo1
 *   Starting wpa_supplicant on wlo1 ...
Successfully initialized wpa_supplicant                                                      [ ok ]
 *   Starting wpa_cli on wlo1 ...                                                            [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlo1 has started, but is inactive


Please help, I have no idea where to go from here.

Thanks in advance for any assistance!
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2744

PostPosted: Mon Aug 28, 2017 7:15 am    Post subject: Reply with quote

See my posting on the other thread post 8110872
Be aware it is a different approach ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum