Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]qt-creator options doesn't work (segmentation fault)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
skorefish
Apprentice
Apprentice


Joined: 21 Jun 2015
Posts: 194

PostPosted: Tue Aug 22, 2017 9:11 pm    Post subject: [solved]qt-creator options doesn't work (segmentation fault) Reply with quote

hi

qtcreator seems to emerge just fine, but when i start it up i can't select tools/options -> segmentation fault.

I don't know where to start first with this. What info do i supply? I also can't start a new project.
At the the end it just closes the program.


Last edited by skorefish on Fri Aug 25, 2017 4:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11174

PostPosted: Wed Aug 23, 2017 1:26 am    Post subject: Reply with quote

Always start by providing the output of emerge --info. In this case, use emerge --info --verbose dev-qt/qt-creator $(eix --only-names -I dev-qt/). If you want to debug this, you will probably need debug symbols for the faulting file, and possibly supporting files.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16244
Location: here

PostPosted: Wed Aug 23, 2017 6:00 am    Post subject: Reply with quote

For debugging with gdb to have backtrace see here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
skorefish
Apprentice
Apprentice


Joined: 21 Jun 2015
Posts: 194

PostPosted: Wed Aug 23, 2017 9:21 pm    Post subject: Reply with quote

emerge --info --verbose dev-qt/qt-creator $(eix --only-names -I dev-qt/): https://paste.pound-python.org/show/4IKonqMNOGrNGSfXaOkX/

eselect ruby list
after changing to gcc5 seems ruby can be changed to

ok found eselect python list also

i'm rebuilding qtwebengine for the moment
result
Code:
error: undefined reference to 'google::protobuf::internal::WireFormatLite::WriteBytes(int, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, google::protobuf::io::CodedOutputStream*)'

which lib do i need to install ???
emerge dev-libs/protobuf -av , ... (something else?)
Back to top
View user's profile Send private message
Chiitoo
Moderator
Moderator


Joined: 28 Feb 2010
Posts: 1378
Location: Here and Away Again

PostPosted: Fri Aug 25, 2017 10:38 am    Post subject: ><)))°€ Reply with quote

Possibly an issue with GCC.

See for example this post: 8108250.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
gen2saurus
n00b
n00b


Joined: 20 Aug 2017
Posts: 10

PostPosted: Fri Aug 25, 2017 3:08 pm    Post subject: Reply with quote

skorefish wrote:
emerge --info --verbose dev-qt/qt-creator $(eix --only-names -I dev-qt/): https://paste.pound-python.org/show/4IKonqMNOGrNGSfXaOkX/
...
emerge dev-libs/protobuf -av , ... (something else?)
Output of
Code:
cpuinfo2cpuflags-x86
would be useful too.
Back to top
View user's profile Send private message
wjb
Guru
Guru


Joined: 10 Jul 2005
Posts: 381
Location: Fife, Scotland

PostPosted: Fri Aug 25, 2017 3:46 pm    Post subject: Reply with quote

If you updated from an older version, it's probably worth deleting (or renaming) the current config files and letting it create some new ones the next time it starts.
Code:

~/.config/QtProject/
~/.config/QtProject.conf
Back to top
View user's profile Send private message
skorefish
Apprentice
Apprentice


Joined: 21 Jun 2015
Posts: 194

PostPosted: Fri Aug 25, 2017 4:24 pm    Post subject: Reply with quote

CPU_FLAGS_X86="mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
i emerged version 4.3.1 now it works thx

(but i also did a lot of qt rebuilds)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum