Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] aMule: a voi funziona bene?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Jan 08, 2017 5:44 pm    Post subject: [RISOLTO] aMule: a voi funziona bene? Reply with quote

Ciao a tutti,

non uso quasi mai aMule ma ogni tanto provo ad usarlo e come faccio partire una ricerca ma anche dopo 1/2 minuti che è stato avviato, la ventola del laptop va al massimo e poi crasha.
Al momento la versione che ho sul sistema è quella *9999 perché già tempo fa, ho avuto problemi con le versioni "normali".
Ho provato anche a cancellare la directory ~/.aMule e riconfigurarlo ma non cambia nulla.

C'è qualcuno che riesce ad usarlo senza problemi?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Mon Jan 09, 2017 8:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16502
Location: here

PostPosted: Sun Jan 08, 2017 8:07 pm    Post subject: Reply with quote

Purtroppo non uso amule, l'unica cosa che posso suggerirti e' quello di compilarlo per debuggin e farlo partire con gdb per vedere dove si crash (vedi qui la guida).
Vedo che sul bug tracker di amule c'e' questo errore magari e' simile al tuo.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2016
Posts: 110

PostPosted: Mon Jan 09, 2017 5:38 am    Post subject: Reply with quote

Io uso senza problemi la versione 2.3.1

https://packages.gentoo.org/packages/net-p2p/amule
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Jan 09, 2017 8:56 pm    Post subject: Reply with quote

Grazie,

ho fatto downgrade alla versione 2.3.1 sembra che non ci siano più problemi.
Strano perché l'avevo già fatto qualche tempo fa (è qualche mese che ho questi problemi) ma non funzionava lo stesso.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
nollo
n00b
n00b


Joined: 15 Mar 2013
Posts: 30
Location: Ferrara - Italy

PostPosted: Wed Jan 11, 2017 9:42 am    Post subject: Reply with quote

Io mi sono adattato una ebuild con amule svn 10981 e funziona abbastanza bene, qualche tempo fa ho avuto dei problemi che dipendevano dalla versione di wxgtk utilizzata, per vedere quale versione è la corrente bisogna utilizzare il comando

Code:
eselect wxwidgets list


con le ultime versioni di amule sarebbe preferibile la 3
_________________
λάθε βιώσας
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Wed Jan 11, 2017 6:08 pm    Post subject: Reply with quote

Perfetto grazie!

Ho controllato e sto usando l'ultima: gtk2-unicode-3.0.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sat Aug 19, 2017 12:28 pm    Post subject: Reply with quote

Ciao,

purtroppo ci risiamo. Credo che uno degli ultimi aggiornamenti di sistema abbia tolto la 2.3.1 e messo la 2.3.2-r1 senza possibilità di scelta.
Questo è un estratto dei log dopo che è successo il freeze completo del sistema.
Ho lasciato il PC acceso e fortunatamente dopo aver killato aMule, si è ripreso.

Avete qualche altro suggerimento?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16502
Location: here

PostPosted: Sat Aug 19, 2017 2:27 pm    Post subject: Reply with quote

Prova a vedere il commento 3 di questo bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
Guru
Guru


Joined: 03 Jan 2012
Posts: 481

PostPosted: Sat Aug 19, 2017 6:02 pm    Post subject: Reply with quote

e provando a cambiare WXGTK con

Code:
# eselect wxwidgets set gtk2-unicode-release-2.8


controlla i vari moduli disponibili con
Code:
# eslect  wxwidgets list

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Aug 20, 2017 7:44 am    Post subject: Reply with quote

Ciao!

Grazie per la risposta.
Nel frattempo ho installato aMule SVN rev. 10990.
Credevo che mi scaricasse la 10981, avendo dato il nome del file all'ebuild (amule-10981.ebuild) con quel numero ma ora provo questa versione che almeno per ora sembra funzionare.

Per comodità posto l'ebuild che ho trovato e modificato in modo tale che funzionasse sul mio sistema:

Code:
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="5"

inherit eutils flag-o-matic kde4-base wxwidgets git-2

MY_P="aMule-SVN-r${PV}"
S="${WORKDIR}"/${MY_P}

DESCRIPTION="aMule, the all-platform eMule p2p client"
HOMEPAGE="http://sourceforge.net/projects/amule/"
#SRC_URI="http://amule.sourceforge.net/tarballs/${MY_P}.tar.bz2"
EGIT_REPO_URI="git://repo.or.cz/amule.git"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="asio daemon debug ed2k fileview geoip gtk nls mmap plasma remote static stats unicode upnp xchat"

RESTRICT="nomirror"

DEPEND="=x11-libs/wxGTK-2.8.12*
>=dev-libs/crypto++-5.5.2
   >=sys-libs/zlib-1.2.1
   asio? ( dev-libs/boost )
   stats? ( >=media-libs/gd-2.0.26[jpeg] )
   geoip? ( dev-libs/geoip )
   upnp? ( >=net-libs/libupnp-1.6.6 )
   remote? ( >=media-libs/libpng-1.2.0
   unicode? ( >=media-libs/gd-2.0.26 ) )
   plasma? ( kde-frameworks/kdelibs:4 )"

   RDEPEND="$DEPEND
   xchat? ( net-irc/xchat[perl] )"

   pkg_setup() {
      if ! use gtk && ! use remote && ! use daemon; then
         eerror ""
            eerror "You have to specify at least one of gtk, remote or daemon"
            eerror "USE flag to build amule."
            eerror ""
            die "Invalid USE flag set"
            fi

            if use stats && ! use gtk; then
               einfo "Note: You would need both the gtk and stats USE flags"
                  einfo "to compile aMule Statistics GUI."
                  einfo "I will now compile console versions only."
                  fi
   }

pkg_preinst() {
   if use daemon || use remote; then
      enewgroup p2p
      enewuser p2p -1 -1 /home/p2p p2p
   fi
}

src_configure() {
   local myconf

      WX_GTK_VER="2.8"

      if use gtk; then
         einfo "wxGTK with gtk support will be used"
            need-wxwidgets unicode
      else
         einfo "wxGTK without X support will be used"
            need-wxwidgets base
            fi

            if use gtk ; then
               use stats && myconf="${myconf}
--enable-wxcas
   --enable-alc"
   use remote && myconf="${myconf}
--enable-amule-gui"
            else
               myconf="
                  --disable-monolithic
                  --disable-amule-gui
                  --disable-wxcas
                  --disable-alc"
                  fi

                  econf \
                  --with-wx-config=${WX_CONFIG} \
                  --enable-amulecmd \
                  $(use_with asio boost ) \
                  $(use_enable debug) \
                  $(use_enable !debug optimize) \
                  $(use_enable daemon amule-daemon) \
                  $(use_enable ed2k) \
                  $(use_enable fileview) \
                  $(use_enable geoip) \
                  $(use_enable nls) \
                  $(use_enable mmap) \
                  $(use_enable plasma plasmamule ) \
                  $(use_enable remote webserver) \
                  $(use_enable static) \
                  $(use_enable stats cas) \
                  $(use_enable stats alcc) \
                  $(use_enable upnp) \
                  $(use_enable xchat xas) \
                  ${myconf} || die
}

src_compile() {
   cd ${S}
   emake
}

src_install() {
   emake DESTDIR="${D}" install || die

      if use asio; then
         insinto /usr/share/doc/${PN}
   doins docs/README.Asio.txt
      fi
      if use daemon; then
         newconfd "${FILESDIR}"/amuled.confd amuled
         newinitd "${FILESDIR}"/amuled.initd amuled
      fi
      if use remote; then
         newconfd "${FILESDIR}"/amuleweb.confd amuleweb
         newinitd "${FILESDIR}"/amuleweb.initd amuleweb
      fi
}


_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum