Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Tastiera USB HID non rilevata nell'installazione
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
alogim
n00b
n00b


Joined: 21 Aug 2015
Posts: 14

PostPosted: Thu Aug 10, 2017 2:01 pm    Post subject: [RISOLTO] Tastiera USB HID non rilevata nell'installazione Reply with quote

Buon giorno a tutti.
Ho iniziato ad usare Gentoo alcuni giorni fa, e dopo averlo provato per un po' in una macchina virtuale, ho deciso di passare da Archlinux a Gentoo. Ho scaricato il Minimal Installation CD da qui, tuttavia la mia tastiera non viene rilevata.
Attualmente possiedo una scheda madre AsRock Z77 Pro4, con un processore Intel Core i5-3570k ed un mouse wireless Logitech M280. Quest'ultimo viene rilevato e funzione perfettamente. La mia tastiera USB Trust GXT 18 USB tuttavia, non funziona affatto. In particolare, quando il CD viene avviato, funziona nel momento in cui devo inserire cosa avviare (scrivo semplicemente "gentoo" lì), ma appena pigio il tasto invio e il CD di installazione parte, la tastiera non risponde più. Di conseguenza, non riesco neppure a selezionare il layout.

Ho provato con SystemRescueCD: tuttavia, sembra affetto dallo stesso problema, poiché anche là non riesco a selezionare il layout di tastiera. Una volta che l'ambiente grafico si è avviato però, la tastiera funziona perfettamente . In particolare, ho notato che viene rilevata all'inizio qui:
Code:

[    2.799012] usb 2-1.7: New USB device found, idVendor=04d9, idProduct=a055
[    2.799013] usb 2-1.7: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    2.799014] usb 2-1.7: Product: USB Keyboard
[    2.799015] usb 2-1.7: Manufacturer: KB

poi la mia scheda grafica viene rilevata (Sapphire Radeon HD 7950) e poi a quanto pare viene disabilitata e riabilitata:
Code:

[   35.828278] usb 2-1-port7: disabled by hub (EMI?), re-enabling...
[   35.828283] usb 2-1.7: USB disconnect, device number 4
[   36.067674] usb 2-1.7: new low-speed USB device number 5 using ehci-pci
[   36.165281] usb 2-1.7: New USB device found, idVendor=04d9, idProduct=a055
[   36.165284] usb 2-1.7: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   36.165285] usb 2-1.7: Product: USB Keyboard
[   36.165287] usb 2-1.7: Manufacturer: KB
[   36.175890] input: KB USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.7/2-1.7:1.0/0003:04D9:A055.0005/input/input10
[   36.228010] holtek_kbd 0003:04D9:A055.0005: input,hidraw2: USB HID v1.10 Keyboard [KB USB Keyboard] on usb-0000:00:1d.0-1.7/input0
[   36.246232] input: KB USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.7/2-1.7:1.1/0003:04D9:A055.0006/input/input11
[   36.298045] holtek_kbd 0003:04D9:A055.0006: input,hidraw3: USB HID v1.10 Keyboard [KB USB Keyboard] on usb-0000:00:1d.0-1.7/input1


Sono riuscito ad installare Gentoo con SystemRescueCD, installando anche Xfce come desktop, tuttavia la tastiera non risponde comunque. Ho abilitato UHCI ed EHCI nel kernel e anche nel BIOS/UEFI sia le porte USB 2, sia le porte USB 3 sono abilitate. Qualche idea per risolvere questo problema?


Last edited by alogim on Fri Aug 11, 2017 11:19 am; edited 2 times in total
Back to top
View user's profile Send private message
sabayonino
Guru
Guru


Joined: 03 Jan 2012
Posts: 454

PostPosted: Thu Aug 10, 2017 2:33 pm    Post subject: Reply with quote

non arrivi a selezionare nulla perchè molto probabilmente non sono ancora stati caricati i moduli relativi all'usb.

usa una tastiera ps2 normale per selezionare il layout e poi prova a ricollegare l'altra.
ciao
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
alogim
n00b
n00b


Joined: 21 Aug 2015
Posts: 14

PostPosted: Thu Aug 10, 2017 2:43 pm    Post subject: Reply with quote

sabayonino wrote:
non arrivi a selezionare nulla perchè molto probabilmente non sono ancora stati caricati i moduli relativi all'usb.

Appunto, come faccio a caricarli? Come ho scritto, anche dopo averlo installato, la tastiera non risponde, ciò significa che manca qualcosa, avrei bisogno di una mano appunto in questo. È un problema che mi sta dando unicamente Gentoo e SystemRescueCD (che è pure basato su Gentoo), quindi vorrei capire come fare a risolverlo.

sabayonino wrote:
usa una tastiera ps2 normale per selezionare il layout e poi prova a ricollegare l'altra.

Se avessi una tastiera PS2 non mi sarei posto il problema, ma non ce l'ho. Ripeto, la tastiera NON viene rilevata, neppure scollegandola e ricollegandola, in nessuna porta USB 2/3. Il mouse, pur essendo wireless invece, funziona benissimo.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 15727
Location: here

PostPosted: Thu Aug 10, 2017 3:44 pm    Post subject: Reply with quote

La tastiera e' connessa direttamente al pc o tramite hub?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
alogim
n00b
n00b


Joined: 21 Aug 2015
Posts: 14

PostPosted: Thu Aug 10, 2017 4:12 pm    Post subject: Reply with quote

Ho provato in ambo i modi, comunque attualmente è connessa ad una porta USB collegata direttamente alla scheda madre.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 15727
Location: here

PostPosted: Thu Aug 10, 2017 4:27 pm    Post subject: Reply with quote

Nel kernel hai attivato CONFIG_HID_HOLTEK (sembrerebbe quello per la tua tastiera).

https://github.com/torvalds/linux/blob/master/drivers/hid/hid-holtek-kbd.c
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
Guru
Guru


Joined: 03 Jan 2012
Posts: 454

PostPosted: Fri Aug 11, 2017 9:39 am    Post subject: Reply with quote

Quote:

Se avessi una tastiera PS2 non mi sarei posto il problema, ma non ce l'ho. Ripeto, la tastiera NON viene rilevata, neppure scollegandola e ricollegandola, in nessuna porta USB 2/3. Il mouse, pur essendo wireless invece, funziona benissimo.


che ne so. io ne ho sempre una a portata di tiro proprio per non trovarmi in queste situazioni.

comunque puoi postare il tuo make.conf?

ad esempio potrebbe mancare

INPUT_DEVICES="evdev void"

https://wiki.gentoo.org/wiki/Evdev

:wink:
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
alogim
n00b
n00b


Joined: 21 Aug 2015
Posts: 14

PostPosted: Fri Aug 11, 2017 11:18 am    Post subject: Reply with quote

Finalmente ho risolto. È bastato abilitare Holtek HID Devices nel kernel, più precisamente come di seguito:
Code:

    Device Drivers  --->
        HID support  --->
              Special HID drivers  --->
              <*> Holtek HID devices
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum