Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
UT2004 not found in mirrors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
bent
n00b
n00b


Joined: 26 Mar 2003
Posts: 74
Location: New Zealand

PostPosted: Sun Jul 27, 2014 4:33 am    Post subject: UT2004 not found in mirrors Reply with quote

Been running ut2004 fine for some time, but when trying to emerge it on a new machine, *** could not be found on any mirrors. As luck would have it, I just blew away everything in /usr/portage/distfiles to make space for ut2004-data, where there was probably a cached copy.

Searching the web, I noticed a lot of other places with links to download that file were also 404'ing, though with persistence I eventually found a copy. But I couldn't find any info on why it should no longer be on the Gentoo mirrors.

Code:

littledebbie ~ # emerge ut2004
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) games-fps/ut2004-3369.3-r1
 * ut2004-lnxpatch3369-2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                     [ ok ]
>>> Downloading 'http://gentoo-distfiles.mirrors.tds.net/distfiles/ut2004-v3369-3-linux-dedicated.7z'
--2014-07-27 16:32:54--  http://gentoo-distfiles.mirrors.tds.net/distfiles/ut2004-v3369-3-linux-dedicated.7z
Resolving gentoo-distfiles.mirrors.tds.net... 216.165.129.135
Connecting to gentoo-distfiles.mirrors.tds.net|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2014-07-27 16:32:55 ERROR 404: Not Found.

(and again and again for each mirror tried)

_________________
amd64, x86, ppc. Gave away my mips, broke my foot on the alpha, someone stole my sparc :'(
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2166
Location: Germany

PostPosted: Sun Jul 27, 2014 6:36 pm    Post subject: Reply with quote

Hi!

Check out: http://www.utserver.de/component/option,com_remository/Itemid,33/func,startdown/id,26/

Got that link from bugs.gentoo.org 506112 but its still not resolved in the upstream. :/

Regrats
Back to top
View user's profile Send private message
bent
n00b
n00b


Joined: 26 Mar 2003
Posts: 74
Location: New Zealand

PostPosted: Sun Jul 27, 2014 9:58 pm    Post subject: Re: UT2004 not found in mirrors Reply with quote

As I'd mentioned I had already found a copy:
bent wrote:
Searching the web, I noticed a lot of other places with links to download that file were also 404'ing, though with persistence I eventually found a copy. But I couldn't find any info on why it should no longer be on the Gentoo mirrors.

What I should have added is: why should the file have disappeared from the Gentoo mirrors? Should I file a bug?
_________________
amd64, x86, ppc. Gave away my mips, broke my foot on the alpha, someone stole my sparc :'(
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2474

PostPosted: Sun Jul 27, 2014 10:06 pm    Post subject: Re: UT2004 not found in mirrors Reply with quote

bent wrote:
What I should have added is: why should the file have disappeared from the Gentoo mirrors? Should I file a bug?
The answer to that is, no idea. Someone probably goofed.

Second is you should, but check first. In this case the bug has already been filed so no you shouldn't make a duplicate bug report.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
bent
n00b
n00b


Joined: 26 Mar 2003
Posts: 74
Location: New Zealand

PostPosted: Sun Jul 27, 2014 10:39 pm    Post subject: Reply with quote

Thanks Doc. Since it seems to have disappeared from so many places at once (about other sites I googled had links that 404'd) I wondered if it might have been no accident, as if Midway (or whoever owns the UT2004 rights) had sent takedown notices, perhaps?

I didn't find any reported bugs when researching the problem, so I'll open one. Cheers

EDIT: I didn't find it then, but there is in fact a bug open since March: https://bugs.gentoo.org/show_bug.cgi?id=506112
The bug has a link to a good copy of the file, but nothing's been done since the bug was opened :/
_________________
amd64, x86, ppc. Gave away my mips, broke my foot on the alpha, someone stole my sparc :'(
Back to top
View user's profile Send private message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 770
Location: Arrakis

PostPosted: Mon Sep 12, 2016 7:28 am    Post subject: Reply with quote

lets necro this bugger as this file seem to have diasppeared fagain rom everywhere but the dark web
_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5211

PostPosted: Mon Sep 12, 2016 11:40 pm    Post subject: Reply with quote

This isn't the first time this has happened, I had to file a bug for one of the base map packs going missing, and it looks like the rest are gone now too...

Don't know if anyone else has a better idea, but I'm going to install go-ipfs-bin and start throwing anything I can find on the web into it.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5211

PostPosted: Wed Sep 14, 2016 5:18 pm    Post subject: Reply with quote

Well, my plan works. Sort of.

I've gone hunting for everything needed to do emerge ut2004-ded ut2004-bonuspack-cbp{1,2} and put the files into ipfs:
Code:
 ~ $ ipfs ls QmXQ98o5iv3fAXGNNTgJQwsJRp23ezkPvpnJzfBmEFcMtH
QmQCpjBGdMYof2yNF5cQHrQNSzjvGkXh15uZN2RbS1HJjz 11021142  UT2004-ONSBonusMapPack.zip
QmdphFqmxmA4AVbfYXkX41e9Ad2VDEvR1WgHy57F5cbP3X 203814752 cbp2-volume1_zip.zip
QmV8H3Kf6LQDwfUB4EKfMAoW1bhmE6b3m3XNCcnpaMGGeD 200491866 cbp2-volume2_zip.zip
QmYM5AnzgZFWHgPB17rHn7Ayxq8SqC2MD5rLZxAohaZkZ8 914431429 dedicatedserver3339-bonuspack.zip
QmaaQUGbUAx1nJTuoGmmsX9Vmw55BCfRPq3v3SQuo66c8p 22470559  ut2004-lnxpatch3369-2.tar.bz2
QmUe7zL7umztdNrmoNSMB6EFX4WHJWJfzxuCcqn1ZM7PhP 5015176   ut2004-v3369-3-linux-dedicated.7z
QmXcU3L3yhq4aVBdP9Lx7Ego9vH63D5Kx1PouvTuh8orz4 203172466 ut2004megapack-linux.tar.bz2


Don't bother trying to download them. ipfs is *abysmally slow* over the internet when there's only one node hosting the stuff. I gave up waiting after leaving it overnight twice and just scp'ed the files to my server. It might actually work with more volunteers, I dunno.
Back to top
View user's profile Send private message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 770
Location: Arrakis

PostPosted: Wed Sep 21, 2016 9:00 am    Post subject: Reply with quote

The map packs and such can be found tho, this particular patch however seems to have disappeared.
_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat
Back to top
View user's profile Send private message
hurikhan77
n00b
n00b


Joined: 01 May 2017
Posts: 7
Location: Germany

PostPosted: Mon May 01, 2017 9:13 pm    Post subject: Reply with quote

I took the challenge to bring this online in ipfs:

https://ipfs.io/ipfs/QmXQ98o5iv3fAXGNNTgJQwsJRp23ezkPvpnJzfBmEFcMtH

I pinned it in my ipfs storage so it stays online.
Back to top
View user's profile Send private message
merlin2k
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2006
Posts: 124
Location: Hamburg, Germany

PostPosted: Thu May 11, 2017 2:59 pm    Post subject: Reply with quote

hurikhan77 wrote:
I pinned it in my ipfs storage so it stays online.


Unfortunately I get this error message when trying to download:

Code:
ipfs resolve -r /ipfs/QmXQ98o5iv3fAXGNNTgJQwsJRp23ezkPvpnJzfBmEFcMtH/ut2004-v3369-3-linux-dedicated.7z: Failed to get block for QmUe7zL7umztdNrmoNSMB6EFX4WHJWJfzxuCcqn1ZM7PhP: context deadline exceeded


Can you please upload these files again? :)
(or switch on your node for a while...)
Back to top
View user's profile Send private message
hurikhan77
n00b
n00b


Joined: 01 May 2017
Posts: 7
Location: Germany

PostPosted: Thu May 11, 2017 5:01 pm    Post subject: Reply with quote

merlin2k wrote:
hurikhan77 wrote:
I pinned it in my ipfs storage so it stays online.


Unfortunately I get this error message when trying to download:

Code:
ipfs resolve -r /ipfs/QmXQ98o5iv3fAXGNNTgJQwsJRp23ezkPvpnJzfBmEFcMtH/ut2004-v3369-3-linux-dedicated.7z: Failed to get block for QmUe7zL7umztdNrmoNSMB6EFX4WHJWJfzxuCcqn1ZM7PhP: context deadline exceeded


Can you please upload these files again? :)
(or switch on your node for a while...)


My node is online all the time with 25mbit/s upstream... Last time I looked it was available through the official ipfs.io node. You can try to download it there. It may give you the same error but if you look one or two hours later, it should be there.

Then please add the file to your own ipfs.

Have you tried to pin the file id so it is added to your wantlist? Check

Code:
ipfs pin ls


You can PM me so I could send you my current IPv6 node address to connect to. But I restarted my node just in case (sometimes it looses connection after a few days).
Back to top
View user's profile Send private message
merlin2k
Tux's lil' helper
Tux's lil' helper


Joined: 24 Nov 2006
Posts: 124
Location: Hamburg, Germany

PostPosted: Thu May 11, 2017 7:18 pm    Post subject: Reply with quote

It works finally!
Thank you very much!

hurikhan77 wrote:
Then please add the file to your own ipfs.

At the moment I have no permanently running server, but I'll consider to set up an ipfs node in the next weeks.
Back to top
View user's profile Send private message
hurikhan77
n00b
n00b


Joined: 01 May 2017
Posts: 7
Location: Germany

PostPosted: Thu May 11, 2017 8:12 pm    Post subject: Reply with quote

merlin2k wrote:
It works finally!
Thank you very much!


Good but then you didn't get it from my node. It shows only 200MB uploaded... ;-)
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Sun Aug 06, 2017 3:18 pm    Post subject: Reply with quote

Some files are still missing from the mirrors :-/
It's a pity for such a great game
Back to top
View user's profile Send private message
hurikhan77
n00b
n00b


Joined: 01 May 2017
Posts: 7
Location: Germany

PostPosted: Wed Aug 09, 2017 11:47 am    Post subject: Reply with quote

barul wrote:
Some files are still missing from the mirrors :-/
It's a pity for such a great game


Which ones? Did you check the ipfs repo? If you're finding the files there, just download and drop them to distfiles.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5211

PostPosted: Tue Dec 12, 2017 6:08 pm    Post subject: Reply with quote

It looks like this topic's relevant again now that 17.0 is forcing an emerge -e @world on everyone - everyone with these installed is going to get fetch errors from them.

You don't need to reinstall them for the profile switch, they're just data files and unaffected by it. I'm not sure about the main game, but as a proprietary blob reinstalling it won't help either. Do something like this to save yourself the time:
Code:
emerge -ae @world --exclude=games-fps/ut2004{,-{data,bonuspack-{cbp{1,2},ece}}}
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5211

PostPosted: Thu Jul 19, 2018 3:09 pm    Post subject: Reply with quote

Small update: Gentoo's QA appears to be moribund, so I've taken it upon myself to create IPFS-ified ebuilds for all of the above packages (except ut2004-data) so they don't vanish from the internet forever.

If anyone wants to use them, `eselect repository enable flussence`, and add an ipfs mirror line in /etc/portage/mirrors. For a local node it should be "ipfs http://localhost:8080". I still have everything pinned in my repo, but I have basically no upload bandwidth. They appear to be cached on ipfs.io at least, which helps.

If anyone knows any similar things that are at risk of being lost, ask and I'll make ebuilds for those too.
Back to top
View user's profile Send private message
hurikhan77
n00b
n00b


Joined: 01 May 2017
Posts: 7
Location: Germany

PostPosted: Thu Jul 19, 2018 3:30 pm    Post subject: Reply with quote

I have a (currently) permanent mirror here with symmetric bandwidth to the internet:

https://jupiter.ipfs.kaishome.de/

But it's a very cheap VM, it may be down sometimes.

And it may be very slow in first access due to very poor NS resolution performance within ipfs.
Back to top
View user's profile Send private message
hurikhan77
n00b
n00b


Joined: 01 May 2017
Posts: 7
Location: Germany

PostPosted: Sun Sep 16, 2018 1:18 am    Post subject: More files Reply with quote

Here's the result of my current hunt for the game files:

https://ipfs.io/ipfs/QmSJrwpZfaGcMj7nWcgW3Pxm6T7ybVuRfQm4tcy3AdYaHc/distfiles

Only Strikeforce is missing... Anyone has the file?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2166
Location: Germany

PostPosted: Fri Sep 21, 2018 9:56 pm    Post subject: Reply with quote

hi hurikhan77,

i am not sure, and try to set up a mirror on my own, by clone your files frome ipfs.io
Not sure if i want to share it through my isp because i just have 10 MB Upload right now and do not throttle my upload. If its 100% used, some Connections stuck.

However during the search for the strikeforce File, i found this:
Edit: Ok seems wrong, just 98 MB instead of the 428 MB sorry But can we use the .exe File too?

https://gitweb.gentoo.org/repo/gentoo.git/snapshot/gentoo-c8d98cc687543eb78da0d7bdb7bf9a78b5216b79.zip
With google on this link: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c8d98cc687543eb78da0d7bdb7bf9a78b5216b79&context=4&ignorews=0&dt=0

And it seems to be a gentoo-ebuild commit with a snapshot of that file!

But i did not check it.. because i did not install ut2004. However i know that i uninstall it because of some chat about unsecure server code. However Offline or in Lan it shoud work. ;D

All Links i tried before on the official forum are dead: http://www.strikeforcemod.com/phpBB3/viewtopic.php?f=4&t=1908

I just found the 428MB .exe Files for that on the web.

Like this one:
Code:
 sha512sum ./strikeforce-ce-v4.1.exe
d83c043bd417eb07add1780ec39a3054865f189f4b722e7ee75c81a42e16651e6aaea394e3d1b0b319375b8d11b3af894329ddea5aa5d3a06468c67e6624b416  ./strikeforce-ce-v4.1.exe
Back to top
View user's profile Send private message
hurikhan77
n00b
n00b


Joined: 01 May 2017
Posts: 7
Location: Germany

PostPosted: Fri Sep 21, 2018 10:50 pm    Post subject: Reply with quote

ChrisJumper wrote:
hi hurikhan77,

i am not sure, and try to set up a mirror on my own, by clone your files frome ipfs.io
Not sure if i want to share it through my isp because i just have 10 MB Upload right now and do not throttle my upload. If its 100% used, some Connections stuck.


I'm not sure what you are trying to say. Is your upload volume capped to 10 MB? Then you probably don't want to use ipfs.

Is your upload speed capped at 10 MB? Then what is it? Bytes or bits? Per second? Ipfs should run just fine with 10 Mbps upload. But it won't run well with routers that limit connection tracking too much, you should configure a connection limit then.

See https://github.com/ipfs/go-ipfs/blob/master/docs/config.md#swarm, configuration options ConnMgr. But I'm not sure how to tune these values correctly, I'm just using defaults (which is something like basic/900/600).

ChrisJumper wrote:

However during the search for the strikeforce File, i found this:
Edit: Ok seems wrong, just 98 MB instead of the 428 MB sorry But can we use the .exe File too?


This is the file I found, too. And it exists in different versions with different hashes so I believe that some EXE files may bundle unwanted code. So I'm against using the EXE file even because we have no hash of the original vendor file.

ChrisJumper wrote:

https://gitweb.gentoo.org/repo/gentoo.git/snapshot/gentoo-c8d98cc687543eb78da0d7bdb7bf9a78b5216b79.zip
With google on this link: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c8d98cc687543eb78da0d7bdb7bf9a78b5216b79&context=4&ignorews=0&dt=0


This doesn't help at all, it's just an old portage tree. I traversed the history of the tree already to find older manifest files with other checksums, then google the checksums. There're no usable results other than this manifest file.

ChrisJumper wrote:

And it seems to be a gentoo-ebuild commit with a snapshot of that file!


No it's not, it's just a snapshot of the ebuild and manifest, but not the file. The file was never part of any official gentoo mirror. It was always required to be downloaded from the vendor.

ChrisJumper wrote:

But i did not check it.. because i did not install ut2004. However i know that i uninstall it because of some chat about unsecure server code. However Offline or in Lan it shoud work. ;D

All Links i tried before on the official forum are dead: http://www.strikeforcemod.com/phpBB3/viewtopic.php?f=4&t=1908

I just found the 428MB .exe Files for that on the web.

Like this one:
Code:
 sha512sum ./strikeforce-ce-v4.1.exe
d83c043bd417eb07add1780ec39a3054865f189f4b722e7ee75c81a42e16651e6aaea394e3d1b0b319375b8d11b3af894329ddea5aa5d3a06468c67e6624b416  ./strikeforce-ce-v4.1.exe


In theory I could just use 7zip to safely uncompress the exe (it works in Linux, I tried).

But I prefer to find the original zip file with a hash matching the manifest to know that the file has not been tampered with. Many download sites (especially ad-supported mirrors) tamper with the downloads and include drive-by downloaders. I don't want any such code being downloaded by portage, even if it probably wouldn't work with Linux. There's a chance that a user would run a downloaded EXE in wine or Windows.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2166
Location: Germany

PostPosted: Fri Sep 21, 2018 11:05 pm    Post subject: Reply with quote

Its a Cable 10 MB/s Upload and if Apache upload some Files and use 100% of the affordable Bandwidth the Download stuck too, for every Client in my Network. I just want to throttle it down to 25%. The Chance that i have to upload 3 or More files at the same time is low. However the Lan Clients sometimes use the full bandwidth and my Network stuck.

However this could be an issue of my network not sharing the bandwidth equally and could be fixed.

I try to use the torrent network now to download the zip File. If i have success i come back!

Edit: But it seems that this torrent File is dead.
Mirror is online
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum