Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kein Zugriff auf verschlüsselte Festplatte: cryptsetup hängt
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2243
Location: Konradsreuth (Germany)

PostPosted: Fri Jul 21, 2017 6:40 am    Post subject: Kein Zugriff auf verschlüsselte Festplatte: cryptsetup hängt Reply with quote

Hallo allerseits!

Ich habe gerade ein Problem mit einer verschlüsselten Festplatte (die ich schon länger nicht mehr benutzt habe, deswegen weiß ich auch nicht, was für ein Update das gewesen sein könnte …)

Ich habe bisher die Festplatte immer per KDE gemountet. Das hat auch problemlos funktioniert. Heute bekomme ich „Sie haben nicht die Berechtigung, das Gerät einzuhängen“ oder sowas. Also hab ich mir das mal auf der Konsole angeschaut.
Code:
# cryptsetup -v luksOpen /dev/sdb1 backup

hängt „einfach so“, der Prozess belegt 100 % CPU. Die Debug-Option ist nicht viel aussagekräftiger:
Code:
# cryptsetup --debug luksOpen /dev/sdb1 backup
# cryptsetup 1.7.4 processing "cryptsetup --debug luksOpen /dev/sdb1 backup"
# Running command open.
# Locking memory.
# Installing SIGINT/SIGTERM handler.
# Unblocking interruption on signal.
# Allocating crypt device /dev/sdb1 context.

Keine Fehlermeldung, nichts in dmesg, nichts in einer Logdatei. Der Prozess hängt und belegt 100 % CPU. Was tun?!
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 380
Location: 09xxx

PostPosted: Fri Jul 21, 2017 9:54 pm    Post subject: Reply with quote

starte es doch mal mit trace. Da dürfte etwas mehr rauskommen.
_________________
Linux ryzen 4.12.12-gentoo #2 SMP Wed Oct 25 10:53:02 CEST 2017 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
tberger2
n00b
n00b


Joined: 05 Feb 2013
Posts: 55

PostPosted: Thu Aug 03, 2017 9:57 am    Post subject: Reply with quote

Hast Du ein LUKS header backup?
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2243
Location: Konradsreuth (Germany)

PostPosted: Thu Aug 03, 2017 5:17 pm    Post subject: Reply with quote

Glücklicherweise hat sich das Problem mittlerweile erledigt: Ich hab auf ~sys-fs/cryptsetup-1.7.5 upgedatet, und jetzt geht's wieder …
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum