Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Audio through HDMI in Steam's Big Picture mode [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 303
Location: Oleiros

PostPosted: Sun Jun 25, 2017 8:01 am    Post subject: Audio through HDMI in Steam's Big Picture mode [solved] Reply with quote

Hi,

is this even possible? I have Steam installed using "steam-overlay" and it works without a glitch, but some of the games I'd rather play them on my TV , which is connected to the computer through a HDMI cable. My setup is fine for playing movies since vlc/mpv allow to choose the audio output. However, I can't find any such option inside steam. Moreover, when in "Big Picture", if I go to "Audio Device", I get the message "Audio settings unavailable. Failed to connect to audio Service." Not sure if this is even relevant since if I go to "Voice" then I can see that ALSA is present.

Anyway, anyone got this kind of setup to work (without Pulseaudio if possible)?

Cheers


Last edited by mani001 on Sat Jul 01, 2017 7:23 am; edited 1 time in total
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4710
Location: The Peanut Gallery

PostPosted: Sun Jun 25, 2017 2:08 pm    Post subject: Reply with quote

Do you have SDL_AUDIODRIVER=alsa in the env?

I don't use it myself, but this came up as a tip from Naib before. Check the following post from mv.
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 303
Location: Oleiros

PostPosted: Mon Jun 26, 2017 7:33 am    Post subject: Reply with quote

Thanks for the prompt reply, steveL.

I tried that and still see the same message. However, the sound in itself is not the problem: I can hear sound both in "regular mode" and "Big picture" mode. The problem is I can't find any way to send the sound through HDMI.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 10803

PostPosted: Tue Jun 27, 2017 1:21 am    Post subject: Reply with quote

In some configurations, HDMI sound output ends up represented as an alternate sound card. If sound works for you in general (but not to the device you want), then probably this is a general issue with ALSA's defaults differing from what you want, and fixing that may make Steam work without any Steam-specific changes. What is the output of aplay --list-devices ; aplay --list-pcm? Can you route sound from aplay (or mplayer) to HDMI with the right command line option to set a particular card? If yes, then you need an ALSA configuration file to make that routing default. I think mplayer's syntax would be mplayer -ao alsa:device=hw=M.N for some integers M, N based on your devices. Note that this opens the device in exclusive mode, which may not be what you want long term.
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 303
Location: Oleiros

PostPosted: Sat Jul 01, 2017 7:23 am    Post subject: Reply with quote

Sorry for the delay (during the week I didn't get round to try this stuff)

Thanks Hu, that helped and I got it working now. For future reference, I put

Code:
pcm.!default {
      type hw
      card 1
      device 8
 }


inside .asoundrc.hdmi and if I want to route the sound to hdmi from Steam/mpv/whatever I use

Code:
ALSA_CONFIG_PATH=~/.asoundrc.hdmi steam/mpv
Back to top
View user's profile Send private message
ronaldoc
n00b
n00b


Joined: 03 Jul 2017
Posts: 11

PostPosted: Mon Jul 17, 2017 7:36 am    Post subject: Reply with quote

pcm.!default {
type hw
card 1
device 8
}

This worked for you? Hmm I guess I need to try something else
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 303
Location: Oleiros

PostPosted: Mon Jul 17, 2017 8:09 am    Post subject: Reply with quote

yes...I guess :)

Of course, the "card 1" and "device 8" are specific for my system. You can use the commands Hu posted above to check those values for you...or maybe vlc (you can try selecting different values from the "Audio device" list until it works).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum