Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox and Thunderbird on arm64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38388
Location: 56N 3W

PostPosted: Mon May 22, 2017 8:47 am    Post subject: Firefox and Thunderbird on arm64 Reply with quote

Team,

Both Firefox and Thunderbird on a Raspberry Pi 3 in 64 bit mode appear to stall at
Code:
        --optimizejars \
         \
         \
        package-manifest ../../dist ../../dist/thunderbird \
        --non-resource defaults/messenger/mailViews.dat
 * Unable to trace static ELF: /sbin/ldconfig: /sbin/ldconfig -p
 * Unable to trace static ELF: /sbin/ldconfig: /sbin/ldconfig -p
Warning: /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/mail/installer/package-manifest:241: Missing file(s): bin/components/mozldap.xpt
Warning: /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/mail/installer/package-manifest:243: Missing file(s): bin/components/nsAbLDAPAutoCompleteSearch.js
Warning: /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/mail/installer/package-manifest:244: Missing file(s): bin/components/nsLDAPProtocolHandler.js
Warning: /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/mail/installer/package-manifest:245: Missing file(s): bin/components/ldapComponents.manifest
Warning: /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/mail/installer/package-manifest:246: Missing file(s): bin/libldap60.so
Warning: /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/mail/installer/package-manifest:247: Missing file(s): bin/libldif60.so
Warning: /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/mail/installer/package-manifest:248: Missing file(s): bin/libprldap60.so
Executing /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/dist/bin/xpcshell -g /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/dist/bin/ -a /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/tbird/dist/bin/ -f /var/tmp/portage/mail-client/thunderbird-52.1.0/work/thunderbird-52.1.0/mozilla/toolkit/mozapps/installer/precompile_cache.js -e precompile_startupcache("resource://gre/");


I left firefox for over 48h.
There is no CPU activity, 148M in swap.

It appears to want to rum some java and there is a selection of java-vm installed.
Code:
Pi3 64bit ~ # eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-7  system-vm
  [2]   icedtea-8
  [3]   oracle-jdk-bin-1.8


Any hints as to how to investigate this?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2141
Location: Berlin, Germany

PostPosted: Tue May 23, 2017 7:15 am    Post subject: Reply with quote

I think this problem is not 64 bit specific. A user reported this last year on arm, but did not follow up on it:
https://archives.gentoo.org/gentoo-user/message/b2a663a8785f27b09ffdedc6032c81bf

Also at least one other user has independently rediscovered this issue, but nobody bothered to report a bug apparently: My first idea would be to check if a manual build works, and if it does disable Gentoo specific stuff like sandbox.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38388
Location: 56N 3W

PostPosted: Tue May 23, 2017 8:35 am    Post subject: Reply with quote

chithanh,

Thanks, I'll try that when libreoffice finishes building. That probably won't be today.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3053
Location: Gainesville, Florida

PostPosted: Mon Jun 05, 2017 9:11 pm    Post subject: Reply with quote

Neddy,
I just had the same thing happen with thunderbird on my Ryzen ~amd64 systems. There's a post on bugzilla that said downgrading sandbox to 2.10-r1 worked for some, so I tried it but failed with exactly the same error.

https://bugs.gentoo.org/show_bug.cgi?id=580726 I am running gcc-7.1.0-r1, so there's that....
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.25-r3, gcc-7.1.0-r1 kernel-4.12.6 gentoo USE=experimental
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38388
Location: 56N 3W

PostPosted: Mon Jun 05, 2017 9:21 pm    Post subject: Reply with quote

wrc1944,

There is also https://bugs.gentoo.org/show_bug.cgi?id=617882.

As I posted on the bug, there is no logic behind the workaround there.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 497
Location: Venice FL

PostPosted: Mon Jun 05, 2017 11:07 pm    Post subject: Reply with quote

Just to chime in...

I'm also seeing this on Ryzen with gcc-7.1.0-r1, have not had time to look onto it much, and did not record the error message in dmesg, but easy to reproduce, oom killer kicks it out which was a surprise since I have 32G of ram.

George
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 497
Location: Venice FL

PostPosted: Tue Jun 06, 2017 12:47 am    Post subject: Reply with quote

well FWIW setting USE="custom-cflags custom-optimization" for firefox and emerging with:
Code:

CXXFLAGS="${CXXFLAGS} -mno-avx" emerge -1v firefox

Worked fine here.

George
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3053
Location: Gainesville, Florida

PostPosted: Tue Jun 06, 2017 8:40 pm    Post subject: Reply with quote

thumper,
On thunderbird-52.1.1
Code:
CXXFLAGS="${CXXFLAGS} -mno-avx" emerge thunderbird
worked perfectly for me on ~amd64 Ryzen system, gcc-7.1.0-r1. :)

Thanks much to you and Neddy for the tips. Much appreciated.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.25-r3, gcc-7.1.0-r1 kernel-4.12.6 gentoo USE=experimental
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 497
Location: Venice FL

PostPosted: Fri Jun 16, 2017 1:00 am    Post subject: Reply with quote

FWIW.

For firefox-54.0 and thunderbird-52.2.0 I had to change it to the following to get them installed.

Code:

CXXFLAGS="${CXXFLAGS} -Os -mno-avx" USE="custom-cflags custom-optimization" emerge -1v firefox
CXXFLAGS="${CXXFLAGS} -Os -mno-avx" USE="custom-cflags custom-optimization" emerge -1v thunderbird


YMMV.

George
Back to top
View user's profile Send private message
mDup
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 126

PostPosted: Mon Jun 19, 2017 9:24 pm    Post subject: Reply with quote

thumper wrote:
FWIW.

For firefox-54.0 and thunderbird-52.2.0 I had to change it to the following to get them installed.

Code:

CXXFLAGS="${CXXFLAGS} -Os -mno-avx" USE="custom-cflags custom-optimization" emerge -1v firefox
CXXFLAGS="${CXXFLAGS} -Os -mno-avx" USE="custom-cflags custom-optimization" emerge -1v thunderbird


YMMV.

George

Did your emerge for firefox-54.0 also require rust and cargo?
Emering rust itself requires rustc so I first built it from git src and installed in /usr/local.
But now (unlike build from git src) emerge for rust fails with errors like:
Code:
# grep error.*: build.log | sort | uniq -c
     74 error[E0433]: failed to resolve. Could not find `Try` in `ops`
      1 error: requires `freeze` lang_item
      5 error: unused macro definition

here is the emerge -pv of firefox:
Code:
# emerge -pv firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-lang/rust-1.16.0:stable/1.16::gentoo  USE="-clang -debug (-doc) -libcxx" 27,804 KiB
[ebuild  N     ] dev-util/cargo-0.17.0::gentoo  USE="-debug (-doc) (-libressl)" 14,253 KiB
[ebuild     U  ] www-client/firefox-54.0::gentoo [50.1.0-r1::rpi3] USE="dbus gmp-autoupdate hwaccel jemalloc pulseaudio system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-sqlite -bindist -custom-cflags -custom-optimization -debug (-hardened) -jack -neon -nsplugin% (-pgo) (-selinux) -startup-notification (-system-cairo) {-test} -wifi (-gtk2%) (-jit%*) (-skia%)" L10N="-ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-GB -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -ka% -kab% -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW (-be%)" 223,816 KiB

Total: 3 packages (1 upgrade, 2 new), Size of downloads: 265,872 KiB
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38388
Location: 56N 3W

PostPosted: Mon Jun 19, 2017 9:35 pm    Post subject: Reply with quote

mDup,

The rust and cargo ebuilds fetch the birnaries that they need to build with.
If this is arm64 they both need patches but they are keyworded for ~arm64 and ~x86.

The arm64 patches and instructions are on the Gentoo Wiki
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 497
Location: Venice FL

PostPosted: Mon Jun 19, 2017 9:50 pm    Post subject: Reply with quote

My emerge log for that day shows:
Code:
     Thu Jun 15 17:38:11 2017 >>> dev-lang/rust-1.16.0
     Thu Jun 15 17:41:35 2017 >>> dev-util/cargo-0.17.0
     Thu Jun 15 20:14:42 2017 >>> www-client/firefox-54.0
     Thu Jun 15 20:49:22 2017 >>> mail-client/thunderbird-52.2.0


I'm on x86_64 (Ryzen) and the build for firefox and thunderbird failed with the same error as mentioned in this post.
I would guess that ARM has the avx processor flag as well that seems to be at the root of the problem.

According to this rustc is part of rust:
Code:
#  equery belongs /usr/bin/rustc
 * Searching for /usr/bin/rustc ...
dev-lang/rust-1.16.0 (/usr/bin/rustc-1.16.0)


George
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38388
Location: 56N 3W

PostPosted: Mon Jun 19, 2017 9:52 pm    Post subject: Reply with quote

thumper,

Nope. Setting -fno-avx on arm64 upsets gcc. Its not a legal setting.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mDup
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 126

PostPosted: Mon Jun 19, 2017 9:54 pm    Post subject: Reply with quote

NeddySeagoon wrote:
mDup,

The rust and cargo ebuilds fetch the birnaries that they need to build with.
If this is arm64 they both need patches but they are keyworded for ~arm64 and ~x86.

The arm64 patches and instructions are on the Gentoo Wiki

I will give that a try.
Keep you informed.
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 497
Location: Venice FL

PostPosted: Mon Jun 19, 2017 10:04 pm    Post subject: Reply with quote

NeddySeagoon wrote:
thumper,

Nope. Setting -fno-avx on arm64 upsets gcc. Its not a legal setting.


Interesting, same failure, different cause, well, not being a user of ARM I will step out. :)

Cheers;

George
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3053
Location: Gainesville, Florida

PostPosted: Tue Jun 20, 2017 8:07 pm    Post subject: Reply with quote

Hmmmm.. FWIW, one of my ~amd64 Ryzen systems also pulled in rust (didn't notice cargo though). Guess it was firefox that needed it, but I do also have Thunderbird on one of my Ryzen systems. IIRC rust took quite a while to compile, even on a pretty powerful system.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.25-r3, gcc-7.1.0-r1 kernel-4.12.6 gentoo USE=experimental
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38388
Location: 56N 3W

PostPosted: Tue Jun 20, 2017 8:32 pm    Post subject: Reply with quote

wrc1944,

That's the bundled LLVM.

Code:
aarch64 NeddySeagoon_Static / # genlop -t rust cargo firefox
 * dev-lang/rust

     Sun Jun 18 04:30:42 2017 >>> dev-lang/rust-1.16.0-r100
       merge time: 7 hours, 8 minutes and 6 seconds.

 * dev-util/cargo

     Sun Jun 18 10:07:42 2017 >>> dev-util/cargo-0.17.0
       merge time: 36 minutes and 7 seconds.

 * www-client/firefox

     Tue Jun 20 21:14:21 2017 >>> www-client/firefox-54.0
       merge time: 2 hours, 51 minutes and 8 seconds.


--- edit ---

Posting this update from firefox-54.0 built with rust and cargo in an aarch64 chroot then installed on a 64 bit Raspberry Pi 3.
Code:
FEATURES="-sandbox -usersandbox" MAKEOPTS="-j8" emerge firefox
is ugly though.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mDup
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 126

PostPosted: Tue Jun 20, 2017 10:52 pm    Post subject: Reply with quote

mDup wrote:
NeddySeagoon wrote:
mDup,

The rust and cargo ebuilds fetch the birnaries that they need to build with.
If this is arm64 they both need patches but they are keyworded for ~arm64 and ~x86.

The arm64 patches and instructions are on the Gentoo Wiki

I will give that a try.
Keep you informed.


rust and cargo emerge fine natively

native firefox 54.0 emerge has same problem as reported by others (and myself) elsewhere

Code:
Executing /var/tmp/portage/www-client/firefox-54.0/work/firefox-54.0/ff/dist/bin/xpcshell -g /var/tmp/portage/www-client/firefox-54.0/work/firefox-54.0/ff/dist/bin/ -a /var/tmp/portage/www-client/firefox-54.0/work/firefox-54.0/ff/dist/bin/ -f /var/tmp/portage/www-client/firefox-54.0/work/firefox-54.0/toolkit/mozapps/installer/precompile_cache.js -e precompile_startupcache("resource://gre/");


takes forever
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 38388
Location: 56N 3W

PostPosted: Tue Jun 20, 2017 11:14 pm    Post subject: Reply with quote

mDup,

Turn off the sandbox.
Code:
FEATURES="-sandbox -usersandbox" emerge firefox -av
worked for me.
Firefox-54.0 runs on a Pi3 too. I have not tested audio yet.

I also have
/etc/portage/patches/www-client/firefox/no-optimise.patch:

--- ./browser/config/mozconfigs/linux32/common-opt.orig 2017-03-27 16:47:57.039428674 -0700
+++ ./browser/config/mozconfigs/linux32/common-opt      2017-03-27 16:43:26.004591584 -0700
@@ -3,6 +3,7 @@
 ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}
 ac_add_options --with-google-api-keyfile=/builds/gapi.data
 ac_add_options --with-mozilla-api-keyfile=/builds/mozilla-desktop-geoloc-api.key
+ac_add_options --disable-startupcache
 
 . $topsrcdir/build/unix/mozconfig.linux32
 
--- ./browser/config/mozconfigs/linux64/common-opt.orig 2017-03-27 16:46:54.794982020 -0700
+++ ./browser/config/mozconfigs/linux64/common-opt      2017-03-27 16:47:05.345170624 -0700
@@ -3,6 +3,7 @@
 ac_add_options --enable-update-channel=${MOZ_UPDATE_CHANNEL}
 ac_add_options --with-google-api-keyfile=/builds/gapi.data
 ac_add_options --with-mozilla-api-keyfile=/builds/mozilla-desktop-geoloc-api.key
+ac_add_options --disable-startupcache
 
 . $topsrcdir/build/unix/mozconfig.linux
as that was supposed to fix the stall on its own.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mDup
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 126

PostPosted: Wed Jun 21, 2017 1:05 pm    Post subject: Reply with quote

NeddySeagoon wrote:
mDup,
Turn off the sandbox.
Code:
FEATURES="-sandbox -usersandbox" emerge firefox -av
worked for me.
Firefox-54.0 runs on a Pi3 too. I have not tested audio yet.

@NeddySeagoon
Thanks for expert advice. firefox-54.0 builds now (no patch needed).
Unfortunately I regularly get 'Segmentation fault's. Even with entire mozilla files cleaned.
But that may be my specific problem.
update
firefox-54.0 runs fine under 4.12.x (of course: no audio as it is WIP on amlogic mainline)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum