Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Steam complains: "Unsupported video card...?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1075

PostPosted: Mon Jun 19, 2017 6:39 am    Post subject: Steam complains: "Unsupported video card...? Reply with quote

I installed steam as an ovelay and it works ok. However after downloading some games,
I get an error while trying to start a game: "Unsupported video card. Your video card or it's driver may not be supported..."

I have this video card and open source radeon driver is installed in my system:
Code:
lspci | grep -i VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cypress PRO [Radeon HD 5850]
lspci -nnk | grep -i vga -A3 | grep 'in use'
   Kernel driver in use: radeon

Please advise how to run the game by terminal (or any log file) so can see what are exact complains of steam?
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2142
Location: Berlin, Germany

PostPosted: Mon Jun 19, 2017 7:32 am    Post subject: Reply with quote

Normally that is because of your OpenGL version.

Install mesa-progs and run
Code:
$ glxinfo | grep "version string"

For your Evergreen generation card It should output something like
Code:
OpenGL core profile version string: 4.1 (Core Profile) Mesa 17.0.6
If not, then you need to investigate why that is.
  • Make sure that mesa and llvm are upgraded to latest stable versions at least
  • bindist flag needs to be disabled in mesa if you want >OpenGL 3.3
  • Look for firmware related errors in dmesg
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1075

PostPosted: Mon Jun 19, 2017 11:58 am    Post subject: Reply with quote

chithanh,

Quote:
Normally that is because of your OpenGL version.

You are right! OpenGL was old version: OpenGL version string: 2.1 Mesa 17.0.6
I added media-libs/mesa -bindist to package.use and after updating the system I get now:
Code:
OpenGL core profile version string: 4.1 (Core Profile) Mesa 17.0.6

At the moment it fixed the "Unsupported video card..." message however the game still does not start,
and get this error message: "An Error occurred while updating the game..."
In dmesg looks the right radeon firmware.
Here llvm - Is it latest?
Code:

[I] sys-devel/llvm
     Available versions: 
     (0)    ~*3.4.2-r100(0/3.4) ~*3.5.2-r100(0/3.5) ~*3.6.2-r100(0/3.6) 3.7.1-r3(0/3.7.1) ~3.8.1-r2(0/3.8.0) 3.9.1-r1(0/3.9.1)
     (4)    ~4.0.0-r2
     (5)    **9999
       {clang debug default-compiler-rt default-libcxx (+)doc gold libedit +libffi lldb multitarget ncurses ocaml python +sanitize +static-analyzer test xml ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" ELIBC="musl" KERNEL="Darwin FreeBSD" LLVM_TARGETS="AArch64 AMDGPU ARM BPF Hexagon Lanai MSP430 Mips NVPTX PowerPC RISCV Sparc SystemZ X86 XCore" PYTHON_TARGETS="python2_7" VIDEO_CARDS="radeon"}
     Installed versions:  3.9.1-r1(10:55:55 PM 06/07/2017)(libffi ncurses sanitize static-analyzer xml -clang -debug -default-compiler-rt -default-libcxx -doc -gold -libedit -lldb -multitarget -ocaml -python -test ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" ELIBC="-musl" KERNEL="-Darwin -FreeBSD" LLVM_TARGETS="AMDGPU BPF NVPTX X86 -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7")
     Homepage:            http://llvm.org/
     Description:         Low Level Virtual Machine


EDIT: How to run the game from terminal in order to see error messages? Or may be can view any log file?

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2142
Location: Berlin, Germany

PostPosted: Tue Jun 20, 2017 1:51 am    Post subject: Reply with quote

pmam wrote:
At the moment it fixed the "Unsupported video card..." message however the game still does not start,

"The" game? Do you mean all the games, or just some?
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1075

PostPosted: Tue Jun 20, 2017 5:09 am    Post subject: Reply with quote

Quote:
"The" game? Do you mean all the games, or just some?

All games, even small one.
I wish to run the game through terminal, so can see full error messages? Or any log file?

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3253

PostPosted: Tue Jun 20, 2017 3:32 pm    Post subject: Reply with quote

pmam wrote:
Or any log file?

Thanks


/var/log/Xorg.0.log - does that have anything useful?
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
rh
n00b
n00b


Joined: 19 Sep 2006
Posts: 55

PostPosted: Tue Jun 20, 2017 6:14 pm    Post subject: Reply with quote

pmam wrote:
game still does not start, and get this error message: "An Error occurred while updating the game..."


As always, try to run steam without steam runtime (STEAM_RUNTIME=0 steam), and forcing it over system libraries (STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam). If this doesn't work, from steam settings empty your download cache, verify game download, and try another download server. In order to dig deeper, you would need to provide more info about your system. To be more specific, anything unusual with security (such as hardened kernel), filesystem and network would be prime suspects. As an example, you might have 64bit NetworkManager which conflicts with the 32bit version which steam ships and requires. I have set both 64bit and 32bit ABI system wide, and my only issue is I should have done it long ago.

pmam wrote:
Here llvm - Is it latest?


Radeon 5850 should use mesa "radeon" driver instead of "radeonsi", and with radeon llvm isn't used as shader compiler. Running both mesa and llvm as stable or keyworded is just fine.

pmam wrote:
How to run the game from terminal in order to see error messages?


Default install location is ~/.local/share/Steam/Steamapps/common/the_game, just run from terminal. Most games depends on steam to be running, but some work without steam running. Many games will depend on steam runtime, and might not lauch, but some are shipped with libraries they need, and will work.

pmam wrote:
Or may be can view any log file?


/tmp/dumps/USER_stdout.txt
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1075

PostPosted: Wed Jun 21, 2017 7:03 am    Post subject: Reply with quote

Quote:
"The" game? Do you mean all the games, or just some?

Correction - I double checked and found out that light game like Radiator 2 works ok sometimes -
not always - don't know why? war thunder crash on starting.

I am going to try rh tips later on

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
rh
n00b
n00b


Joined: 19 Sep 2006
Posts: 55

PostPosted: Wed Jun 21, 2017 7:52 am    Post subject: Reply with quote

rh wrote:
Radeon 5850 should use mesa "radeon" driver instead of "radeonsi"


Oops, I mean "r600" driver, not "radeon" which is the kernel driver, but my point remains valid.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1075

PostPosted: Wed Jun 21, 2017 11:53 am    Post subject: Reply with quote

rh,

I tried to run with:
Code:
STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam

and had the same problem. Then went to this directory:
Code:
 ~/.local/share/Steam/steamapps/common/War Thunder

and after command ./run the game finally had started!
After "checking files and downloading..." the game has launched, however... The colors not ok, psychedelic :cry:
BTW: Why can not run the game from steam run-time ( I mean running steam from menu rather than terminal)

Quote:
anything unusual with security (such as hardened kernel), filesystem and network would be prime suspects.

AFAK do not have any of that. ALso have ABI_X86="64 32" in make.conf.

I see following error in terminal while running the game:
Code:
EE /var/tmp/portage/media-libs/mesa-17.0.6/work/mesa-17.0.6/src/gallium/drivers/r600/r600_state_common.c:799 r600_shader_select - Failed to build shader variant (type=1) -1
EE /var/tmp/portage/media-libs/mesa-17.0.6/work/mesa-17.0.6/src/gallium/drivers/r600/r600_shader.c:183 r600_pipe_shader_create - translation from TGSI failed !


P.S: This machine with win7 runs ok War Thunder.

EDIT: In the past War Thunder was running ok with fglrx propriety driver, but got the same issue of "The colors not ok, psychedelic" while using radeon's open source driver. At the moment fglrx is not supported by radeon and is not compatible with latest ver xorg.
May be we still have advantage of the propriety driver vs open source?

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
rh
n00b
n00b


Joined: 19 Sep 2006
Posts: 55

PostPosted: Thu Jun 22, 2017 8:36 am    Post subject: Reply with quote

pmam wrote:
I tried to run with:
Code:
STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam

and had the same problem. Then went to this directory:
Code:
 ~/.local/share/Steam/steamapps/common/War Thunder

and after command ./run the game finally had started!
After "checking files and downloading..." the game has launched, however... The colors not ok, psychedelic :cry:
BTW: Why can not run the game from steam run-time ( I mean running steam from menu rather than terminal)


Good to hear that you are getting forward. Steam ships it's own runtime of really old libraries for game developers to link to, and these libraries are the issue. By launching steam you are getting a mix of system and steam's libraries, and these somehow conflict in a way that doesn't in you case let War Thunder connect to it's servers. Now that we know it works without steam runtime, we can be certain the cause isn't somewhere else.

pmam wrote:
I see following error in terminal while running the game:
Code:
EE /var/tmp/portage/media-libs/mesa-17.0.6/work/mesa-17.0.6/src/gallium/drivers/r600/r600_state_common.c:799 r600_shader_select - Failed to build shader variant (type=1) -1
EE /var/tmp/portage/media-libs/mesa-17.0.6/work/mesa-17.0.6/src/gallium/drivers/r600/r600_shader.c:183 r600_pipe_shader_create - translation from TGSI failed !


There is a bug report on that:
https://bugs.freedesktop.org/show_bug.cgi?id=100387
You could try an older or git version of mesa, but if that doesn't work it might take some time before it gets fixed.

pmam wrote:
In the past War Thunder was running ok with fglrx propriety driver, but got the same issue of "The colors not ok, psychedelic" while using radeon's open source driver. At the moment fglrx is not supported by radeon and is not compatible with latest ver xorg.
May be we still have advantage of the propriety driver vs open source?


Well, r600 is an old driver, and not many developers care about it. Also, back in the day when r600 was in active developement, they decided to use a shader compiler called sb. Person who wrote it couldn't stay around to support it, and not too many developers understand it well enough to easily fix bugs. But even sb is being worked upon, as you can see from logs:
https://cgit.freedesktop.org/mesa/mesa/log/src/gallium/drivers/r600/sb
The prop driver is abandoned. You just need to pick the lesser of two evils.

If I were in you boots, I would just setup wine with gallium-nine to play it, and cc to b.f.o #100387 linked above to get news when the bug is fixed. You might ever get better performance with gallium-nine.
Back to top
View user's profile Send private message
pmam
Veteran
Veteran


Joined: 30 Dec 2013
Posts: 1075

PostPosted: Thu Jun 22, 2017 6:33 pm    Post subject: Reply with quote

Dear rh,

By your great support, at least I know the status of current setup...
I will follow the bug process and hope for good news.
I am not familiar with gallium-nine - need to read and see how to setup.
Looks that radeon and linux do not keep on good relationship with old hardware.

Thanks a lot!
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
rh
n00b
n00b


Joined: 19 Sep 2006
Posts: 55

PostPosted: Fri Jun 23, 2017 7:23 am    Post subject: Reply with quote

Good to hear I could help you someway.

For gallium-nine, you just enable USE=d3d9 for mesa and wine. If you are using masked testing ebuilds for wine, pick either wine-d3d9 or wine-any, but default wine-2.3 will work too. After that you just run winecfg, and set "Enable Gallium Nine for better D3D9 graphic performance". I think you can install steam with winetricks. I have a 5770 on an another computer, and it's still doing fine. Most games work, but not everything.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum