Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Displayport(DP) Audio Issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
tlb96
n00b
n00b


Joined: 05 Apr 2017
Posts: 1

PostPosted: Wed Apr 05, 2017 3:44 am    Post subject: Displayport(DP) Audio Issue Reply with quote

I am using GTX 980, dp output connected to my display. The speaker is also connected to the display.
This setup works fine under windows, sound comes out perfectly, but under gentoo, there is no sound coming out of the speaker.
The audio devices on my pc are listed below:
Quote:
lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
03:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)



the cmd aplay -l output:
Quote:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: Generic Analog [Generic Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Generic Digital [Generic Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: Generic Digital [Generic Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

and the related kext is
Quote:
snd_hda_codec_hdmi 32911 0
snd_hda_codec_realtek 57731 0


When I switch DP to HDMI, the sound comes out fine. Also HDA output on the motherboard(which corresponds to HDA Intel) works fine. So I think the problem is that I did not compile/load proper kext for dp audio. However, I cannot find anything related to DP audio in the kernel source.
Is there any idea how to solve this issue?
I appreciate your help!
Back to top
View user's profile Send private message
solo_segler
n00b
n00b


Joined: 17 Aug 2002
Posts: 17
Location: Vienna, Austria

PostPosted: Wed Apr 19, 2017 11:33 am    Post subject: Nvidia troubleshooting guide Reply with quote

Hi tlb96!

I recently run into the same problem after installing a new Nvidia GTX 1070 and found your topic. Maybe you will find the following guide from Nvidia helpful for your problem. In fact it solved mine.

ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html#_under_enumeration_of_hdmi_devices

Greetings from Vienna

Christian
Back to top
View user's profile Send private message
carb92
n00b
n00b


Joined: 18 Apr 2017
Posts: 4

PostPosted: Fri Apr 21, 2017 7:48 am    Post subject: Reply with quote

This should be a good future reference Christian.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum