Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Nasty screen flicker issue since gnome 3.22
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 247

PostPosted: Fri Apr 14, 2017 4:21 pm    Post subject: [solved] Nasty screen flicker issue since gnome 3.22 Reply with quote

Hi,
I experience nasty screen flicker since the emerge of gnome 3.22 a few weeks ago.

To date, I did not find out whats wrong. It seems that the shell, gnome terminal and firefox are more hurt than for instance chromium

Code:
 # emerge --info
!!! Invalid PORTDIR_OVERLAY (not a dir): '/var/lib/layman/palemoon'
Portage 2.3.3 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.9.4, glibc-2.23-r3, 4.9.16-gentoo x86_64)
=================================================================
System uname: Linux-4.9.16-gentoo-x86_64-AMD_Athlon-tm-_II_X4_630_Processor-with-gentoo-2.3
KiB Mem:    12302464 total,   6704824 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 14 Apr 2017 08:42:21 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.26.1 p1.0) 2.26.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.3_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.2::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.15::gentoo
sys-devel/binutils:       2.26.1::gentoo
sys-devel/gcc:            4.9.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo
    priority: -1000

Rudis
    location: /usr/local/portage/overlay
    masters: gentoo
    priority: 0

brother-overlay
    location: /usr/local/overlay/brother-overlay
    sync-type: git
    sync-uri: git://github.com/stefan-langenmaier/brother-overlay.git
    masters: gentoo

eva
    location: /var/lib/layman/eva
    masters: gentoo
    priority: 50

mrueg
    location: /var/lib/layman/mrueg
    masters: gentoo
    priority: 50

steam-overlay
    location: /usr/local/portage/steam-overlay
    sync-type: git
    sync-uri: https://github.com/anyc/steam-overlay.git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="(-selinux) 3dnow 3dnowext 3dnowprefetch X a52 aac abm acl acpi alsa amd64 apache2 apic berkdb bluetooth branding bzip2 cairo cdda cdr clflush cli cmov cmp_legacy colord constant_tsc cr8_legacy cracklib crypt cups cx16 cx8 cxx dbus de dri dts dvd dvdr eds egl emboss encode evo exif extapic extd_apicid fam ffh264vdpau ffmpeg firefox flac fortran fpu fxsr fxsr_opt gdbm gif glamor gles gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk3 ht hw_pstate ibs iconv icu introspection ipv6 jpeg lahf_lm lbrv lcms libnotify libsamplerate libsecret lm lm_sensors mad mca mce minizip misalignsse mmx mmxext mng modules monitor mono mp3 mp4 mpeg msr mtrr multilib mysql nautilus ncurses nls nonstop_tsc nopl npt nptl nrip_save nx ogg opengl openmp osvw pae pam pango pat pcre pdf pdpe1gb pge php pipe png policykit popcnt ppds pse pse36 pulseaudio python qt3support qt4 rdtscp readline rep_good sdl seccomp sep session skinit spell sse sse2 sse3 sse4a ssl startup-notification svg svm svm_lock syscall systemd tcpd telepathy threads thunderbird tiff tracker truetype tsc udev udisks unicode upower usb vaapi vala vdpau vme vmmcall vorbis wayland wdt weston winbind wxwidgets x264 xattr xcb xml xv xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="rme96" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext popcnt sse sse2 sse3 sse4a" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


I have nvidia-drivers enabled: /usr/portage/x11-drivers/nvidia-drivers/nvidia-drivers-378.13.ebuild

I have no idea what could possibly be wrong...
R.


Last edited by Wallsandfences on Thu Apr 27, 2017 8:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 247

PostPosted: Fri Apr 14, 2017 7:50 pm    Post subject: Reply with quote

Xorg.0.log yields nothing:
Code:
cat /var/log/Xorg.0.log
[    19.833] (--) Log file renamed from "/var/log/Xorg.pid-1320.log" to "/var/log/Xorg.0.log"
[    19.833]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[    19.834] X Protocol Version 11, Revision 0
[    19.834] Build Operating System: Linux 4.9.6-gentoo-r1 x86_64 Gentoo
[    19.834] Current Operating System: Linux eg-server 4.9.16-gentoo #1 SMP Fri Apr 14 16:35:11 CEST 2017 x86_64
[    19.834] Kernel command line: BOOT_IMAGE=/vmlinuz-4.9.16-gentoo root=UUID=daa21940-c704-4c28-a58a-0de829b635cc ro root=PARTUUID=00023e5c-02 ro init=/usr/lib/systemd/systemd modprobe.blacklist=nouveau systemd.setenv=GPUMOD=nvidia
[    19.834] Build Date: 16 March 2017  10:46:22AM
[    19.834] 
[    19.834] Current version of pixman: 0.34.0
[    19.834]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    19.834] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.834] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Apr 14 18:27:00 2017
[    19.835] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    19.835] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    19.837] (==) No Layout section.  Using the first Screen section.
[    19.837] (==) No screen section available. Using defaults.
[    19.837] (**) |-->Screen "Default Screen Section" (0)
[    19.837] (**) |   |-->Monitor "<default monitor>"
[    19.837] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[    19.837] (**) |   |-->Device "Device0"
[    19.837] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    19.838] (==) Automatically adding devices
[    19.838] (==) Automatically enabling devices
[    19.838] (==) Automatically adding GPU devices
[    19.838] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    19.840] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    19.840]    Entry deleted from font path.
[    19.840] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    19.840]    Entry deleted from font path.
[    19.840] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    19.840]    Entry deleted from font path.
[    19.840] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    19.840]    Entry deleted from font path.
[    19.840]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    19.841] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    19.841]    Entry deleted from font path.
[    19.841]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    19.841] (==) FontPath set to:
   /usr/share/fonts/misc/
[    19.841] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
[    19.841] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    19.841] (II) Loader magic: 0x81ed80
[    19.841] (II) Module ABI versions:
[    19.841]    X.Org ANSI C Emulation: 0.4
[    19.841]    X.Org Video Driver: 23.0
[    19.841]    X.Org XInput driver : 24.1
[    19.841]    X.Org Server Extension : 10.0
[    19.842] (++) using VT number 7

[    19.843] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c2
[    19.843] (II) xfree86: Adding drm device (/dev/dri/card0)
[    19.844] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[    19.845] (--) PCI:*(0:1:0:0) 10de:1040:0000:0000 rev 161, Mem @ 0xfb000000/16777216, 0xd8000000/134217728, 0xd6000000/33554432, I/O @ 0x0000dc00/128, BIOS @ 0x????????/131072
[    19.845] (II) LoadModule: "glx"
[    19.846] (II) Loading /usr/lib64/opengl/nvidia/extensions/libglx.so
[    19.925] (II) Module glx: vendor="NVIDIA Corporation"
[    19.925]    compiled for 4.0.2, module version = 1.0.0
[    19.925]    Module class: X.Org Server Extension
[    19.927] (II) NVIDIA GLX Module  378.13  Tue Feb  7 18:25:34 PST 2017
[    19.928] (II) LoadModule: "nvidia"
[    19.931] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    19.941] (II) Module nvidia: vendor="NVIDIA Corporation"
[    19.941]    compiled for 4.0.2, module version = 1.0.0
[    19.941]    Module class: X.Org Video Driver
[    19.942] (II) NVIDIA dlloader X Driver  378.13  Tue Feb  7 18:01:51 PST 2017
[    19.942] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    19.942] (II) systemd-logind: releasing fd for 226:0
[    19.944] (II) Loading sub module "fb"
[    19.944] (II) LoadModule: "fb"
[    19.944] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    19.946] (II) Module fb: vendor="X.Org Foundation"
[    19.946]    compiled for 1.19.2, module version = 1.0.0
[    19.946]    ABI class: X.Org ANSI C Emulation, version 0.4
[    19.946] (II) Loading sub module "wfb"
[    19.946] (II) LoadModule: "wfb"
[    19.946] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    19.948] (II) Module wfb: vendor="X.Org Foundation"
[    19.948]    compiled for 1.19.2, module version = 1.0.0
[    19.948]    ABI class: X.Org ANSI C Emulation, version 0.4
[    19.948] (II) Loading sub module "ramdac"
[    19.948] (II) LoadModule: "ramdac"
[    19.948] (II) Module "ramdac" already built-in
[    19.951] (II) NVIDIA(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    19.951] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    19.951] (==) NVIDIA(0): RGB weight 888
[    19.951] (==) NVIDIA(0): Default visual is TrueColor
[    19.951] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    19.952] (**) NVIDIA(0): Option "NoLogo" "True"
[    19.952] (**) NVIDIA(0): Enabling 2D acceleration
[    20.403] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[    20.403] (--) NVIDIA(0):     CRT-0
[    20.403] (--) NVIDIA(0):     CRT-1
[    20.403] (--) NVIDIA(0):     DFP-0 (boot)
[    20.403] (--) NVIDIA(0):     DFP-1
[    20.404] (II) NVIDIA(0): NVIDIA GPU GeForce GT 520 (GF119) at PCI:1:0:0 (GPU-0)
[    20.404] (--) NVIDIA(0): Memory: 1048576 kBytes
[    20.404] (--) NVIDIA(0): VideoBIOS: 75.19.1b.00.00
[    20.404] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    20.420] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    20.420] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    20.420] (--) NVIDIA(GPU-0):
[    20.421] (--) NVIDIA(GPU-0): CRT-1: disconnected
[    20.421] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    20.421] (--) NVIDIA(GPU-0):
[    20.453] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): connected
[    20.453] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): Internal TMDS
[    20.453] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): 330.0 MHz maximum pixel clock
[    20.453] (--) NVIDIA(GPU-0):
[    20.453] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    20.453] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    20.453] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    20.453] (--) NVIDIA(GPU-0):
[    20.455] (==) NVIDIA(0):
[    20.455] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    20.455] (==) NVIDIA(0):     will be used as the requested mode.
[    20.455] (==) NVIDIA(0):
[    20.456] (II) NVIDIA(0): Validated MetaModes:
[    20.456] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[    20.456] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[    20.472] (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
[    20.472] (--) NVIDIA(0):     option
[    20.472] (--) Depth 24 pixmap format is 32 bpp
[    20.472] (II) NVIDIA: Using 12288.00 MB of virtual memory for indirect memory
[    20.472] (II) NVIDIA:     access.
[    20.474] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    20.474] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    20.474] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    20.474] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    20.474] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    20.474] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    20.474] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    20.474] (II) NVIDIA(0):     Config Options in the README.
[    20.491] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[    20.533] (==) NVIDIA(0): Disabling shared memory pixmaps
[    20.533] (==) NVIDIA(0): Backing store enabled
[    20.533] (==) NVIDIA(0): Silken mouse enabled
[    20.535] (==) NVIDIA(0): DPMS enabled
[    20.535] (II) Loading sub module "dri2"
[    20.535] (II) LoadModule: "dri2"
[    20.535] (II) Module "dri2" already built-in
[    20.535] (II) NVIDIA(0): [DRI2] Setup complete
[    20.535] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    20.535] (--) RandR disabled
[    20.537] (II) Initializing extension GLX
[    20.537] (II) Indirect GLX disabled.
[    20.613] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[    20.613] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    20.613] (**) Power Button: Applying InputClass "system-keyboard"
[    20.613] (II) LoadModule: "evdev"
[    20.614] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[    20.615] (II) Module evdev: vendor="X.Org Foundation"
[    20.615]    compiled for 1.19.2, module version = 2.10.5
[    20.615]    Module class: X.Org XInput Driver
[    20.615]    ABI class: X.Org XInput driver, version 24.1
[    20.615] (II) Using input driver 'evdev' for 'Power Button'
[    20.616] (II) systemd-logind: got fd for /dev/input/event1 13:65 fd 36 paused 0
[    20.616] (**) Power Button: always reports core events
[    20.616] (**) evdev: Power Button: Device: "/dev/input/event1"
[    20.616] (--) evdev: Power Button: Vendor 0 Product 0x1
[    20.616] (--) evdev: Power Button: Found keys
[    20.616] (II) evdev: Power Button: Configuring as keyboard
[    20.616] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[    20.616] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    20.616] (**) Option "xkb_rules" "evdev"
[    20.616] (**) Option "xkb_model" "pc105"
[    20.616] (**) Option "xkb_layout" "de"
[    20.616] (**) Option "xkb_variant" "nodeadkeys"
[    20.616] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    20.645] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[    20.645] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    20.645] (**) Power Button: Applying InputClass "system-keyboard"
[    20.645] (II) Using input driver 'evdev' for 'Power Button'
[    20.645] (II) systemd-logind: got fd for /dev/input/event0 13:64 fd 37 paused 0
[    20.646] (**) Power Button: always reports core events
[    20.646] (**) evdev: Power Button: Device: "/dev/input/event0"
[    20.646] (--) evdev: Power Button: Vendor 0 Product 0x1
[    20.646] (--) evdev: Power Button: Found keys
[    20.646] (II) evdev: Power Button: Configuring as keyboard
[    20.646] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[    20.646] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[    20.646] (**) Option "xkb_rules" "evdev"
[    20.646] (**) Option "xkb_model" "pc105"
[    20.646] (**) Option "xkb_layout" "de"
[    20.646] (**) Option "xkb_variant" "nodeadkeys"
[    20.646] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    20.646] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event13)
[    20.646] (II) No input driver specified, ignoring this device.
[    20.646] (II) This device may have been added with another device file.
[    20.647] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event14)
[    20.647] (II) No input driver specified, ignoring this device.
[    20.647] (II) This device may have been added with another device file.
[    20.647] (II) config/udev: Adding input device Logitech USB Laser Mouse (/dev/input/event3)
[    20.647] (**) Logitech USB Laser Mouse: Applying InputClass "evdev pointer catchall"
[    20.647] (II) Using input driver 'evdev' for 'Logitech USB Laser Mouse'
[    20.700] (II) systemd-logind: got fd for /dev/input/event3 13:67 fd 38 paused 0
[    20.700] (**) Logitech USB Laser Mouse: always reports core events
[    20.700] (**) evdev: Logitech USB Laser Mouse: Device: "/dev/input/event3"
[    20.700] (--) evdev: Logitech USB Laser Mouse: Vendor 0x46d Product 0xc062
[    20.700] (--) evdev: Logitech USB Laser Mouse: Found 12 mouse buttons
[    20.700] (--) evdev: Logitech USB Laser Mouse: Found scroll wheel(s)
[    20.700] (--) evdev: Logitech USB Laser Mouse: Found relative axes
[    20.700] (--) evdev: Logitech USB Laser Mouse: Found x and y relative axes
[    20.700] (II) evdev: Logitech USB Laser Mouse: Configuring as mouse
[    20.700] (II) evdev: Logitech USB Laser Mouse: Adding scrollwheel support
[    20.700] (**) evdev: Logitech USB Laser Mouse: YAxisMapping: buttons 4 and 5
[    20.700] (**) evdev: Logitech USB Laser Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    20.700] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:12.0/usb3/3-2/3-2:1.0/0003:046D:C062.0001/input/input3/event3"
[    20.700] (II) XINPUT: Adding extended input device "Logitech USB Laser Mouse" (type: MOUSE, id 8)
[    20.700] (II) evdev: Logitech USB Laser Mouse: initialized for relative axes.
[    20.700] (**) Logitech USB Laser Mouse: (accel) keeping acceleration scheme 1
[    20.700] (**) Logitech USB Laser Mouse: (accel) acceleration profile 0
[    20.700] (**) Logitech USB Laser Mouse: (accel) acceleration factor: 2.000
[    20.700] (**) Logitech USB Laser Mouse: (accel) acceleration threshold: 4
[    20.701] (II) config/udev: Adding input device Logitech USB Laser Mouse (/dev/input/mouse0)
[    20.701] (II) No input driver specified, ignoring this device.
[    20.701] (II) This device may have been added with another device file.
[    20.701] (II) config/udev: Adding input device HDA ATI SB Line Out CLFE (/dev/input/event10)
[    20.701] (II) No input driver specified, ignoring this device.
[    20.701] (II) This device may have been added with another device file.
[    20.701] (II) config/udev: Adding input device HDA ATI SB Line Out Side (/dev/input/event11)
[    20.701] (II) No input driver specified, ignoring this device.
[    20.701] (II) This device may have been added with another device file.
[    20.702] (II) config/udev: Adding input device HDA ATI SB Front Headphone (/dev/input/event12)
[    20.702] (II) No input driver specified, ignoring this device.
[    20.702] (II) This device may have been added with another device file.
[    20.702] (II) config/udev: Adding input device HDA ATI SB Rear Mic (/dev/input/event5)
[    20.702] (II) No input driver specified, ignoring this device.
[    20.702] (II) This device may have been added with another device file.
[    20.702] (II) config/udev: Adding input device HDA ATI SB Front Mic (/dev/input/event6)
[    20.702] (II) No input driver specified, ignoring this device.
[    20.702] (II) This device may have been added with another device file.
[    20.702] (II) config/udev: Adding input device HDA ATI SB Line (/dev/input/event7)
[    20.702] (II) No input driver specified, ignoring this device.
[    20.702] (II) This device may have been added with another device file.
[    20.702] (II) config/udev: Adding input device HDA ATI SB Line Out Front (/dev/input/event8)
[    20.702] (II) No input driver specified, ignoring this device.
[    20.702] (II) This device may have been added with another device file.
[    20.703] (II) config/udev: Adding input device HDA ATI SB Line Out Surround (/dev/input/event9)
[    20.703] (II) No input driver specified, ignoring this device.
[    20.703] (II) This device may have been added with another device file.
[    20.703] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[    20.703] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    20.703] (**) AT Translated Set 2 keyboard: Applying InputClass "system-keyboard"
[    20.703] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    20.704] (II) systemd-logind: got fd for /dev/input/event2 13:66 fd 39 paused 0
[    20.704] (**) AT Translated Set 2 keyboard: always reports core events
[    20.704] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[    20.704] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    20.704] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    20.704] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    20.704] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input2/event2"
[    20.704] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    20.704] (**) Option "xkb_rules" "evdev"
[    20.704] (**) Option "xkb_model" "pc105"
[    20.704] (**) Option "xkb_layout" "de"
[    20.704] (**) Option "xkb_variant" "nodeadkeys"
[    20.704] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    20.704] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[    20.704] (II) No input driver specified, ignoring this device.
[    20.704] (II) This device may have been added with another device file.
[    21.067] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    21.067] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    21.067] (--) NVIDIA(GPU-0):
[    21.068] (--) NVIDIA(GPU-0): CRT-1: disconnected
[    21.068] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    21.068] (--) NVIDIA(GPU-0):
[    21.100] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): connected
[    21.100] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): Internal TMDS
[    21.100] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): 330.0 MHz maximum pixel clock
[    21.100] (--) NVIDIA(GPU-0):
[    21.100] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    21.100] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    21.100] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    21.100] (--) NVIDIA(GPU-0):
[    23.910] (--) NVIDIA(GPU-0): CRT-0: disconnected
[    23.910] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[    23.910] (--) NVIDIA(GPU-0):
[    23.911] (--) NVIDIA(GPU-0): CRT-1: disconnected
[    23.911] (--) NVIDIA(GPU-0): CRT-1: 400.0 MHz maximum pixel clock
[    23.911] (--) NVIDIA(GPU-0):
[    23.942] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): connected
[    23.942] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): Internal TMDS
[    23.942] (--) NVIDIA(GPU-0): ProView/EMC/PTS (DFP-0): 330.0 MHz maximum pixel clock
[    23.942] (--) NVIDIA(GPU-0):
[    23.943] (--) NVIDIA(GPU-0): DFP-1: disconnected
[    23.943] (--) NVIDIA(GPU-0): DFP-1: Internal TMDS
[    23.943] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[    23.943] (--) NVIDIA(GPU-0):
[    30.828] (II) systemd-logind: got pause for 13:64
[    30.828] (II) systemd-logind: got pause for 13:66
[    30.828] (II) systemd-logind: got pause for 13:67
[    30.828] (II) systemd-logind: got pause for 13:65
Back to top
View user's profile Send private message
gordonb3
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2015
Posts: 127

PostPosted: Thu Apr 20, 2017 8:59 am    Post subject: Reply with quote

Same here.

Windows are constantly refreshing in what appears to be three different sizes. If I move a window about, the content becomes steady, but as soon as I hover over a button (e.g. in this reply screen) content starts flickering at a high rate. Typical: the smilies here on the left that are animated are moving extremely fast. Some kind of timer issue?
Back to top
View user's profile Send private message
gordonb3
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2015
Posts: 127

PostPosted: Thu Apr 20, 2017 9:34 am    Post subject: Reply with quote

Phew...

Managed to revert back to 3.20. Lucky I create bin packages. Definitely caused by Gnome 3.22.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 247

PostPosted: Thu Apr 20, 2017 11:51 am    Post subject: Reply with quote

interesting to hear, sonds very similar to my box here. Are you on nividia-drivers?
With another box that uses intel graphics, all is well with gnome 3.22

R.
Back to top
View user's profile Send private message
gordonb3
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2015
Posts: 127

PostPosted: Thu Apr 20, 2017 4:56 pm    Post subject: Reply with quote

Yes, I am on Nvidia drivers. Haven't had time yet to investigate any further because the updates I ran yesterday also caused my vmware virtual machines only to run in the background. Only just managed to fix that.
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 970
Location: Massachusetts USA

PostPosted: Thu Apr 20, 2017 8:16 pm    Post subject: Reply with quote

Try nividia-drivers 375.39 or 381.09
Back to top
View user's profile Send private message
gordonb3
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2015
Posts: 127

PostPosted: Thu Apr 20, 2017 8:39 pm    Post subject: Reply with quote

jburns wrote:
Try nividia-drivers 375.39 or 381.09

Reverting to 375.39 was the first thing I did. No change. I suspect x11-wm/mutter myself but currently can't afford to experiment with this machine.
Back to top
View user's profile Send private message
gordonb3
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2015
Posts: 127

PostPosted: Wed Apr 26, 2017 9:50 am    Post subject: Reply with quote

Confirmed (more or less)

Mutter requires gnome-shell to be the same x.yy version though. If you have 3.20 and 3.22 in either combination there is no screen at all and after some time a segfault is returned:
Code:
gnome-session-f[682]: segfault at 0 ip 00007f294472bcc9 sp 00007fffa718eb90 error 4 in libgtk-3.so.0.2200.11[7f2944449000+701000]
Back to top
View user's profile Send private message
gordonb3
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2015
Posts: 127

PostPosted: Wed Apr 26, 2017 11:46 am    Post subject: Reply with quote

And solved :D

Apparently I changed something before to fix a display issue with a previous version of gnome and this is now causing issues. Need to go into /etc/environment and remove (or comment) the line ‘CLUTTER_PAINT=disable-clipped-redraws:disable-culling´
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 247

PostPosted: Thu Apr 27, 2017 8:47 pm    Post subject: Reply with quote

You nailed it!
Solved for me as well by commenting it out.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum