Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Portage] Problema con emerge @preserved-rebuild (Solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Sun Apr 16, 2017 8:46 pm    Post subject: [Portage] Problema con emerge @preserved-rebuild (Solved) Reply with quote

Hola.

Al hacer emerge de cualquier aplicación, al finalizar me aparece el siguiente mensaje:

Code:

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: sys-libs/ncurses-5.9-r5
 *  - /lib64/libncursesw.so.5
 *  - /lib64/libncursesw.so.5.9
 *      used by /bin/more (sys-apps/util-linux-2.25.2-r2)
 *      used by /bin/nano (app-editors/nano-2.3.6)
 *      used by /sbin/cfdisk (sys-apps/util-linux-2.25.2-r2)
 *      used by 20 other files
 *  - /usr/lib64/libpanelw.so.5
 *  - /usr/lib64/libpanelw.so.5.9
 *      used by /usr/lib64/openoffice/program/python-core-2.7.6/lib/lib-dynload/_curses_panel.so (app-office/openoffice-bin-4.1.1)
 *      used by /usr/lib64/python2.7/lib-dynload/_curses_panel.so (dev-lang/python-2.7.9-r1)
 *      used by /usr/lib64/python3.4/lib-dynload/_curses_panel.cpython-34.so (dev-lang/python-3.4.1)
 *  - /lib64/libncurses.so.5
 *  - /lib64/libncurses.so.5.9
 *      used by /bin/bash (app-shells/bash-4.3_p39)
 *      used by /lib64/libeinfo.so.1 (sys-apps/openrc-0.17)
 *      used by /lib64/libgpm.so.1.20.0 (sys-libs/gpm-1.20.7-r2)
 *      used by 18 other files
 *  - /usr/lib32/libncurses.so.5
 *  - /usr/lib32/libncurses.so.5.9
 *      used by /usr/lib32/libgpm.so.1.20.0 (sys-libs/gpm-1.20.7-r2)
 *      used by /usr/lib32/libreadline.so.6.3 (sys-libs/readline-6.3_p8-r2)
>>> package: dev-libs/libgdata-0.16.1
 *  - /usr/lib64/libgdata.so.19
 *  - /usr/lib64/libgdata.so.19.2.1
 *      used by /usr/bin/gnome-photos (media-gfx/gnome-photos-3.14.3)
 *      used by /usr/lib64/evolution/3.12/modules/module-cal-config-google.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/gnome-documents/libgdprivate-1.0.so (gnome-extra/gnome-documents-3.14.3)
 *      used by 2 other files
>>> package: dev-libs/icu-55.1
 *  - /usr/lib32/libicudata.so.55
 *  - /usr/lib32/libicudata.so.55.1
 *  - /usr/lib32/libicuuc.so.55
 *  - /usr/lib32/libicuuc.so.55.1
 *      used by /usr/lib32/libharfbuzz-icu.so.0.10301.0 (media-libs/harfbuzz-1.3.1)
 *  - /usr/lib64/libicuuc.so.55
 *  - /usr/lib64/libicuuc.so.55.1
 *      used by /usr/lib64/libQt5Core.so.5.6.1 (dev-qt/qtcore-5.6.1)
 *      used by /usr/lib64/libQt5WebKit.so.5.6.1 (dev-qt/qtwebkit-5.6.1)
 *      used by /usr/lib64/libharfbuzz-icu.so.0.10301.0 ()
 *      used by 31 other files
 *  - /usr/lib64/libicui18n.so.55
 *  - /usr/lib64/libicui18n.so.55.1
 *      used by /usr/lib64/libQt5Core.so.5.6.1 (dev-qt/qtcore-5.6.1)
 *      used by /usr/lib64/libQt5WebKit.so.5.6.1 (dev-qt/qtwebkit-5.6.1)
 *      used by /usr/lib64/libjavascriptcoregtk-1.0.so.0.16.17 (net-libs/webkit-gtk-2.4.9-r200)
 *      used by 30 other files
 *  - /usr/lib64/libicudata.so.55
 *  - /usr/lib64/libicudata.so.55.1
 *      used by /usr/lib64/libjavascriptcoregtk-1.0.so.0.16.17 (net-libs/webkit-gtk-2.4.9-r200)
 *      used by /usr/lib64/libjavascriptcoregtk-3.0.so.0.16.17 (net-libs/webkit-gtk-2.4.9)
 *      used by /usr/lib64/libtracker-miner-1.0.so.0.203.3 (app-misc/tracker-1.2.6)
 *      used by 24 other files
>>> package: gnome-extra/evolution-data-server-3.12.11
 *  - /usr/lib64/libebackend-1.2.so.7
 *  - /usr/lib64/libebackend-1.2.so.7.0.0
 *      used by /usr/lib64/evolution/3.12/libemail-engine.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libevolution-calendar.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libevolution-mail-composer.so (mail-client/evolution-3.12.11)
 *      used by 27 other files
 *  - /usr/lib64/libedataserver-1.2.so.18
 *  - /usr/lib64/libedataserver-1.2.so.18.0.0
 *      used by /usr/bin/evolution (mail-client/evolution-3.12.11)
 *      used by /usr/bin/gnome-contacts (gnome-extra/gnome-contacts-3.14.2)
 *      used by /usr/lib64/evolution/3.12/libeabutil.so (mail-client/evolution-3.12.11)
 *      used by 52 other files
 *  - /usr/lib64/libebook-contacts-1.2.so.0
 *  - /usr/lib64/libebook-contacts-1.2.so.0.0.0
 *      used by /usr/lib64/evolution/3.12/libeabutil.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libecontacteditor.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libecontactlisteditor.so (mail-client/evolution-3.12.11)
 *      used by 13 other files
 *  - /usr/lib64/libcamel-1.2.so.49
 *  - /usr/lib64/libcamel-1.2.so.49.0.0
 *      used by /usr/bin/evolution (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libeabutil.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libecontacteditor.so (mail-client/evolution-3.12.11)
 *      used by 26 other files
 *  - /usr/lib64/libedata-book-1.2.so.20
 *  - /usr/lib64/libedata-book-1.2.so.20.0.0
 *  - /usr/lib64/libecal-1.2.so.16
 *  - /usr/lib64/libecal-1.2.so.16.0.0
 *      used by /usr/lib64/evolution/3.12/libevolution-calendar-importers.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libevolution-calendar.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libevolution-util.so (mail-client/evolution-3.12.11)
 *      used by 9 other files
 *  - /usr/lib64/libebook-1.2.so.14
 *  - /usr/lib64/libebook-1.2.so.14.3.1
 *      used by /usr/lib64/evolution/3.12/libecontacteditor.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libecontactlisteditor.so (mail-client/evolution-3.12.11)
 *      used by /usr/lib64/evolution/3.12/libevolution-addressbook-importers.so (mail-client/evolution-3.12.11)
 *      used by 11 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.





El problema es que al hacer emerge @preserved-rebuild aparece lo siguiente:


Code:

laptop ~ # emerge @preserved-rebuild

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/ruby:1.9".
(dependency required by "@preserved-rebuild" [argument])




¿Que puedo hacer?
Muchas gracias.

Un saludo.
_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.


Last edited by ZaPa on Sat Apr 29, 2017 10:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1194

PostPosted: Sun Apr 16, 2017 9:13 pm    Post subject: Reply with quote

Mira a ver quien necesita ese paquete:
Code:
equery depends ruby
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Sun Apr 16, 2017 9:44 pm    Post subject: Reply with quote

Code:

laptop ~ # equery depends ruby
 * These packages depend on ruby:
dev-qt/qtwebkit-5.6.1 (dev-lang/ruby)
dev-ruby/json-1.8.2-r1 (ruby_targets_ruby20 ? dev-lang/ruby:2.0)
                       (ruby_targets_ruby21 ? dev-lang/ruby:2.1)
dev-ruby/racc-1.4.11 (ruby_targets_ruby20 ? dev-lang/ruby:2.0)
                     (ruby_targets_ruby21 ? dev-lang/ruby:2.1)
                     (ruby_targets_ruby22 ? dev-lang/ruby:2.2)
dev-ruby/rake-10.5.0 (ruby_targets_ruby20 ? dev-lang/ruby:2.0)
                     (ruby_targets_ruby21 ? dev-lang/ruby:2.1)
                     (ruby_targets_ruby22 ? dev-lang/ruby:2.2)
                     (ruby_targets_ruby23 ? dev-lang/ruby:2.3)
dev-ruby/rdoc-4.2.0 (ruby_targets_ruby20 ? dev-lang/ruby:2.0)
                    (ruby_targets_ruby21 ? dev-lang/ruby:2.1)
                    (ruby_targets_ruby22 ? dev-lang/ruby:2.2)
dev-ruby/rubygems-2.5.2 (ruby_targets_ruby20 ? dev-lang/ruby:2.0)
                        (ruby_targets_ruby21 ? dev-lang/ruby:2.1)
                        (ruby_targets_ruby22 ? dev-lang/ruby:2.2)
                        (ruby_targets_ruby23 ? dev-lang/ruby:2.3)
sys-block/thin-provisioning-tools-0.4.1 (test ? dev-lang/ruby:2.9)
                                        (test ? dev-lang/ruby:2.8)
                                        (test ? dev-lang/ruby:2.7)
                                        (test ? dev-lang/ruby:2.6)
                                        (test ? dev-lang/ruby:2.5)
                                        (test ? dev-lang/ruby:2.4)
                                        (test ? dev-lang/ruby:2.3)
                                        (test ? dev-lang/ruby:2.2)
                                        (test ? dev-lang/ruby:2.1)
                                        (test ? dev-lang/ruby:2.0)
                                        (test ? dev-lang/ruby:1.9)
                                        (test ? dev-lang/ruby:1.8)
virtual/rubygems-10 (ruby_targets_ruby20 ? dev-lang/ruby:2.0)
                    (ruby_targets_ruby21 ? dev-lang/ruby:2.1)

_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1168
Location: La Plata, Argentina

PostPosted: Sun Apr 16, 2017 9:49 pm    Post subject: Reply with quote

el unico paquete que depende de ruby:1.9 es sys-block/thin-provisioning-tools y solo con la flag test activa.

desactiva esa flag y deberia solucionarse...
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Sun Apr 16, 2017 10:07 pm    Post subject: Reply with quote

He realizado lo siguiente

Code:
echo "sys-block/thin-provisioning-tools -test" > /etc/portage/package.use/thin-provisioning-tools


Y al realizar el emerge @preserved-rebuild sigue apareciendo lo mismo:

Code:
laptop ~ # emerge @preserved-rebuild

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/ruby:1.9".
(dependency required by "@preserved-rebuild" [argument])

_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1194

PostPosted: Sun Apr 16, 2017 10:18 pm    Post subject: Reply with quote

Mira a ver si lo tienes instalado:
Code:
equery list ruby
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Mon Apr 17, 2017 10:22 am    Post subject: Reply with quote

Ahi va:

Code:
laptop ~ # equery list ruby
 * Searching for ruby ...
[I--] [??] dev-lang/ruby-1.9.3_p551-r1:1.9
[I--] [??] dev-lang/ruby-2.0.0_p645:2.0
[IP-] [  ] dev-lang/ruby-2.1.9:2.1

_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1194

PostPosted: Mon Apr 17, 2017 11:53 am    Post subject: Reply with quote

Desinstalalo:
Code:
(root)# emerge --unmerge =dev-lang/ruby-1.9.3_p551-r1
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Mon Apr 17, 2017 10:36 pm    Post subject: Reply with quote

Sigo sin poder solucionar el problema....

Code:

laptop ~ # emerge @preserved-rebuild

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild     U  ] virtual/libintl-0-r2 [0-r1]
[ebuild     U  ] dev-libs/gobject-introspection-common-1.50.0 [1.42.0]
[ebuild     U  ] dev-lang/python-exec-2.4.4 [2.0.1-r1] PYTHON_TARGETS="(python3_5%*) (python3_6%*)"
[ebuild     U  ] sys-libs/readline-6.3_p8-r3 [6.3_p8-r2]
[ebuild   R    ] net-ftp/tnftp-20141104
[ebuild     U  ] app-eselect/eselect-python-20160516 [20111108]
[blocks b      ] <app-eselect/eselect-python-20160206 ("<app-eselect/eselect-python-20160206" is blocking dev-lang/python-exec-2.4.4)
[ebuild     U  ] sys-apps/less-487 [478]
[ebuild     U  ] dev-util/gtk-doc-am-1.25-r1 [1.24]
[ebuild     U  ] dev-lang/python-2.7.12 [2.7.9-r1] USE="(-libressl)"
[blocks b      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking dev-lang/python-exec-2.4.4)
[ebuild     U  ] dev-lang/python-3.4.5 [3.4.1] USE="(-libressl)"
[blocks b      ] <dev-lang/python-3.4.3-r4:3.4 ("<dev-lang/python-3.4.3-r4:3.4" is blocking dev-lang/python-exec-2.4.4)
[ebuild     U  ] dev-libs/libxml2-2.9.4-r1 [2.9.2-r1] PYTHON_TARGETS="(-python3_5)"
[ebuild     U  ] x11-libs/libXrandr-1.5.1 [1.4.2]
[ebuild   R    ] media-sound/lame-3.99.5-r1  USE="frontend%*"
[ebuild     U  ] media-libs/babl-0.1.18 [0.1.10-r1] CPU_FLAGS_X86="sse2%* -f16c% -sse4_1%"
[ebuild   R    ] media-libs/libtheora-1.1.1-r1  ABI_X86="32*"
[ebuild   R    ] net-misc/telnet-bsd-1.2-r1
[ebuild  N     ] dev-python/py-1.4.30  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild  N     ] dev-python/chardet-2.3.0  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)"
[ebuild  N     ] dev-python/requests-2.12.5  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-python3_5) (-python3_6)"
[ebuild     U  ] dev-util/gdbus-codegen-2.50.3 [2.44.1] PYTHON_TARGETS="(-python3_5)"
[ebuild     U  ] dev-libs/glib-2.50.3-r1 [2.44.1]
[ebuild     U  ] app-editors/vim-core-8.0.0386 [7.4.273]
[ebuild     U  ] dev-java/java-config-2.2.0-r3 [2.2.0] USE="{-test%}" PYTHON_TARGETS="(-python3_5)"
[ebuild  N     ] dev-lang/ruby-2.1.9  USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs"
[ebuild   R    ] dev-ruby/json-1.8.2-r1
[ebuild   R    ] dev-ruby/racc-1.4.11
[ebuild  N     ] virtual/tmpfiles-0
[ebuild     U  ] sys-process/procps-3.3.12 [3.3.9-r2] USE="kill%* -modern-top%"
[ebuild     U  ] dev-qt/qtcore-5.6.2-r1 [5.6.1]
[ebuild     U  ] dev-qt/qtnetwork-5.6.2 [5.6.1]
[ebuild     U  ] dev-qt/qtdbus-5.6.2 [5.6.1]
[ebuild     U  ] dev-qt/qtsql-5.6.2 [5.6.1]
[ebuild  N     ] media-libs/libsdl2-2.0.4  USE="X alsa dbus joystick opengl pulseaudio sound threads udev video (-altivec) (-custom-cflags) (-fusionsound) -gles -haptic -nas -oss -static-libs -tslib -wayland -xinerama -xscreensaver" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx sse sse2 -3dnow"
[ebuild     U  ] sys-devel/gettext-0.19.8.1 [0.19.4]
[ebuild     U  ] sys-apps/util-linux-2.28.2 [2.25.2-r2] USE="readline%* -build% -kill%" PYTHON_SINGLE_TARGET="(-python3_5)" PYTHON_TARGETS="(-python3_5)"
[ebuild     U  ] x11-themes/adwaita-icon-theme-3.22.0 [3.14.1-r1]
[ebuild     U  ] app-crypt/pinentry-0.9.7-r1 [0.9.5] USE="-qt5%"
[ebuild     U  ] sys-process/psmisc-22.21-r3 [22.21-r2]
[ebuild     U  ] sys-devel/bison-3.0.4-r1 [2.4.3] USE="-examples% {-test%}"
[ebuild     U  ] sys-apps/texinfo-6.1 [5.2]
[ebuild   R    ] app-text/hunspell-1.3.3  L10N="es%* -af% -bg% -ca% -cs% -cy% -da% -de% -de-1901% -el% -en% -eo% -et% -fo% -fr% -ga% -gl% -he% -hr% -hu% -ia% -id% -is% -it% -km% -ku% -lt% -lv% -mk% -ms% -nb% -nl% -nn% -pl% -pt% -pt-BR% -ro% -ru% -sk% -sl% -sq% -sv% -sw% -tn% -uk% -zu%"
[ebuild     U  ] dev-libs/libcdio-0.93 [0.92] ABI_X86="32*"
[ebuild     U  ] app-editors/nano-2.6.3 [2.3.6] USE="-static%"
[ebuild     U  ] dev-libs/gobject-introspection-1.50.0 [1.42.0-r1] PYTHON_SINGLE_TARGET="python2_7%* -python3_4% (-python3_5)" PYTHON_TARGETS="python3_4%* (-python3_5)"
[blocks b      ] <dev-libs/gobject-introspection-1.50.0 ("<dev-libs/gobject-introspection-1.50.0" is blocking dev-libs/gobject-introspection-common-1.50.0)
[ebuild     U  ] dev-scheme/guile-1.8.8-r3 [1.8.8-r1] USE="readline%*"
[ebuild     U  ] sys-apps/gptfdisk-1.0.1 [0.8.10]
[ebuild  N     ] app-misc/jq-1.5-r2  USE="-oniguruma -static-libs {-test}"
[ebuild     U  ] gnome-base/gsettings-desktop-schemas-3.22.0 [3.14.2]
[ebuild   R    ] media-libs/harfbuzz-1.3.1
[ebuild     U  ] app-accessibility/at-spi2-core-2.22.1 [2.14.1] ABI_X86="32*"
[ebuild   R    ] sys-libs/gpm-1.20.7-r2
[ebuild     U  ] app-shells/bash-4.3_p48-r1 [4.3_p39]
[ebuild     U  ] dev-libs/libgusb-0.2.9 [0.2.5] ABI_X86="32*"
[ebuild     U  ] media-libs/gstreamer-1.10.3 [1.4.5] USE="caps%* (-unwind)" ABI_X86="32*"
[ebuild   R    ] sys-block/parted-3.2
[ebuild     U  ] sys-devel/gdb-7.10.1 [7.7.1] PYTHON_SINGLE_TARGET="(-python3_5)" PYTHON_TARGETS="(-python3_5)"
[ebuild     U  ] x11-libs/pango-1.40.4 [1.36.8] USE="{-test%}"
[ebuild     U  ] x11-misc/colord-1.3.4 [1.2.10] ABI_X86="32*"
[ebuild     U  ] app-accessibility/at-spi2-atk-2.22.0 [2.14.1] ABI_X86="32*"
[ebuild     U  ] dev-qt/qtgui-5.6.2 [5.6.1]
[ebuild  NS    ] sys-libs/ncurses-5.9-r101 [6.0-r1] USE="gpm unicode -tinfo" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] app-editors/vim-8.0.0386 [7.4.273] PYTHON_TARGETS="(-python3_5) (-python3_6)"
[ebuild     U  ] x11-libs/gtk+-3.22.11 [3.14.13] ABI_X86="32*"
[ebuild     U  ] media-libs/gst-plugins-base-1.10.3 [1.4.5] ABI_X86="32*"
[ebuild     U  ] dev-qt/qtwidgets-5.6.2 [5.6.1]
[ebuild     U  ] app-office/openoffice-bin-4.1.3 [4.1.1]
[ebuild     U  ] media-libs/gst-plugins-bad-1.10.3 [1.4.5] USE="bzip2%* gtk%* vcd%* {-test%}" ABI_X86="32*"
[ebuild     U  ] dev-qt/qtopengl-5.6.2 [5.6.1]
[ebuild     U  ] media-libs/openjpeg-2.1.1_p20160922 [2.1.0] ABI_X86="32%* (64%*) (-x32)"
[ebuild     U  ] dev-qt/qtwebkit-5.6.2 [5.6.1]
[ebuild     U  ] media-video/ffmpeg-3.2.4 [2.6.3] USE="-chromaprint% -ebur128% -gcrypt% -gmp% -kvazaar% -libilbc% (-mmal) -nvenc% -openh264% -rubberband% -snappy% -zimg%" CPU_FLAGS_X86="-aes%" FFTOOLS="sidxindex%*"
[ebuild     U  ] net-libs/webkit-gtk-2.4.11-r1 [2.4.9] USE="geolocation%* gnome-keyring%*"
[ebuild  NS    ] media-libs/grilo-0.3.3 [0.2.11] USE="gtk introspection network playlist -examples {-test} -vala"
[ebuild     U  ] media-libs/grilo-0.2.15 [0.2.11]
[ebuild     U  ] net-misc/dropbox-20.3.18 [5.3.18] PYTHON_TARGETS="python2_7%*"
[ebuild     U  ] net-libs/webkit-gtk-2.4.11-r200 [2.4.9-r200] USE="gnome-keyring%*"
[ebuild  NS    ] media-libs/gegl-0.3.8 [0.2.0-r2] USE="cairo ffmpeg introspection jpeg2k lcms raw sdl svg tiff v4l -debug -lensfun -openexr {-test} -umfpack -vala -webp" CPU_FLAGS_X86="mmx sse"
[ebuild  N     ] net-libs/dleyna-core-0.5.0
[ebuild  N     ] net-libs/dleyna-connector-dbus-0.2.0
[ebuild     U  ] sys-apps/openrc-0.23.2 [0.17]
[ebuild     U  ] net-libs/webkit-gtk-2.14.5 [2.6.6] USE="(X%*) geolocation%* gnome-keyring%* libnotify%* nsplugin%* (-aqua) -gles2% -wayland%"
[ebuild  N     ] x11-libs/libcryptui-3.12.2  USE="introspection libnotify -debug"
[ebuild     U  ] x11-wm/mutter-3.22.3 [3.14.4] USE="udev%* -gles2%" INPUT_DEVICES="-wacom%"
[ebuild  N     ] app-text/libgepub-0.4  USE="introspection"
[ebuild     U  ] app-misc/tracker-1.10.5 [1.2.6] USE="seccomp%* -libav% -stemmer%"
[ebuild     U  ] gnome-extra/nautilus-tracker-tags-1.10.5 [1.2.6]
[ebuild     U  ] net-libs/gnome-online-accounts-3.22.5 [3.14.4]
[ebuild     U  ] dev-libs/libgdata-0.17.7 [0.17.6]
[ebuild     U  ] sci-geosciences/geocode-glib-3.20.1 [3.14.0]
[ebuild     U  ] net-misc/gnome-online-miners-3.22.0 [3.14.3] USE="-flickr%"
[ebuild     U  ] media-plugins/grilo-plugins-0.2.17 [0.2.13] USE="-subtitles%"
[ebuild     U  ] media-gfx/gnome-photos-3.22.5 [3.14.3] USE="-flickr% {-test%} -upnp-av%"
[ebuild  N     ] gnome-extra/evolution-data-server-3.22.7  USE="berkdb gnome-online-accounts gtk introspection ipv6 ldap vala weather -api-doc-extras -google -kerberos {-test}"
[ebuild     U  ] dev-libs/folks-0.11.3 [0.10.1-r1]
[ebuild     U  ] mail-client/evolution-3.22.6 [3.12.11] USE="-archive% -geolocation%"
[ebuild     U  ] gnome-extra/gnome-contacts-3.22.1 [3.14.2]
[ebuild     U  ] gnome-extra/gnome-documents-3.22.1 [3.14.3]
[ebuild     U  ] gnome-base/gnome-shell-3.22.3-r1 [3.14.4] USE="browser-extension%* ibus%* nsplugin%*" PYTHON_TARGETS="python3_4%* (-python3_5)"
[ebuild  N     ] gnome-extra/chrome-gnome-shell-8-r1  PYTHON_SINGLE_TARGET="python2_7 -python3_4 (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)"
[ebuild   R    ] app-editors/xemacs-21.4.24

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/libintl:0

  (virtual/libintl-0-r1:0/0::gentoo, installed) pulled in by
    =virtual/libintl-0-r1 required by (sys-apps/texinfo-6.1:0/0::gentoo, ebuild scheduled for merge)
    ^                ^^^^                                                                                                                                 
    (and 5 more with the same problem)

  (virtual/libintl-0-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/libintl-0-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                ^^^^                                                                                                                                                                                                                                                                                                       
    =virtual/libintl-0-r2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/glib-2.50.3-r1:2/2::gentoo, ebuild scheduled for merge)
    ^                ^^^^                                                                                                                                                                                                                                                                                                     
    (and 2 more with the same problems)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.2[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                 
    (and 2 more with the same problem)

  (dev-qt/qtgui-5.6.1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.6.1[gles2=] required by (dev-qt/qtdeclarative-5.6.1-r1:5/5.6::gentoo, installed)
    ^             ^^^^^                                                                                                                                   
    (and 2 more with the same problem)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.2[icu] required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    (and 6 more with the same problem)

  (dev-qt/qtcore-5.6.1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.6.1 required by (dev-qt/qttest-5.6.1:5/5.6::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 7 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

  (dev-qt/qtdbus-5.6.1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.6.1 required by (dev-qt/qtgui-5.6.1:5/5.6::gentoo, installed)
    ^              ^^^^^                                                                                                                 

media-video/ffmpeg:0

  (media-video/ffmpeg-3.2.4:0/55.57.57::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/ffmpeg-2.8:0= required by (media-libs/gegl-0.3.8:0.3/0.3::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^                                                                                                                                                         

  (media-video/ffmpeg-2.6.3:0/54.56.56::gentoo, installed) pulled in by
    >=media-video/ffmpeg-2.2:0/54.56.56=[abi_x86_64(-)] required by (media-plugins/gst-plugins-libav-1.4.5-r1:1.0/1.0::gentoo, installed)
                            ^^^^^^^^^^^^                                                                                                                                     
    (and 1 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     

  (dev-qt/qtnetwork-5.6.1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.6.1 required by (dev-qt/qtdeclarative-5.6.1-r1:5/5.6::gentoo, installed)
    ^                 ^^^^^                                                                                                                           
    (and 1 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.6.2 required by (dev-qt/qtwebkit-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                     
    (and 1 more with the same problem)

  (dev-qt/qtwidgets-5.6.1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.6.1[gles2=] required by (dev-qt/qtprintsupport-5.6.1:5/5.6::gentoo, installed)
    ^                 ^^^^^                                                                                                                                 
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1194

PostPosted: Mon Apr 17, 2017 11:25 pm    Post subject: Reply with quote

No exactamente. Has solucionado el problema pero ahora tienes otro (u otros).
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1194

PostPosted: Mon Apr 17, 2017 11:30 pm    Post subject: Reply with quote

Tienes demasiados paquetes a reconstruir. Creo que te conviene ver que tal resultaría una actualización completa del sistema:
Code:
emerge -pv --update --deep --newuse world
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1053

PostPosted: Tue Apr 18, 2017 2:12 pm    Post subject: Reply with quote

SI, pero aunque hagas eso dudo que este problema se solucione.
Esto normalmente se arregla de varias formas. (puede ser que tengas que llevar a cabo alguna combinación de estos métodos)
1º emerge --backtrack=30 @preserved-rebuild (si esto funciona fantástico)
2º Intentando emerger uno a uno los paquetes que se quejan
3º emerge --update --deep --with-bdeps=y --newuse --backtrack=30 -q @world
4º Enmascarando los paquetes y hacer
emerge --update --deep --with-bdeps=y --newuse -q @world y luego desenmascarar de nuevo y volver a intentar
con los pasos anteriores
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Sat Apr 22, 2017 10:56 pm    Post subject: Reply with quote

Hola de nuevo.

El problema parece haberse solucionado con la solución que plantea 'cameta'. Concretamente con el siguiente comando:

Code:

emerge --backtrack=30 @preserved-rebuild


Ha compilado 300 y pico paquetes, y despues de esto actualmente estoy haciendo un emerge @preserved-rebuild correctamente.

Ahora me gustaría saber que hace exactamente el comando emerge --backtrack=30 @preserved-rebuild.

¿Alguien me podria dar información sobre lo que ha hecho esto para solucionar mi problema, y que significa para portage el carácter '@'.
¿Y sobre el comando emerge @preserved-rebuild? ¿Que es lo que hace exáctamente y para que es necesario?


Muchas gracias.
Un saludo.
_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1053

PostPosted: Sun Apr 23, 2017 11:09 pm    Post subject: Reply with quote

@ en portage lo aplican a los sets
https://wiki.gentoo.org/wiki//etc/portage/sets
puedes ver la lista de los sets disponibles con este comando emerge --list-sets
En cuanto a lo del bactrack
https://dev.gentoo.org/~zmedico/portage/doc/man/emerge.1.html
--backtrack=COUNT
Specifies an integer number of times to backtrack if dependency calculation fails due to a conflict or an unsatisfied dependency (default: '3').
bactrack se puede traducir como ir hacia atrás, desandar. Esto significa que haces como retroceder el portage y aparecen más paquetes que necesitas recompilar.

Una página interesante sobre como tratar problemas de bloqueos.
https://gentoohaskell.wordpress.com/2016/05/08/how-to-deal-with-portage-blockers/
Espero haberte servido de ayuda, aunque a veces aquí hacemos las cosas sin saber muy bien para que sirven.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Mon Apr 24, 2017 2:57 pm    Post subject: Reply with quote

Hola.

Muchas gracias cameta por tu respuesta, voy a echarle un ojo a la documentación que me has facilitado.

Es cierto que aveces ejecutamos comandos portage sin saber 100% realmente para que sirven como bien dices, pero pienso que esto deberia ser más claro en la documentación sobre portage. Por que pienso, que esta es la esencia de gentoo, saber en cada momento que se esta ejecutando en nuestra máquina.

No he podido terminar el 'emerge @preserved-rebuild' ya que ahora es el paquete webkit-gtk el que no compila. Este es el error:

Code:

libtool: link: x86_64-pc-linux-gnu-gcc -ansi -fno-strict-aliasing -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -pthread -I/usr/include/libsoup-2.4 -I/usr/include/libxml2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -march=corei7 -O2 -pipe -pthread -std=c99 -Wl,-O1 -Wl,--no-keep-memory -Wl,--reduce-memory-overheads -Wl,--no-demangle -o Programs/GtkLauncher Tools/GtkLauncher/Programs_GtkLauncher-LauncherInspectorWindow.o Tools/GtkLauncher/Programs_GtkLauncher-main.o -Wl,--export-dynamic -pthread -pthread  -Wl,--as-needed ./.libs/libwebkitgtk-1.0.so /var/tmp/portage/net-libs/webkit-gtk-2.4.11-r200/work/webkitgtk-2.4.11/.libs/libjavascriptcoregtk-1.0.so -lenchant -ljpeg -lsecret-1 -lxslt -lxml2 -lGL -lEGL -ldl -lpng16 -lsqlite3 -lwebp -lXcomposite -lXdamage -lXfixes -lXrender -lXt -lX11 ./.libs/libjavascriptcoregtk-1.0.so -lpthread -lz -licui18n -licuuc -licudata -lharfbuzz-icu -lharfbuzz -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lpango-1.0 -lfontconfig -lfreetype -lgmodule-2.0 -lgthread-2.0 -lsoup-2.4 -lgio-2.0 -lgstapp-1.0 -lgstaudio-1.0 -lgstfft-1.0 -lm -lgstpbutils-1.0 -lgstvideo-1.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -pthread -Wl,-rpath -Wl,/var/tmp/portage/net-libs/webkit-gtk-2.4.11-r200/work/webkitgtk-2.4.11/.libs
Traceback (most recent call last):
  File "/usr/bin/g-ir-scanner", line 66, in <module>
    sys.exit(scanner_main(sys.argv))
  File "/usr/lib64/gobject-introspection/giscanner/scannermain.py", line 526, in scanner_main
    transformer = create_transformer(namespace, options)
  File "/usr/lib64/gobject-introspection/giscanner/scannermain.py", line 396, in create_transformer
    transformer.register_include(include_obj)
  File "/usr/lib64/gobject-introspection/giscanner/transformer.py", line 141, in register_include
    self._parse_include(filename)
  File "/usr/lib64/gobject-introspection/giscanner/transformer.py", line 224, in _parse_include
    parser.parse(filename)
  File "/usr/lib64/gobject-introspection/giscanner/girparser.py", line 63, in parse
    tree = parse(filename)
  File "<string>", line 62, in parse
  File "<string>", line 38, in parse
cElementTree.ParseError: not well-formed (invalid token): line 6174, column 17
GNUmakefile:82600: recipe for target 'WebKit-1.0.gir' failed
make[1]: *** [WebKit-1.0.gir] Error 1
make[1]: Leaving directory '/var/tmp/portage/net-libs/webkit-gtk-2.4.11-r200/work/webkitgtk-2.4.11'
GNUmakefile:25836: recipe for target 'all' failed


Nunca he tenido un problema tan gordo con gentoo con los 10 años que llevo con él.

No sé a que será debido, si a alguna mala configuración realizada por mi parte, alguna variable CFLAG mal introducida... ni idea, el caso es que me estoy dando cabezazos para intentar solucionar esto.

Sigo con la investigación y cualquier solución la escribiré en este hilo para que le sirva a otro usuario. Cualquier sugerencia será bienvenida.


Muchas gracias.
Un saludo.
_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1053

PostPosted: Fri Apr 28, 2017 1:19 am    Post subject: Reply with quote

Si no has tocado nada mas de emerge
emerge --resume --skipfirst te permite seguir la compilación esquivando el paquete problematico.
¿Causas del fallo?
A ver poner CFLAGS agresivas es un fallo mejor pon las recomendadas.
Pero normalmente una de las causas de los problemas son no usar las uses correctas.
emerge -pv webkit-gtk te dice cuales son las uses que usa el programa
¿que perfil tienes seleccionado?
eselect profile list
¿que gcc usas?
gcc-config -l
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Fri Apr 28, 2017 10:14 pm    Post subject: Reply with quote

Hola.

Finalmente resolví el problema, actualicé y recompile todo el sistema. He solucionado el problema y ahora mi sistema esta 100% actualizado :).

Mi make.conf es el siguiente, no se si tengo algo mal fijado ahí:

Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=corei7 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="ruby_targets_ruby22 xvmc wifi acpi apm pmu lm_sensors nforce2 ipv6 efiemu amd64 alsa bindist mmx sse sse2 nsplugin java mp3 cdparanoia ffmpeg -kde -qt3 -qt4 -qt5 gnome gtk X audiofile bzip2 zip cdr dbus dri dvd dvdr jpeg jpeg2k mp4 scanner v4l vcd systemd"


PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

GRUB_PLATFORMS="efi-64"
VIDEO_CARDS="intel i965"
INPUT_DEVICES="evdev synaptics"
LINGUAS="es es_ES"
L10N="es-ES es"
ACCEPT_LICENSE="*"

GENTOO_MIRRORS="http://ftp.swin.edu.au/gentoo http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ http://mirrors.telepoint.bg/gentoo/ http://gentoo.gossamerhost.com http://gentoo.mirrors.tera-byte.com/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://trumpetti.atm.tut.fi/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ http://files.gentoo.gr http://mirror.neolabs.kz/gentoo/pub http://gentoo-euetib.upc.es/mirror/gentoo/ http://ftp.df.lth.se/pub/gentoo/ http://mirror.mdfnet.se/gentoo http://mirror.bytemark.co.uk/gentoo/"
laptop ~ #



La versión de gcc:

Code:
gcc-config -l
 [1] x86_64-pc-linux-gnu-4.9.4 *
 [2] x86_64-pc-linux-gnu-5.4.0



cameta, no tenia ni idea de la existencia de --resume --skipfirst...

Y... una pregunta más... ¿Que significa el flag --with-bdeps=y para emerge?

Saludos.
_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1053

PostPosted: Sat Apr 29, 2017 1:26 pm    Post subject: Reply with quote

Hola,
Code:
CFLAGS="-march=corei7 -O2 -pipe"

Esto está bien.
Code:
MAKEOPTS="-j2"

Esto casí seguro que no
https://wiki.gentoo.org/wiki/MAKEOPTS
grep processor /proc/cpuinfo
A ver cuantos núcleos tienes. Si tienes 8 pues tendrás que poner -j8
Quote:
La versión de gcc:

gcc-config 2
y con ello cambiarás a la nueva versión de gcc
Ah y una vez echo esto
emerge -p --depclean
para comprobar que paquetes se han de eliminar
seguramente te aparecerá el antiguo gcc entre otros
si todo parece correcto
emerge --depclean
revdep-rebuild
Code:
¿Que significa el flag --with-bdeps=y?

según el man emerge
Quote:
--with-bdeps < y | n >
In dependency calculations, pull in build time dependencies that are not strictly required. This defaults to ´n´ for installation actions, meaning they
will not be installed, and ´y´ for the --depclean action, meaning they will not be removed. This setting can be added to EMERGE_DEFAULT_OPTS (see
make.conf(5)) and later overridden via the command line.

En cristiano, se usa está opción para hacer una actualización en profundidad.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 762

PostPosted: Sat Apr 29, 2017 10:08 pm    Post subject: Reply with quote

Vaya! Postee el listado de las versiones de gcc y no me di cuenta que no estana seteado con la ultima versión de gcc... Que despistado soy!!!


Lo de makeopts -j2 tampoco entiendo por que estaba asi. Ya que comentan alli que ese numero debe ser seguido del.numero de nucleos +2, no se si estoy en lo correcto. Ahora lo cambio.


Gracias por toda la info cameta y a todos los que ayudaron en lasolución de mi problema.
Doy este hilo por solucionado, ya que se soluciono con una actualización y recompilación del sistema entero.


Muchas gracias.
Saludos.
_________________
--
http://www.monovarlinux.org. Información y experiencias con linux, especialmente con Gentoo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum