Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] emerge blockers z.b. boost
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Linubie
Apprentice
Apprentice


Joined: 11 Jun 2004
Posts: 217

PostPosted: Wed Mar 15, 2017 6:27 am    Post subject: [solved] emerge blockers z.b. boost Reply with quote

Ich hatte eine paar tage gewartet weil ich dachte das erledigt sich vielleicht von alleine, aber boost zickt rum beim update:

Code:
emerge --update -N --deep world --verbose-conflicts
Calculating dependencies... done!
[ebuild     U  ] sci-libs/suitesparseconfig-4.2.1-r1 [4.2.1] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] sys-devel/binutils-config-5-r3 [5-r2]
[ebuild     U  ] dev-libs/libevent-2.1.8 [2.0.22] USE="(-libressl)"
[ebuild     U  ] dev-util/boost-build-1.62.0-r1 [1.56.0]
[ebuild     U  ] dev-libs/boost-1.62.0-r1 [1.56.0-r1] USE="(-mpi*)" PYTHON_TARGETS="(-python3_5)"
[ebuild     U  ] dev-perl/XML-LibXML-2.12.800-r1 [2.12.100] USE="-examples% -minimal%"
[ebuild     U  ] app-portage/gentoolkit-0.3.3 [0.3.2-r1]
[ebuild     U  ] net-misc/wget-1.19.1-r1 [1.18]
[ebuild     U  ] media-gfx/enblend-4.2.0_p20161007-r1 [4.1.3-r1] USE="-tcmalloc%" CPU_FLAGS_X86="sse2%*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libevent:0

  (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libevent-2.0.22:0/0::gentoo, installed) pulled in by
    <=dev-libs/libevent-2.1 required by (net-fs/nfs-utils-1.3.1-r5:0/0::gentoo, installed)
    ^^                  ^^^                                                                                                                     
    dev-libs/libevent:0/0=[threads] required by (www-plugins/freshplayerplugin-0.3.5-r2:0/0::gentoo, installed)
                     ^^^^^                                                                                                                         

dev-libs/boost:0

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed) pulled in by
    >=dev-libs/boost-1.49.0-r1:0/1.56.0= required by (media-gfx/hugin-2015.0.0-r1:0/0::gentoo, installed)
                              ^^^^^^^^^^                                                                                                     
    >=dev-libs/boost-1.55:0/1.56.0= required by (app-office/libreoffice-5.2.3.3-r1:0/0::gentoo, installed)
                         ^^^^^^^^^^                                                                                                           
    >=dev-libs/boost-1.51.0:0/1.56.0= required by (dev-libs/liborcus-0.11.2:0/0.11::gentoo, installed)
                           ^^^^^^^^^^                                                                                                     
    dev-libs/boost:0/1.56.0= required by (dev-cpp/libcmis-0.5.2_pre20160820:0.5/0.5::gentoo, installed)
                  ^^^^^^^^^^                                                                                                               
    >=dev-libs/boost-1.35.0-r5:0/1.56.0= required by (kde-apps/kdepimlibs-4.14.11_pre20160211-r3:4/4.14::gentoo, installed)
                              ^^^^^^^^^^                                                                                                                       
    dev-libs/boost:0/1.56.0= required by (kde-apps/akonadi-1.13.1_pre20160203-r1:4/4::gentoo, installed)
                  ^^^^^^^^^^                                                                                                               
    dev-libs/boost:0/1.56.0=[threads] required by (dev-libs/libixion-0.11.1:0/0.11::gentoo, installed)
                  ^^^^^^^^^^                                                                                                             
    dev-libs/boost:0/1.56.0= required by (kde-apps/kdepim-runtime-4.14.11_pre20160211:4/4.14::gentoo, installed)
                  ^^^^^^^^^^                                                                                                                       
    dev-libs/boost:0/1.56.0= required by (dev-libs/librevenge-0.0.4:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                   
    dev-libs/boost:0/1.56.0= required by (dev-db/mysql-connector-c++-1.1.6:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                         
    >=dev-libs/boost-1.46:0/1.56.0= required by (app-text/libmwaw-0.3.8:0/0::gentoo, installed)
                         ^^^^^^^^^^                                                                                               
    dev-libs/boost:0/1.56.0= required by (media-sound/ardour-5.0:5/5::gentoo, installed)
                  ^^^^^^^^^^                                                                                               
    dev-libs/boost:0/1.56.0= required by (dev-util/mdds-1.2.2:1/1.2::gentoo, installed)
                  ^^^^^^^^^^                                                                                               
    >=dev-libs/boost-1.52.0-r6:0/1.56.0=[python,python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),python_single_target_python2_7(+)] required by (media-libs/vigra-1.9.0:0/0::gentoo, installed)
                              ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                           

  (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/boost-1.62.0 required by (media-gfx/enblend-4.2.0_p20161007-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^               ^^^^^^                                                                                                                                                 

dev-util/boost-build:0

  (dev-util/boost-build-1.56.0:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed)
    ^                     ^^^^^                                                                                                                         

  (dev-util/boost-build-1.62.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.62* required by (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, ebuild scheduled for merge)


Wäre nett wenn mir jemand helfen könnte, danke!
_________________
Mircosoft software is like having sex with a stranger, you always have to be careful not to get infected with something...


Last edited by Linubie on Fri Mar 17, 2017 3:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3122
Location: de

PostPosted: Wed Mar 15, 2017 7:11 am    Post subject: Reply with quote

Der erste Versuch sollte immer sein:
Code:
emerge -1uDN world --backtrack=500


Dadurch lässt du emerge länger suchen, um die Konflikte selbst zu lösen.

Da das aber eher selten zum Erfolg führt, solltest du das Problem selbst lösen:
Code:

  (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libevent-2.0.22:0/0::gentoo, installed) pulled in by
    <=dev-libs/libevent-2.1 required by (net-fs/nfs-utils-1.3.1-r5:0/0::gentoo, installed)
    ^^                  ^^^                                                                                                                     
    dev-libs/libevent:0/0=[threads] required by (www-plugins/freshplayerplugin-0.3.5-r2:0/0::gentoo, installed)

heißt: nfs-utils ist installiert und will max. libevent-2.1 haben. Also deinstallier die nfs-utils. Eventuell musst du auch noch das freshplayerplugin erst mal runterschmeißen.

Nachdem libevent aktualisiert wurde, kannst du die deinstallierten Pakete wieder installieren.

Bei Boost gehst du genauso vor. Die ganzen deinstallierten Pakete, die als Abhängigkeit installiert wurden und nicht im Worldfile standen, werden sowieso wieder re-installiert.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3212
Location: Germany

PostPosted: Wed Mar 15, 2017 11:29 am    Post subject: Reply with quote

Ja, problematisch ist hier scheinbar die alte net-fs/nfs-utils-1.3.1-r5 Version.

Vorschlag: Schalte dir die =net-fs/nfs-utils-1.3.4 Version frei:
Code:
echo "=net-fs/nfs-utils-1.3.4" >> /etc/portage/package.accept_keywords
Das ist auch die Version die zZt grade stabilisiert wird --> Bug 608152

Zudem achte darauf das dev-libs/libevent mit USE=threads gebaut wird.

(Pakete deinstallieren sollte normal nicht notwendig sein)
Back to top
View user's profile Send private message
Linubie
Apprentice
Apprentice


Joined: 11 Jun 2004
Posts: 217

PostPosted: Thu Mar 16, 2017 5:25 pm    Post subject: Reply with quote

Hallo und vielen Dank für die Tipps,

leider hängt portage nun an binutils-libs fest.

Portage verlangt ein emerge @preserved-rebuild, doch sobald das durchgelaufen ist verlangt er es wieder.

Ich habe die libs bereits deinstalliert und dann erneut ein emerge @preserved-rebuild gemacht allerdings ohne Erfolg.

Quote:
!!! existing preserved libs:
>>> package: sys-libs/binutils-libs-2.27
* - /usr/lib64/libbfd-2.25.1.so
* used by /usr/lib64/binutils/x86_64-pc-linux-gnu/2.25.1/libopcodes-2.25.1.so (sys-devel/binutils-2.25.1-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries

_________________
Mircosoft software is like having sex with a stranger, you always have to be careful not to get infected with something...
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3212
Location: Germany

PostPosted: Fri Mar 17, 2017 1:13 am    Post subject: Reply with quote

Hm, poste bitte mal die Ausgabe von
Code:
eselect binutils list

Sofern da zwei Versionen (2.25.1 und 2.26.1) verfügbar sind, setze bitte die aktuell 2.26.1 Version, und nutze dann ein
Code:
emerge -a --depclean
Back to top
View user's profile Send private message
Linubie
Apprentice
Apprentice


Joined: 11 Jun 2004
Posts: 217

PostPosted: Fri Mar 17, 2017 3:51 pm    Post subject: Reply with quote

Nachdem ich über eselect die neuste binutils version gesetzt habe und depclean -a ausgeführt habe, funktioniert nun alles soweit.

Danke!
_________________
Mircosoft software is like having sex with a stranger, you always have to be careful not to get infected with something...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum