Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Bluetooth] Probleme de fonctionnement
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Mar 02, 2017 12:25 pm    Post subject: [Bluetooth] Probleme de fonctionnement Reply with quote

Bonjour à tous,

J'ai retrouvé dans mon placard une clé USB Bluetooth, du coup hop je me suis dit on l'installe sur ma Gentoo (avec Kde Plasma 5).
J'ai donc suivie ce tuto : https://wiki.gentoo.org/wiki/Bluetooth
J'ai utilisé bluez-5.

Premier probleme l'icone du bluetooth n'apparait pas au lancement de KDE, je suis obligé d'aller "Configuration Systeme -> bluetooth, et ensuite cliquez 2 fois sur corriger le problème pour avoir l'icône du bluetooth dans le systray.

2m problème, j'ai appareillé mon téléphone et mon PC (Sous la daube), jusqu'ici tout va bien on mets le code saans problème, mais ensuite impossible d'envoyer un fichier que ce soit de la gentoo vers le PC ou Portable et vis et versa.

3m problème j'ai une souris Appel visble par le bluetooth et un home cinema, mais j'ai une erreur quand je veux l'appareiller a partir de gentoo.

Par avance merci.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7218
Location: ~Brussels - Belgique

PostPosted: Thu Mar 02, 2017 12:35 pm    Post subject: Reply with quote

Bonjour,

Est-ce que cela fonctionne en ligne de commande ?

As-tu essayé les commandes mentionnées dans le wiki (activation, appariement, ...) ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Mar 02, 2017 1:55 pm    Post subject: Reply with quote

Merci pour ta réponse Xavier.

en ligne de commande quand je fais un :
pair X0:X6:X8:X5:X5:XB
Attempting to pair with X0:X6:X8:X5:X5:XB
Failed to pair: org.bluez.Error.AlreadyExists

Comme il me dit qu'il exist je fais :

connect X0:X6:X8:X5:X5:XB
Attempting to connect to X0:X6:X8:X5:X5:XB
[CHG] Device X0:X6:X8:X5:X5:XB Connected: yes
[CHG] Device X0:X6:X8:X5:X5:XB ServicesResolved: yes
Failed to connect: org.bluez.Error.NotAvailable
[CHG] Device 2X0:X6:X8:X5:X5:XB ServicesResolved: no
[CHG] Device X0:X6:X8:X5:X5:XB Connected: no

j'ai pas l'impression que ça fonctionne.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7218
Location: ~Brussels - Belgique

PostPosted: Thu Mar 02, 2017 2:00 pm    Post subject: Reply with quote

Ok, essaie d'abord de gérer ces soucis en ligne de commande, puis vois ce que çà donne dans KDE.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Thu Mar 02, 2017 2:40 pm    Post subject: Reply with quote

Bon j'ai supprimer tout les périphériques couplés

J'ai ensuite fait :

En ligne de commande j'arrive a appareiller ma gentoo et ma daube, mais ensuite la connexion échoue :(

J'ai tllement fouillé sur le net que je ne sais plus ou donner de la tête.

[bluetooth]# devices
Device X0:X6:X8:X5:X5:XB PASCAL
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -83
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -70
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -78
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -69
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -77
[bluetooth]# scan off
[CHG] Device X0:X6:X8:X5:X5:XB RSSI is nil
Discovery stopped
[CHG] Controller X0:X6:X8:X5:X5:XB Discovering: no
[bluetooth]# pair X0:X6:X8:X5:X5:XB
Attempting to pair with X0:X6:X8:X5:X5:XB
[CHG] Device X0:X6:X8:X5:X5:XB Connected: yes
Request PIN code
[agent] Enter PIN code: 1234
[CHG] Device X0:X6:X8:X5:X5:XB Modalias: bluetooth:v0006p0001d0A00
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001115-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB ServicesResolved: yes
[CHG] Device X0:X6:X8:X5:X5:XB Paired: yes
Pairing successful
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001115-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001200-0000-1000-8000-00805f9b34fb
Authorize service
[agent] Authorize service 0000110e-0000-1000-8000-00805f9b34fb (yes/no): YES
[CHG] Device X0:X6:X8:X5:X5:XB ServicesResolved: no
[CHG] Device X0:X6:X8:X5:X5:XB Connected: no
[bluetooth]# trust X0:X6:X8:X5:X5:XB
[CHG] Device X0:X6:X8:X5:X5:XB Trusted: yes
Changing X0:X6:X8:X5:X5:XB trust succeeded
[bluetooth]# connect X0:X6:X8:X5:X5:XB
Attempting to connect to X0:X6:X8:X5:X5:XB
[CHG] Device X0:X6:X8:X5:X5:XB Connected: yes
[CHG] Device X0:X6:X8:X5:X5:XB ServicesResolved: yes
Failed to connect: org.bluez.Error.NotAvailable
[CHG] Device X0:X6:X8:X5:X5:XB ServicesResolved: no
[CHG] Device 2X0:X6:X8:X5:X5:XB Connected: no
[bluetooth]# info X0:X6:X8:X5:X5:XB
Device X0:X6:X8:X5:X5:XB
Name: PASCAL
Alias: PASCAL
Class: 0x02010c
Icon: computer
Paired: yes
Trusted: yes
Blocked: no
Connected: no
LegacyPairing: yes
UUID: Service Discovery Serve.. (00001000-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: PANU (00001115-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
Modalias: bluetooth:v0006p0001d0A00
[bluetooth]#
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Fri Mar 03, 2017 7:47 am    Post subject: Reply with quote

Bonjour à tous,

Voila j'avance un peu.

J'ai tout nettoyé et tout repris à 0.
Donc a présent en ligne de commande tout fonctionne.
Maintenant c'est sous KDE que je rencontre un problème.

Merci pour tout :)

en ligne de commande ça donne ça :

$ bluetoothctl
[NEW] Controller 00:00:00:00:00:00 tuxkenny [default]
[bluetooth]# list
Controller 00:00:00:00:00:00 tuxkenny [default]
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# agent on
Agent registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# discoverable on
Changing discoverable on succeeded
[bluetooth]# pairable on
Changing pairable on succeeded
[bluetooth]# scan on
Discovery started
[CHG] Controller 00:00:00:00:00:00 Discovering: yes
[NEW] Device X0:X6:X8:X5:X5:XB PASCAL
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -71
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -88
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -73
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -88
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -77
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -86
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -73
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -85
[CHG] Device X0:X6:X8:X5:X5:XB RSSI: -74
[bluetooth]# scan off
[CHG] Device X0:X6:X8:X5:X5:XB RSSI is nil
Discovery stopped
[CHG] Controller 00:00:00:00:00:DF Discovering: no
[bluetooth]# devices
Device X0:X6:X8:X5:X5:XB PASCAL
[bluetooth]# pair X0:X6:X8:X5:X5:XB
Attempting to pair with X0:X6:X8:X5:X5:XB
[CHG] Device X0:X6:X8:X5:X5:XB Connected: yes
Request PIN code
[agent] Enter PIN code: 1234
[CHG] Device X0:X6:X8:X5:X5:XB Modalias: bluetooth:v0006p0001d0A00
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001115-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB ServicesResolved: yes
[CHG] Device X0:X6:X8:X5:X5:XB Paired: yes
Pairing successful
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001115-0000-1000-8000-00805f9b34fb
[CHG] Device X0:X6:X8:X5:X5:XB UUIDs: 00001200-0000-1000-8000-00805f9b34fb
Authorize service
[agent] Authorize service 0000110e-0000-1000-8000-00805f9b34fb (yes/no): yes
[PASCAL]# trust X0:X6:X8:X5:X5:XB
[CHG] Device X0:X6:X8:X5:X5:XB Trusted: yes
Changing X0:X6:X8:X5:X5:XB trust succeeded
[PASCAL]# info X0:X6:X8:X5:X5:XB
Device X0:X6:X8:X5:X5:XB
Name: PASCAL
Alias: PASCAL
Class: 0x02010c
Icon: computer
Paired: yes
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: yes
UUID: Service Discovery Serve.. (00001000-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: PANU (00001115-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
Modalias: bluetooth:v0006p0001d0A00
[PASCAL]# quit
Agent unregistered
[DEL] Controller 00:00:00:00:00:00 tuxkenny [default]
$
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 641
Location: S.O. France

PostPosted: Fri Mar 03, 2017 9:22 am    Post subject: Reply with quote

Est-ce que quand tu te connecte en ligne de commande et que tu lance le bluetooth sous kde ca Fonctionne?
Quote:
je suis obligé d'aller "Configuration Systeme -> bluetooth, et ensuite cliquez 2 fois sur corriger le problème pour avoir l'icône du bluetooth dans le systray.

T'as pas un détail de ces messages d'erreur? T'as bien les services bluetooth lancés au demarrage? Bluedevil est bien installé?
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Fri Mar 03, 2017 9:42 am    Post subject: Reply with quote

Salut sebB,

Merci pour ta réponse.
Quand je passe par ligne de commande j'ai l'icône bluetooth qui apparait dans le systray, quand il est apparailler en ligne de commande le logo du bluetooth du systray passe eu bleu.

Par l'environnement graphique je ne peut pas faire de transfère, du coup j'essaie de transféré de Windoaube a gentoo et Windows me signal un échec.
De Windaube à mon tel ou mon Mac aucune problème.

Et la je vien de me rendre compte que si je fait en ligne de commande :

disconnect XX:XX:XX:XX:XX:XX

le prériphérique est deconecter.

Et si je refais :

connect XX:XX:XX:XX:XX:XX
Ca ne se connecte plus.

Il faut que je supprimer le périphérique que je refasse toute la procédure avec l'appareillage pour pouvoir me reconnecter (en ligne de commande)

8O
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 641
Location: S.O. France

PostPosted: Fri Mar 03, 2017 10:48 am    Post subject: Reply with quote

Quote:
De Windaube à mon tel ou mon Mac aucune problème.

Comme quoi Windows n'a pas que du mauvais...

Lance une console et surveille les logs en direct (journalctl -kf ou tail -f /var/log/(messages ou dmesg) )
Ensuite lance le bluetooth depuis kde et regarde les erreurs.
Regarde aussi quand tu fais disconnect/reconnect ce qu'il se passe

Sinon tu peux tester sur un livecd pour voir si ca fonctionne?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3027
Location: Paris

PostPosted: Sat Mar 04, 2017 2:33 pm    Post subject: Reply with quote

Bonjour,
Bon, désolé je n'ai pas tout saisi dans les résultats de tes tests avec tes différents équipements ;) (essaie de faire une liste ou quelque chose d'un peu plus lisible).

Mais j'espère que tu ne tentes pas un appairage sous un OS (PC A avec périphérique Z) en pensant qu'il fonctionne ensuite en dual boot sur un autre OS (toujours A avec Z)... Ça n'a aucune chance se fonctionner, puisque le PC est "PC A" sous un OS, mais est en fait "PC B" sous un autre OS (2 OS ne partagent pas les configurations bluetooth ni les données d'appairages).
L'idéal serait de voir si tu peux faire reconnaître le PC sous chaque OS comme un équipement différent par ton périphérique Z et pouvoir lui faire faire 2 appairages différents.

Ex: faire fonctionner un combo clavier/souris bluetooth en dual-boot, sachant que clavier/souris ne peuvent avoir qu'un appairage actif à la fois... -> c'est mort.
_________________
-Gentoo hardened: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Sun Mar 05, 2017 3:40 pm    Post subject: Reply with quote

Salut El_Goretto et merci pour ta réponse.

Pour le moment j'essaie juste de connecter ma gentoo avec mon téléphone ou mon home cinéma ou un autre PC sous windows.

les tests que j'ai mis plus haut c'est simplement la connexion avec l'autre PC. j'ai réussi a les appareiller (en ligne de commande), mais le transfère d'image (par ex.) ne fonctionne pas.
J'ai bien vérifier qu'aucun autre périphériques bluetooth étaient connectés.

Merci.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3027
Location: Paris

PostPosted: Mon Mar 06, 2017 9:57 am    Post subject: Reply with quote

OK, merci pour les précisions :)

Pour ce qui est du transfert de fichiers, c'est une autre "couche". De mémoire, cela nécessite un support noyau et un démon/serveur ou un client (suivant le sens de communication), et normalement c'est le boulot du paquet bluez (note: penser à démarrer le démon/service qui va avec si tu veux recevoir des fichiers). Il me semble que c'était OBEX (cf: https://en.wikipedia.org/wiki/Bluetooth_protocols) le protocole qui me permettait de transférer des fichiers quand j'ai joué avec (il y a.... pfiou... longtemps).
config noyau wrote:

CONFIG_BT_RFCOMM: RFCOMM provides connection oriented stream transport. RFCOMM support is required for Dialup Networking, OBEX and other Bluetooth applications.

_________________
-Gentoo hardened: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Mon Mar 06, 2017 7:36 pm    Post subject: Reply with quote

Merci El_Goretto pour ta réponse,

j'avais déjà vu ça.
Dans mon kernel le CONFIG_BT_RFCOMM est déjà a y.

J'ai pas mal cherché avant de poster.

je pourrais vous montrer quel fichier de config ou autre pour peut être vous donner une piste ?

Encore merci.

Ps: j'ai testé la clé bluetooth sur un autre pc et elle fonctionne.
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3027
Location: Paris

PostPosted: Tue Mar 07, 2017 12:50 pm    Post subject: Reply with quote

Mon conseil sera le même que celui de xaviermiller (tester en ligne de commande), mais en passant à la couche au dessus (OBEX). Par exemple avec app-mobilephone/obexftp: "There is a sample command line client “obexftp” and a server “obexftpd” included.". Cela permettra de voir si c'est bluez qui pose problème.
_________________
-Gentoo hardened: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Tue Mar 07, 2017 2:13 pm    Post subject: Reply with quote

OK j'installe obexftp, et je ferais le test ce soir.

Merci pour vos pistes :wink:
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Tue Mar 07, 2017 6:40 pm    Post subject: Reply with quote

Voila le résultat :

obexftp -b X0:X8:XD:XB:X0:XE -l
Browsing X0:X8:XD:XB:X0:XE ...
Connecting...failed: connect
unknown error on connect
Still trying to connect
Connecting...failed: connect
unknown error on connect
Still trying to connect
Connecting...failed: connect
unknown error on connect
Still trying to connect
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum