Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot emerge phonon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
10B2
n00b
n00b


Joined: 28 May 2013
Posts: 55

PostPosted: Fri Feb 17, 2017 11:30 am    Post subject: cannot emerge phonon Reply with quote

After a 'painful' system update, the emerge --depclean command is not executed because some packages are not installed, like:
media-libs/phonon[qt4]
dev-qt/qthelp
>=media-libs/glew
I do not want to update again the whole system, I would be happy to solve the issues for these three packages.

phonon: the only version that is recognized by emerge is phonon-9999 and cannot fetch from git repo anongit.kde.org. I would like to try with phonon-4.9.0, whose ebuild is present in /usr/portage but do not know how to get it for emerge.

I reemerged qthelp and glew but this does not solve the problem in emerge --depclean.

How can I overcome these problems? :?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3739
Location: Austro Bavaria

PostPosted: Fri Feb 17, 2017 12:01 pm    Post subject: Reply with quote

Code:
ASUS-G75VW roman # equery y phonon
Keywords for media-libs/phonon:
         |                                 |   u   | 
         | a a         p s   a     n r     |   n   | 
         | l m   h i   p p   r m m i i s   | e u s | r
         | p d a p a p c a x m i 6 o s 3   | a s l | e
         | h 6 r p 6 p 6 r 8 6 p 8 s c 9 s | p e o | p
         | a 4 m a 4 c 4 c 6 4 s k 2 v 0 h | i d t | o
---------+---------------------------------+-------+-------
   4.9.0 | + + + + ~ + + ~ + o o o o o o o | 6 o 0 | gentoo
[I]4.9.1 | ~ ~ ~ ~ ~ ~ ~ ~ ~ o o o o o o o | 6 o   | gentoo
    9999 | o o o o o o o o o o o o o o o o | 6 o   | gentoo


There is no need for emerge --depclean. It is buggy anyway.

you should check which packages depend on them, and fix those issues

Code:
ASUS-G75VW roman # equery depends phonon
 * These packages depend on phonon:
kde-frameworks/knotifications-9999 (media-libs/phonon[qt5])
media-libs/phonon-vlc-0.9.0 (>=media-libs/phonon-4.9.0[qt4=,qt5=])


You should sort out your useflags, than remove / rebuild those packages.

-qt4

kick out any qt4 package. I assume you want ot get rid of qt4? right?

Code:
ASUS-G75VW roman # qlist -Iv qt



--

Code:
ASUS-G75VW roman # emerge -pv glew

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/glew-2.0.0:0/2.0::gentoo  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


whats up with glew? i do not see any qt dependency? is it something else which causes issues?

Quote:
I would like to try with phonon-4.9.0, whose ebuild is present in /usr/portage but do not know how to get it for emerge.


Code:

ASUS-G75VW roman # emerge -av =media-libs/phonon-4.9.1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/phonon-4.9.1::gentoo  USE="pulseaudio qt5 vlc (-aqua) -debug -designer -gstreamer -qt4 (-zeitgeist)" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
10B2
n00b
n00b


Joined: 28 May 2013
Posts: 55

PostPosted: Fri Feb 17, 2017 12:15 pm    Post subject: Reply with quote

Thanks, solved the problem with phonon installing version 4.9.0.

But, concerning glew (pulled from my old libreffice version 5.2.3.3-r1 whereas the newest does not install) I emerged it 9version 1.10.0-r2 but blockage is still there. The same as for qthelp-5.6.2 [I] pulled by qtiplot-0.9.8.9-r3.

Any idea?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5049
Location: Austria

PostPosted: Fri Feb 17, 2017 12:46 pm    Post subject: Reply with quote

Please give us logs, without those no one can help you.


@Roman_Gruber: Once again, reading comprehension! Not one mention of getting rid of Qt4.

Roman_Gruber wrote:
There is no need for emerge --depclean. It is buggy anyway.

Wrong on both.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
10B2
n00b
n00b


Joined: 28 May 2013
Posts: 55

PostPosted: Fri Feb 17, 2017 1:07 pm    Post subject: Reply with quote

Error message from emerge -av --depclean:

Calculating dependencies... done!
* Dependencies could not be completely resolved due to
* the following required packages not being installed:
*
* >=media-libs/glew-1.10:0/2.0= pulled in by:
* app-office/libreoffice-5.2.3.3-r1
*
* dev-qt/qthelp:4 pulled in by:
* sci-visualization/qtiplot-0.9.8.9-r3
*
* dev-qt/qthelp:4[compat] pulled in by:
* sci-visualization/qtiplot-0.9.8.9-r3
*
* Have you forgotten to do a complete update prior to depclean? The
* most comprehensive command for this purpose is as follows:
*
* emerge --update --newuse --deep --with-bdeps=y @world
*
* Note that the --with-bdeps=y option is not required in many
* situations. Refer to the emerge manual page (run `man emerge`)
* for more information about --with-bdeps.
*
* Also, note that it may be necessary to manually uninstall
* packages that no longer exist in the portage tree, since it may
* not be possible to satisfy their dependencies.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 15413
Location: here

PostPosted: Fri Feb 17, 2017 1:10 pm    Post subject: Reply with quote

You can post also output of emerge --update --newuse --deep --with-bdeps=y --tree -p @world ?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
10B2
n00b
n00b


Joined: 28 May 2013
Posts: 55

PostPosted: Fri Feb 17, 2017 1:17 pm    Post subject: Reply with quote

I made a big mess this time with the system update. Today I performed a new emerg-webrsync. I do not want to emerge world again for now. I would prefer to solve the bloicks in depclean individually (qthelp and glew)
Code:

emerge --newuse --deep --with-bdeps=y --tree @world

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.62.0= required by (dev-cpp/libcmis-0.5.2_pre20160820:0.5/0.5::gentoo, installed)
                  ^^^^^^^^^^                                                                                                               
    (and 4 more with the same problem)

kde-frameworks/kio:5

  (kde-frameworks/kio-5.26.0-r2:5/5.26::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-frameworks/kio-5.29.0:5/5.29::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kio-5.29:5 required by (kde-frameworks/kinit-5.29.0:5/5.29::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^                                                                                                                                                               
    (and 3 more with the same problem)

kde-frameworks/kdeclarative:5

  (kde-frameworks/kdeclarative-5.26.0:5/5.26::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


  (kde-frameworks/kdeclarative-5.29.0:5/5.29::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kdeclarative-5.29:5 required by (kde-frameworks/plasma-5.29.0:5/5.29::gentoo, ebuild scheduled for merge)
    ^^                            ^^^^^^                                                                                                                                                               

kde-frameworks/knotifications:5

  (kde-frameworks/knotifications-5.26.0:5/5.26::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-frameworks/knotifications-5.29.0:5/5.29::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/knotifications-5.29:5 required by (kde-frameworks/kio-5.29.0:5/5.29::gentoo, ebuild scheduled for merge)
    ^^                              ^^^^^^                                                                                                                                                             
    (and 2 more with the same problem)

kde-frameworks/kded:5

  (kde-frameworks/kded-5.26.0:5/5.26::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-frameworks/kded-5.29.0:5/5.29::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kded-5.29:5 required by (kde-frameworks/kio-5.29.0:5/5.29::gentoo, ebuild scheduled for merge)
    ^^                    ^^^^^^                                                                                                                                                             

kde-frameworks/kinit:5

  (kde-frameworks/kinit-5.26.0:5/5.26::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (kde-frameworks/kinit-5.29.0:5/5.29::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-frameworks/kinit-5.29:5 required by (kde-frameworks/kded-5.29.0:5/5.29::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^                                                                                                                                                             

dev-libs/libical:0

  (dev-libs/libical-1.0.1:0/1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libical-2.0.0-r2:0/2::gentoo, installed) pulled in by
    dev-libs/libical:0/2= required by (net-wireless/bluez-5.43-r1:0/3::gentoo, installed)
                    ^^^^^                                                                                                   

dev-util/boost-build:0

  (dev-util/boost-build-1.62.0-r1:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.62* required by (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, installed)
    ^                     ^^^^^                                                                                                                         

  (dev-util/boost-build-1.63.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.63* required by (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                       

app-text/texlive-core:0

  (app-text/texlive-core-2015-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/texlive-core-2015-r1:0/0::gentoo, installed) pulled in by
    >=app-text/texlive-core-2010[xetex] required by (dev-texlive/texlive-xetex-2015:0/0::gentoo, installed)
                                 ^^^^^                                                                                                         

virtual/mpi:0

  (virtual/mpi-2.0-r4:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (virtual/mpi-2.0-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/mpi-2.0-r4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,
    >abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,cxx,threads] required by (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                     

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-libs/boost-1.63.0::gentoo[mpi]
# required by @selected
# required by @world (argument)
>=virtual/mpi-2.0-r4 abi_x86_32

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

emerge: there are no ebuilds built with USE flags to satisfy "sys-cluster/mpich2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,cxx?,fortran?,romio?,threads?]".
!!! One of the following packages is required to complete your request:
- virtual/mpi-2.0-r4::gentoo (Change USE: -abi_x86_32)
(dependency required by "virtual/mpi-2.0-r4::gentoo" [ebuild])
(dependency required by "dev-libs/boost-1.63.0::gentoo[mpi]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


[Moderator edit: added [code] tags to preserve output layout. Broke some very long lines. -Hu]
Back to top
View user's profile Send private message
10B2
n00b
n00b


Joined: 28 May 2013
Posts: 55

PostPosted: Fri Feb 17, 2017 3:57 pm    Post subject: Reply with quote

At the end found a way to come out from the depclean issue:
emerges a more recent (and unstable) version of glew and qtiplot. It was then possible to run emerge --depclean :lol:
I will update the system soon, hopefully next time it will be more straightforward...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum