Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Unable to emerge gentoo-sources
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 13 Feb 2017
Posts: 2

PostPosted: Mon Feb 13, 2017 7:47 pm    Post subject: [SOLVED] Unable to emerge gentoo-sources Reply with quote

Somehow I cannot emerge gentoo-sources anymore, always ends with "Unable to dry-run patch on any patch depth lower than 5."
For all versions I have tried, also the stable 4.9.6-r1.
Have cleaned /usr/portage/distfiles, doesn't help.
Can I ever emerge a kernel again?


# cat /var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/temp/build.log
 * Package:    sys-kernel/gentoo-sources-4.9.9
 * Repository: gentoo
 * Maintainer:
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-4.9.tar.xz to /var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/work
 * Excluding Patch #5000_enable-additional-cpu-optimizations-for-gcc.patch ...                                                     [ ok ]
 * Failed to dry-run patch genpatches-4.9-11.base.tar.patch
 * Please attach /var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/temp/genpatches-4.9-11.base.tar.err to any bug you may post.
 * ERROR: sys-kernel/gentoo-sources-4.9.9::gentoo failed (unpack phase):
 *   Unable to dry-run patch on any patch depth lower than 5.
 * Call stack:
 *, line  115:  Called src_unpack
 *   environment, line 3671:  Called kernel-2_src_unpack
 *   environment, line 2018:  Called unipatch '  /var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/distdir/genpatches-4.9-11.base.tar.xz /var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/distdir/genpatches-4.9-11.extras.tar.xz '
 *   environment, line 4452:  Called die
 * The specific snippet of code:
 *                   die "Unable to dry-run patch on any patch depth lower than 5.";
 * If you need support, post the output of `emerge --info '=sys-kernel/gentoo-sources-4.9.9::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/gentoo-sources-4.9.9::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/work/linux-4.9.9-gentoo'
 * S: '/var/tmp/portage/sys-kernel/gentoo-sources-4.9.9/work/linux-4.9.9-gentoo'


# emerge --info '=sys-kernel/gentoo-sources-4.9.9::gentoo'
Portage 2.3.3 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-5.4.0, glibc-2.23-r3, 4.4.40-gentoo x86_64)
                         System Settings
System uname: Linux-4.4.40-gentoo-x86_64-Intel-R-_Core-TM-_i7-4710HQ_CPU_@_2.50GHz-with-gentoo-2.3
KiB Mem:     4052744 total,    343456 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 13 Feb 2017 19:30:01 +0000
sh bash 4.4_p11
ld GNU ld (Gentoo 2.27 p1.0) 2.27
app-shells/bash:          4.4_p11::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.23.1::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.27::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.9::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=native -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif extra fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv introspection ipv6 jpeg lcms ldap libnotify libsecret mad mmx mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline sdl seccomp session smp spell sse sse2 ssl startup-notification svg systemd tcpd threads tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="virtualbox" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


emerge -pqv '=sys-kernel/gentoo-sources-4.9.9::gentoo'
[ebuild  NS   ] sys-kernel/gentoo-sources-4.9.9 [4.4.43, 4.4.47] USE="-build -experimental -symlink"

Last edited by thielec on Mon Feb 13, 2017 10:21 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 23 Jul 2004
Posts: 8643
Location: ~Brussels - Belgique

PostPosted: Mon Feb 13, 2017 7:56 pm    Post subject: Reply with quote


This is related to bug 608644.

Please resync, emerge everything unless gentoo-sources (emerge --resume --skipfirst if gentoo-sources fails), then gentoo sources
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message

Joined: 13 Feb 2017
Posts: 2

PostPosted: Mon Feb 13, 2017 10:21 pm    Post subject: Reply with quote

Thanks, that helped.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum