Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firefox nss nspr problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4259
Location: Dallas area

PostPosted: Wed Jan 11, 2017 12:45 pm    Post subject: firefox nss nspr problem Reply with quote

I'm running ff 45.6 and nss and nspr upgraded this morning

FF seemed to be running fine.......until I clicked on google, then I got a blank tab.
No matter how I tried google would not appear.
If I put "www.google.com" in the url bar I got a blank tab and nothing showing in the url bar

I downgraded both nss and nspr and magically google now appears.

Anyone else seen this weirdness.

Works
FF 45.6.0
nss 3.27.2
nspr 4.12

Problems w/google not showing.
FF 45.6.0
nss 3.28.1
nspr 4.13.1


Edit to add: Other places seemed fine, just google refused to show, in my limited looking around.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Wed Jan 11, 2017 2:46 pm    Post subject: Reply with quote

It's likely more than Google.

I've yet to figure out the reason and a proper solution, but a googled workaround, that seems to work is to disable network.http.spdy.enabled.http2.

BTW, it's either nss/nspr or ca-certificates, cause here, on a mishmash firefox 50 worked fine before updating those.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3691
Location: Germany

PostPosted: Wed Jan 11, 2017 6:50 pm    Post subject: Reply with quote

Update too (current stable) >=firefox-45.6.0-r1 should help,
see Bug 603622
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4259
Location: Dallas area

PostPosted: Wed Jan 11, 2017 7:31 pm    Post subject: Reply with quote

I'm not going to update firefox, at least at the moment, since the issue went away when I backed down to the previous non-arch nss/nspr.
For now, I'll just see what they do over the next few days or weeks.

From looking around it looks like the cuprit is as VoidMage said, it is having to do with http2, his fix should work also.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum