Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
freeorion-0.4.5 fails on start [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 186
Location: Saint-Petersburg, Russia

PostPosted: Sun Jan 08, 2017 12:25 pm    Post subject: freeorion-0.4.5 fails on start [SOLVED] Reply with quote

I emerged new version of freeorion,
Code:

USE="opengl X video alsa -joystick sound pulseaudio" emerge -pv media-libs/libsdl games-strategy/freeorion

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/libsdl-1.2.15-r9::gentoo  USE="X alsa opengl pulseaudio sound video -aalib -custom-cflags -dga -fbcon -joystick -libcaca -nas -oss -static-libs -tslib -xinerama -xv" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R   ~] games-strategy/freeorion-0.4.5-r1::gentoo  USE="-cg" 0 KiB


but if I try to run this I receive an error
Code:

freeorion
Failed to initialize sdl. SDL_Init returned: -1
[2017-01-08 14:02:29.573174] [0x000007f6ca0d2b78] [error]   main() caught exception(std::exception): Quitting application
main() caught exception(std::exception): Quitting application
.

Previous version does not work too. Which way I have to resolve this problem ?

Problem was solved by recompilation media-libs/libsdl2 with USE="X -joystick pulseaudio udev" flags
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum