Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernelin päivitys
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Languages
View previous topic :: View next topic  
Author Message
fotoni
n00b
n00b


Joined: 23 Jan 2004
Posts: 5

PostPosted: Fri Jan 23, 2004 5:44 am    Post subject: Kernelin päivitys Reply with quote

Miten tuo kerneli päivitetään uusimpaan versioonsa? Mulla on nyt joku 2.4.20. Olen aika uus tässä Gentoossa ja linuxissa yleensäkin.
Back to top
View user's profile Send private message
jmz2
Guru
Guru


Joined: 13 Jan 2004
Posts: 421
Location: Finland

PostPosted: Fri Jan 23, 2004 7:49 am    Post subject: Reply with quote

Ensin päivität ytimen lähdekoodit:
Code:
emerge -puU gentoo-sources
emerge gentoo-sources

Tämän jälkeen voit ajaa genkernelin
Code:
genkernel
jos käytät sitä tai kääntää ytimen itse.
Code:
cd /usr/src/linux-lähdekoodien-hakemisto
make menuconfig
make dep
make bzImage modules modules_install install


Tarkempia ohjeita Linuxin käyttämisestä löydät suomeksi esimerkiksi Juho Mäkisen Linux Suomi/Finland FAQ dokumenteista. Siellä kerrotaan myös ytimen kääntämisestä ja päivittämisestä.

Genkernelin käyttö on suositeltavaa jos et tiedä Linuxista paljoakaan. Se osaa päivittää uuteen ytimeen vanhat asetukset, jolloin sinun ei tarvitse muistella mitä kaikkia ajureita pitää laittaa mukaan.

Kun ole kääntänyt ytimen ja uudelleenkäynnistänyt koneen, kirjoita
Code:
uname -r
varmistaaksesi, että uusi ydin on asennettuna. Jos et saa uutta versiota, niin silloin täytyy tarkistaa /boot -hakemistosta vmlinuz -alkuiset tiedotot
Code:
ls -al /boot/vmlinuz*
ja verrata uusimman tiedoston nimeä ja /etc/lilo.conf -tiedoston asetuksia. Lilon asetusten pitäisi olla:
Code:
default=linux
image=/boot/vmlinuz-2.uusin.kernelin-versiosi-gentoo
label=linux
Back to top
View user's profile Send private message
Flammie
Developer
Developer


Joined: 02 Jun 2003
Posts: 633
Location: United States of Europe, Finland, Helsinki

PostPosted: Fri Jan 23, 2004 3:37 pm    Post subject: Reply with quote

Jos aikoo asennella alsaa tai vaikkapa nvidia-kerneliä niin ne voi asentaa ennen käynnistystä ihan muistaakseni siten että pitää huolen että /usr/src/linux osoittaa siihen uuteen kerneliin. On ainakin tuntunut riittävältä, tietysti alsa esimerkiksi taitaa 2.6.x:ssä jo ollakin.

Minä muuten jostain syystä saan kasaan stabiilimpia ratkaisuja vanilla- ja development-sorsilla kuin gentoo- ja gentoo-dev-sorsilla, ilmeisesti niissä on joku pätsi joka ei tykkää koneestani :\
Back to top
View user's profile Send private message
jmz2
Guru
Guru


Joined: 13 Jan 2004
Posts: 421
Location: Finland

PostPosted: Fri Jan 23, 2004 8:02 pm    Post subject: Reply with quote

Flammie wrote:
Minä muuten jostain syystä saan kasaan stabiilimpia ratkaisuja vanilla- ja development-sorsilla kuin gentoo- ja gentoo-dev-sorsilla, ilmeisesti niissä on joku pätsi joka ei tykkää koneestani :\


Näin on. Itselleen parhaan ytimen löytää kokeilemalla. Gentoon tiimikin on päättänyt valita mukaan joitain paikkauksia, jotka toimivat heidän koneillaan/useimmilla. Linuksen ytimet ovat hyvä valinta ellei niissä sitten ole vakausongelmia oman raudan kanssa, tai tarvitsee ajuria, joka on vain jossain toisessa ytimen haarassa.
Back to top
View user's profile Send private message
fotoni
n00b
n00b


Joined: 23 Jan 2004
Posts: 5

PostPosted: Thu Jan 29, 2004 10:10 am    Post subject: Reply with quote

Kiitos teille, nyt on uus kerneli. Mutta nyt on myös uusia ongelmia. En ole tohon vielä saanut emergoitua juurikaan mitään. Kun yritin 'emerge links', tuli vähän ajan kuluttua joku svgalib-error ja asennus loppui siihen:
!!! Function src_compile, line 59.
!!! Failed to build kernel module!

Ja kun yritin asentaa gnomea. Se valitti asennuksen alkuvaiheessa näin:
FATAL ERROR: Autoconf version 2,50 or higher is required for this script.
Back to top
View user's profile Send private message
jmz2
Guru
Guru


Joined: 13 Jan 2004
Posts: 421
Location: Finland

PostPosted: Thu Jan 29, 2004 1:36 pm    Post subject: Reply with quote

fotoni wrote:
Ja kun yritin asentaa gnomea. Se valitti asennuksen alkuvaiheessa näin:
FATAL ERROR: Autoconf version 2,50 or higher is required for this script.


Kokeilehan
Code:
emerge -puU system
tai vaikkapa
Code:
emerge -puUD world

niin saat järjestelmäsi ajan tasalle.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Languages All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum