Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] qt being forced to downgrade. KDE:4 pkgs blocking.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Sun Dec 18, 2016 7:49 pm    Post subject: [solved] qt being forced to downgrade. KDE:4 pkgs blocking. Reply with quote

KDE has upgraded to a new version, and with that usually requires some additions to my accept_keywords and other such things. But for whatever reasons, something in is now trying to force qtcore (and other standard qt libraries) to downgrade and there are a handful of KDE:4 packages blocking the update.

What is the best course of action here? Should I wipe out the blockers and remove the packages they depend on? I don't really get why the :4's would be in conflict with KDE 5.


Code:
(11:54:39) david@gothbox:/etc/portage $ sudo emerge -av kde-apps/kdecore-meta --verbose-conflicts

These are the packages that would be merged, in order:

Calculating dependencies                      ... done!                 
[ebuild  N     ] media-libs/opus-1.1.3::gentoo  USE="-ambisonics -custom-modes -doc (-neon) -static-libs" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="sse" 956 KiB
[ebuild  N     ] net-libs/libsrtp-1.4.4_p20121108-r1::gentoo  USE="-aesicm -console -debug -doc -static-libs -syslog" 475 KiB
[ebuild   R    ] media-libs/libvpx-1.5.0:0/3::gentoo  USE="postproc svc* threads -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="avx avx2 mmx sse sse2 sse3 sse4_1 ssse3" 1,862 KiB
[ebuild     UD ] dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="icu systemd -debug {-test}" 45,728 KiB
[ebuild     UD ] dev-qt/qtnetwork-5.6.2:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="ssl -bindist -connman -debug -libproxy -networkmanager {-test}" 0 KiB
[ebuild     UD ] dev-qt/qttest-5.6.2:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="-debug {-test}" 0 KiB
[ebuild     UD ] dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="-debug {-test}" 1,293 KiB
[ebuild     UD ] dev-qt/qtdbus-5.6.2:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="-debug {-test}" 0 KiB
[ebuild     UD ] dev-qt/qtgui-5.6.2:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="dbus egl gif jpeg png udev xcb -accessibility -debug -eglfs -evdev -gles2 -gtkstyle% -ibus -libinput {-test} -tslib -tuio (-gtk%*)" 0 KiB
[ebuild     UD ] dev-qt/qtwidgets-5.6.2:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="png xcb -debug -gles2 -gtkstyle% {-test}" 0 KiB
[ebuild     UD ] dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo [5.7.1:5/5.7::gentoo] USE="jit widgets xml -debug -gles2 -localstorage {-test}" 18,373 KiB
[ebuild  N     ] dev-libs/jsoncpp-0.10.2-r1::gentoo  USE="-doc {-test}" 193 KiB
[ebuild  N     ] dev-qt/qtwebchannel-5.6.2:5/5.6::gentoo  USE="qml -debug {-test}" 117 KiB
[ebuild     U ~] kde-frameworks/kdnssd-5.29.0:5/5.29::gentoo [5.26.0:5/5.26::gentoo] USE="nls -debug {-test} -zeroconf" 2,470 KiB
[ebuild     U ~] kde-apps/kde-l10n-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook -debug" L10N="-ar -ast -bg -bs -ca -ca-valencia -cs -da -de -el -en-GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt-BR -ro -ru -sk -sl -sr -sr-Latn -sr-Latn-ijekavsk -sr-ijekavsk -sv -tr -ug -uk -wa -zh-CN -zh-TW" 0 KiB
[ebuild  N     ] dev-qt/qtwebengine-5.6.2:5/5.6::gentoo  USE="system-ffmpeg system-icu widgets -bindist -debug -geolocation -pax_kernel {-test}" 140,384 KiB
[ebuild     U ~] kde-frameworks/khtml-5.29.0:5/5.29::gentoo [5.26.0:5/5.26::gentoo] USE="X -debug -libressl {-test}" 4,232 KiB
[ebuild     U ~] kde-apps/konsole-16.12.0:5::gentoo [16.08.3-r1:5::gentoo] USE="X handbook -debug {-test}" 454 KiB
[ebuild  NS   ~] kde-apps/keditbookmarks-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="handbook -debug {-test}" 63 KiB
[ebuild     U ~] kde-apps/baloo-widgets-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="-debug {-test}" 56 KiB
[ebuild     U ~] kde-apps/kwrite-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook -debug" 1,828 KiB
[ebuild  NS   ~] kde-apps/kfind-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="handbook -debug" 60 KiB
[ebuild  NS   ~] kde-apps/kdialog-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="X -debug" 31 KiB
[ebuild     U ~] kde-apps/kio-extras-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="exif handbook mtp phonon sftp -debug -htmlthumbs% -openexr -samba -slp {-test}" 274 KiB
[ebuild     U ~] kde-apps/khelpcenter-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook -debug" 1,431 KiB
[ebuild  NS   ~] kde-apps/konqueror-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="X handbook -activities -debug (-speech) {-test} -tidy" 1,144 KiB
[ebuild     U ~] kde-apps/dolphin-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook semantic-desktop -debug {-test} -thumbnail" 661 KiB
[ebuild     U ~] kde-apps/kdecore-meta-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook nls (-minimal%)" 0 KiB
[blocks B      ] kde-apps/konqueror:4 ("kde-apps/konqueror:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] kde-apps/kdialog:4 ("kde-apps/kdialog:4" is blocking kde-apps/kdialog-16.12.0)
[blocks B      ] kde-apps/kfind:4 ("kde-apps/kfind:4" is blocking kde-apps/kfind-16.12.0)
[blocks B      ] kde-apps/konq-plugins ("kde-apps/konq-plugins" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] kde-apps/kfmclient:4 ("kde-apps/kfmclient:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] kde-apps/keditbookmarks:4 ("kde-apps/keditbookmarks:4" is blocking kde-apps/keditbookmarks-16.12.0)
[blocks B      ] <kde-apps/kde4-l10n-16.12.0 ("<kde-apps/kde4-l10n-16.12.0" is blocking kde-apps/kde-l10n-16.12.0)

Total: 28 packages (10 upgrades, 8 downgrades, 5 new, 4 in new slots, 1 reinstall), Size of downloads: 222,075 KiB
Conflict: 7 blocks (7 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                         
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                   
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                       
    >=dev-qt/qtnetwork-5.7.0:5 required by (kde-apps/kio-extras-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                           
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                         
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                   

  (dev-qt/qtnetwork-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtwebengine-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                       
    ~dev-qt/qtnetwork-5.6.2 required by (dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         

dev-qt/qtcore:5

  (dev-qt/qtcore-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    >=dev-qt/qtcore-5.7.0:5 required by (kde-apps/kio-extras-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                           
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtgraphicaleffects-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                             
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtconcurrent-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtgui-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtxml-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                         
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                         
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                   
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtscript-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                   
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtimageformats-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                         
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                         
    ~dev-qt/qtcore-5.7.1[icu] required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                         
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qdbusviewer-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                         
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                     
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtpaths-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                   
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtx11extras-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    >=dev-qt/qtcore-5.6.1:5/5.7= required by (kde-plasma/kwin-5.8.4:5/5::gentoo, installed)
                         ^^^^^^^                                                                                               
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsql-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                   
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                     
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                     
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                           
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtwebchannel-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qttest-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                   
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtwebengine-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                       
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtnetwork-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qtscript-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                   
    ~dev-qt/qtwidgets-5.7.1[gles2=] required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                               
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                   
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                 
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                   
    ~dev-qt/qtwidgets-5.7.1[gles2=] required by (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                                 
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qdbusviewer-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                       
    >=dev-qt/qtwidgets-5.7.0:5 required by (kde-apps/kio-extras-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                           
    ~dev-qt/qtwidgets-5.7.1[gles2=] required by (dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                           
    ~dev-qt/qtwidgets-5.7.1[gles2=] required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                                 
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                           

  (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.6.2 required by (dev-qt/qtwebengine-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                       
    ~dev-qt/qtwidgets-5.6.2[gles2=] required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                 

dev-qt/qtgui:5

  (dev-qt/qtgui-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                   
    ~dev-qt/qtgui-5.7.1[gles2=] required by (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                                 
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                 
    ~dev-qt/qtgui-5.7.1[gles2=] required by (dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                           
    ~dev-qt/qtgui-5.7.1[gles2=] required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                                 
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                           
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtscript-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                   
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtimageformats-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                         
    >=dev-qt/qtgui-5.7.0:5 required by (kde-apps/kio-extras-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                           
    ~dev-qt/qtgui-5.7.1[xcb] required by (dev-qt/qtx11extras-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                           
    ~dev-qt/qtgui-5.7.1[egl=] required by (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                           
    ~dev-qt/qtgui-5.7.1[gles2=] required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                               
    >=dev-qt/qtgui-5.6.1:5/5.7= required by (kde-plasma/plasma-integration-5.8.4:5/5::gentoo, installed)
                        ^^^^^^^                                                                                                             
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                   
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtgraphicaleffects-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                             
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qdbusviewer-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                       
    ~dev-qt/qtgui-5.7.1[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                                       

  (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.6.2[gles2=] required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                 
    ~dev-qt/qtgui-5.6.2 required by (dev-qt/qtwebengine-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                       
    ~dev-qt/qtgui-5.6.2[gles2=,gtkstyle=,png=,xcb?] required by (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                 

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    >=dev-qt/qtdbus-5.7.0:5 required by (kde-apps/kio-extras-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                           
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    >=dev-qt/qtdbus-5.6.1:5/5.7= required by (kde-frameworks/kauth-5.29.0:5/5.29::gentoo, installed)
                         ^^^^^^^                                                                                                       
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtgui-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qdbusviewer-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                       

  (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

dev-qt/qttest:5

  (dev-qt/qttest-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

  (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qttest-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                         

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.6.2 required by (dev-qt/qtwebengine-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                       
    ~dev-qt/qtdeclarative-5.6.2 required by (dev-qt/qtwebchannel-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

  (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdeclarative-5.7.1[widgets] required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                             
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                           
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                     
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                         
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtgraphicaleffects-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                             
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                       
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                   

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.6.2 required by (dev-qt/qtdeclarative-5.6.2:5/5.6::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

  (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-5.7.1 required by (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                         


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kfind-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/kfind:4 required by @selected
    >=kde-apps/kfind-4.14.3:4[aqua=] (>=kde-apps/kfind-4.14.3:4[-aqua]) required by (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/konqueror-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/konqueror-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kfmclient-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/kfmclient:4 required by @selected
    >=kde-apps/kfmclient-4.14.3:4[aqua=] (>=kde-apps/kfmclient-4.14.3:4[-aqua]) required by (kde-base/kdelibs-4.14.24:4/4.14::gentoo, installed)
    >=kde-apps/kfmclient-4.14.3:4[aqua=] (>=kde-apps/kfmclient-4.14.3:4[-aqua]) required by (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/kdialog-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/kdialog:* required by (kde-apps/kdebase-kioslaves-16.04.3-r2:4/16.04::gentoo, installed)
    kde-apps/kdialog required by (app-emulation/winetricks-20160724:0/0::gentoo, installed)
    >=kde-apps/kdialog-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kde-l10n-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde-l10n-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdeadmin-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdeutils-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/plasma-telepathy-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdegraphics-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdenetwork-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdemultimedia-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kde4-l10n-16.08.3:4/4::gentoo, installed)

  (kde-apps/keditbookmarks-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/keditbookmarks:4 required by @selected
    >=kde-apps/keditbookmarks-4.14.3:4[aqua=] (>=kde-apps/keditbookmarks-4.14.3:4[-aqua]) required by (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed) pulled in by
    >=kde-apps/konqueror-4.14.3:4[aqua=] (>=kde-apps/konqueror-4.14.3:4[-aqua]) required by (kde-apps/nsplugins-16.08.3:4/16.08::gentoo, installed)
    kde-apps/konqueror:4 required by @selected
    >=kde-apps/konqueror-4.14.3:4[aqua=] (>=kde-apps/konqueror-4.14.3:4[-aqua]) required by (kde-apps/konq-plugins-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/konq-plugins-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/konq-plugins:4 required by @selected
    kde-apps/konq-plugins required by @selected

  (kde-apps/kfind-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kfind-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kfind required by @selected
    >=kde-apps/kfind-16.12.0:5 required by (kde-apps/konqueror-16.12.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/keditbookmarks-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/keditbookmarks-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/keditbookmarks required by @selected

  (kde-apps/kde4-l10n-16.08.3:4/4::gentoo, installed) pulled in by
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdenetwork-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdeutils-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdemultimedia-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdegraphics-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.04.3 required by (kde-apps/kdebase-runtime-meta-16.04.3:5/5::gentoo, installed)

  (kde-apps/kdialog-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/kdialog:4 required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Last edited by davidsmind on Mon Dec 19, 2016 6:36 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7006
Location: Austria

PostPosted: Sun Dec 18, 2016 8:07 pm    Post subject: Reply with quote

Fix your package.keywords. You can pick complete package.keywords files from kde overlay Documentation directory.

Also, make sure ALL of Qt 5.7.1 is in package.keywords.

davidsmind wrote:
KDE has upgraded to a new version, and with that usually requires some additions to my accept_keywords and other such things.

It only requires that because you have existing package.keywords entries, they're just incomplete for the upgrade.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Sun Dec 18, 2016 8:16 pm    Post subject: Reply with quote

asturm wrote:
Fix your package.keywords. You can pick complete package.keywords files from kde overlay Documentation directory.

Also, make sure ALL of Qt 5.7.1 is in package.keywords.

davidsmind wrote:
KDE has upgraded to a new version, and with that usually requires some additions to my accept_keywords and other such things.

It only requires that because you have existing package.keywords entries, they're just incomplete for the upgrade.


Perhaps, I'm not using either the KDE or QT overlays tho:

Code:
(12:13:23) david@gothbox:/usr/portage $ sudo layman -l

 * ago                       [Git       ] (git://anongit.gentoo.org/dev/ago.git                                                                                                             )
 * anders-larsson            [Git       ] (https://github.com/anders-larsson/gentoo-overlay.git                                                                                             )
 * multimedia                [Git       ] (https://github.com/gentoo/multimedia.git                                                                                                         )
 * steam-overlay             [Git       ] (git://github.com/anyc/steam-overlay.git                                                                                                          )



And it looks to me like I have all the correct qt.keywords

Code:
(12:15:19) david@gothbox:/etc/portage/package.accept_keywords $ cat qt.keywords
dev-qt/qtdbus ~amd64
dev-qt/qtsql ~amd64
dev-qt/qtsvg ~amd64
dev-qt/qtopengl ~amd64
dev-qt/qtcore ~amd64
dev-qt/qtscript ~amd64
dev-qt/designer ~amd64
dev-qt/qtgui ~amd64
dev-qt/qttest ~amd64
dev-qt/qtwebkit ~amd64
dev-qt/qtxmlpatterns ~amd64
dev-qt/qttranslations ~amd64
dev-qt/qt3support ~amd64
dev-qt/qtdeclarative ~amd64
dev-qt/qtprintsupport ~amd64
dev-qt/qtxml ~amd64
dev-qt/qtwidgets ~amd64
dev-qt/qtmultimedia ~amd64
dev-qt/qtwayland ~amd64
dev-qt/qdbusviewer ~amd64
dev-qt/qtx11extras ~amd64
dev-qt/qtquickcontrols ~amd64
dev-qt/qtimageformats ~amd64
dev-qt/qtpaths ~amd64
dev-qt/qtnetwork ~amd64
dev-qt/qtconcurrent ~amd64
dev-qt/qtgraphicaleffects ~amd64
dev-qt/linguist-tools ~amd64
dev-qt/qdbus ~amd64
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7006
Location: Austria

PostPosted: Sun Dec 18, 2016 8:17 pm    Post subject: Reply with quote

You don't have to use the overlay, you can just copy those files / download from web.

davidsmind wrote:
And it looks to me like I have all the correct qt.keywords

What makes you think that? Here's already one that is missing:
Code:
[ebuild  N     ] dev-qt/qtwebengine-5.6.2:5/5.6::gentoo  USE="system-ffmpeg system-icu widgets -bindist -debug -geolocation -pax_kernel {-test}" 140,384 KiB

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Sun Dec 18, 2016 8:28 pm    Post subject: Reply with quote

Great. So now the qt issue is resolved. On to the blockers.

I put in place the overlay (https://gitweb.gentoo.org/proj/kde.git/tree/Documentation/package.accept_keywords/kde-applications-16.12.keywords), but the :4 slot blockers are still around. Should I delete them and what relies on them and try again or is their a cleaner way? I think kde4-l10n looks suspicious.

Code:
(12:24:31) david@gothbox:/etc/portage/package.accept_keywords $ sudo emerge -av kde-apps/kdecore-meta --verbose-conflicts

These are the packages that would be merged, in order:

Calculating dependencies                     ... done!         
[ebuild  N     ] media-libs/opus-1.1.3::gentoo  USE="-ambisonics -custom-modes -doc (-neon) -static-libs" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="sse" 956 KiB
[ebuild  N     ] net-libs/libsrtp-1.4.4_p20121108-r1::gentoo  USE="-aesicm -console -debug -doc -static-libs -syslog" 475 KiB
[ebuild   R    ] media-libs/libvpx-1.5.0:0/3::gentoo  USE="postproc svc* threads -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="avx avx2 mmx sse sse2 sse3 sse4_1 ssse3" 1,862 KiB
[ebuild  N    ~] dev-qt/qtwebchannel-5.7.1:5/5.7::gentoo  USE="qml -debug {-test}" 120 KiB
[ebuild  N     ] dev-libs/jsoncpp-0.10.2-r1::gentoo  USE="-doc {-test}" 193 KiB
[ebuild     U ~] kde-frameworks/kdnssd-5.29.0:5/5.29::gentoo [5.26.0:5/5.26::gentoo] USE="nls -debug {-test} -zeroconf" 2,470 KiB
[ebuild     U ~] kde-apps/kde-l10n-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook -debug" L10N="-ar -ast -bg -bs -ca -ca-valencia -cs -da -de -el -en-GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt-BR -ro -ru -sk -sl -sr -sr-Latn -sr-Latn-ijekavsk -sr-ijekavsk -sv -tr -ug -uk -wa -zh-CN -zh-TW" 0 KiB
[ebuild  N    ~] dev-qt/qtwebengine-5.7.1:5/5.7::gentoo  USE="system-ffmpeg system-icu widgets -bindist -debug -geolocation -pax_kernel {-test}" 159,944 KiB
[ebuild     U ~] kde-frameworks/khtml-5.29.0:5/5.29::gentoo [5.26.0:5/5.26::gentoo] USE="X -debug -libressl {-test}" 4,232 KiB
[ebuild  NS   ~] kde-apps/keditbookmarks-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="handbook -debug {-test}" 63 KiB
[ebuild     U ~] kde-apps/konsole-16.12.0:5::gentoo [16.08.3-r1:5::gentoo] USE="X handbook -debug {-test}" 454 KiB
[ebuild     U ~] kde-apps/baloo-widgets-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="-debug {-test}" 56 KiB
[ebuild     U ~] kde-apps/kwrite-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook -debug" 1,828 KiB
[ebuild  NS   ~] kde-apps/kfind-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="handbook -debug" 60 KiB
[ebuild  NS   ~] kde-apps/kdialog-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="X -debug" 31 KiB
[ebuild     U ~] kde-apps/kio-extras-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="exif handbook mtp phonon sftp -debug -htmlthumbs% -openexr -samba -slp {-test}" 274 KiB
[ebuild     U ~] kde-apps/khelpcenter-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook -debug" 1,431 KiB
[ebuild     U ~] kde-apps/dolphin-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook semantic-desktop -debug {-test} -thumbnail" 661 KiB
[ebuild  NS   ~] kde-apps/konqueror-16.12.0:5::gentoo [16.08.3:4/16.08::gentoo] USE="X handbook -activities -debug (-speech) {-test} -tidy" 1,144 KiB
[ebuild     U ~] kde-apps/kdecore-meta-16.12.0:5::gentoo [16.08.3:5::gentoo] USE="handbook nls (-minimal%)" 0 KiB
[blocks B      ] kde-apps/konq-plugins ("kde-apps/konq-plugins" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] kde-apps/konqueror:4 ("kde-apps/konqueror:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] <kde-apps/kde4-l10n-16.12.0 ("<kde-apps/kde4-l10n-16.12.0" is blocking kde-apps/kde-l10n-16.12.0)
[blocks B      ] kde-apps/keditbookmarks:4 ("kde-apps/keditbookmarks:4" is blocking kde-apps/keditbookmarks-16.12.0)
[blocks B      ] kde-apps/kfind:4 ("kde-apps/kfind:4" is blocking kde-apps/kfind-16.12.0)
[blocks B      ] kde-apps/kfmclient:4 ("kde-apps/kfmclient:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] kde-apps/kdialog:4 ("kde-apps/kdialog:4" is blocking kde-apps/kdialog-16.12.0)

Total: 20 packages (10 upgrades, 5 new, 4 in new slots, 1 reinstall), Size of downloads: 176,246 KiB
Conflict: 7 blocks (7 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/konqueror-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/konqueror-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/keditbookmarks-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/keditbookmarks:4 required by @selected
    >=kde-apps/keditbookmarks-4.14.3:4[aqua=] (>=kde-apps/keditbookmarks-4.14.3:4[-aqua]) required by (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/kfind-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/kfind:4 required by @selected
    >=kde-apps/kfind-4.14.3:4[aqua=] (>=kde-apps/kfind-4.14.3:4[-aqua]) required by (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/kde4-l10n-16.08.3:4/4::gentoo, installed) pulled in by
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdenetwork-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdeutils-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.04.3 required by (kde-apps/kdebase-runtime-meta-16.04.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdegraphics-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde4-l10n-16.08.3 required by (kde-apps/kdemultimedia-meta-16.08.3:5/5::gentoo, installed)

  (kde-apps/kde-l10n-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/plasma-telepathy-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdemultimedia-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdegraphics-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdeadmin-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdenetwork-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kdeutils-meta-16.08.3:5/5::gentoo, installed)
    >=kde-apps/kde-l10n-16.08.3 required by (kde-apps/kde4-l10n-16.08.3:4/4::gentoo, installed)

  (kde-apps/keditbookmarks-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-apps/keditbookmarks required by @selected
    >=kde-apps/keditbookmarks-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdialog-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdialog-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kdialog:* required by (kde-apps/kdebase-kioslaves-16.04.3-r2:4/16.04::gentoo, installed)
    kde-apps/kdialog required by (app-emulation/winetricks-20160724:0/0::gentoo, installed)

  (kde-apps/kfmclient-16.08.3:4/16.08::gentoo, installed) pulled in by
    >=kde-apps/kfmclient-4.14.3:4[aqua=] (>=kde-apps/kfmclient-4.14.3:4[-aqua]) required by (kde-base/kdelibs-4.14.24:4/4.14::gentoo, installed)
    kde-apps/kfmclient:4 required by @selected
    >=kde-apps/kfmclient-4.14.3:4[aqua=] (>=kde-apps/kfmclient-4.14.3:4[-aqua]) required by (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/konqueror:4 required by @selected
    >=kde-apps/konqueror-4.14.3:4[aqua=] (>=kde-apps/konqueror-4.14.3:4[-aqua]) required by (kde-apps/nsplugins-16.08.3:4/16.08::gentoo, installed)
    >=kde-apps/konqueror-4.14.3:4[aqua=] (>=kde-apps/konqueror-4.14.3:4[-aqua]) required by (kde-apps/konq-plugins-16.08.3:4/16.08::gentoo, installed)

  (kde-apps/konq-plugins-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/konq-plugins:4 required by @selected
    kde-apps/konq-plugins required by @selected

  (kde-apps/kfind-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kfind-16.12.0 required by (kde-apps/kdecore-meta-16.12.0:5/5::gentoo, ebuild scheduled for merge)
    kde-apps/kfind required by @selected
    >=kde-apps/kfind-16.12.0:5 required by (kde-apps/konqueror-16.12.0:5/5::gentoo, ebuild scheduled for merge)

  (kde-apps/kdialog-16.08.3:4/16.08::gentoo, installed) pulled in by
    kde-apps/kdialog:4 required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7006
Location: Austria

PostPosted: Sun Dec 18, 2016 8:42 pm    Post subject: Reply with quote

davidsmind wrote:
Code:
[blocks B      ] kde-apps/konq-plugins ("kde-apps/konq-plugins" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] kde-apps/konqueror:4 ("kde-apps/konqueror:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] <kde-apps/kde4-l10n-16.12.0 ("<kde-apps/kde4-l10n-16.12.0" is blocking kde-apps/kde-l10n-16.12.0)
[blocks B      ] kde-apps/keditbookmarks:4 ("kde-apps/keditbookmarks:4" is blocking kde-apps/keditbookmarks-16.12.0)
[blocks B      ] kde-apps/kfind:4 ("kde-apps/kfind:4" is blocking kde-apps/kfind-16.12.0)
[blocks B      ] kde-apps/kfmclient:4 ("kde-apps/kfmclient:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B      ] kde-apps/kdialog:4 ("kde-apps/kdialog:4" is blocking kde-apps/kdialog-16.12.0)

Check your world file. There should not be any slot:4 entries. And remove kfmclient from there (it is gone).
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Sun Dec 18, 2016 8:59 pm    Post subject: Reply with quote

Found the culprit!

media-sound/kid3:4
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Sun Dec 18, 2016 10:20 pm    Post subject: Reply with quote

Thanks so much Asturm.

I did a rebuild from a backup earlier in the year, and I bet that's where all the explicit :4 entries came from in my world file.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum