Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libmbim compile failing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
phil_r
Apprentice
Apprentice


Joined: 14 Mar 2006
Posts: 218
Location: Lincoln, NE, USA

PostPosted: Thu Nov 03, 2016 5:54 pm    Post subject: libmbim compile failing Reply with quote

So I'm switching from amd64 to ~amd64... running emerge -auDN @world, when I get to emerging libmbim it fails very early.

rm -f mbim-auth.h && \
rm -f mbim-auth.c && \
../../../build-aux/mbim-codegen/mbim-codegen \
--input ../../../data/mbim-service-auth.json \
--output mbim-auth
Makefile:904: recipe for target 'mbim-basic-connect.h' failed
make[4]: *** [mbim-basic-connect.h] Error 127
make[4]: *** Waiting for unfinished jobs....
Makefile:931: recipe for target 'mbim-auth.h' failed
make[4]: *** [mbim-auth.h] Error 127
Makefile:913: recipe for target 'mbim-sms.h' failed
make[4]: *** [mbim-sms.h] Error 127
Makefile:922: recipe for target 'mbim-ussd.h' failed
make[4]: *** [mbim-ussd.h] Error 127
make[4]: Leaving directory '/var/tmp/portage/net-libs/libmbim-1.14.0/work/libmbim-1.14.0/src/libmbim-glib/generated'
Makefile:688: recipe for target 'all-recursive' failed
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory '/var/tmp/portage/net-libs/libmbim-1.14.0/work/libmbim-1.14.0/src/libmbim-glib'
Makefile:378: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/net-libs/libmbim-1.14.0/work/libmbim-1.14.0/src'
Makefile:433: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/net-libs/libmbim-1.14.0/work/libmbim-1.14.0'
Makefile:365: recipe for target 'all' failed
make: *** [all] Error 2


Logs:
undertaker portage # emerge --info =net-libs/libmbim-1.14.0::gentoo
Portage 2.3.0 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.3, glibc-2.23-r2, 4.4.26-gentoo x86_64)
=================================================================
System Settings
=================================================================
System uname: Linux-4.4.26-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1075T_Processor-with-gentoo-2.3
KiB Mem: 24608168 total, 4298568 free
KiB Swap: 0 total, 0 free
Timestamp of repository gentoo: Thu, 03 Nov 2016 17:30:01 +0000
sh bash 4.3_p48
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash: 4.3_p48::gentoo
dev-lang/perl: 5.22.2::gentoo
dev-lang/python: 2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake: 3.5.2-r1::gentoo
dev-util/pkgconfig: 0.29.1::gentoo
sys-apps/baselayout: 2.3::gentoo
sys-apps/openrc: 0.21.7::gentoo
sys-apps/sandbox: 2.10-r2::gentoo
sys-devel/autoconf: 2.13::gentoo, 2.69::gentoo
sys-devel/automake: 1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils: 2.25.1-r1::gentoo
sys-devel/gcc: 4.9.3::gentoo
sys-devel/gcc-config: 1.8-r1::gentoo
sys-devel/libtool: 2.4.6::gentoo
sys-devel/make: 4.1-r1::gentoo
sys-kernel/linux-headers: 4.7::gentoo (virtual/os-headers)
sys-libs/glibc: 2.23-r2::gentoo
Repositories:

gentoo
location: /usr/portage
sync-type: rsync
sync-uri: rsync://rsync.gentoo.org/gentoo-portage
priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cddb cdparanoia cdr cli consolekit corefonts cracklib crypt cxx dbus declarative dri dts dvd dvdr dvdread emboss encode exif faac faad fam fbcon fdk ffmpeg firefox flac fontconfig fortran freerdp gdbm gif glamor gpm gtk h264 iconv id3tag imagemagick imlib jpeg jpeg2k jpg k kde kipi lastfm lcms ldap libnotify lm_sensors lzo m4a mad mencoder mjpeg mmx mmxext mng modules mov mp3 mp4 mpeg mpg multilib musicbrainz ncurses nls nptl nss offensive ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 quicktime rdesktop rdp readline samba sdl seccomp semantic-desktop session spell sse sse2 ssl startup-notification svg symlink taglib tcpd tga theora tiff truetype udev udisks unicode upower usb vaapi vcd vdpau vorbis widgets win32codecs win64codecs wmf wmv wxwidgets x264 xattr xcb xcomposite xga xinerama xml xscreensaver xv xvid yahoo zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="apic mmx sse sse2 mmxext 3dnowext 3dnow sse4a misalignsse 3dnowprefetch popcnt" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox

emerge -pqv =net-libs/libmbim-1.14.0::gentoo
[ebuild N ] net-libs/libmbim-1.14.0 USE="udev -static-libs"


Anyone have any ideas? Thanks!
_________________
Just when you think you know the answers, I change the questions.

AMD64 Phenom-II 6-core, 440Gb Intel SSD NVMe, 4Tb SATA II, 20576Mb, 1Gb Ethernet, GeForce GTS 950, x64
MacBook, ESX servers, many other toys
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22052
Location: here

PostPosted: Thu Nov 03, 2016 5:59 pm    Post subject: Reply with quote

You can post all build.log with wgetpaste?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
phil_r
Apprentice
Apprentice


Joined: 14 Mar 2006
Posts: 218
Location: Lincoln, NE, USA

PostPosted: Thu Nov 03, 2016 6:11 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You can post all build.log with wgetpaste?


https://paste.pound-python.org/show/nY33MDUxPjwENyjAOmzA/
_________________
Just when you think you know the answers, I change the questions.

AMD64 Phenom-II 6-core, 440Gb Intel SSD NVMe, 4Tb SATA II, 20576Mb, 1Gb Ethernet, GeForce GTS 950, x64
MacBook, ESX servers, many other toys
Back to top
View user's profile Send private message
aahamlin
n00b
n00b


Joined: 28 Nov 2011
Posts: 6

PostPosted: Tue Feb 14, 2017 1:23 am    Post subject: Any solution yet? Reply with quote

I am running into this same compile errors, did you find a solution?

EDIT: figured it out

A generated python script was failing. Had to upgrade the system to use python3 by default, https://www.gentoo.org/support/news-items/2015-07-25-python-targets.html. Then world upgrade seemed to work, though I had to get through some other upgrade issues first (such as switching from ruby20 to ruby21).
Back to top
View user's profile Send private message
Pistos
Apprentice
Apprentice


Joined: 29 Jul 2003
Posts: 175
Location: Canada

PostPosted: Fri Oct 20, 2017 7:27 pm    Post subject: Reply with quote

@aahamlin: What generated python script was failing? Did you do any manual builds of anything before trying the world build? I am having a very similar issue as OP (build output is not QUITE the same though), and can't get past this.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum