Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X upgrade issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mgnut57
Apprentice
Apprentice


Joined: 12 Jan 2008
Posts: 190

PostPosted: Sat Oct 29, 2016 11:01 pm    Post subject: X upgrade issues Reply with quote

Please help me resolve this set of conflicts. This is the end of what I get from "emerge --ask -uD world". Note that the desktop environment on this installation is MATE:
Code:
[ebuild     U  ]   dev-libs/gmp-6.1.0 [6.0.0a] USE="asm%*"
[ebuild     U  ] virtual/libc-1 [0]
[blocks B      ]   <x11-drivers/xf86-input-evdev-2.10.0 ("<x11-drivers/xf86-input-evdev-2.10.0" is blocking x11-base/xorg-drivers-1.18-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.2:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-ExtUtils-MakeMaker-7.40.100_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                         
    (and 16 more with the same problem)

  (dev-lang/perl-5.20.2:0/5.20::gentoo, installed) pulled in by
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    (and 28 more with the same problem)

dev-libs/gmp:0

  (dev-libs/gmp-6.1.0:0/10.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gmp-6.0.0a:0/0::gentoo, installed) pulled in by
    >=dev-libs/gmp-4.1:0/0= required by (dev-scheme/guile-1.8.8-r2:12/12::gentoo, installed)
                      ^^^^^                                                                                                     

x11-libs/libxcb:0

  (x11-libs/libxcb-1.12:0/1.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.11.1:0/1.11.1::gentoo, installed) pulled in by
    >=x11-libs/libxcb-1.10:0/1.11.1=[xkb] required by (dev-qt/qtgui-5.6.1:5/5.6::gentoo, installed)
                          ^^^^^^^^^^                                                                                                   
    (and 5 more with the same problem)

x11-base/xorg-server:0

  (x11-base/xorg-server-1.17.4:0/1.17.4::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.17.4= required by (x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                                                           
    <=x11-base/xorg-server-1.17.49[-minimal] required by (x11-drivers/ati-drivers-15.12-r1:1/1::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                       
    (and 2 more with the same problems)

  (x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-base/xorg-server-1.18[udev] required by (x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^                                                                                         
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7105
Location: almost Mile High in the USA

PostPosted: Sun Oct 30, 2016 4:06 am    Post subject: Reply with quote

I ran into this issue, fix by masking the 1.18 version of xorg-server, I have the needed masks in this thread:

https://forums.gentoo.org/viewtopic-t-1053484-highlight-.html

I will crosslink your post to that thread as I wanted to get a discussion going of the weird perl slot conflict you're seeing - I saw it too but it went away when I masked xorg-server-1.18 (both current versions of ati-drivers and nvidia-drivers do not like xorg-server-1.18).
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21675
Location: here

PostPosted: Sun Oct 30, 2016 8:06 am    Post subject: Reply with quote

For gmp, libxcb and ati problems you can see here (for ati you can also mask xorg-1.18 as eccerr0r says).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum