Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
List of programs/libs that cannot be used in no-multilib?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
cyisfor
n00b
n00b


Joined: 19 Feb 2016
Posts: 13
Location: Oregon

PostPosted: Fri Feb 19, 2016 8:41 am    Post subject: List of programs/libs that cannot be used in no-multilib? Reply with quote

If I were to disable multilib, that means I can't use...

  1. Adobe Flash
  2. Wine
  3. ancient drivers from paranoid morons in hardware production

anything else worth mentioning...?
Back to top
View user's profile Send private message
alinefr
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jul 2009
Posts: 108
Location: São Paulo, Brasil

PostPosted: Fri Feb 19, 2016 8:57 am    Post subject: Reply with quote

* Skype
* Android development (as we need java 32 bits ).

But we do have flash 64 bits. Also you could build wine, but it would only emulate 64 bits windows binaries.
Back to top
View user's profile Send private message
cyisfor
n00b
n00b


Joined: 19 Feb 2016
Posts: 13
Location: Oregon

PostPosted: Fri Feb 19, 2016 9:03 am    Post subject: Reply with quote

alinefr wrote:
* Skype
That freaking program...
Quote:
But we do have flash 64 bits.
Yeah, but not Adobe Flash, right?
Quote:
Also you could build wine, but it would only emulate 64 bits windows binaries.
Huh, good to know.
Back to top
View user's profile Send private message
alinefr
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jul 2009
Posts: 108
Location: São Paulo, Brasil

PostPosted: Fri Feb 19, 2016 9:07 am    Post subject: Reply with quote

cyisfor wrote:

Yeah, but not Adobe Flash, right?


I mean adobe-flash.

Code:

aline@luiza-mouraria ~ $ equery u adobe-flash
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for www-plugins/adobe-flash-11.2.202.569:
 U I
 - - abi_x86_32         : 32-bit (x86) libraries
 + + abi_x86_64         : 64-bit (amd64) libraries
 + + cpu_flags_x86_sse2 : Use the SSE2 instruction set
 - - kde                : Install a KCM plugin for configuring flash player preferences
Back to top
View user's profile Send private message
cyisfor
n00b
n00b


Joined: 19 Feb 2016
Posts: 13
Location: Oregon

PostPosted: Fri Feb 19, 2016 9:55 am    Post subject: Reply with quote

alinefr wrote:

I mean adobe-flash.
Huh. News to me. Shows how much I use Adobe Flash.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7258
Location: ~Brussels - Belgique

PostPosted: Fri Feb 19, 2016 11:07 am    Post subject: Reply with quote

Nope, Flash can be run in non-multilib systems.

The idea : search for 32 bits-only binary blobs (-bin packages or proprietary software that don't has migrated to 64 bits)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 4439

PostPosted: Fri Feb 19, 2016 4:02 pm    Post subject: Reply with quote

A few proprietary games, Steam and everything in it too (even though some 3rd-party developers are competent enough to build 64-bit versions, you can't run them without the 32-bit launcher)

As for Skype, there's a pidgin plugin that lets you use the text IM part of it. It's actually a horrible hack underneath, but it works.
_________________
*.ebuild // /etc/service/*
Back to top
View user's profile Send private message
bstaletic
Apprentice
Apprentice


Joined: 05 Apr 2014
Posts: 219

PostPosted: Fri Feb 19, 2016 6:08 pm    Post subject: Reply with quote

Ant P.

I thought for the pidgin plugin to work one needs skype installed too. Is it not the case anymore?
Back to top
View user's profile Send private message
cyisfor
n00b
n00b


Joined: 19 Feb 2016
Posts: 13
Location: Oregon

PostPosted: Fri Feb 19, 2016 6:46 pm    Post subject: Reply with quote

bstaletic wrote:
I thought for the pidgin plugin to work one needs skype installed too. Is it not the case anymore?
This is the study of skype I read.
Long story short, the client and "protocol is heavily protected, obfuscated and designed to counter reverse engineering attempts." It decrypts its own executable code on the fly just to try to keep you from being able to know what it's doing. So no, nobody's going to reverse engineer that any time soon. They'd just change the protocol if anyone succeeded at that monumental task. It's like AOL's Oscar network, but worse.

I don't know why anyone would ever use it.
Back to top
View user's profile Send private message
bstaletic
Apprentice
Apprentice


Joined: 05 Apr 2014
Posts: 219

PostPosted: Fri Feb 19, 2016 8:43 pm    Post subject: Reply with quote

We're going offtopic, but I've got to ask.

So how did trillian for windows manage to integrate skype chat without skype running along side it?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3248
Location: Germany

PostPosted: Sun Aug 14, 2016 3:49 am    Post subject: List of programs/libs that cannot be used in no-multilib? Reply with quote

Code:
less /usr/portage/profiles/arch/amd64/no-multilib/package.mask
Back to top
View user's profile Send private message
peakeyed
n00b
n00b


Joined: 18 Nov 2004
Posts: 55

PostPosted: Thu Sep 15, 2016 6:16 pm    Post subject: skype and android Reply with quote

skype and android development

so unfortunate i can't have these in pure 64bit environment
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum