Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia-drivers-370.23 gentoo-sources-4.7.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mDup
Apprentice
Apprentice


Joined: 14 Apr 2006
Posts: 190

PostPosted: Wed Aug 17, 2016 2:46 pm    Post subject: nvidia-drivers-370.23 gentoo-sources-4.7.1 Reply with quote

emerge x11-drivers/nvidia-drivers-370.23 fails
Code:
FATAL: modpost: GPL-incompatible module nvidia-drm.ko uses GPL-only symbol 'mutex_destroy'

emerge x11-drivers/nvidia-drivers-367.35-r1 succeeds.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7236
Location: almost Mile High in the USA

PostPosted: Wed Aug 17, 2016 3:14 pm    Post subject: Reply with quote

:(
Looks like a "complain to nvidia" problem or you could work around it by hacking your own kernel that will never be accepted upstream...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Cynede
Developer
Developer


Joined: 30 Nov 2012
Posts: 56

PostPosted: Wed Aug 17, 2016 4:04 pm    Post subject: Reply with quote

https://github.com/torvalds/linux/blob/master/kernel/locking/mutex-debug.c#L120
Back to top
View user's profile Send private message
mDup
Apprentice
Apprentice


Joined: 14 Apr 2006
Posts: 190

PostPosted: Wed Aug 17, 2016 4:06 pm    Post subject: Reply with quote

eccerr0r wrote:
:(
Looks like a "complain to nvidia" problem or you could work around it by hacking your own kernel that will never be accepted upstream...

OK: I see, for now I leave kernel untouched and I hack modpost just to work around particular nvidia GPL issue.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3691
Location: Germany

PostPosted: Wed Aug 17, 2016 9:28 pm    Post subject: Reply with quote

Hm, nvidia-drivers-370.23 build and works here fine with gentoo-sources:4.7.1
Code:
equery b nvidia-drm.ko
 * Searching for nvidia-drm.ko ...
x11-drivers/nvidia-drivers-370.23 (/lib/modules/4.7.1-gentoo/video/nvidia-drm.ko)


Have you old unneeded patches in /etc/portage/patches/x11-drivers/nvidia-drivers/ ?
Back to top
View user's profile Send private message
anomaly257
n00b
n00b


Joined: 04 Mar 2008
Posts: 3

PostPosted: Thu Aug 18, 2016 12:45 am    Post subject: Reply with quote

Try setting CONFIG_DEBUG_MUTEXES=n in your kernel config and recompiling. This fixed it for me here. Perhaps it's a kernel bug that this symbol is flagged GPL only when debugging is enabled? Or maybe it doesn't exist otherwise. Anyway this is the quick and simple fix, assuming nothing else you use requires mutex debugging to be enabled.
Back to top
View user's profile Send private message
jorgicio
n00b
n00b


Joined: 17 Oct 2014
Posts: 45

PostPosted: Sat Aug 20, 2016 11:06 pm    Post subject: Reply with quote

Somewhere in Twitter I found this:
https://twitter.com/Cynede/status/765879300348342272?lang=es

It seems you need to downgrade your kernel :(
Back to top
View user's profile Send private message
jorgicio
n00b
n00b


Joined: 17 Oct 2014
Posts: 45

PostPosted: Sun Aug 21, 2016 12:20 am    Post subject: Reply with quote

I found a fix for the 367.35 version and works fine with Kernel 4.7:

Just apply this patch:

http://pastebin.com/cw1tncgm
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Aug 22, 2016 10:12 am    Post subject: Reply with quote

anomaly257 wrote:
Try setting CONFIG_DEBUG_MUTEXES=n in your kernel config and recompiling. This fixed it for me here. Perhaps it's a kernel bug that this symbol is flagged GPL only when debugging is enabled? Or maybe it doesn't exist otherwise. Anyway this is the quick and simple fix, assuming nothing else you use requires mutex debugging to be enabled.


Worked for me.

Only functionality loss now is that this kernel breaks the acpi event for toggle touchpad functionality.
Back to top
View user's profile Send private message
jorgicio
n00b
n00b


Joined: 17 Oct 2014
Posts: 45

PostPosted: Sun Sep 11, 2016 3:55 pm    Post subject: Reply with quote

A workaround:

Patch the kernel with this, or modify the respective file:

http://pastebin.com/mTtDpN2K

Code:

--- a/kernel/locking/mutex-debug.c   2016-01-10 20:01:32.000000000 -0300
+++ b/kernel/locking/mutex-debug.c   2016-09-11 02:38:11.331048350 -0300
@@ -117,4 +117,4 @@
    lock->magic = NULL;
 }
 
-EXPORT_SYMBOL_GPL(mutex_destroy);
+EXPORT_SYMBOL(mutex_destroy);


Then rebuild the kernel and then try to install nvidia-drivers 370.28. Works for me.
Back to top
View user's profile Send private message
stqn
n00b
n00b


Joined: 07 Apr 2015
Posts: 49

PostPosted: Fri Dec 16, 2016 12:09 am    Post subject: Reply with quote

anomaly257 wrote:
Try setting CONFIG_DEBUG_MUTEXES=n in your kernel config and recompiling.

Thanks, worked for me with nvidia-drivers 375.26 and linux 4.4.38.
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 290

PostPosted: Sun Dec 25, 2016 5:12 pm    Post subject: Reply with quote

Where do I find CONFIG_DEBUG_MUTEXES?
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 290

PostPosted: Sun Dec 25, 2016 5:23 pm    Post subject: Reply with quote

Answer by myself: I didn't find it, but I disabled "kernel hacking -> Kernel debugging" (no idea if it was enabled by default) and that made it
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
stqn
n00b
n00b


Joined: 07 Apr 2015
Posts: 49

PostPosted: Sun Dec 25, 2016 5:51 pm    Post subject: Reply with quote

Vrenn wrote:
Where do I find CONFIG_DEBUG_MUTEXES?

In make menuconfig (or genkernel --menuconfig) you can press "/" then "DEBUG_MUTEXES" to search for the option, then "1" to go to the result and change it.
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 290

PostPosted: Mon Dec 26, 2016 2:27 pm    Post subject: Reply with quote

Thanks for the trick, never new that.
This will make things more easy.
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Dec 26, 2016 6:46 pm    Post subject: Reply with quote

stqn wrote:
Vrenn wrote:
Where do I find CONFIG_DEBUG_MUTEXES?

In make menuconfig (or genkernel --menuconfig) you can press "/" then "DEBUG_MUTEXES" to search for the option, then "1" to go to the result and change it.


ah - so that's how search and go-to works :lol:

thanks !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
ticoombs
n00b
n00b


Joined: 27 Dec 2016
Posts: 2

PostPosted: Tue Dec 27, 2016 9:10 am    Post subject: Reply with quote

stqn wrote:
anomaly257 wrote:
Try setting CONFIG_DEBUG_MUTEXES=n in your kernel config and recompiling.

Thanks, worked for me with nvidia-drivers 375.26 and linux 4.4.38.


Confirming working with v375.26 and Kernel 4.4.39
_________________
emerge cpu
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 711

PostPosted: Wed Jan 25, 2017 12:47 pm    Post subject: Reply with quote

ticoombs wrote:
stqn wrote:
anomaly257 wrote:
Try setting CONFIG_DEBUG_MUTEXES=n in your kernel config and recompiling.

Thanks, worked for me with nvidia-drivers 375.26 and linux 4.4.38.


Confirming working with v375.26 and Kernel 4.4.39


Hi,
this tips works for me also
(nv-drivers 375.26 , Kernel 4.4.39)

tnx :)
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
fabien29200
n00b
n00b


Joined: 12 Jun 2006
Posts: 32

PostPosted: Fri May 26, 2017 1:50 pm    Post subject: Reply with quote

anomaly257 wrote:
Try setting CONFIG_DEBUG_MUTEXES=n in your kernel config and recompiling.

Did the job for me !
Kernel : 4.9.16-gentoo and nvidia drivers : 381.22

Thanks !
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 534

PostPosted: Mon Jun 19, 2017 11:44 pm    Post subject: Reply with quote

This happened to me, too, when I decided to be lazy for once and use a generic kernel instead of configuring it for myself. Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum