Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
python_targets blocking updates
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
froosh
n00b
n00b


Joined: 10 Jul 2014
Posts: 23

PostPosted: Tue Sep 06, 2016 7:01 pm    Post subject: python_targets blocking updates Reply with quote

So there are a few package that are failing to update. Here is one of error messages I see:

Code:
emerge -pv media-sound/gnome-music

These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for media-sound/gnome-music
... done!

!!! The ebuild selected to satisfy "media-sound/gnome-music" has unmet requirements.
- media-sound/gnome-music-3.18.2::gentoo USE="" ABI_X86="64" PYTHON_TARGETS="-python3_3 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_targets_python3_3 python_targets_python3_4 python_targets_python3_5 )



But I have python3.3 running. Here is some more info about the python flags on my system:
Code:
eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *
  [3]   python3.4


Code:
grep -r python /etc/portage

/etc/portage/package.use:media-sound/gnome-music python_single_target_python3_3 python_targets_python3_3
/etc/portage/make.conf:PYTHON_TARGETS="python2_7 python3_3"
/etc/portage/make.conf:PYTHON_SINGLE_TARGET="python3_3"


What's curious is that in the PYTHON_TARGETS="-python3_3" there is a minus sign when in make.conf and package.use I have it set to use this version.

I have read that this version is depreciated, but why would it tell me that it's okay to use this version and then reject it?

Any help would be much appreciated!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3189
Location: Germany

PostPosted: Wed Sep 07, 2016 6:47 am    Post subject: Reply with quote

Hi,
dev-lang/python:3.3 is outdated and hard masked.

Suggestion: Remove your
froosh wrote:
Code:
grep -r python /etc/portage

/etc/portage/package.use:media-sound/gnome-music python_single_target_python3_3 python_targets_python3_3
/etc/portage/make.conf:PYTHON_TARGETS="python2_7 python3_3"
/etc/portage/make.conf:PYTHON_SINGLE_TARGET="python3_3"
settings, and set
Code:
eselect python set python3.4

(or python2.7)
And run a
Code:
emerge -avuDN @world
emerge -av --depclean python:3.3
Update
should work.
Back to top
View user's profile Send private message
froosh
n00b
n00b


Joined: 10 Jul 2014
Posts: 23

PostPosted: Wed Sep 07, 2016 7:04 am    Post subject: Reply with quote

Hi thanks for the reply.

I read about python3.3 being masked so I switched versions using eselect python set N (where N points to python3.4) and ran python-updater and nothing really happened.

I removed the python_targets_python3_3 use flags as well per your suggestion.

Now when I try to run a world update I get a massive list of dependency hell. Nearly every python package wants to be rebuilt, for example:
Code:
[ebuild   R    ] dev-python/ipython-3.2.1-r1::gentoo  USE="qt4 smp wxwidgets -doc -examples -matplotlib -mongodb -nbconvert -notebook -octave {-test}" PYTHON_TARGETS="python2_7 python3_4* (-python3_3*) (-python3_5)" 0 KiB

which seems normal, it's now using python3_4.

But then below is something like this:

Code:
dev-python/packaging:0

  (dev-python/packaging-15.3-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/packaging-15.3[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pip-7.1.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    >=dev-python/packaging-15.3-r1[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-18.4:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  (dev-python/packaging-15.3-r2:0/0::gentoo, installed) pulled in by
    >=dev-python/packaging-15.3-r1[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/setuptools-18.4:0/0::gentoo, installed)


for multiple package like dev-python/certif and dev-python/setuptools.

I don't know how to resolve this many dependency errors?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3189
Location: Germany

PostPosted: Wed Sep 07, 2016 7:46 am    Post subject: Reply with quote

Hm, can you please provide the complete output from
Code:
emerge -avuDN @world --backtrack=300
via a pastebin-service?

Edit/
and current output from
Code:
grep -r python /etc/portage/ /etc/make.conf
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Wed Sep 07, 2016 7:53 am    Post subject: Reply with quote

You may set those two config options in your make.conf like I did

Of course you have to choose on which ones you like

Code:
ASUS-G75VW roman # grep PYTHON_TARGETS /etc/make.conf
PYTHON_TARGETS="python2_7 python3_5"
ASUS-G75VW roman # grep PYTHON_SINGLE_TARGET /etc/make.conf
PYTHON_SINGLE_TARGET="python3_5"


You can set those also in your package.use.

I recommend that you go my way like shown above.

You may than also only keep python 2.7 and 3.5 installed and remove the others.

Quote:
any-of ( python_targets_python3_3 python_targets_python3_4 python_targets_python3_5 )


Portage, our package manager, just tells you that you have to choose just one of those python targets. And as the package manger only goes on a package basis, which is called ebuild here, you have to set it al for htose packages separately or on a global basis via make.conf.

--

Just for information. A recent update has shown me an ebuild with active introduced python 3.3 option although its obsolete.

--

Code:
ASUS-G75VW roman # grep python_single_target /etc/portage/package.use
app-text/asciidoc python_single_target_python2_7


This bugger here annoyed me so I had to set it to 2.7 to quiet down my portage. An example on how to set it on a package basis
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3189
Location: Germany

PostPosted: Wed Sep 07, 2016 7:59 am    Post subject: Reply with quote

I think the sane defaults from profile should work on a stable system.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3758
Location: Austro Bavaria

PostPosted: Wed Sep 07, 2016 10:50 am    Post subject: Reply with quote

Just additional info, as it seems the original poster is not that familiar with gentoo linux, same stuff exists with ruby "profiles" "implementations.
Portage could also complain about that in the future. ... Just ask when you want to know about those ruby settings in make.conf

--

@ Josef . I accept your opinion. I think the better approach is to give the users a way to deal with such issues themself. I do not know if those tricks are documented. They were only once shown in the eselect news sections several months back. I do not rely on default settings as these hardly worked here, regardless if it was windows 95, android or any other piece of electronics with a firmware. That plug and play never worked and will never work for all cases
Back to top
View user's profile Send private message
froosh
n00b
n00b


Joined: 10 Jul 2014
Posts: 23

PostPosted: Wed Sep 07, 2016 4:29 pm    Post subject: Reply with quote

Here is the output of the world update with --backtrack=300: https://bpaste.net/show/c7459516638a

For my make.conf

Code:
grep -r python /etc/portage/make.conf
/etc/portage/make.conf:PYTHON_TARGETS="python2_7 python3_4"
/etc/portage/make.conf:PYTHON_SINGLE_TARGET="python3_4"


Specific packages (removing comments like "required by")
Code:
grep -r python /etc/portage
/etc/portage/package_mask.bk:>=dev-python/pytables-3.0.0
/etc/portage/package.accept_keywords:=dev-python/pandas-0.14.0 ~amd64
/etc/portage/package.accept_keywords:=dev-python/sympy-0.7.4.1 ~amd64
/etc/portage/package.accept_keywords:=dev-python/mpmath-0.19 ~amd64
/etc/portage/package.accept_keywords:=dev-python/numexpr-2.4 ~amd64
/etc/portage/package.accept_keywords:=dev-python/spyder-2.3.5.2 ~amd64
/etc/portage/package.accept_keywords:=dev-python/flask-cors-2.1.0 ~amd64
/etc/portage/package.accept_keywords:=dev-python/protobuf-python-3.0.0_beta3_p1 ~amd64
/etc/portage/package.use:=dev-python/numpy-1.8.0-r1 lapack
/etc/portage/package.use:=dev-python/numpy-1.9.0-r1 lapack
/etc/portage/package.use:>=x11-proto/xcb-proto-1.11 abi_x86_32 python_targets_python3_4
/etc/portage/package.use:app-text/asciidoc python_single_target_python2_7
/etc/portage/package.use:>=dev-python/numpy-1.9.2 lapack
/etc/portage/package.use:>=dev-python/PyQt4-4.11.1 webkit
/etc/portage/package.mask:>=dev-python/pytables-3.0.0
/etc/portage/make.conf:PYTHON_TARGETS="python2_7 python3_4"
/etc/portage/make.conf:PYTHON_SINGLE_TARGET="python3_4"
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3189
Location: Germany

PostPosted: Thu Sep 08, 2016 12:10 am    Post subject: Reply with quote

Hm, I think problem is the old installed sci-libs/scipy-0.14.0-r1 version.
from pastebin wrote:
Code:
  (dev-python/numpy-1.10.4:0/0::gentoo, installed) pulled in by
    dev-python/numpy[lapack,python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sci-libs/scipy-0.14.0-r1:0/0::gentoo, installed)

These version is not more available in the main-tree.
Please uninstall this sci-libs/scipy package with
Code:
emerge -av --depclean sci-libs/scipy
or update to a current version.

(Please excuse my bad English)
Back to top
View user's profile Send private message
froosh
n00b
n00b


Joined: 10 Jul 2014
Posts: 23

PostPosted: Thu Sep 08, 2016 1:32 am    Post subject: Reply with quote

Josef.95 wrote:
Hm, I think problem is the old installed sci-libs/scipy-0.14.0-r1 version.
from pastebin wrote:
Code:
  (dev-python/numpy-1.10.4:0/0::gentoo, installed) pulled in by
    dev-python/numpy[lapack,python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (sci-libs/scipy-0.14.0-r1:0/0::gentoo, installed)

These version is not more available in the main-tree.
Please uninstall this sci-libs/scipy package with
Code:
emerge -av --depclean sci-libs/scipy
or update to a current version.

(Please excuse my bad English)


Hi, I actually did this a few hours prior by deleting scipy, matplotlib, and numpy and everything updated. I noticed that I had to install a newer version of scipy as a result though.

Just out of curiosity, how on Earth did you read that and narrow it down to scipy so quickly? What was I missing?

Thank-you for the help though!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3189
Location: Germany

PostPosted: Thu Sep 08, 2016 6:11 pm    Post subject: Reply with quote

Hehe, fine :)

Code:
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.
I think this should help :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum