Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Duplicate] Emerge random downgrade gentoo-sources
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Astronome
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 148

PostPosted: Sun Aug 21, 2016 4:59 pm    Post subject: [Duplicate] Emerge random downgrade gentoo-sources Reply with quote

I added to my package.use:

Code:
media-plugins/gst-plugins-meta mp3


Then went to update my system:

Code:

$ sudo emerge -uDU @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] sys-kernel/gentoo-sources-4.1.15-r1 [4.4.6] USE="-build -experimental -kdbus -symlink"
[ebuild  N     ] media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/gst-plugins-ugly-0.10.19-r1  USE="nls orc" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-plugins/gst-plugins-mad-0.10.19-r1  ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] media-plugins/gst-plugins-meta-0.10-r10  USE="mp3*"


What the... kernel downgrade? Let's try that again:

Code:

$ sudo emerge -uDU @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/gst-plugins-ugly-0.10.19-r1  USE="nls orc" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-plugins/gst-plugins-mad-0.10.19-r1  ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] media-plugins/gst-plugins-meta-0.10-r10  USE="mp3*"


Er, hang on. Why did it want to downgrade the kernel? One more time, just to be sure:

Code:

$ sudo emerge -uDU @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] sys-kernel/gentoo-sources-4.1.15-r1 [4.4.6] USE="-build -experimental -kdbus -symlink"
[ebuild  N     ] media-libs/libmad-0.15.1b-r8  USE="-debug -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/gst-plugins-ugly-0.10.19-r1  USE="nls orc" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-plugins/gst-plugins-mad-0.10.19-r1  ABI_X86="(64) -32 (-x32)"
[ebuild   R    ] media-plugins/gst-plugins-meta-0.10-r10  USE="mp3*"


Wtf is going on?


Last edited by Astronome on Sun Aug 21, 2016 5:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18821
Location: here

PostPosted: Sun Aug 21, 2016 5:02 pm    Post subject: Reply with quote

Read this topic
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Astronome
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 148

PostPosted: Sun Aug 21, 2016 5:14 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Read this topic


Doh, I searched for a duplicate but in the wrong forum.

Thanks!
Back to top
View user's profile Send private message
Chiitoo
Moderator
Moderator


Joined: 28 Feb 2010
Posts: 1507
Location: Here and Away Again

PostPosted: Sun Aug 21, 2016 9:21 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of Why stable downgrade, from kernel-4.4.6 to 4.1.15.

Seems to be about the same issue, which looks like being confirmed in preceding posts.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum