Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How are fonts rendered in the KDE 5 Applications menu?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Tue Aug 09, 2016 10:08 am    Post subject: How are fonts rendered in the KDE 5 Applications menu? Reply with quote

Does anyone know how the fonts in the KDE 5 Plasma Applications Menu are rendered. Which packages are involved?

I am having problems with bad rendering of these fonts (including fonts in e.g. Dolphin and the system clock in the lower right corner of the panel).

See screenshot: http://picpaste.com/bad_fonts-Gx3OVOhi.png
_________________
/Phil
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 249

PostPosted: Tue Aug 09, 2016 1:23 pm    Post subject: Reply with quote

You should emerge plasma-desktop with fontconfig enabled. Then look for the font settings in system settings
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Tue Aug 09, 2016 4:08 pm    Post subject: Reply with quote

I do have kde-plasma/plasma-desktop-5.7.3 with fontconfig set (see below). My problem arose when I changed the Workspace Theme, frrom Breeze to Oxygen and back to Breeze again. Possibly the problem arose when I also changed fonts the first time. Even though my settings are back to KDE 5 Plasma default everywhere, the uggly fonts persist.

I have also tried to create a new user to see if the problem persist. And it does. So the problem seem to be system wide.

Code:
# equery uses plasma-desktop
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for kde-plasma/plasma-desktop-5.7.3:
 U I
 - - debug                   : Enable extra debug codepaths, like asserts and extra output. If you want
                               to get meaningful backtraces see
                               https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 + + fontconfig              : Support for configuring and customizing font access via
                               media-libs/fontconfig
 - - gtk2                    : Add support for gtk+2-based applications using legacy xembed systray icons
                               via libappindicator.
 - - gtk3                    : Add support for gtk+3-based applications using legacy xembed systray icons
                               via libappindicator.
 + + handbook                : Enable handbooks generation for packages by KDE
 - - ibus                    : Use ibus input method via app-i18n/ibus
 + + input_devices_evdev     : INPUT_DEVICES setting to build driver for evdev input devices
 + + input_devices_synaptics : INPUT_DEVICES setting to build driver for synaptics input devices
 - - legacy-systray          : Add support for applications using legacy xembed systray icons.
 - - pulseaudio              : Add support for PulseAudio sound server
 + + qt4                     : Add support for the Qt GUI/Application Toolkit version 4.x
 - - scim                    : Enable applets that use app-i18n/scim
 - - test                    : Workaround to pull in packages needed to run with FEATURES=test.
                               Portage-2.1.2 handles this internally, so don't set it in
                               make.conf/package.use anymore

_________________
/Phil
Back to top
View user's profile Send private message
telle
n00b
n00b


Joined: 18 Aug 2016
Posts: 3

PostPosted: Thu Aug 18, 2016 5:08 am    Post subject: Reply with quote

Could you please to re-upload your screenshot?
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Thu Aug 18, 2016 7:58 am    Post subject: Reply with quote

Here is the screen shot (it stays for a week from 2016-08-18):

http://picpaste.com/bad_fonts-mgDfySUT.png

If you have the same problem there is a way to mitigate the problem.

KDE Application Menu -> Settings -> System Settings -> Fonts -> <check the Force Fonts DPI button> and set it to 120

and

KDE Application Menu -> Settings -> System Settings -> Fonts -> Use Anti-aliasing -> <change this from "System settings to" Enabled">

then proceed from there into the Configure... menu and experiment with RGB etc settings. For me it worked with:
"Exclude range tick box": <Unchecked>
"Subpixel rendering type": <RGB>"
"Hinting style": <Medium>

I think the root cause is still an unsolved problem though. I am not sure if it would be a KDE bug or Gentoo issue. The main problem , in my opinion is that the KDE suite together with Xorg should recognize the type of monitor I have and set the System default settings accordingly.

My screen is high resolution 2560x1440 pixel 14" monitor.

Code:
# xrandr
Screen 0: minimum 8 x 8, current 2560 x 1440, maximum 32767 x 32767                 
eDP1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 310mm x 174mm
   2560x1440     60.00*+                                                           
   1920x1440     60.00                                                             
   1856x1392     60.01                                                             
   1792x1344     60.01                                                             
   1600x1200     60.00                                                             
   1400x1050     59.98                                                             
   1280x1024     60.02                                                             
   1280x960      60.00                                                             
   1024x768      60.00 
   800x600       60.32    56.25 
   640x480       59.94 
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

_________________
/Phil


Last edited by philip on Thu Aug 18, 2016 5:01 pm; edited 2 times in total
Back to top
View user's profile Send private message
telle
n00b
n00b


Joined: 18 Aug 2016
Posts: 3

PostPosted: Thu Aug 18, 2016 10:20 am    Post subject: Reply with quote

Yes, I had the same problem. This morning I found workaround by changing Noto fonts to Liberation fonts in System Settings. After your reply I wanted to check Noto fonts with your antialiasing settings and discovered that after changing fonts (by clicking on Defaults button), Noto fonts were rendered properly.

In my case I think some configs were corrupted by system update and replaced by updating settings manually.

Could you please reset your font settings to defaults again to check my guess?
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Thu Aug 18, 2016 5:10 pm    Post subject: Reply with quote

I am not sure what exactly it is you would like me to test.
If I revert to default settings for everything under Application Launcher -> Settings -> System settings -> Fonts
I just get my problem back again.
_________________
/Phil
Back to top
View user's profile Send private message
telle
n00b
n00b


Joined: 18 Aug 2016
Posts: 3

PostPosted: Fri Aug 19, 2016 3:47 am    Post subject: Reply with quote

Thank you :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum