Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
difficulties to emerge atom editor
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
lowley
n00b
n00b


Joined: 22 Jul 2016
Posts: 47

PostPosted: Wed Aug 03, 2016 11:51 am    Post subject: difficulties to emerge atom editor Reply with quote

hello,

I'm a newbie in using gentoo and I have difficulties to install the atom editor.

I'm using KDE, and here is my last result when typing emerge app-editors/atom:

Code:
[ebuild  N    ~] app-editors/atom-1.8.0

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2h-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2g:0=[-bindist] required by (dev-util/electron-0.36.12-r3:0/36::gentoo, ebuild scheduled for merge)
                                 ^^^^^^^^                                                                                                                         

  (dev-libs/openssl-1.0.2h-r2:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0[bindist=] required by (dev-qt/qtnetwork-5.6.1:5/5.6::gentoo, installed)
                       ^^^^^^^^                                                                                                   
    >=dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.2_p2-r1:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.4:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:=[icu] required by (dev-util/electron-0.36.12-r3:0/36::gentoo, ebuild scheduled for merge)
                       ^^^                                                                                                                         

  (dev-libs/libxml2-2.9.4:2/2::gentoo, installed) pulled in by
    dev-libs/libxml2:2[!icu?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)
                       ^^^^^                                                                                                                                                                                                                                                                 


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-editors/atom (argument)


here is my make.conf:
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=native"
CXXFLAGS="${CFLAGS}"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

# These are the USE and USE_EXPAND flags that were used for
# buidling in addition to what is provided by the profile.
USE="bindist alsa usb -gnome -gtk kde Xy
 wayland -bluetooth cpu_flags_x86_mmxext qt5 sqlite webkit cpu_flags_x86_mmx cpu_flags_x86_mmxext"
CPU_FLAGS_X86="mmx sse sse2"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

GRUB_PLATFORMS="pc"
VIDEO_CARDS="radeon r300"
LINGUAS="fr_FR"
INPUT_DEVICES="evdev synaptics"
L10N="fr"
ACCEPTED_KEYWORDS="~amd64"


and /etc/portage/package.usr/general
Code:
*/* -qt4

media-video/vlc dbug ogg vorbis qt5
app-crypt/qca qt4
media-libs/phonon-vlc qt4
media-libs/phonon qt4
dev-libs/libdbusmenu-qt qt4
dev-util/kdevelop -gdbui
app-editors/atom gtk icu gnome-keyring ssh
dev-libs/openssl -bindist
media-libs/harfbuzz icu
dev-libs/libgit2 ssh
app-crypt/gcr gtk
dev-libs/libxml2 icu
app-crypt/pinentry gnome-keyring
media-video/ffmpeg vpx opus


is it possible to install atom with gtk though my OS is based on kde?
why the "accept_keywords" in make.conf seems to have no effect?
how to resolve these conflicts?

thanks you

olivier

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23494
Location: here

PostPosted: Wed Aug 03, 2016 12:34 pm    Post subject: Reply with quote

You need disable bindist use flag from openssl, openssh, qtnetwork packages and activate icu use flag to libxml2, qtwebkit:4 package.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lowley
n00b
n00b


Joined: 22 Jul 2016
Posts: 47

PostPosted: Wed Aug 03, 2016 2:08 pm    Post subject: Reply with quote

hello, thank you for your answers, I made the changes but here's what I' m getting now:

Code:
[ebuild  N    ~] app-editors/atom-1.8.0

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2h-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2g:0=[-bindist] required by (dev-util/electron-0.36.12-r3:0/36::gentoo, ebuild scheduled for merge)
                                 ^^^^^^^^                                                                                                                         

  (dev-libs/openssl-1.0.2h-r2:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0[bindist=] required by (dev-qt/qtnetwork-5.6.1:5/5.6::gentoo, installed)
                       ^^^^^^^^                                                                                                   
    >=dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.2_p2-r1:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.4:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:=[icu] required by (dev-util/electron-0.36.12-r3:0/36::gentoo, ebuild scheduled for merge)
                       ^^^                                                                                                                         

  (dev-libs/libxml2-2.9.4:2/2::gentoo, installed) pulled in by
    dev-libs/libxml2:2[!icu?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)
                       ^^^^^                                                                                                                                                                                                                                                                 


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-editors/atom (argument)
=app-editors/atom-1.8.0 ~amd64
# required by app-editors/atom-1.8.0::gentoo
# required by app-editors/atom (argument)
=dev-util/electron-0.36.12-r3 ~amd64


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23494
Location: here

PostPosted: Wed Aug 03, 2016 3:00 pm    Post subject: Reply with quote

Before emerging atom try
Code:
# emerge --changed-use -a @world

You should see packages with use flags changed
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lowley
n00b
n00b


Joined: 22 Jul 2016
Posts: 47

PostPosted: Wed Aug 03, 2016 6:44 pm    Post subject: Reply with quote

aaarghh!

it's an awful mess!
plz help me!

if I use "bindisp" I'm asked to remove it, and if I remove it I'm advised to put it!

example :
Code:

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-util/electron-0.36.12-r3::gentoo
# required by app-editors/atom-1.8.0::gentoo
# required by app-editors/atom (argument)
>=dev-libs/openssl-1.0.2h-r2 -bindist
Back to top
View user's profile Send private message
lowley
n00b
n00b


Joined: 22 Jul 2016
Posts: 47

PostPosted: Wed Aug 03, 2016 11:04 pm    Post subject: Reply with quote

well, I read some tutorials but I still can't emerge atom.

for example, when I type the following statement, I get an error:
Code:

USE="cpu_flags_x86_mmxext" emerge -a --newuse --oneshot =dev-libs/libxml2-2.9.4:2 --oneshot =dev-libs/openssl-1.0.2h:0/0::gentoo dev-qt/qtwebkit dev-util/electron

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.4:2/2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2:=[icu] required by (dev-util/electron-0.36.12-r3:0/36::gentoo, ebuild scheduled for merge)
                       ^^^                                                                                                                         
    =dev-libs/libxml2-2.9.4:2 (Argument)

  (dev-libs/libxml2-2.9.4:2/2::gentoo, installed) pulled in by
    dev-libs/libxml2:2[!icu?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)


the flag [icu] needs icu, it's ...simple
the flag [!icu?], if I understood, means that if icu is set, dev-libs/libxml2:2 will be emerged, without any change coming from icu... it does not add or remove any functionality to libsml2.
so both cases should work when icu is set...

next, here is my package.use:

Code:
gentoo:~ 00:52:03 $ cat /etc/portage/package.use/general
*/* -qt4

media-video/vlc dbug ogg vorbis qt5
app-crypt/qca qt4
media-libs/phonon-vlc qt4
media-libs/phonon qt4
dev-libs/libdbusmenu-qt qt4
dev-util/kdevelop -gdbui
app-editors/atom gtk icu gnome-keyring ssh
media-libs/harfbuzz icu
dev-libs/libgit2 ssh
app-crypt/gcr gtk
dev-libs/libxml2 icu
app-crypt/pinentry gnome-keyring
media-video/ffmpeg vpx opus
net-misc/openssh -bindist
dev-qt/qtnetwork -bindist
dev-qt/qtwebkit icu
media-video/ffmpeg opus vorbis vpx
dev-libs/openssl -bindist
dev-util/electron cpu_flags_x86_mmxext


you can see that libxml2 has got the icu flag...

where is my error?

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23494
Location: here

PostPosted: Thu Aug 04, 2016 6:38 am    Post subject: Reply with quote

Try
Code:
# USE="cpu_flags_x86_mmxext" emerge -a --newuse --oneshot =dev-libs/libxml2-2.9.4:2 =dev-libs/openssl-1.0.2h:0/0::gentoo dev-qt/qtwebkit:4 dev-util/electron

Is qtwebkit:4 that need icu flag. If you have installed also qtwebkit:5 with 'emerge dev-qt/qtwebkit' portage try to reinstall version 5.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lowley
n00b
n00b


Joined: 22 Jul 2016
Posts: 47

PostPosted: Thu Aug 04, 2016 12:09 pm    Post subject: Reply with quote

ok, I begin to understand.
I managed to launch the emerge statement, but the compilation of electron needs at least 3Gb of RAM, but for the moment my computer has not got that.

thank you!

NB : what does mean the 4 in dev-qt/qtwebkit:4 ?
the long name is dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo

I know that
dev-qt is the group
qtwebkit is the short name of the package
3.8.1 is the version
::gentoo is the repository

what are r1 (release?4.8.6 does not suffice?) and :4/4?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23494
Location: here

PostPosted: Thu Aug 04, 2016 12:36 pm    Post subject: Reply with quote

lowley wrote:
what are r1 (release?4.8.6 does not suffice?) and :4/4?

-rX is ebuild revision
:4/4 is slot and sub-slot number
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23494
Location: here

PostPosted: Thu Aug 04, 2016 1:05 pm    Post subject: Reply with quote

lowley wrote:
but the compilation of electron needs at least 3Gb of RAM, but for the moment my computer has not got that.

You can create a temporary swap file for make up lack of ram :
Code:
# dd if=/dev/zero of=swapfile.swp bs=1024 count=1M

this code create 1024x1M=1G swap size
Code:
# mkswap swapfile.swp
# swapon swapfile.swp
# emerge <something>

when emerge finish
Code:
# swapoff swapfile.swp
# rm swapfile.swp

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lowley
n00b
n00b


Joined: 22 Jul 2016
Posts: 47

PostPosted: Thu Aug 04, 2016 1:51 pm    Post subject: Reply with quote

I tried but strangely it does not work.
It seems emerge needs 3Gb of "real" RAM.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14949

PostPosted: Fri Aug 05, 2016 1:44 am    Post subject: Reply with quote

Whenever you get an error with which you need assistance, you should post the exact error output. If I were to guess based on the paraphrase you provided, you are being blocked by check-reqs.eclass. It looks at MemTotal, which excludes swap. You can override this with $I_KNOW_WHAT_I_AM_DOING, but this check was likely put there for good reason. If your RAM is substantially less than the requirement specified, you will likely experience considerable swapping during the build. This will make the build very slow. Perhaps you should find an editor that is more lightweight, such as Vim or Emacs.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum