Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE Plasma Clock widget does not show date
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Sun Jul 24, 2016 5:40 pm    Post subject: KDE Plasma Clock widget does not show date Reply with quote

Hello,

Since a couple of weeks I run KDE Plasma 5.5.5 and Qt-version 5.5.1 on a 4.4.6 kernel.

After this upgrade everything looks alright, except my standard clock widget does not show a date (when selected in the setting menu) anymore.

Between selecting and deselecting, the size of the clock numbers changes. When the date is selected, the numbers are small and a empty space below the clock appears.

So, there is room to print something :D .

Does anyone have an idea?

Regards,

GenHeDi
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 204
Location: Bavaria

PostPosted: Tue Jul 26, 2016 5:43 am    Post subject: Reply with quote

Did you try to change clock style settings like font (maybe also bold or italic) or date format?
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3707
Location: Hamburg

PostPosted: Tue Jul 26, 2016 7:44 am    Post subject: Reply with quote

Similar for analog clock - displaying the time zone let the clock itself vanish.
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Sat Jul 30, 2016 11:38 am    Post subject: Reply with quote

I did try several other fonts and used bold and/or italic.

No luck so far.

On another machine I use Kubuntu 16.04 LTS, clock and date are shown here without problem.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Sat Jul 30, 2016 11:42 am    Post subject: Reply with quote

By the way, I had following upgrade today:

KDE Plasma 5.6.5 KDE-Frameworks 5.23.0 and Qt-version 5.6.1 on a 4.4.6 kernel OS-type 64 bit.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Sat Aug 06, 2016 10:13 am    Post subject: Reply with quote

Unfortunately no improvement so far.

Still same issue.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sat Aug 06, 2016 10:42 am    Post subject: Reply with quote

I would like to help you but I can't reproduce the behavior at all. You have tried to change the size of your panel already, did you?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 533
Location: Venice FL

PostPosted: Sat Aug 06, 2016 8:03 pm    Post subject: Reply with quote

I had that problem after an upgrade a month or two ago, found out the the time zone data was corrupted.

Had to delete /etc/localtime and reemerge timezone-data and setup my time zone again.

YMMV

George
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Sun Aug 21, 2016 4:28 pm    Post subject: Reply with quote

@genstorm: I changed the size of the panel but no improvement.

@thumper: I followed your tip and re-emerged timezone-data and did a "emerge --config timezone-data"

When I "cat /etc/localtime", I see a lot of unreadable stuff.

At the end, also no improvement.

Can someone explain to me how to attach a picture to this post, so you can see how my clock looks like?
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 533
Location: Venice FL

PostPosted: Sun Aug 21, 2016 9:44 pm    Post subject: Reply with quote

GenHeDi wrote:
@genstorm: I changed the size of the panel but no improvement.

@thumper: I followed your tip and re-emerged timezone-data and did a "emerge --config timezone-data"

When I "cat /etc/localtime", I see a lot of unreadable stuff.

At the end, also no improvement.

Can someone explain to me how to attach a picture to this post, so you can see how my clock looks like?


Use
Code:
zdump -v /etc/localtime
to see the contents.

George
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Mon Aug 22, 2016 7:00 pm    Post subject: Reply with quote

George:

I did a
Code:
zdump -v /etc/localtime


It is a lot of info, it contains 2212 lines, I will put a couple of the beginning lines:

Code:
/etc/localtime  -9223372036854775808 = NULL
/etc/localtime  -9223372036854689408 = NULL
/etc/localtime  Wed Dec 31 23:40:27 1834 UT = Wed Dec 31 23:59:59 1834 LMT isdst=0 gmtoff=1172
/etc/localtime  Wed Dec 31 23:40:28 1834 UT = Thu Jan  1 00:00:00 1835 AMT isdst=0 gmtoff=1172
/etc/localtime  Sun Apr 30 23:40:27 1916 UT = Sun Apr 30 23:59:59 1916 AMT isdst=0 gmtoff=1172
/etc/localtime  Sun Apr 30 23:40:28 1916 UT = Mon May  1 01:00:00 1916 NST isdst=1 gmtoff=4772
/etc/localtime  Sat Sep 30 22:40:27 1916 UT = Sat Sep 30 23:59:59 1916 NST isdst=1 gmtoff=4772
/etc/localtime  Sat Sep 30 22:40:28 1916 UT = Sat Sep 30 23:00:00 1916 AMT isdst=0 gmtoff=1172
/etc/localtime  Mon Apr 16 01:40:27 1917 UT = Mon Apr 16 01:59:59 1917 AMT isdst=0 gmtoff=1172
/etc/localtime  Mon Apr 16 01:40:28 1917 UT = Mon Apr 16 03:00:00 1917 NST isdst=1 gmtoff=4772


and a couple of the end lines:
Code:
/etc/localtime  Sun Mar 30 01:00:00 2498 UT = Sun Mar 30 03:00:00 2498 CEST isdst=1 gmtoff=7200
/etc/localtime  Sun Oct 26 00:59:59 2498 UT = Sun Oct 26 02:59:59 2498 CEST isdst=1 gmtoff=7200
/etc/localtime  Sun Oct 26 01:00:00 2498 UT = Sun Oct 26 02:00:00 2498 CET isdst=0 gmtoff=3600
/etc/localtime  Sun Mar 29 00:59:59 2499 UT = Sun Mar 29 01:59:59 2499 CET isdst=0 gmtoff=3600
/etc/localtime  Sun Mar 29 01:00:00 2499 UT = Sun Mar 29 03:00:00 2499 CEST isdst=1 gmtoff=7200
/etc/localtime  Sun Oct 25 00:59:59 2499 UT = Sun Oct 25 02:59:59 2499 CEST isdst=1 gmtoff=7200
/etc/localtime  Sun Oct 25 01:00:00 2499 UT = Sun Oct 25 02:00:00 2499 CET isdst=0 gmtoff=3600
/etc/localtime  9223372036854689407 = NULL
/etc/localtime  9223372036854775807 = NULL

_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Thu Aug 25, 2016 4:00 am    Post subject: Reply with quote

I wonder if this is a locale problem. What does 'echo $LANG' return on your system? Have you tried setting a different locale as a test to see if the date appears then?

Apparently KDE 4 used its own locale code, while Plasma (KDE) 5 depends on the Qt locale code, which various bug reports indicate has a number of issues and limitations.
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Thu Aug 25, 2016 5:55 pm    Post subject: Reply with quote

radio_flyer:

Quote:
echo $LANG
results into
Code:
nl_NL.iso885915@euro


Setting a different locale I have to try.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Thu Aug 25, 2016 6:11 pm    Post subject: Reply with quote

radio_flyer:

There is something strange going on:

When I start my computer and login in the commandline (so no X11 or KDE active)

echo $LANG shows nl_NL.iso8859-15@euro

after starting X11 and KDE (startx)

I open xterm and then echo $LANG shows nl_NL.US-ASCII 8O

when I do
Code:
source /etc/profile


then echo $LANG shows nl_NL.iso8859-15@euro again 8O

I'm a little confused now.

Is it ment to work this way?
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Thu Aug 25, 2016 9:58 pm    Post subject: Reply with quote

Unfortunately I'm not a locale expert. I have the basic U.S. English setup:

Code:

~ $ locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE=C
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=


However, I get the same results both on the command line in a VT and in a KDE Konsole window. The fact that you get different results might be because you and/or KDE have set up a slightly different locale environment than the one set up in the base system (ie 'Applications-->Settings-->System Settings-->Regional Settings' is different from what 'eselect locale' provides.)

I would try using 'eselect locale' to switch back to a basic C or POSIX locale and set up KDE to match. If you now get a date field showing in the KDE (oops...Plasma) clock, then your issue is probably either a misconfiguration of the locale in KDE or a bug in the Qt libraries for your specific locale. If it is a configuration issue, perhaps this https://wiki.gentoo.org/wiki/Localization/Guide will help.
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Mon Aug 29, 2016 6:34 pm    Post subject: Reply with quote

radio_flyer:

Thanks, I will give it a try during this week.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Fri Sep 02, 2016 4:48 pm    Post subject: Reply with quote

radio_flyer:

I went to C by using eselect. After that I put KDE/Plasma also to C. After a reboot, still no date in mij digital clock.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 260
Location: Northern California

PostPosted: Fri Sep 02, 2016 6:24 pm    Post subject: Reply with quote

Strange. I have no idea then what could be causing that problem on your system. My plasma clock at this moment shows the time and date just fine:

11:21AM
2016-09-02

This may be a question you'll have to take to the KDE forum: http://forum.kde.org
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 533
Location: Venice FL

PostPosted: Fri Sep 02, 2016 8:24 pm    Post subject: Reply with quote

Out of curiosity I rummaged around the config files looking for clues, found a file that contains a property listed as showDate, should not hurt to look into it, could get lucky.
Code:
$  cat ~/.config/plasma-org.kde.plasma.desktop-appletsrc | grep showDate


Mine revealed two entries:
Code:
showDate=true
showDate=true


You could edit the file if it shows otherwise, or back it up and delete it, but you would probably have to re setup what ever it actually relates to.

Best of luck.

George
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Sat Sep 10, 2016 6:42 pm    Post subject: Reply with quote

Hello thumper,

I had a look around. The file you mentioned is present, although a slightly different name:

Code:
cat plasma-org.kde.plasma.desktop-appletsrc | grep showDate
showDate=true


I copied the section with the showDate:
Code:
[Containments][1][Applets][6][Configuration][Appearance]
dateFormat=isoDate
lastSelectedTimezone=Europe/Amsterdam
selectedTimeZones=Europe/Amsterdam
showDate=true
showWeekNumbers=true
use24hFormat=2


Today, during a emerge update, I noticed that emerge is complaining about an unsupported locale setting

Code:
emerge -avuDN @world
setlocale: unsupported locale setting
setlocale: unsupported locale setting

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

Nothing to merge; quitting.


For clarity, this emerge is carried out after a complete update. Therefore, there are no updates :D

Unfortunately I can not confirm since when this message occurs.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 533
Location: Venice FL

PostPosted: Sat Sep 10, 2016 9:20 pm    Post subject: Reply with quote

have you edited /etc/locale.gen

and run locale-get to generate your locales?

and in /etc/portage/make.conf there is apparently two variables to set, my make.conf contains:
Code:
LINGUAS="en en_US"
L10N="en en_US"


George
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Fri Sep 16, 2016 6:38 pm    Post subject: Reply with quote

Hello thumper,

Yes I edited /etc/locale.gen (added last two lines ):
Code:
#en_US ISO-8859-1
#en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15
#es_MX ISO-8859-1
#fa_IR UTF-8
#fr_FR ISO-8859-1
#fr_FR@euro ISO-8859-15
#it_IT ISO-8859-1
nl_NL@euro ISO-8859-15
nl_NL UTF-8


I did run locale-gen

My /etc/portage/make.conf contains:
Code:
LINGUAS="nl"
L10N="nl"


The remark during emerge still apears.
_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 533
Location: Venice FL

PostPosted: Fri Sep 16, 2016 7:03 pm    Post subject: Reply with quote

I could be wrong, but I think that in your case
Code:
nl_NL

should be in the make.conf also.

George
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1753
Location: United Kingdom

PostPosted: Fri Sep 16, 2016 7:05 pm    Post subject: Reply with quote

GenHeDi wrote:
Hello thumper,

Yes I edited /etc/locale.gen (added last two lines ):
Code:
#en_US ISO-8859-1
#en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15
#es_MX ISO-8859-1
#fa_IR UTF-8
#fr_FR ISO-8859-1
#fr_FR@euro ISO-8859-15
#it_IT ISO-8859-1
nl_NL@euro ISO-8859-15
nl_NL UTF-8


I did run locale-gen

My /etc/portage/make.conf contains:
Code:
LINGUAS="nl"
L10N="nl"


The remark during emerge still apears.


Notice the contents of /usr/share/i18n/SUPPORTED are as follows:

Code:
clevow230ss fitzcarraldo # grep -i nl /usr/share/i18n/SUPPORTED
fy_NL UTF-8
li_NL UTF-8
nds_NL UTF-8
nl_AW UTF-8
nl_BE.UTF-8 UTF-8
nl_BE ISO-8859-1
nl_BE@euro ISO-8859-15
nl_NL.UTF-8 UTF-8
nl_NL ISO-8859-1
nl_NL@euro ISO-8859-15


I notice that you currently have the following:

Code:
nl_NL@euro ISO-8859-15
nl_NL UTF-8

i.e. you are missing the second "UTF-8". So edit /etc/locale.gen to contain the following, then re-run locale-gen:

Code:
nl_NL@euro ISO-8859-15
nl_NL.UTF-8 UTF-8

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
GenHeDi
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 129

PostPosted: Fri Sep 23, 2016 6:54 pm    Post subject: Reply with quote

Hello Fitzcarraldo

in my case:
Code:
grep -i nl /usr/share/i18n/SUPPORTED
fy_NL UTF-8
li_NL UTF-8
nds_NL UTF-8
nl_AW UTF-8
nl_BE.UTF-8 UTF-8
nl_BE ISO-8859-1
nl_BE@euro ISO-8859-15
nl_NL.UTF-8 UTF-8
nl_NL ISO-8859-1
nl_NL@euro ISO-8859-15


I modified /etc/locale.gen to:
Code:
#en_US ISO-8859-1
#en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15
#es_MX ISO-8859-1
#fa_IR UTF-8
#fr_FR ISO-8859-1
#fr_FR@euro ISO-8859-15
#it_IT ISO-8859-1
nl_NL@euro ISO-8859-15
nl_NL.UTF-8 UTF-8


Then I re-run locale-gen and after that I did a restart of the compute.

unfortunately the error still exists:

Code:
emerge -avuDN @world
setlocale: unsupported locale setting
setlocale: unsupported locale setting

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

Nothing to merge; quitting.

_________________
Nulla tenaci invia est via
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum