Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Invisible Sliders, Fields, and Widget in Firefox and others
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Sat Jul 23, 2016 1:26 pm    Post subject: Invisible Sliders, Fields, and Widget in Firefox and others Reply with quote

Somewhere along the line, many of my scrolling sliders and widgets have turned invisible.

I'm running KDE Plasma on an ~AMD64 system.

Now I can't see the scroll sliders in Firefox, and other field borders are invisible. They are actually there and work, but are invisible. This means I can use the mouse to scroll, but I can't see where the slider is.

This does not effect all applications, but it does effect a lot of major ones. For example, Firefox and EasyTag. I've also tried to install firefox-bin, and it gives the same effect.

Dolphin, LibreOffice, and KDE applications work fine.

Anybody have any ideas?
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6880
Location: Austria

PostPosted: Sat Jul 23, 2016 1:57 pm    Post subject: Reply with quote

Did you recently upgrade to gtk+-3.20?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Sat Jul 23, 2016 2:07 pm    Post subject: Reply with quote

Yes. I have GTK+ 3.2.

GTK3 USE flag is NOT set, but I see that it is the default for gtk apps under plasma.
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6880
Location: Austria

PostPosted: Sat Jul 23, 2016 2:11 pm    Post subject: Reply with quote

GTK+ 3.20 is known to break themes.

Plasma does not set any default, your gtk+ based applications decide over being gtk+2 or 3 based.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic


Last edited by asturm on Sat Jul 23, 2016 4:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tyler_Durden
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 189
Location: Germany

PostPosted: Sat Jul 23, 2016 3:40 pm    Post subject: Re: Invisible Sliders, Fields, and Widget in Firefox and oth Reply with quote

Vorlon wrote:
Anybody have any ideas?

just try https://github.com/dirruk1/gnome-breeze

It's working fine with gtk-3.20 and gtk2/3 -apps.
_________________
Gentoo 17.1 x86_64
Intel Core i7-6700K
Asus MAXIMUS VIII HERO
Asus Geforce GTX1080 Ti
Asus STRIX RAID DLX
32GB DDR4
Samsung SSD SM951-NVMe 256GB
8x Seagate Archive (SATA-RAID 64TB)
Digital Devices Cine S2 V6.5 DVB Adapter
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Sat Jul 23, 2016 4:22 pm    Post subject: Reply with quote

Tyler, thanks for your suggestion. I've tried it, but I am probably doing something wrong.

I downloaded the gtk.css file from github and put it in /usr/share/themes/Breeze/gtk-3.0. Then I selected Breeze theme from KDE system settings, adn restarted Firefox. No change. I also tried creating /usr/share/themes/Breeze/gtk-3.2 and putting the file ther, but no good.

Where id you put the gtk.css file to make it active?
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
Tyler_Durden
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 189
Location: Germany

PostPosted: Sat Jul 23, 2016 5:19 pm    Post subject: Reply with quote

Vorlon wrote:
Tyler, thanks for your suggestion. I've tried it, but I am probably doing something wrong.

I downloaded the gtk.css file from github and put it in /usr/share/themes/Breeze/gtk-3.0. Then I selected Breeze theme from KDE system settings, adn restarted Firefox. No change. I also tried creating /usr/share/themes/Breeze/gtk-3.2 and putting the file ther, but no good.

Where id you put the gtk.css file to make it active?


Too complicated ;-) As the Install instructions told you, just copy the folders "Breeze-gtk" & "Breeze-dark-gtk" in ~/.themes and you'll find new entries with the same name in the plasma settings.
_________________
Gentoo 17.1 x86_64
Intel Core i7-6700K
Asus MAXIMUS VIII HERO
Asus Geforce GTX1080 Ti
Asus STRIX RAID DLX
32GB DDR4
Samsung SSD SM951-NVMe 256GB
8x Seagate Archive (SATA-RAID 64TB)
Digital Devices Cine S2 V6.5 DVB Adapter
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Sat Jul 23, 2016 5:53 pm    Post subject: Reply with quote

Doh! <sheepishly>I didn't even notice the stoopid instructions (sigh)</sheepish>

OK, I installed the themes, and can change them, but the scroll bar slider is still invisible.

I must have something else screwed up, firefox is goofy. (I've read some traffic on the internet that applications have to be modified to use gtk3+)


Thanks for your help!
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6880
Location: Austria

PostPosted: Sat Jul 23, 2016 5:59 pm    Post subject: Reply with quote

Vorlon wrote:
(I've read some traffic on the internet that applications have to be modified to use gtk3+)

For sure there's a lot of code changes involved. Nothing you can do playing around with themes. Do note though that you can switch it in Firefox by use flags.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4404

PostPosted: Sun Jul 24, 2016 3:02 am    Post subject: Reply with quote

Here is a patch to fix the issue:
https://bugs.gentoo.org/show_bug.cgi?id=578326#c17
You can apply it via user-patches. That requires www-client/firefox - it won't work with www-client/firefox-bin.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum