Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Staying with KDE-4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sat May 14, 2016 3:31 pm    Post subject: Reply with quote

BobWya wrote:
..a DE with an interface that's unstable is really quite a significant problem.

Bingo.
Back to top
View user's profile Send private message
gentooP4
Apprentice
Apprentice


Joined: 20 Sep 2010
Posts: 182
Location: NZ

PostPosted: Sat May 14, 2016 11:57 pm    Post subject: Re: Staying with KDE-4 Reply with quote

steveL wrote:

From toralf:
Code:
$ grep qt[45] /etc/portage/package.use/z_misc
app-text/poppler    qt4
app-office/akonadi-server  qt4 -qt5
media-video/smplayer    qt4 -qt5
media-video/vlc                         qt4 -qt5
net-analyzer/wireshark        -qt5
net-print/hplip                                                         qt4
net-wireless/wpa_supplicant   -qt4


I've added the following to the above list:
media-libs/phonon qt4 -qt5
media-libs/phonon-vlc qt4 -qt5
dev-libs/libdbusmenu qt4 -qt5
sys-auth/polkit-qt qt4 -qt5

but for whatever reason they still want in:
Code:
Calculating dependencies... done!
.....

[ebuild   R    ] dev-libs/libdbusmenu-qt-0.9.3_pre20140619-r1  USE="qt5*"
[ebuild   R    ] media-libs/phonon-4.7.2  USE="qt5*"
[ebuild   R    ] media-libs/phonon-vlc-0.7.2  USE="qt5*"
[ebuild   R    ] sys-auth/polkit-qt-0.112.0-r1  USE="qt5*"


I really like my KDE4 setup and don't plan on changing DE's in the foreseeable future.
_________________
The United States has announced that it will deploy thoughts and prayers in the battle against online extremism.

If you voted for Trump or Brexit, you were likely influenced by the Cambridge Analytica propaganda machine.
Back to top
View user's profile Send private message
BobWya
Apprentice
Apprentice


Joined: 12 Aug 2012
Posts: 228
Location: Cambridge,UK

PostPosted: Sun May 15, 2016 12:15 am    Post subject: Re: Staying with KDE-4 Reply with quote

gentooP4 wrote:
I really like my KDE4 setup and don't plan on changing DE's in the foreseeable future.


Keep up the good fight against Qt5. Get it out of here!! 8)

Sits watching random black blobs appearing randomly on his desktop (well not this minute actually - small mercies)... 8O
Hopefully my desktop will be stable again - in say 2020... :roll:
_________________
system: G751JT (ASUS-NotebookSKU); processor: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz; memory: 32GiB System Memory; display: GM204M [GeForce GTX 970M]; disk: 2048GB Samsung SSD 850;BD-CMB UJ172 S;1024GB Samsung SSD 850
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Sun May 15, 2016 7:48 am    Post subject: Re: Staying with KDE-4 Reply with quote

gentooP4 wrote:
I've added the following to the above list: ...

There are new package versions incoming with qt5 use flag probably each --sync, so it might be easier to set this globally.

Did you add steveL's slot 5 masks from the OP? If yes, there still remain version bumps of misc packages (not within kde-* categories) that can hard-depend on kf5/qt5. Usually that dependency will be listed right afterwards the scheduled USE changes, if not, you'll need to find out what is pulling those in e.g. using --exclude.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
gentooP4
Apprentice
Apprentice


Joined: 20 Sep 2010
Posts: 182
Location: NZ

PostPosted: Mon May 16, 2016 6:33 am    Post subject: Re: Staying with KDE-4 Reply with quote

genstorm wrote:
gentooP4 wrote:
I've added the following to the above list: ...

There are new package versions incoming with qt5 use flag probably each --sync, so it might be easier to set this globally.


It's set globally, just not being honoured globally or locally it seems.

genstorm wrote:
.....If yes, there still remain version bumps of misc packages (not within kde-* categories) that can hard-depend on kf5/qt5. Usually that dependency will be listed right afterwards the scheduled USE changes, if not, you'll need to find out what is pulling those in e.g. using --exclude.


Okay, adding sys-block/partitionmanager to package.mask solved this for me.

Thanks genstorm.
_________________
The United States has announced that it will deploy thoughts and prayers in the battle against online extremism.

If you voted for Trump or Brexit, you were likely influenced by the Cambridge Analytica propaganda machine.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Tue May 24, 2016 1:56 pm    Post subject: Reply with quote

Beware of upcoming changes :)

For ~arch users: >=kde4-l10n-16.04.1 switched to USE=+minimal by default which means it pulls in kde-l10n:5 to provide complete translations.
Solution for KDE4-only: set it to -minimal in package.use

For amd64 users: KDE Applications 15.12.3 stabilisation is imminent, and this time it is the real deal including slot 5 packages (but excluding not-ready-yet kdepim:5), so if you haven't masked slot 5 before as shown in the OP, you'll have to do it with next sync.

Also, some slot 4 packages have already been masked for removal from Portage and moved to kde-sunset, which was recently revived to account for the in-tree pkgmoves that have taken place.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jonfr
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1006
Location: Iceland

PostPosted: Tue May 24, 2016 4:39 pm    Post subject: Reply with quote

I just gave up on KDE 5. It was unstable and for no reason it started crashing random parts of it. I'm moving to latest version of KDE 4 in portage. While KDE 4 does have it's bugs and is far from perfect, it runs far better than KDE 5 at the moment.
Back to top
View user's profile Send private message
tholin
Apprentice
Apprentice


Joined: 04 Oct 2008
Posts: 173

PostPosted: Wed May 25, 2016 10:23 am    Post subject: Reply with quote

Where is the new kde-sunset hosted? Can't find it in layman. Are there any properly written guide for how to use it?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Wed May 25, 2016 12:24 pm    Post subject: Reply with quote

No guide that i know of, it is unsupported after all.

tholin wrote:
Where is the new kde-sunset hosted? Can't find it in layman.

It was removed due to permanent absence of any maintainer. It is still where it has (afaik) always been, if you use layman to organise overlays I am sure there's a howto in layman wiki on how to manually add one.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Fri May 27, 2016 12:11 am    Post subject: Reply with quote

genstorm wrote:
Beware of upcoming changes :)

Thanks for the heads-up.

edit:
genstorm wrote:
Also, some slot 4 packages have already been masked for removal from Portage and moved to kde-sunset, which was recently revived to account for the in-tree pkgmoves that have taken place.

This is a terrible idea. I'll see what #gentoo-desktop are smoking this week.. ;)
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 202
Location: Bavaria

PostPosted: Fri May 27, 2016 9:08 am    Post subject: Reply with quote

For the moment I also try to stay at KDE4 (however I am testing KDE5, but I cannot put it on my family's computers because it is not as stable yet).
After todays sync I get some blocks that I do not understand.

It looks like for example dolphin and konsole (and some others) got slotted for KDE4 and KDE5:
Code:

[ebuild  NS    ] kde-apps/dolphin-15.12.3-r1:5::gentoo [4.14.3-r1:4/4.14::gentoo] USE="handbook semantic-desktop -debug {-test} -thumbnail" 644 KiB
[ebuild  NS    ] kde-apps/konsole-15.12.3:5::gentoo [4.14.3-r2:4/4.14::gentoo] USE="X handbook -debug {-test}" 449 KiB


So far so good. But the different slotted versions may not be installed at the same time:
Code:

[blocks B      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.12.3-r1)
[blocks B      ] kde-apps/konsole:4 ("kde-apps/konsole:4" is blocking kde-apps/konsole-15.12.3)


The KDE4 versions are pulled in by kdebase-meta, wha the KDE5 versions are pulled in by update world:
Code:

  (kde-apps/konsole-4.14.3-r2:4/4.14::gentoo, installed) pulled in by
    >=kde-apps/konsole-4.14.3:4[aqua=] (>=kde-apps/konsole-4.14.3:4[-aqua]) required by (kde-apps/kdebase-meta-4.14.3-r2:4/4::gentoo, installed)
  (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed) pulled in by
    >=kde-apps/dolphin-4.14.3:4[aqua=] (>=kde-apps/dolphin-4.14.3:4[-aqua]) required by (kde-apps/kdebase-meta-4.14.3-r2:4/4::gentoo, installed)


Similar blockers exist for gwenview, baloo-widgets, kde4-l10n, libkipi.

Does anybody know what is causing this and how I can get around this?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Fri May 27, 2016 3:35 pm    Post subject: Reply with quote

If that happens on your systems that shall stay on KDE4, then that's exactly what I was talking about, two posts above - you need to mask slot 5. However the blocks don't make sense as portage should be perfectly able to auto-resolve it, unless you have other things in the output below that themselves depend on dolphin:4, such as dolphin-plugins:4, in your world file.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
tomtom69
Apprentice
Apprentice


Joined: 09 Nov 2010
Posts: 202
Location: Bavaria

PostPosted: Sat May 28, 2016 8:56 am    Post subject: Reply with quote

Oh, I was thinking this was just for people that do not want to get the updated apps.
Thank you for pointing this out, genstorm :-)
Back to top
View user's profile Send private message
elmar283
Apprentice
Apprentice


Joined: 06 Dec 2004
Posts: 299
Location: Haarlem, Netherlands

PostPosted: Sun Jun 05, 2016 2:13 pm    Post subject: Reply with quote

For me this worked to make shure plasma en framework does not sneek in:
Code:

elmar@Minidlna_server /etc/init.d $ cat /etc/portage/package.mask/kde4
>=kde-frameworks/kauth-5
>=kde-frameworks/kconfigwidgets-5
>=kde-frameworks/kiconthemes-5
>=kde-plasma/polkit-kde-agent-5
Back to top
View user's profile Send private message
jjtp
n00b
n00b


Joined: 10 Jun 2016
Posts: 7

PostPosted: Fri Jun 10, 2016 11:46 am    Post subject: Reply with quote

Hi people.

Today an upgrade with the usual masks on the first post triggered a upgrade of lots of kde-frameworks packages. It seems to be because I have yakuake installed and it got updated. Masking
Code:
kde-misc/*:5
was enough for me to stop it.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1703
Location: United Kingdom

PostPosted: Mon Jun 13, 2016 4:15 pm    Post subject: Reply with quote

jjtp wrote:
Hi people.

Today an upgrade with the usual masks on the first post triggered a upgrade of lots of kde-frameworks packages. It seems to be because I have yakuake installed and it got updated. Masking
Code:
kde-misc/*:5
was enough for me to stop it.

Thanks for the 'heads up'. Added it to the list:

Code:
fitzcarraldo@clevow230ss ~ $ cat /etc/portage/package.mask/kde
kde-plasma/*
kde-frameworks/*:5
kde-apps/*:5
kde-misc/*:5

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
sidamos
Apprentice
Apprentice


Joined: 16 Dec 2007
Posts: 210

PostPosted: Sat Jun 25, 2016 10:04 am    Post subject: Reply with quote

Had to mask this today, to avoid conflicts:
Code:

>=media-video/kaffeine-2
>=kde-plasma/polkit-kde-agent-5


This is getting cumbersome. I have profile set to kde, so that should be in the profile probably.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Mon Jun 27, 2016 6:29 am    Post subject: Reply with quote

First and foremost, kde profile is for using Plasma-4 workspace. It is not meant to prevent updates to applications.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
sidamos
Apprentice
Apprentice


Joined: 16 Dec 2007
Posts: 210

PostPosted: Mon Jun 27, 2016 5:18 pm    Post subject: Reply with quote

Sorry, I did not realize that.
Back to top
View user's profile Send private message
augustin
Guru
Guru


Joined: 23 Feb 2015
Posts: 318

PostPosted: Wed Jun 29, 2016 11:37 pm    Post subject: Reply with quote

SteveL,
Since this thread seem to be the main thread where information about sticking to KDE4 is centralised, can you edit you first post:

/etc/portage/ $ cat package.mask/kde
Code:
kde-plasma/*
kde-frameworks/*:5
kde-apps/*:5
kde-misc/*:5


Simply add a ":5" to kde-frameworks, as per:

https://forums.gentoo.org/viewtopic-p-7907416.html#790
Fitzcarraldo wrote:
There are some KDE 4 packages in the frameworks category, so I masked as shown below, because I wanted to install thunderbird-45.0_beta3 from the mozilla overlay, and that requires kde-frameworks/oxygen-icons-4.14.3:

Code:
fitzcarraldo@clevow230ss ~ $ cat /etc/portage/package.mask/kde
kde-plasma/*
kde-frameworks/*:5
kde-apps/*:5


I stumbled upon this problem, too:

Code:
!!! The following installed packages are masked:
- kde-frameworks/oxygen-icons-4.14.3::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

$ emerge -pv --depclean kde-frameworks/oxygen-icons

Calculating dependencies... done!
  kde-frameworks/oxygen-icons-4.14.3 pulled in by:
    app-office/kmymoney-4.7.2 requires kde-frameworks/oxygen-icons
    app-office/libalkimia-4.3.2-r1 requires kde-frameworks/oxygen-icons
    app-office/libreoffice-5.1.2.2 requires kde-frameworks/oxygen-icons
    kde-apps/attica-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/baloo-widgets-4.14.3 requires kde-frameworks/oxygen-icons
    kde-apps/dolphin-4.14.3-r1 requires kde-frameworks/oxygen-icons
    kde-apps/drkonqi-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/gwenview-4.14.3 requires kde-frameworks/oxygen-icons
    kde-apps/kaddressbook-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kate-4.14.3 requires kde-frameworks/oxygen-icons
    kde-apps/kcalc-4.14.3 requires kde-frameworks/oxygen-icons
    kde-apps/kcmshell-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kcontrol-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kde-wallpapers-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdebase-data-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdebase-desktoptheme-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdebase-kioslaves-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdebase-menu-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdebase-menu-icons-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdebugdialog-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdenlive-0.9.8 requires kde-frameworks/oxygen-icons
    kde-apps/kdepim-common-libs-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kdepim-icons-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kdepim-kresources-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kdepim-runtime-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kdepimlibs-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kdesu-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdialog-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kdontchangethehostname-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/keditbookmarks-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/keditfiletype-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kfile-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kfind-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kfmclient-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kglobalaccel-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/khelpcenter-4.14.3 requires kde-frameworks/oxygen-icons
    kde-apps/kiconfinder-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kimgio-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kioclient-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kleopatra-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kmail-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kmimetypefinder-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/knetattach-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/knewstuff-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/knotify-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/konqueror-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/konsole-4.14.3-r2 requires kde-frameworks/oxygen-icons
    kde-apps/konsolepart-4.14.3 requires kde-frameworks/oxygen-icons
    kde-apps/kontact-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/korganizer-4.14.10 requires kde-frameworks/oxygen-icons
    kde-apps/kpasswdserver-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kquitapp-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kreadconfig-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kstart-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/ktimezoned-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/ktraderclient-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kuiserver-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kurifilter-plugins-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kwalletd-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/kwalletmanager-15.04.3 requires kde-frameworks/oxygen-icons
    kde-apps/libkdcraw-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/libkexiv2-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/libkipi-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/libkonq-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/okular-15.08.3-r1 requires kde-frameworks/oxygen-icons
    kde-apps/phonon-kde-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/plasma-apps-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/plasma-runtime-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/renamedlg-plugins-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/solid-runtime-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/svgpart-15.08.3 requires kde-frameworks/oxygen-icons
    kde-apps/zeroconf-ioslave-15.08.3 requires kde-frameworks/oxygen-icons
    kde-base/baloo-4.14.3 requires kde-frameworks/oxygen-icons
    kde-base/kactivities-4.13.3-r2 requires kde-frameworks/oxygen-icons
    kde-base/kactivitymanagerd-4.13.3-r1 requires kde-frameworks/oxygen-icons
    kde-base/katepart-4.14.3 requires kde-frameworks/oxygen-icons
    kde-base/kcheckpass-4.11.22-r1 requires kde-frameworks/oxygen-icons
    kde-base/kcminit-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/kdebase-startkde-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/kdelibs-4.14.16 requires kde-frameworks/oxygen-icons
    kde-base/kephal-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/kfilemetadata-4.14.3 requires kde-frameworks/oxygen-icons
    kde-base/khotkeys-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/krosspython-4.14.3 requires kde-frameworks/oxygen-icons
    kde-base/krunner-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/ksmserver-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/ksplash-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/kstartupconfig-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/ksysguard-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/kwin-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/legacy-icons-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/libkgreeter-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/libkworkspace-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/liboxygenstyle-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/libplasmaclock-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/libplasmagenericshell-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/libtaskmanager-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/plasma-workspace-4.11.22 requires kde-frameworks/oxygen-icons
    kde-base/pykde4-4.14.3 requires kde-frameworks/oxygen-icons
    kde-base/systemsettings-4.11.22-r1 requires kde-frameworks/oxygen-icons
    kde-misc/kde-gtk-config-2.2.1 requires kde-frameworks/oxygen-icons
    kde-misc/krename-4.0.9-r3 requires kde-frameworks/oxygen-icons
    kde-misc/kscreen-1.0.71_p20150824 requires kde-frameworks/oxygen-icons
    media-sound/kmid-2.4.0-r1 requires kde-frameworks/oxygen-icons
    media-sound/kmidimon-0.7.5 requires kde-frameworks/oxygen-icons
    media-video/kmplayer-0.11.3d-r3 requires kde-frameworks/oxygen-icons
    net-libs/libbluedevil-2.1 requires kde-frameworks/oxygen-icons
    net-libs/libktorrent-1.3.1 requires kde-frameworks/oxygen-icons
    net-p2p/ktorrent-4.3.1-r1 requires kde-frameworks/oxygen-icons
    net-wireless/bluedevil-2.1.1 requires kde-frameworks/oxygen-icons
    sys-auth/polkit-kde-agent-0.99.1-r1 requires kde-frameworks/oxygen-icons
    virtual/freedesktop-icon-theme-0 requires kde-frameworks/oxygen-icons
    x11-libs/libkscreen-1.0.5_p20150822 requires kde-frameworks/oxygen-icons


Back to top
View user's profile Send private message
gentooP4
Apprentice
Apprentice


Joined: 20 Sep 2010
Posts: 182
Location: NZ

PostPosted: Sat Jul 09, 2016 8:43 am    Post subject: Reply with quote

Is this realistically workable (given the latest developments) or can someone recommend me a desktop-environment that isn't Gnome3 or KDE5? :cry: :cry: :cry:
_________________
The United States has announced that it will deploy thoughts and prayers in the battle against online extremism.

If you voted for Trump or Brexit, you were likely influenced by the Cambridge Analytica propaganda machine.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Sat Jul 09, 2016 9:24 am    Post subject: Reply with quote

Plasma-4 is still in the tree, but it is a bit of a WIP right now so hold off on any move for a day or two.

EDIT: To stay on Plasma-4 you will need to remove kdebase-meta and kde-meta, and install kde-base/kdebase-startkde instead. Applications w/ slot 4 have been removed, which means the new slot 5 meta packages will pull in your applications.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DurianCakes
n00b
n00b


Joined: 09 Jul 2016
Posts: 9

PostPosted: Sat Jul 09, 2016 9:46 pm    Post subject: Reply with quote

Thanks for the info, genstorm. However, it looks like one of kde-base/kdebase-startkde's dependencies, kde-apps/kdebase-runtime-meta, only has slot 5 packages available now. The slot 4 packages have been removed. Does anyone know if kdebase-startkde will no longer depend on that package, or will I just have to stick the slot 4 packages for kdebase-runtime-meta in my local overlay? I already had to do that for kdenlive a few weeks ago.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Sat Jul 09, 2016 10:47 pm    Post subject: Reply with quote

Re-sync in a few hours, there is no more slot 5 dep.

...well, there is going to be kde-plasma/kactivitymanagerd that is replacing the slot 4 version even for Plasma-4.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
IceSunrise
n00b
n00b


Joined: 03 Mar 2008
Posts: 24
Location: Russia, Saint-Petersburg

PostPosted: Mon Jul 11, 2016 10:10 am    Post subject: Reply with quote

As everyone else here I'm trying to stay with KDE4 and prevent upgrading to KDE5 but it gets more and more difficult :(
Today morning after my usual sync I got this:
Code:

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by kde-plasma/kactivitymanagerd-5.5.0::gentoo
# required by kde-base/kactivities-4.13.3-r2::gentoo
# required by kde-apps/okular-15.08.3-r1::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
# dev-qt/*:5
=dev-qt/qtsql-5.5.1
# required by kde-base/kactivities-4.13.3-r2::gentoo
# required by kde-apps/okular-15.08.3-r1::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
# >=kde-plasma/kactivitymanagerd-5.5.0
=kde-plasma/kactivitymanagerd-5.5.0


I have kactivitymanagerd-4.13.3-r1 installed and the new 5.5.0 version masked:
Code:

~ # eix -vI kactivitymanagerd
* kde-plasma/kactivitymanagerd
     Available versions:  (5) [m]5.5.0 [m]~5.6.5 [m]~5.7.0
     IUSE (all versions): debug
     Installed versions:  Version:   4.13.3-r1(4/4.13)
                          Date:      06:19:27 PM 03/13/2016
                          USE:       -aqua
                          EAPI:      5
     Recommendation:      Downgrade
     Homepage:            https://www.kde.org/
     Find open bugs:      https://bugs.gentoo.org/buglist.cgi?quicksearch=kde-plasma%2Fkactivitymanagerd
     Description:         System service to manage user's activities, track the usage patterns etc.
     License:             || ( GPL-2 GPL-3 )


Why is portage still trying to upgrade it?? I don't understand.
Has anyone got the same problem?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Next
Page 2 of 10

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum