Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox 45.1 behaves differently than Firefox-bin-45.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7070
Location: almost Mile High in the USA

PostPosted: Wed May 04, 2016 11:20 pm    Post subject: Firefox 45.1 behaves differently than Firefox-bin-45.1 Reply with quote

Yeah both are unstable so I guess it's to be expected...

Just wondering if anyone has seen Firefox 45.1 when compiled from source starts up with a black screen... and overall very slow and sketchy. When using Firefox-bin 45.1, it works perfectly fine.

I am using fglrx and xfce4 on this particular system, but unsure if they have something to do with the issue.

I do get a warning EGLImageTargetRenderbufferStorageOES as a missing symbol when running the compiled-from-source version.

Any ideas what's going on here?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Thu May 05, 2016 6:58 am    Post subject: Reply with quote

I had Firefox compiled from source, and at compile time it gave me error 9 (swap memory low)... i recompiled it out of Kde GUI and with tmpfs line in fstab file (for extend memory), so i was able to compile it... but it was not working well. It had some problems.
Then i compiled Firefox-bin, and it works very fine.

Maybe, might it be a memory problem?
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2553

PostPosted: Thu May 05, 2016 7:10 am    Post subject: Reply with quote

I'd bet it is just a use flag difference.

But don't ask me which flags. I really wouldn't know how frefox-bin is built.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3583
Location: Germany

PostPosted: Fri May 06, 2016 1:06 pm    Post subject: Reply with quote

Is probably the hardware acceleration (with the fglrx video driver).
Try in firefox --> about:preferences#advanced
and disable the hardware acceleration by default
or build firefox with USE=-hwaccel
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7070
Location: almost Mile High in the USA

PostPosted: Fri May 06, 2016 1:11 pm    Post subject: Reply with quote

I was thinking that, perhaps the binary from mozilla.org has it compiled off? I think both are accessing the same .mozilla/firefox/... config directories and unless the binary is hardcoded off, both versions would have the same setting?

Alas it looks like it is indeed a workaround. Thanks.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum