Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore durante aggiornamento: ati-drivers-15.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
Lux-68
n00b
n00b


Joined: 19 May 2013
Posts: 34
Location: Provincia di Torino

PostPosted: Sun Mar 06, 2016 10:34 pm    Post subject: Errore durante aggiornamento: ati-drivers-15. Reply with quote

Ciao a tutti,
dopo aver risolto l'intoppo del topic precedente mi ritrovo con il seguente problema:
la compilazione degli aggiornamenti si blocca su ati-drivers-15.9r1

Code:

 * Building fgl_glxgears ...
In file included from /usr/include/GL/glu.h:38:0,
                 from fgl_glxgears.c:64:
/usr/include/GL/gl.h:2055:22: fatal error: GL/glext.h: No such file or directory
 #include <GL/glext.h>
                      ^
compilation terminated.
 * ERROR: x11-drivers/ati-drivers-15.9-r1::gentoo failed (compile phase):
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_compile
 *   environment, line 3739:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11
 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of `emerge --info
 '=x11-drivers/ati-drivers-15.9-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv
 '=x11-drivers/ati-drivers-15.9-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/temp/environment'.
 * Working directory:
 '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work/extra/fgl_glxgears'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work'

>>> Failed to emerge x11-drivers/ati-drivers-15.9-r1, Log file:

>>>  '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/temp/build.log'

 * Messages for package x11-drivers/ati-drivers-15.9-r1:

 *   CONFIG_DRM must be disabled or compiled as a
 *              module and not loaded for direct rendering to work.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
 *   CONFIG_DRM must be disabled or compiled as a
 *              module and not loaded for direct rendering to work.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.

* Messages for package x11-drivers/ati-drivers-15.9-r1:

 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * https://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 * ERROR: x11-drivers/ati-drivers-15.9-r1::gentoo failed (compile phase):
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line 133:  Called src_compile
 *   environment, line 3739:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11
 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of `emerge --info
 '=x11-drivers/ati-drivers-15.9-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv
 '=x11-drivers/ati-drivers-15.9-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/temp/environment'.
 * Working directory:
 '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work/extra/fgl_glxgears'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-15.9-r1/work'


Il sistema ha il kernel:

Code:

Linux Host-001 3.8.13-gentoo #27 SMP Sat Nov 29 23:20:47 CET 2014 x86_64 AMD FX(tm)-8150 Eight-Core Processor AuthenticAMD GNU/Linux


Da premettere che l'ultimo aggiornamento è stato effettuato ad agosto 2015 senza problemi per questo pacchetto.
La scheda grafica è una Ati Radeon Sapphire HD7750 con RAM 1GB DDR5.
Ho trovato qualche soluzione per i kernel superiori al mio.

Qualche idea?
Grazie.
_________________
Luciano.
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 250
Location: Milan, IT

PostPosted: Mon Mar 07, 2016 11:31 am    Post subject: Reply with quote

Ciao Lux-68
l'errore è in fase di compilazione:
Lux-68 wrote:
Code:
/usr/include/GL/gl.h:2055:22: fatal error: GL/glext.h: No such file or directory
 #include <GL/glext.h>


la cosa curiosa è che lo stesso identico problema è stato segnalato per altri ebuild: love2d e freeglut-3.0.0 (quest'ultimo ha un bug aperto)

La "soluzione" suggerita è di aggiornare le librerie MESA:
Code:
# emerge -1ua media-libs/mesa


Fammi sapere se risolve
Ciao
_________________
Regards

root is the root of all evil
Back to top
View user's profile Send private message
Lux-68
n00b
n00b


Joined: 19 May 2013
Posts: 34
Location: Provincia di Torino

PostPosted: Mon Mar 07, 2016 7:47 pm    Post subject: Reply with quote

kikko wrote:
Ciao Lux-68
l'errore è in fase di compilazione:
Lux-68 wrote:
Code:
/usr/include/GL/gl.h:2055:22: fatal error: GL/glext.h: No such file or directory
 #include <GL/glext.h>


la cosa curiosa è che lo stesso identico problema è stato segnalato per altri ebuild: love2d e freeglut-3.0.0 (quest'ultimo ha un bug aperto)

La "soluzione" suggerita è di aggiornare le librerie MESA:
Code:
# emerge -1ua media-libs/mesa


Fammi sapere se risolve
Ciao


Ciao,
ho effettuato la compilazione come indicato. A fine compilazione ottengo il messaggio
Code:


* Messages for package media-libs/mesa-11.0.6:

 * This package will overwrite one or more files that may belong to other
 * packages (see list below). You can use a command such as `portageq
 * owners / <filename>` to identify the installed package that owns a
 * file. If portageq reports that only one package owns a file then do
 * NOT file a bug report. A bug report is only useful if it identifies at
 * least two or more packages that are known to install the same file(s).
 * If a collision occurs and you can not explain where the file came from
 * then you should simply ignore the collision since there is not enough
 * information to determine if a real problem exists. Please do NOT file
 * a bug report at http://bugs.gentoo.org unless you report exactly which
 * two packages install the same file(s). See
 * http://wiki.gentoo.org/wiki/Knowledge_Base:Blockers for tips on how to
 * solve the problem. And once again, please do NOT file a bug report
 * unless you have completely understood the above message.
 *
 * Detected file collision(s):
 *
 *      /usr/include/GL/glxext.h
 *      /usr/include/GL/glext.h
 *      /usr/include/GL/glx.h
 *      /usr/include/GL/gl.h
 *      /usr/include/GLES2/gl2platform.h
 *      /usr/include/GLES2/gl2.h
 *      /usr/include/GLES2/gl2ext.h
 *      /usr/include/KHR/khrplatform.h
 *      /usr/include/EGL/eglextchromium.h
 *      /usr/include/EGL/eglplatform.h
 *      /usr/include/EGL/eglext.h
 *      /usr/include/EGL/eglmesaext.h
 *      /usr/include/EGL/egl.h
 *      /usr/include/GLES3/gl3platform.h
 *      /usr/include/GLES3/gl3ext.h
 *      /usr/include/GLES3/gl3.h
 *      /usr/lib64/libGL.so
 *      /usr/lib64/libEGL.so
 *      /usr/lib64/libEGL.so.1
 *      /usr/lib64/libGL.so.1
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * None of the installed packages claim the file(s).
 *
 * Package 'media-libs/mesa-11.0.6' merged despite file collisions. If
 * necessary, refer to your elog messages for the whole content of the
 * above message.
 * Note that in order to have full S3TC support, it is necessary to install
 * media-libs/libtxc_dxtn as well. This may be necessary to get nice
 * textures in some apps, and some others even require this to run.
>>> Auto-cleaning packages...


Ho riavviato la compilazione del world e il driver Ati si compilava con messaggio

Code:

* To switch to AMD OpenGL, run "eselect opengl set ati"
 * To change your xorg.conf you can use the bundled "aticonfig"
 *
 * If you experience unexplained segmentation faults and kernel crashes
 * with this driver and multi-threaded applications such as wine,
 * set UseFastTLS in xorg.conf to either 0 or 1, but not 2.
 *
 * Fully rebooting the system after an ati-drivers update is recommended
 * Stopping Xorg, reloading fglrx kernel module and restart Xorg
 * might not work
 *
 * Updating module dependencies for 3.8.13-gentoo ...                                                                                                                        [ ok ]
 * Adding module to moduledb.
Switching to ati OpenGL interface... done
Switching to amd OpenCL interface... done
>>> x11-drivers/ati-drivers-15.9-r1 merged.
>>> Regenerating /etc/ld.so.cache...


Sembra tutto OK. Vedremo al riavvio se funziona.


Grazie tante.
_________________
Luciano.
Back to top
View user's profile Send private message
Lux-68
n00b
n00b


Joined: 19 May 2013
Posts: 34
Location: Provincia di Torino

PostPosted: Thu Mar 10, 2016 8:22 pm    Post subject: Reply with quote

Lux-68 wrote:
kikko wrote:
Ciao Lux-68
l'errore è in fase di compilazione:
Lux-68 wrote:
Code:
/usr/include/GL/gl.h:2055:22: fatal error: GL/glext.h: No such file or directory
 #include <GL/glext.h>


la cosa curiosa è che lo stesso identico problema è stato segnalato per altri ebuild: love2d e freeglut-3.0.0 (quest'ultimo ha un bug aperto)

La "soluzione" suggerita è di aggiornare le librerie MESA:
Code:
# emerge -1ua media-libs/mesa


Fammi sapere se risolve
Ciao


Ciao,
ho effettuato la compilazione come indicato.
Ho riavviato la compilazione del world e il driver Ati si compilava con messaggio

Code:

* To switch to AMD OpenGL, run "eselect opengl set ati"
 * To change your xorg.conf you can use the bundled "aticonfig"
 *
 * If you experience unexplained segmentation faults and kernel crashes
 * with this driver and multi-threaded applications such as wine,
 * set UseFastTLS in xorg.conf to either 0 or 1, but not 2.
 *
 * Fully rebooting the system after an ati-drivers update is recommended
 * Stopping Xorg, reloading fglrx kernel module and restart Xorg
 * might not work
 *
 * Updating module dependencies for 3.8.13-gentoo ...                                                                                                                        [ ok ]
 * Adding module to moduledb.
Switching to ati OpenGL interface... done
Switching to amd OpenCL interface... done
>>> x11-drivers/ati-drivers-15.9-r1 merged.
>>> Regenerating /etc/ld.so.cache...


Sembra tutto OK. Vedremo al riavvio se funziona.


Grazie tante.


Purtroppo al riavvio il sistema si blocca (freeze) all'avvio dell'interfaccia grafica.
Ho dovuto disabilitare KDM e disinstallare il driver installando al suo posto quello generico per ATI come da wiki di Gentoo.
_________________
Luciano.
Back to top
View user's profile Send private message
xdarma
Guru
Guru


Joined: 08 Dec 2003
Posts: 592
Location: tra veneto e friuli (Italy)

PostPosted: Sun Apr 17, 2016 7:31 pm    Post subject: Reply with quote

Lux-68 wrote:
Purtroppo al riavvio il sistema si blocca (freeze) all'avvio dell'interfaccia grafica.

Vado a memoria perché è passato un po' di tempo, ma dovrebbe esserci un broken link in /usr/lib32/xorg/modules/extensions/ che puntava a libglx.so
Rimuovendolo dovrebbe caricarsi correttamente il modulo fglrx.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum