Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Black screen with mouse on kde5 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
atemv
n00b
n00b


Joined: 09 Aug 2014
Posts: 63

PostPosted: Mon Apr 11, 2016 1:12 pm    Post subject: Black screen with mouse on kde5 [SOLVED] Reply with quote

I upgraded to KDE plasma 5.5.5 following the KDE 4.11 the Gentoo wiki page:
https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#SDDM_display_issues

sddm works fine, I can start a working openbox session with it. (Yes sddm is in the video group)

However, when I start plasma, I get a dark screen with working a mouse and a limited krunner.

I have an extensive xorg logfile:
http://pastebin.com/m0mHVXJq

I extracted some relevant lines from it:
Code:
QCoreApplication::arguments: Please instantiate the QApplication object first
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kscreen: Failed to request backend: unknown error


I use openrc and a Nvidia GeForce GTX 760 with 361.28 driver version with 3 displays but two xscreens.


Last edited by atemv on Mon Apr 11, 2016 2:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Mon Apr 11, 2016 1:17 pm    Post subject: Reply with quote

Provided you use openrc: dbus and consolekit are in default runlevel?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
atemv
n00b
n00b


Joined: 09 Aug 2014
Posts: 63

PostPosted: Mon Apr 11, 2016 1:20 pm    Post subject: Reply with quote

genstorm wrote:
Provided you use openrc: dbus and consolekit are in default runlevel?


Yes they are.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Mon Apr 11, 2016 1:45 pm    Post subject: Reply with quote

Based on error output, you can try to remove ~/.cache directory or temporarily remove kscreen to take it out of the equation.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
atemv
n00b
n00b


Joined: 09 Aug 2014
Posts: 63

PostPosted: Mon Apr 11, 2016 2:29 pm    Post subject: Reply with quote

genstorm wrote:
Based on error output, you can try to remove ~/.cache directory or temporarily remove kscreen to take it out of the equation.


I tried it it had no effect.

However I disabled Xinerama in my xorg.conf, and this solved the problem.
Back to top
View user's profile Send private message
deefster
Tux's lil' helper
Tux's lil' helper


Joined: 19 Apr 2004
Posts: 77

PostPosted: Mon May 09, 2016 3:39 am    Post subject: Reply with quote

I had the very same issue, where the greeter would start ok, but after authenticating the plasma session was just a black screen.

In my case, I had to change my .xinitrc to only contain "startkde". Originally I had "exec startkde", which does not work for some reason.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum