Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE Plasma 5 + Localization
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Maxim Sheviakov
n00b
n00b


Joined: 01 Feb 2016
Posts: 6
Location: /dev/Earth/country/Russia/Moscow

PostPosted: Mon Feb 01, 2016 10:36 am    Post subject: KDE Plasma 5 + Localization Reply with quote

Hello, Gentoo users!
So, I'm new to Gentoo, although I'm an experienced Linux user. I've succeeded in installation and configuration of my system, however, there is a kind of an issue: there is no extra locale support in Plasma at all. The only avalible choice is "American English", and that's not good. I have nls USE and LINGUAS var configured to "ru". How can I add more KDE locales/fix them?
_________________
Missed me, ya' wankers?
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1655
Location: United Kingdom

PostPosted: Mon Feb 01, 2016 12:38 pm    Post subject: Re: KDE Plasma 5 + Localization Reply with quote

Do you have the KDE internationalisation package installed?:

Code:
fitzcarraldo@meshedgedx ~ $ eix -I l10n
[I] kde-apps/kde-l10n
     Available versions:  (5) (~)15.08.3
       {debug +handbook LINGUAS="ar bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru sk sl sr sv tr ug uk wa zh_CN zh_TW"}
     Installed versions:  15.08.3(5)(18:52:13 30/11/15)(-debug -handbook LINGUAS="en_GB pt_BR -ar -bg -bs -ca -ca@valencia -cs -da -de -el -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -ro -ru -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW")
     Homepage:            http://l10n.kde.org
     Description:         KDE internationalization package

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Maxim Sheviakov
n00b
n00b


Joined: 01 Feb 2016
Posts: 6
Location: /dev/Earth/country/Russia/Moscow

PostPosted: Mon Feb 01, 2016 2:00 pm    Post subject: Reply with quote

Fitzcarraldo, I actually have (some). Here's the output:
Code:

root@m-Gentoo-PC /h/maxik# eix -I l10n
[I] kde-apps/kde-l10n
     Доступные версии:      (5) (~)15.08.3 (~)15.12.1
       {debug +handbook LINGUAS="ar bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru sk sl sr sv tr ug uk wa zh_CN zh_TW"}
     Установленные версии:  15.12.1(5)(23:18:41 31.01.2016)(handbook -debug LINGUAS="ru -ar -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW")
     Домашняя страница:     http://l10n.kde.org
     Описание:              KDE internationalization package

[I] kde-apps/kde4-l10n
     Доступные версии:      (4) 4.14.3(4/4.14) (~)4.14.3-r1(4/4.14) (~)15.08.3-r2(4/15.08) (~)15.12.1-r1(4/15.12)
       {aqua +handbook minimal LINGUAS="ar bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru sk sl sr sv tr ug uk wa zh_CN zh_TW"}
     Установленные версии:  15.12.1-r1(4)(23:48:06 31.01.2016)(handbook minimal -aqua LINGUAS="ru -ar -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW")
     Домашняя страница:     http://l10n.kde.org
     Описание:              KDE internationalization package

[I] kde-apps/kdepim-l10n
     Доступные версии:     
     (4)    4.4.11.1-r1(4/4.4) (~)4.4.11.1-r2(4/4.4) 4.14.3(4/4.14) (~)4.14.3-r1(4/4.14)
     (5)    (~)15.08.3 (~)15.12.1
       {aqua debug +handbook LINGUAS="ar bg bs ca ca@valencia cs csb da de el en_GB eo es et eu fa fi fr fy ga gl gu he hi hr hu ia id is it ja kk km kn ko lt lv mai mk ml mr nb nds nl nn pa pl pt pt_BR ro ru si sk sl sr sv tg tr ug uk wa zh_CN zh_TW"}
     Установленные версии:  15.12.1(5)(00:01:05 01.02.2016)(handbook -debug LINGUAS="ru -ar -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW")
     Домашняя страница:     http://l10n.kde.org
     Описание:              KDE PIM internationalization package

Найдено 3 совпадение.

_________________
Missed me, ya' wankers?
Back to top
View user's profile Send private message
Maxim Sheviakov
n00b
n00b


Joined: 01 Feb 2016
Posts: 6
Location: /dev/Earth/country/Russia/Moscow

PostPosted: Mon Feb 01, 2016 5:44 pm    Post subject: Reply with quote

Aaaalrightey, I think I've figured it out.
Some QT packages are at ver 4.XXX, despite the fact of 5.XXX avaliblity. Right now I'm building those packages (which won't probably take long on my FX8320-powered rig), then I will report if there is something - hopefully, localization support.
_________________
Missed me, ya' wankers?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Mon Feb 01, 2016 6:09 pm    Post subject: Reply with quote

You will need both Qt4 and Qt5 packages installed for some time (the better half of 2016 at least), unless you take manual steps to clean out any Qt4-based apps (that will probably clean half of your KDE Applications...). So that likely won't be the problem here.

Code:
$ equery f kde-l10n

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Maxim Sheviakov
n00b
n00b


Joined: 01 Feb 2016
Posts: 6
Location: /dev/Earth/country/Russia/Moscow

PostPosted: Mon Feb 01, 2016 6:25 pm    Post subject: Reply with quote

genstorm, here you go. Oh, by the way, nothing changed. Could somebody give a list of possible USEflags and packages to enable localization?

Oh, and here is my ~/.xsession-errors: http://pastebin.com/Fb2yRM47
_________________
Missed me, ya' wankers?
Back to top
View user's profile Send private message
Maxim Sheviakov
n00b
n00b


Joined: 01 Feb 2016
Posts: 6
Location: /dev/Earth/country/Russia/Moscow

PostPosted: Mon Feb 01, 2016 6:34 pm    Post subject: Reply with quote

My make.conf:
Quote:
CFLAGS="-march=native -mtune=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="nls bindist mmx sse sse2 sse3 sse4 -consolekit -graphite gtk libkms qt5 pango X \
alsa latex python policykit pulseaudio xkb systemd dbus udev polkit udisks lz4 \
ffmpeg vaapi vdpau egl"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j15"
ACCEPT_KEYWORDS="~amd64"
#CONFIG_PROTECT="-*"
VIDEO_CARDS="radeon radeonsi amdgpu"
INPUT_DEVICES="evdev synaptics joystick libinput keyboard mouse"
LINGUAS="en ru RU ru_RU"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/"
#PYTHON_TARGETS="python3_5"
RUBY_TARGETS="ruby23"
#FEATURES="ccache"
#CCACHE_SIZE="2G"

_________________
Missed me, ya' wankers?
Back to top
View user's profile Send private message
Maxim Sheviakov
n00b
n00b


Joined: 01 Feb 2016
Posts: 6
Location: /dev/Earth/country/Russia/Moscow

PostPosted: Tue Feb 02, 2016 4:46 am    Post subject: Reply with quote

As I haven't succeeded in getting other languages support, I think my only option is to look at Arch's Plasma packages and their deps to determine whether I'm missing something or not. Right now I don't see any other ways of getting the language pack to work.

Could someone with working Plasma 5 configuration provide the make.conf and package-specific use flags, if they are present? Also, a copy of "eix -I qt", where qt is the common name for all qt libraries, would be appreciated.
_________________
Missed me, ya' wankers?
Back to top
View user's profile Send private message
papas
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2014
Posts: 78
Location: Athens

PostPosted: Tue Feb 02, 2016 4:58 pm    Post subject: Reply with quote

Hello
Recently I upgraded from plasma 5.4 to 5.5.2 no problems at all... my "make.conf" :
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe -march=core2"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx plasma  ipv6 sse sse2 X apache2  kde cdr gnome dvdr alsa qt4  gtk cxx -nocxx systemd sasl"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j2"
LINGUAS="us el"
PHP_TARGETS="php5-6"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="nvidia"
CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi"
source /var/lib/layman/make.conf


but I have also this lines in my "package.accept.words":
Code:

kde-apps/* ~amd64
kde-plasma/* ~amd64
kde-frameworks/* ~amd64
dev-qt/* ~amd64

good luck
P.S my make.conf its against wiki guide but i had no trouble.
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Sun Apr 10, 2016 12:34 pm    Post subject: Reply with quote

Right now some applications are translated while others are not...right? Or is it just me?

I guess it's because both kde4-l10n blocks kde-l10n cannot be installed at the same time...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Sun Apr 10, 2016 12:44 pm    Post subject: Reply with quote

that's not right, kde4-l10n can be installed if the minimal use flag is set, which the plasma profile is doing automatically for you.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Sun Apr 10, 2016 12:50 pm    Post subject: Reply with quote

The update installed (or kept) kde4-l10n, and if I try to additionally install kde-l10n, after unmasking it, I get
Code:

Calculating dependencies... done!
[ebuild  N    ~] kde-apps/kde-l10n-15.12.3:5::gentoo  USE="handbook -debug" LINGUAS="es -ar -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW" 21.081 KiB
[blocks B      ] <kde-apps/kde4-l10n-15.12.3 ("<kde-apps/kde4-l10n-15.12.3" is blocking kde-apps/kde-l10n-15.12.3)

Total: 1 package (1 new), Size of downloads: 21.081 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde4-l10n-15.08.3-r2:4/15.08::gentoo, installed) pulled in by
    kde-apps/kde4-l10n required by @selected

  (kde-apps/kde-l10n-15.12.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-l10n


that, despite the fact that kde4-l10n is indeed installed, as you said, with the minimal flag activated.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Sun Apr 10, 2016 12:53 pm    Post subject: Reply with quote

kde-l10n is for kf5-based applications translations, kde-plasma/ packages carry their own.

kde-l10n blocks lower versions of kde4-l10n than its own, they always need to be on par. Portage is telling you that right there:

Code:
[blocks B      ] <kde-apps/kde4-l10n-15.12.3 ("<kde-apps/kde4-l10n-15.12.3" is blocking kde-apps/kde-l10n-15.12.3)

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Sun Apr 10, 2016 1:34 pm    Post subject: Reply with quote

Ok, I see, I didn't know that...

And what about kde-apps (in the portage tree)? I have konsole in English but Akregator in Spanish when both are under kde-apps...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Sun Apr 10, 2016 1:35 pm    Post subject: Reply with quote

akregator is a KDE PIM application, its translations are part of kdepim-l10n.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Sun Apr 10, 2016 2:26 pm    Post subject: Reply with quote

Right...still I don't get why I have konsole in English and okular in Spanish (both part of KDE applications). They are at versions 4.14.3-r2 and 15.08.3-r1, respectively, and I have kde4-l10n-15.08.3-r2 installed, but this was also the case before updating to Plasma 5, and they were both in Spanish. Quite confusing... :?

Sorry for nagging about this...I just want to know if there is something wrong with my setup or we all need to wait for the rest of the KDE applications to reach version 15-*
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Sun Apr 10, 2016 2:42 pm    Post subject: Reply with quote

Yes, what you see there is a bit unfortunate, while we are waiting for Applications stabilisation.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 278
Location: Rome, Italy

PostPosted: Thu Apr 28, 2016 9:24 am    Post subject: Reply with quote

Same problem here.
Something seems to go to my language (it) and something seems to go to American English.
Also, I cannot guess how italian is detected as my language, since American English is the unique available translation in the KDE settings and /etc/env.d/02locale is LANG="en_US.UTF-8". The one italian setting is the X keyboard layout.

Regards,
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
zoulou99
n00b
n00b


Joined: 15 Jan 2015
Posts: 16

PostPosted: Thu Apr 28, 2016 1:27 pm    Post subject: Reply with quote

same thing here, half in French & half English
genstorm wrote:
kde-l10n is for kf5-based applications translations, kde-plasma/ packages carry their own.


yes half of the kde-plasma/ & kde-frameworks/ are in "en-US.UTF-8", even with locale set to "fr_FR.UTF-8".
there is no *.mo files installed in "/usr/share/locale/fr/LC_MESSAGES/".
its like the "nls" use flag dont work, or an issue with 'kde-frameworks/ki18n'.

Code:
$ cat /etc/locale.gen
en_US.UTF-8 UTF-8
fr_FR.UTF-8 UTF-8


Code:
$ cat /etc/env.d/02locale
LANG="fr_FR.UTF-8"


Code:
$ locale -a
C
en_US.utf8
fr_FR.utf8
POSIX


i tried both with 'fr_FR.utf8' & 'fr_FR.UTF-8'
Code:
$ eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   en_US.utf8
  [3]   
  [4]   POSIX
  [5]   fr_FR.UTF-8 *
  [ ]   (free form)


Code:
$ locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

_________________
mydigitallife
Back to top
View user's profile Send private message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 278
Location: Rome, Italy

PostPosted: Fri Apr 29, 2016 9:10 am    Post subject: Reply with quote

Giving a locale command in konsole gives an unexpected result:
locale:
LANG=it_IT.UTF-8
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=

This is different from the result obtained in vt, where my LANG is en_US.UTF-8.

Those settings are in:
~/.config/.plasma-localerc:
[Formats]
LANG=it_IT.UTF-8
LC_NUMERIC=en_US.UTF-8
useDetailed=true

[Translations]
LANGUAGE=en_US

Here you can find how to try (and fail) to set the translations, adding for
example:
~/.config/.plasma-localerc:
[Formats]
LANG=it_IT.UTF-8
LC_NUMERIC=en_US.UTF-8
useDetailed=true

[Translations]
LANGUAGE=it:en_GB:en_US

That syntax is accepted by plasma, that gives an odd error message:
Quote:
The translation files for the languages with the codes 'it', 'en_GB' could not be found. These languages have been removed from your configuration. If you want to add them back, please install the localization files for it and the languages again.

And this is surprising, because my LINGUAS="it en_GB" and because the environment is partially translated in italian.

:?
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Fri Apr 29, 2016 9:27 am    Post subject: Reply with quote

zoulou99 wrote:
yes half of the kde-plasma/ & kde-frameworks/ are in "en-US.UTF-8", even with locale set to "fr_FR.UTF-8".

What package manager do you use, and what content does LINGUAS have on your system?

zoulou99 wrote:
there is no *.mo files installed in "/usr/share/locale/fr/LC_MESSAGES/".
its like the "nls" use flag dont work, or an issue with 'kde-frameworks/ki18n'.

ki18n is not carrying translations for plasma, each plasma package ships its own. That means `equery f plasma-workspace` should give you plenty of content inside /usr/share/locale/<YOUR_LINGUAS>/LC_MESSAGES, can you check?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 278
Location: Rome, Italy

PostPosted: Fri Apr 29, 2016 10:58 am    Post subject: Reply with quote

genstorm wrote:
That means `equery f plasma-workspace` should give you plenty of content inside /usr/share/locale/<YOUR_LINGUAS>/LC_MESSAGES


Not for my kde-plasma/plasma-workspace-5.6.3
equery f plasma-workspace | grep locale gives an empty result.

Also, I begin to suppose that the problem concerns the 5.6.3 verson(s).
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Fri Apr 29, 2016 11:14 am    Post subject: Reply with quote

No, since that works perfectly fine for me, and I'm not aware of any change wrt how LINGUAS are done since 5.6.0.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
hujuice
Apprentice
Apprentice


Joined: 16 Oct 2007
Posts: 278
Location: Rome, Italy

PostPosted: Fri Apr 29, 2016 11:20 am    Post subject: Reply with quote

I can confirm that in another desktop where I have the stable kde-plasma/plasma-workspace (5.5.5-r2) I don't have the same problem and
equery f plasma-workspace | grep locale
gives the expected 'it' and 'en_GB' lists of .mo files.

Those files are there, anyway, in the =kde-plasma/plasma-workspace-5.6.3 system too, but they belongs to kde-apps/kde4-l10n, pulled in by kdepim and others.
Trying to re- emerge -1 plasma-workspace gives no collisions.

Regards,
HUjuice
_________________
Who hasn't a spine, should have a method.
Chi non ha carattere, deve pur avere un metodo.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6998
Location: Austria

PostPosted: Fri Apr 29, 2016 11:31 am    Post subject: Reply with quote

Files installed by kde4-l10n only belong to legacy parts of KDE SC 4 that are still present as a dependency. That plasma-workspace installs no translations for you is strange.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum